Debian Bug report logs - #527541
libc6: after upgrade of libc iceweasel stops working

version graph

Package: libc6; Maintainer for libc6 is GNU Libc Maintainers <debian-glibc@lists.debian.org>; Source for libc6 is src:eglibc.

Reported by: Norbert Preining <preining@logic.at>

Date: Fri, 8 May 2009 01:42:01 UTC

Severity: critical

Tags: pending

Found in version eglibc/2.9-11

Fixed in version eglibc/2.9-12

Done: Aurelien Jarno <aurel32@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 01:42:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Norbert Preining <preining@logic.at>:
New Bug report received and forwarded. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 01:42:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Norbert Preining <preining@logic.at>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libc6: after upgrade of libc iceweasel stops working
Date: Fri, 08 May 2009 03:38:35 +0200
Package: libc6
Version: 2.9-11
Severity: critical
Justification: breaks unrelated software

after upgrading today suddenly iceweasel does not start anymore, only
in safe mode I can convince it to start.

Since the only things were libc and some java lib that has been upgraded
I guess it is libc:
Aptitude 0.4.11.11: log report
Fri, May  8 2009 01:48:54 +0200

IMPORTANT: this log only lists intended actions; actions which fail due to
dpkg problems may not be completed.

Will install 5 packages, and remove 0 packages.
16.4kB of disk space will be used
===============================================================================
[UPGRADE] libc6 2.9-10 -> 2.9-11
[UPGRADE] libc6-dev 2.9-10 -> 2.9-11
[UPGRADE] libc6-i386 2.9-10 -> 2.9-11
[UPGRADE] libjgoodies-looks-java 2.2.1-1 -> 2.2.2-1
[UPGRADE] locales 2.9-10 -> 2.9-11
===============================================================================


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-rc4 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libc6 depends on:
ii  libgcc1                       1:4.4.0-4  GCC support library

libc6 recommends no packages.

Versions of packages libc6 suggests:
pn  glibc-doc                     <none>     (no description available)
ii  locales                       2.9-11     GNU C Library: National Language (

-- debconf information:
  glibc/upgrade: true
  glibc/disable-screensaver:
  glibc/restart-failed:
* glibc/restart-services: cron




Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 07:42:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Aurelien Jarno <aurelien@aurel32.net>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 07:42:02 GMT) Full text and rfc822 format available.

Message #10 received at 527541@bugs.debian.org (full text, mbox):

From: Aurelien Jarno <aurelien@aurel32.net>
To: Norbert Preining <preining@logic.at>, 527541@bugs.debian.org
Subject: Re: Bug#527541: libc6: after upgrade of libc iceweasel stops working
Date: Fri, 8 May 2009 09:39:20 +0200
Hi,

On Fri, May 08, 2009 at 03:38:35AM +0200, Norbert Preining wrote:
> Package: libc6
> Version: 2.9-11
> Severity: critical
> Justification: breaks unrelated software
> 
> after upgrading today suddenly iceweasel does not start anymore, only
> in safe mode I can convince it to start.
> 
> Since the only things were libc and some java lib that has been upgraded
> I guess it is libc:
> Aptitude 0.4.11.11: log report
> Fri, May  8 2009 01:48:54 +0200
> 
> IMPORTANT: this log only lists intended actions; actions which fail due to
> dpkg problems may not be completed.
> 
> Will install 5 packages, and remove 0 packages.
> 16.4kB of disk space will be used
> ===============================================================================
> [UPGRADE] libc6 2.9-10 -> 2.9-11
> [UPGRADE] libc6-dev 2.9-10 -> 2.9-11
> [UPGRADE] libc6-i386 2.9-10 -> 2.9-11
> [UPGRADE] libjgoodies-looks-java 2.2.1-1 -> 2.2.2-1
> [UPGRADE] locales 2.9-10 -> 2.9-11
> ===============================================================================

Thanks for your bug report. Unfortunately I am unable to reproduce it,
so I will need some help from you side to understand what happens:
- Could you please try to install again version 2.9.10 before it
  disappears from the mirrors to confirm iceweasel is working again.
- What is your version of iceweasel and related packages?
- Does it works as another user or by temporarily moving .firefox?

Thanks,
Aurelien

PS: if someone is able to reproduce this bug, please say it here.

-- 
Aurelien Jarno	                        GPG: 1024D/F1BCDB73
aurelien@aurel32.net                 http://www.aurel32.net




Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 08:21:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Richard Renard <richard.renard@gmail.com>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 08:21:06 GMT) Full text and rfc822 format available.

Message #15 received at 527541@bugs.debian.org (full text, mbox):

From: Richard Renard <richard.renard@gmail.com>
To: 527541@bugs.debian.org
Subject: Re: Bug#527541: libc6: after upgrade of libc iceweasel stops working
Date: Fri, 8 May 2009 10:19:23 +0200
Hi,

I am having the same problem, iceweasel stopped working after libc6
upgrade from 2.9-10 to 2.9-11, same for epiphany-browser.

Downgrading to 2.9-10 fixes the problem.

What kind of traces may help you ?


Richard.




Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 08:42:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Linas Žvirblis <0x0007@gmail.com>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 08:42:08 GMT) Full text and rfc822 format available.

Message #20 received at 527541@bugs.debian.org (full text, mbox):

From: Linas Žvirblis <0x0007@gmail.com>
To: 527541@bugs.debian.org
Subject: Re: Bug#527541: libc6: after upgrade of libc iceweasel stops, working
Date: Fri, 08 May 2009 11:37:09 +0300
I can confirm this bug. Both iceweasel and epiphany-gecko fail with
libc6 2.9-11. Epiphany starts and is able to browse websites, but hangs
when downloading a file.

The mirror I was using did not contain 2.9-11, so I downgraded to 2.9-4.
Although 2.9-10 did work.

Here is reportbug information for libc6 (already downgraded to 2.9-4),
iceweasel, and epiphany-gecko.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1,
'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=lt_LT.UTF-8, LC_CTYPE=lt_LT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages iceweasel depends on:
ii  debianutils            3.1.3      Miscellaneous utilities specific t
ii  fontconfig             2.6.0-3    generic font configuration library
ii  libc6                  2.9-4      GNU C Library: Shared libraries
ii  libglib2.0-0           2.20.1-2   The GLib library of C routines
ii  libgtk2.0-0            2.16.1-2   The GTK+ graphical user interface
ii  libnspr4-0d            4.7.4-2    NetScape Portable Runtime Library
ii  libstdc++6             4.4.0-4    The GNU Standard C++ Library v3
ii  procps                 1:3.2.7-11 /proc file system utilities
ii  psmisc                 22.6-1     Utilities that use the proc filesy
ii  xulrunner-1.9          1.9.0.10-1 XUL + XPCOM application runner

Versions of packages epiphany-gecko depends on:
ii  dbus-x11               1.2.12-1     simple interprocess messaging
ii  epiphany-browser-data  2.26.1-1     Data files for the GNOME web
ii  gnome-icon-theme       2.24.0-4     GNOME Desktop icon theme
ii  iso-codes              3.9-1        ISO language, territory
ii  libavahi-client3       0.6.25-1     Avahi client library
ii  libavahi-common3       0.6.25-1     Avahi common library
ii  libavahi-gobject0      0.6.25-1     Avahi GObject library
ii  libc6                  2.9-4        GNU C Library: Shared libraries
ii  libcanberra-gtk0       0.11-1       Gtk+ helper for playing widget
ii  libcanberra0           0.11-1       a simple abstract interface for
ii  libdbus-1-3            1.2.12-1     simple interprocess messaging
ii  libdbus-glib-1-2       0.80-4       simple interprocess messaging
ii  libenchant1c2a         1.4.2-3.3    a wrapper library for various
ii  libgcc1                1:4.4.0-4    GCC support library
ii  libgconf2-4            2.26.0-1     GNOME configuration database
ii  libglade2-0            1:2.6.4-1    library to load .glade files at
ii  libglib2.0-0           2.20.1-2     The GLib library of C routines
ii  libgnome2-0            2.26.0-1     The GNOME library - runtime
ii  libgnomeui-0           2.24.1-1     The GNOME 2 libraries (User
ii  libgtk2.0-0            2.16.1-2     The GTK+ graphical user
ii  libnotify1 [libnotify1-gtk2 0.4.5-1  sends desktop notifications to
ii  libnspr4-0d            4.7.4-2      NetScape Portable Runtime
ii  libpango1.0-0          1.24.0-3+b1  Layout and rendering of
ii  libstdc++6             4.4.0-4      The GNU Standard C++ Library v3
ii  libx11-6               2:1.2.1-1    X11 client-side library
ii  libxml2                2.7.3.dfsg-1 GNOME XML library
ii  libxslt1.1             1.1.24-2     XSLT processing library
ii  python2.5              2.5.4-1      An interactive high-level
ii  xulrunner-1.9          1.9.0.10-1   XUL + XPCOM application runner
ii  xulrunner-1.9-gnome-support 1.9.0.10-1   Support for GNOME in

Versions of packages epiphany-gecko recommends:
ii  epiphany-extensions    2.26.1-1   Extensions for Epiphany web browse
ii  yelp                   2.24.0-2   Help browser for GNOME 2

Versions of packages libc6 depends on:
ii  libgcc1                 1:4.4.0-4  GCC support library

Versions of packages libc6 suggests:
pn  glibc-doc               <none>     (no description available)
ii  locales                 2.9-11     GNU C Library: National Language




Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 09:06:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Norbert Preining <preining@logic.at>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 09:06:04 GMT) Full text and rfc822 format available.

Message #25 received at 527541@bugs.debian.org (full text, mbox):

From: Norbert Preining <preining@logic.at>
To: Aurelien Jarno <aurelien@aurel32.net>
Cc: 527541@bugs.debian.org
Subject: Re: Bug#527541: libc6: after upgrade of libc iceweasel stops working
Date: Fri, 8 May 2009 11:05:20 +0200
On Fr, 08 Mai 2009, Aurelien Jarno wrote:
> - Could you please try to install again version 2.9.10 before it
>   disappears from the mirrors to confirm iceweasel is working again.

Confirmed. Downgrading to -10 did make iceweasel start again.

> - What is your version of iceweasel and related packages?

dpkg -l '*iceweasel*' | grep ^ii

ii  iceweasel                3.0.9-1                  lightweight web browser based on Mozilla
ii  iceweasel-gnome-support  3.0.9-1                  Support for GNOME in Iceweasel
ii  iceweasel-scrapbook      1.3.3.9-1                Iceweasel extension to save and manage Web pages

dpkg -l '*mozilla*' | grep ^ii

ii  moonlight-plugin-mozilla 1.0.1-3                  Free Software
clone of Silverlight 1.0 - Xulrunner 1.9 plugin
ii  mozilla-diggler          0.9-16                   A set of URL
manipulation utilities for Iceape and Iceweasel's l
ii  mozilla-openthesaurus-de 20061008-4               OpenThesaurus
search plugin for Iceweasel/Iceape
ii  swfdec-mozilla           0.8.2-1                  Mozilla plugin for
SWF files (Macromedia Flash)
ii  totem-mozilla            2.24.3-3                 Totem Mozilla
plugin


> - Does it works as another user or by temporarily moving .firefox?

move .mozilla and .firefox away and the same still happens.

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <preining@logic.at>        Vienna University of Technology
Debian Developer <preining@debian.org>                         Debian TeX Group
gpg DSA: 0x09C5B094      fp: 14DF 2E6C 0307 BE6D AD76  A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
`If there's anything more important than my ego around, I
want it caught and shot now.'
                 --- Zaphod.
                 --- Douglas Adams, The Hitchhikers Guide to the Galaxy




Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 09:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michal Kašpar <mkaspar@it-media.cz>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 09:21:03 GMT) Full text and rfc822 format available.

Message #30 received at 527541@bugs.debian.org (full text, mbox):

From: Michal Kašpar <mkaspar@it-media.cz>
To: 527541@bugs.debian.org
Subject: Re: Bug#527541: libc6: after upgrade of libc iceweasel stops, working
Date: Fri, 08 May 2009 11:17:29 +0200
Got same problem. Strace on iceweasel (epiphany-browser too) ends with:
stat("/home/mkaspar/.gnome2/vfs/modules", 0x7fff0ffc1db0) = -1 ENOENT
(No such file or directory)
stat("/etc/gnome-vfs-2.0/modules", {st_mode=S_IFDIR|0755,
st_size=4096, ...}) = 0
geteuid()                               = 1000
getegid()                               = 1000
getuid()                                = 1000
tgkill(18215, 18219, SIGRT_1)           = 0
tgkill(18215, 18217, SIGRT_1)           = 0
tgkill(18215, 18216, SIGRT_1)           = 0
futex(0x7fff0ffc1e80, FUTEX_WAIT_PRIVATE, 4294967295, NULL

If I try to remove etc/gnome-vfs-2.0/modules/default (or even comment
out file: file), iceweasel starts just fine.
So it seems to be some problem of new eglibc with gnome-vfs.

-- 
Michal Kašpar





Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 10:03:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Aurelien Jarno <aurelien@aurel32.net>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 10:03:02 GMT) Full text and rfc822 format available.

Message #35 received at 527541@bugs.debian.org (full text, mbox):

From: Aurelien Jarno <aurelien@aurel32.net>
To: Linas Žvirblis <0x0007@gmail.com>, 527541@bugs.debian.org
Subject: Re: Bug#527541: libc6: after upgrade of libc iceweasel stops, working
Date: Fri, 8 May 2009 11:56:45 +0200
On Fri, May 08, 2009 at 11:37:09AM +0300, Linas Žvirblis wrote:
> I can confirm this bug. Both iceweasel and epiphany-gecko fail with
> libc6 2.9-11. Epiphany starts and is able to browse websites, but hangs
> when downloading a file.
> 

Thanks, I am able to reproduce the problem here, a fix is under way.

-- 
Aurelien Jarno	                        GPG: 1024D/F1BCDB73
aurelien@aurel32.net                 http://www.aurel32.net




Tags added: pending Request was from Aurelien Jarno <aurel32@alioth.debian.org> to control@bugs.debian.org. (Fri, 08 May 2009 10:12:06 GMT) Full text and rfc822 format available.

Reply sent to Aurelien Jarno <aurel32@debian.org>:
You have taken responsibility. (Fri, 08 May 2009 12:24:09 GMT) Full text and rfc822 format available.

Notification sent to Norbert Preining <preining@logic.at>:
Bug acknowledged by developer. (Fri, 08 May 2009 12:24:09 GMT) Full text and rfc822 format available.

Message #42 received at 527541-close@bugs.debian.org (full text, mbox):

From: Aurelien Jarno <aurel32@debian.org>
To: 527541-close@bugs.debian.org
Subject: Bug#527541: fixed in eglibc 2.9-12
Date: Fri, 08 May 2009 12:17:20 +0000
Source: eglibc
Source-Version: 2.9-12

We believe that the bug you reported is fixed in the latest version of
eglibc, which is due to be installed in the Debian FTP archive:

eglibc-source_2.9-12_all.deb
  to pool/main/e/eglibc/eglibc-source_2.9-12_all.deb
eglibc_2.9-12.diff.gz
  to pool/main/e/eglibc/eglibc_2.9-12.diff.gz
eglibc_2.9-12.dsc
  to pool/main/e/eglibc/eglibc_2.9-12.dsc
glibc-doc_2.9-12_all.deb
  to pool/main/e/eglibc/glibc-doc_2.9-12_all.deb
libc6-dbg_2.9-12_amd64.deb
  to pool/main/e/eglibc/libc6-dbg_2.9-12_amd64.deb
libc6-dev-i386_2.9-12_amd64.deb
  to pool/main/e/eglibc/libc6-dev-i386_2.9-12_amd64.deb
libc6-dev_2.9-12_amd64.deb
  to pool/main/e/eglibc/libc6-dev_2.9-12_amd64.deb
libc6-i386_2.9-12_amd64.deb
  to pool/main/e/eglibc/libc6-i386_2.9-12_amd64.deb
libc6-pic_2.9-12_amd64.deb
  to pool/main/e/eglibc/libc6-pic_2.9-12_amd64.deb
libc6-prof_2.9-12_amd64.deb
  to pool/main/e/eglibc/libc6-prof_2.9-12_amd64.deb
libc6-udeb_2.9-12_amd64.udeb
  to pool/main/e/eglibc/libc6-udeb_2.9-12_amd64.udeb
libc6_2.9-12_amd64.deb
  to pool/main/e/eglibc/libc6_2.9-12_amd64.deb
libnss-dns-udeb_2.9-12_amd64.udeb
  to pool/main/e/eglibc/libnss-dns-udeb_2.9-12_amd64.udeb
libnss-files-udeb_2.9-12_amd64.udeb
  to pool/main/e/eglibc/libnss-files-udeb_2.9-12_amd64.udeb
locales-all_2.9-12_amd64.deb
  to pool/main/e/eglibc/locales-all_2.9-12_amd64.deb
locales_2.9-12_all.deb
  to pool/main/e/eglibc/locales_2.9-12_all.deb
nscd_2.9-12_amd64.deb
  to pool/main/e/eglibc/nscd_2.9-12_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 527541@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aurelien Jarno <aurel32@debian.org> (supplier of updated eglibc package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 08 May 2009 11:57:16 +0200
Source: eglibc
Binary: glibc-doc eglibc-source locales locales-all nscd libc6 libc6-dev libc6-dbg libc6-prof libc6-pic libc6-udeb libc6.1 libc6.1-dev libc6.1-dbg libc6.1-prof libc6.1-pic libc6.1-udeb libc0.3 libc0.3-dev libc0.3-dbg libc0.3-prof libc0.3-pic libc0.3-udeb libc0.1 libc0.1-dev libc0.1-dbg libc0.1-prof libc0.1-pic libc0.1-udeb libc6-i386 libc6-dev-i386 libc6-sparc64 libc6-dev-sparc64 libc6-s390x libc6-dev-s390x libc6-amd64 libc6-dev-amd64 libc6-powerpc libc6-dev-powerpc libc6-ppc64 libc6-dev-ppc64 libc6-mipsn32 libc6-dev-mipsn32 libc6-mips64 libc6-dev-mips64 libc0.1-i386 libc0.1-dev-i386 libc6-sparcv9b libc6-i686 libc6-xen libc0.1-i686 libc6.1-alphaev67 libnss-dns-udeb libnss-files-udeb
Architecture: source all amd64
Version: 2.9-12
Distribution: unstable
Urgency: low
Maintainer: Aurelien Jarno <aurel32@debian.org>
Changed-By: Aurelien Jarno <aurel32@debian.org>
Description: 
 eglibc-source - Embedded GNU C Library: sources
 glibc-doc  - GNU C Library: Documentation
 libc0.1    - GNU C Library: Shared libraries
 libc0.1-dbg - GNU C Library: detached debugging symbols
 libc0.1-dev - GNU C Library: Development Libraries and Header Files
 libc0.1-dev-i386 - GNU C Library: 32bit development libraries for AMD64
 libc0.1-i386 - GNU C Library: 32bit shared libraries for AMD64
 libc0.1-i686 - GNU C Library: Shared libraries [i686 optimized]
 libc0.1-pic - GNU C Library: PIC archive library
 libc0.1-prof - GNU C Library: Profiling Libraries
 libc0.1-udeb - GNU C Library: Shared libraries - udeb (udeb)
 libc0.3    - GNU C Library: Shared libraries
 libc0.3-dbg - GNU C Library: detached debugging symbols
 libc0.3-dev - GNU C Library: Development Libraries and Header Files
 libc0.3-pic - GNU C Library: PIC archive library
 libc0.3-prof - GNU C Library: Profiling Libraries
 libc0.3-udeb - GNU C Library: Shared libraries - udeb (udeb)
 libc6      - GNU C Library: Shared libraries
 libc6-amd64 - GNU C Library: 64bit Shared libraries for AMD64
 libc6-dbg  - GNU C Library: detached debugging symbols
 libc6-dev  - GNU C Library: Development Libraries and Header Files
 libc6-dev-amd64 - GNU C Library: 64bit Development Libraries for AMD64
 libc6-dev-i386 - GNU C Library: 32bit development libraries for AMD64
 libc6-dev-mips64 - GNU C Library: 64bit Development Libraries for MIPS64
 libc6-dev-mipsn32 - GNU C Library: n32 Development Libraries for MIPS64
 libc6-dev-powerpc - GNU C Library: 32bit powerpc development libraries for ppc64
 libc6-dev-ppc64 - GNU C Library: 64bit Development Libraries for PowerPC64
 libc6-dev-s390x - GNU C Library: 64bit Development Libraries for IBM zSeries
 libc6-dev-sparc64 - GNU C Library: 64bit Development Libraries for UltraSPARC
 libc6-i386 - GNU C Library: 32bit shared libraries for AMD64
 libc6-i686 - GNU C Library: Shared libraries [i686 optimized]
 libc6-mips64 - GNU C Library: 64bit Shared libraries for MIPS64
 libc6-mipsn32 - GNU C Library: n32 Shared libraries for MIPS64
 libc6-pic  - GNU C Library: PIC archive library
 libc6-powerpc - GNU C Library: 32bit powerpc shared libraries for ppc64
 libc6-ppc64 - GNU C Library: 64bit Shared libraries for PowerPC64
 libc6-prof - GNU C Library: Profiling Libraries
 libc6-s390x - GNU C Library: 64bit Shared libraries for IBM zSeries
 libc6-sparc64 - GNU C Library: 64bit Shared libraries for UltraSPARC
 libc6-sparcv9b - GNU C Library: Shared libraries [v9b optimized]
 libc6-udeb - GNU C Library: Shared libraries - udeb (udeb)
 libc6-xen  - GNU C Library: Shared libraries [Xen version]
 libc6.1    - GNU C Library: Shared libraries
 libc6.1-alphaev67 - GNU C Library: Shared libraries (EV67 optimized)
 libc6.1-dbg - GNU C Library: detached debugging symbols
 libc6.1-dev - GNU C Library: Development Libraries and Header Files
 libc6.1-pic - GNU C Library: PIC archive library
 libc6.1-prof - GNU C Library: Profiling Libraries
 libc6.1-udeb - GNU C Library: Shared libraries - udeb (udeb)
 libnss-dns-udeb - GNU C Library: NSS helper for DNS - udeb (udeb)
 libnss-files-udeb - GNU C Library: NSS helper for files - udeb (udeb)
 locales    - GNU C Library: National Language (locale) data [support]
 locales-all - GNU C Library: Precompiled locale data
 nscd       - GNU C Library: Name Service Cache Daemon
Closes: 527541
Changes: 
 eglibc (2.9-12) unstable; urgency=low
 .
   [ Petr Salinger ]
   * kfreebsd/local-sysdeps.diff: update to revision 2503 (from glibc-bsd).
 .
   [ Aurelien Jarno ]
   * any/local-revert-3270.diff: new patch to revert fix for PR nptl/3270.
     (closes: bug#527541).
Checksums-Sha1: 
 634e1f44fd7763214889fc3ec85a62e1caf2d14a 2662 eglibc_2.9-12.dsc
 f1179a8383b1837baedc9b1e9c9d1fe821900a1a 739283 eglibc_2.9-12.diff.gz
 c8fd5be4f1d8f0334cde2030ab11861dfc9188ee 1671408 glibc-doc_2.9-12_all.deb
 7d575cf0a180465a8484c5bc7d02308b39b99a5b 11202620 eglibc-source_2.9-12_all.deb
 8f5af42ec453fa5af8d1a225ec0f2608be90a797 4662114 locales_2.9-12_all.deb
 e71bb4109b4837cc9fa59503d97e60b75f260cca 4937914 libc6_2.9-12_amd64.deb
 e53950a2ef836870613ea87eba81781285604f8d 2527688 libc6-dev_2.9-12_amd64.deb
 e1a9c3faa242664ad09c8c3dff758dc40604ff7b 1951960 libc6-prof_2.9-12_amd64.deb
 e7acd9b4fff65960c933aaf274bbc0a13dfb1413 1487620 libc6-pic_2.9-12_amd64.deb
 aff380ceacda1aef91e7c402b9dc6e862d1d17be 2961284 locales-all_2.9-12_amd64.deb
 6400748d8d06c1f317cd256e06fd1ce3bdb19905 3752444 libc6-i386_2.9-12_amd64.deb
 abc9ff9db8984a1dc868228032d6f126813b82f8 1506028 libc6-dev-i386_2.9-12_amd64.deb
 0521c3d9a62ca4a9408c0ad92fd719ba4e38e285 186242 nscd_2.9-12_amd64.deb
 c0b79e2ea4f0ee3b1d61fbc079ec37636c6d79e1 10617182 libc6-dbg_2.9-12_amd64.deb
 0d5a7d42d442586829034f4ecf2acffc58be921f 1117060 libc6-udeb_2.9-12_amd64.udeb
 ab45b3d9207393b543aa73c876055d5ec58cf96c 10834 libnss-dns-udeb_2.9-12_amd64.udeb
 e2060e17ded164f9040f1b2c1bd98144cbc7cba9 18782 libnss-files-udeb_2.9-12_amd64.udeb
Checksums-Sha256: 
 9bd36798307bb756cb0807ca5762001044235420f0d997cf9b059aad9d5b9023 2662 eglibc_2.9-12.dsc
 9006b2350ef8c6a1162217ee47b72a82a5ee6716754a9bb3db07ba2d52cad40e 739283 eglibc_2.9-12.diff.gz
 47a8aba314a6c4596964d819bd1cd677af4685f8a2bca6bf0894ddde32a56b65 1671408 glibc-doc_2.9-12_all.deb
 7b5a2ced128f95d96bf5bd705837e9000766c9f3af2eaed9c592fe86122852d8 11202620 eglibc-source_2.9-12_all.deb
 c84510eac0ba1cdcfa269eca30fce01f863de22df79d323528775cfc91cf3a29 4662114 locales_2.9-12_all.deb
 0e5ef364693e2062a15960066984451b83af79e20d0df04ef6ddb63e72f23f0d 4937914 libc6_2.9-12_amd64.deb
 65ff1f071bfaca2c86536ca2606581223af2f3734385026bfda1d4a22c974754 2527688 libc6-dev_2.9-12_amd64.deb
 32b78534f34c0f6c188d458a98f2d4802b8d3156f715d62a60f7f29dd0ddd573 1951960 libc6-prof_2.9-12_amd64.deb
 febb60fbb3b56212896b2b5dde3962f177f3fbceeec0bd3561723a2a868abd46 1487620 libc6-pic_2.9-12_amd64.deb
 ee9b34bab0049d53a190cee07a9c2487514c056f62e5485f1b443948b59867ad 2961284 locales-all_2.9-12_amd64.deb
 c809a469cb85912e3cfac1dfa9d5104bf1ac12c64d1a7e06ce01d19a3ff3326e 3752444 libc6-i386_2.9-12_amd64.deb
 f9a050ad0a2f887d7818730f39d472756e3ba6bf00bf99ef50732b9b8f59c6b4 1506028 libc6-dev-i386_2.9-12_amd64.deb
 86912248a96d2b5d99557e2ca5315182cf8c12075a61cf153d724f3ba7c5b933 186242 nscd_2.9-12_amd64.deb
 e0c61a295d87b0f25ab7ce4149a313c962e76d9f0839118d8142645f9d0d179b 10617182 libc6-dbg_2.9-12_amd64.deb
 ff9fdd45a34258c6fe235063ac8aaa2fb229fb50ea69a7aed16401f4715cb45d 1117060 libc6-udeb_2.9-12_amd64.udeb
 4cae53c8bb8b8d3cf301982013d22681cbf47bc87fb690d37c91d2977e479209 10834 libnss-dns-udeb_2.9-12_amd64.udeb
 aef9b2b7eda66849a6715d4e24c7cad5fffd2bc22f148a74aa8026290f53d149 18782 libnss-files-udeb_2.9-12_amd64.udeb
Files: 
 0f627217141cabf58839d40b24d8dad8 2662 libs required eglibc_2.9-12.dsc
 6bf058119917ef7ec5905512b1b94595 739283 libs required eglibc_2.9-12.diff.gz
 e7f06f42a36642021e286e98648a9b6e 1671408 doc optional glibc-doc_2.9-12_all.deb
 0745b46a25048f9705f2c36834207b99 11202620 devel optional eglibc-source_2.9-12_all.deb
 acd1d9de5fc333a1b861888e9499a487 4662114 libs standard locales_2.9-12_all.deb
 b0554a9826b4bb0319a38fac6caf36cc 4937914 libs required libc6_2.9-12_amd64.deb
 a1dd6540fe00fbe4ab175e0b62c42dc4 2527688 libdevel optional libc6-dev_2.9-12_amd64.deb
 8e3282a5fe06371ae10aca4f8e25f318 1951960 libdevel extra libc6-prof_2.9-12_amd64.deb
 dd13df04fe527b58ed99df92b7efcfd1 1487620 libdevel optional libc6-pic_2.9-12_amd64.deb
 8f844f183c63018b5065d0ef235fa0ad 2961284 libs extra locales-all_2.9-12_amd64.deb
 be4199d15f352e22f3cf24d17d7a7bad 3752444 libs optional libc6-i386_2.9-12_amd64.deb
 c964bfe35bd45ab2f47c7cae3069c1ee 1506028 libdevel optional libc6-dev-i386_2.9-12_amd64.deb
 93b294c2412e8a73a06c33005a009e88 186242 admin optional nscd_2.9-12_amd64.deb
 6bbd4240fa248a17a5b19bfea8a3fd0b 10617182 debug extra libc6-dbg_2.9-12_amd64.deb
 6307d3ef0d58e6d75164fc17bedfd19a 1117060 debian-installer extra libc6-udeb_2.9-12_amd64.udeb
 26629676a3ac725771a0620dab292bd4 10834 debian-installer extra libnss-dns-udeb_2.9-12_amd64.udeb
 b5f261ee07f676d782ecded26a9dd7d1 18782 debian-installer extra libnss-files-udeb_2.9-12_amd64.udeb
Package-Type: udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFKBB0xw3ao2vG823MRAmYcAJ9gQ9YIkcD+YytWsh1TF/7prdciPACfT6sV
L0Sw5TMBa4q7ntIZ+eVE/UE=
=AAW/
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 14:48:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dai <dai@bickham.freeserve.co.uk>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 14:48:07 GMT) Full text and rfc822 format available.

Message #47 received at 527541@bugs.debian.org (full text, mbox):

From: Dai <dai@bickham.freeserve.co.uk>
To: 527541@bugs.debian.org
Subject: libc6 bug
Date: Fri, 08 May 2009 15:44:19 +0100
I have no issues with libc6_2.9-11 with iceweasel . . . I have seen 
others with / without the problem . . .
. . . but I can't save attachments in icedove or forward e-mails from 
icedove. Going back to libc6/testing and everything is fine

drb




Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 16:33:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Andreas Juch <debbugs@juch.cc>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Fri, 08 May 2009 16:33:05 GMT) Full text and rfc822 format available.

Message #52 received at 527541@bugs.debian.org (full text, mbox):

From: Andreas Juch <debbugs@juch.cc>
To: 527541@bugs.debian.org
Subject: Problem solved for me
Date: Fri, 8 May 2009 18:28:15 +0200
[Message part 1 (text/plain, inline)]
Hi!

I just wanted to let you know that I was affected by this bug (AMD64
system) and the update to libc6 2.9-12 solved the problem.

Thanks,
Andreas Juch
[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, josh@freedesktop.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#527541; Package libc6. (Fri, 08 May 2009 21:48:47 GMT) Full text and rfc822 format available.

Message #55 received at 527541@bugs.debian.org (full text, mbox):

From: Josh Triplett <josh@freedesktop.org>
To: Debian Bug Tracking System <527541@bugs.debian.org>
Subject: libc6: Additional confirmation
Date: Fri, 08 May 2009 14:32:30 -0700
Package: libc6
Severity: normal

I can confirm this as well: after upgrading to 2.9-11, iceweasel failed
to start, though it would start if run with -safe-mode.  After upgrading
to 2.9-12, iceweasel works again.

- Josh Triplett

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libc6 depends on:
ii  libgcc1                       1:4.4.0-4  GCC support library

libc6 recommends no packages.

Versions of packages libc6 suggests:
ii  glibc-doc                     2.9-12     GNU C Library: Documentation
ii  locales                       2.9-12     GNU C Library: National Language (

-- debconf information excluded




Tags added: pending Request was from Aurelien Jarno <aurel32@alioth.debian.org> to control@bugs.debian.org. (Sat, 09 May 2009 22:16:23 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 07 Jun 2009 07:32:59 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 00:32:31 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.