Debian Bug report logs - #526999
clive: support installation without depends on libterm-progressbar-perl?

version graph

Package: clive; Maintainer for clive is Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>; Source for clive is src:clive.

Reported by: Michael Prokop <mika@grml.org>

Date: Mon, 4 May 2009 21:09:01 UTC

Severity: wishlist

Found in version clive/2.1.11-1

Fixed in version clive/2.1.11-2

Done: Damyan Ivanov <dmn@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#526999; Package clive. (Mon, 04 May 2009 21:09:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Prokop <mika@grml.org>:
New Bug report received and forwarded. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Mon, 04 May 2009 21:09:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Michael Prokop <mika@grml.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: clive: support installation without depends on libterm-progressbar-perl?
Date: Mon, 04 May 2009 23:07:49 +0200
Package: clive
Version: 2.1.11-1
Severity: wishlist


Depends of clive:

# apt-cache show clive | grep Depends
Depends: perl, libconfig-tiny-perl (>= 2.12), libwww-curl-perl (>= 4.05), libhtml-parser-perl (>= 2.37), libterm-progressbar-perl (>= 2.09), libberkeleydb-perl (>= 0.34), liburi-perl (>= 1.37), libexpect-perl (>= 1.20), libterm-readkey-perl, perl (>= 5.10) | libdigest-sha-perl

whereas libterm-progressbar-perl depends on:

# apt-cache show libterm-progressbar-perl | grep Depends
Depends: perl (>= 5.6.0-16), libclass-methodmaker-perl, libterm-readkey-perl

... now libclass-methodmaker-perl is a pretty huge package:

# apt-cache show libclass-methodmaker-perl | grep Size
Installed-Size: 22568
Size: 498768

Is there any chance that the progressbar of clive becomes optional
and the dependeny on libterm-progressbar-perl could become a
recommends/suggest?

thx && regards,
-mika-




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#526999; Package clive. (Tue, 05 May 2009 08:00:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Toni Gundogdu <legatvs@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Tue, 05 May 2009 08:00:07 GMT) Full text and rfc822 format available.

Message #10 received at 526999@bugs.debian.org (full text, mbox):

From: Toni Gundogdu <legatvs@gmail.com>
To: Michael Prokop <mika@grml.org>, 526999@bugs.debian.org
Subject: Re: Bug#526999: clive: support installation without depends on libterm-progressbar-perl?
Date: Tue, 5 May 2009 10:59:00 +0300
On Tue, May 5, 2009 at 12:07 AM, Michael Prokop <mika@grml.org> wrote:
> Package: clive
> Version: 2.1.11-1
> Severity: wishlist
>
>
> Depends of clive:
>
> # apt-cache show clive | grep Depends
> Depends: perl, libconfig-tiny-perl (>= 2.12), libwww-curl-perl (>= 4.05), libhtml-parser-perl (>= 2.37), libterm-progressbar-perl (>= 2.09), libberkeleydb-perl (>= 0.34), liburi-perl (>= 1.37), libexpect-perl (>= 1.20), libterm-readkey-perl, perl (>= 5.10) | libdigest-sha-perl
>
> whereas libterm-progressbar-perl depends on:
>
> # apt-cache show libterm-progressbar-perl | grep Depends
> Depends: perl (>= 5.6.0-16), libclass-methodmaker-perl, libterm-readkey-perl
>
> ... now libclass-methodmaker-perl is a pretty huge package:
>
> # apt-cache show libclass-methodmaker-perl | grep Size
> Installed-Size: 22568
> Size: 498768
>
> Is there any chance that the progressbar of clive becomes optional
> and the dependeny on libterm-progressbar-perl could become a
> recommends/suggest?

Term::Progressbar (libterm-progressbar-perl) hasn't been a
prerequisite since 2.1.0.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>:
Bug#526999; Package clive. (Tue, 05 May 2009 15:15:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ryan Niebur <ryanryan52@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>. (Tue, 05 May 2009 15:15:02 GMT) Full text and rfc822 format available.

Message #15 received at 526999@bugs.debian.org (full text, mbox):

From: Ryan Niebur <ryanryan52@gmail.com>
To: Toni Gundogdu <legatvs@gmail.com>, 526999@bugs.debian.org
Cc: Michael Prokop <mika@grml.org>
Subject: Re: Bug#526999: clive: support installation without depends on libterm-progressbar-perl?
Date: Tue, 5 May 2009 08:13:36 -0700
[Message part 1 (text/plain, inline)]
tag 526999 pending confirmed
quit

On Tue, May 05, 2009 at 10:59:00AM +0300, Toni Gundogdu wrote:
> 
> Term::Progressbar (libterm-progressbar-perl) hasn't been a
> prerequisite since 2.1.0.
> 

ok, thanks, removed the dependency in the git repo.

-- 
_________________________
Ryan Niebur
ryanryan52@gmail.com
[signature.asc (application/pgp-signature, inline)]

Reply sent to Damyan Ivanov <dmn@debian.org>:
You have taken responsibility. (Thu, 07 May 2009 09:27:09 GMT) Full text and rfc822 format available.

Notification sent to Michael Prokop <mika@grml.org>:
Bug acknowledged by developer. (Thu, 07 May 2009 09:27:09 GMT) Full text and rfc822 format available.

Message #20 received at 526999-close@bugs.debian.org (full text, mbox):

From: Damyan Ivanov <dmn@debian.org>
To: 526999-close@bugs.debian.org
Subject: Bug#526999: fixed in clive 2.1.11-2
Date: Thu, 07 May 2009 09:19:26 +0000
Source: clive
Source-Version: 2.1.11-2

We believe that the bug you reported is fixed in the latest version of
clive, which is due to be installed in the Debian FTP archive:

clive_2.1.11-2.diff.gz
  to pool/main/c/clive/clive_2.1.11-2.diff.gz
clive_2.1.11-2.dsc
  to pool/main/c/clive/clive_2.1.11-2.dsc
clive_2.1.11-2_all.deb
  to pool/main/c/clive/clive_2.1.11-2_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 526999@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Damyan Ivanov <dmn@debian.org> (supplier of updated clive package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 07 May 2009 11:39:26 +0300
Source: clive
Binary: clive
Architecture: source all
Version: 2.1.11-2
Distribution: unstable
Urgency: low
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Changed-By: Damyan Ivanov <dmn@debian.org>
Description: 
 clive      - Video extraction utility for YouTube, Google Video and others
Closes: 526999
Changes: 
 clive (2.1.11-2) unstable; urgency=low
 .
   [ Ryan Niebur ]
   * remove unneeded libterm-progressbar-perl dependency (Closes:
     #526999)
Checksums-Sha1: 
 f4a68aa458f802efa0544745d2ac78eda8bc7c1e 1457 clive_2.1.11-2.dsc
 1e9c789943c784beb14f5f10029938a25b16695d 4703 clive_2.1.11-2.diff.gz
 c830257776e23f07493a329edbcacf7775418f12 36052 clive_2.1.11-2_all.deb
Checksums-Sha256: 
 dffbe3027ee572b0872fa0d30069e600a99793b01df096f2be759091e0a1b64d 1457 clive_2.1.11-2.dsc
 1e423f6c87b1056a760f54f6c31f10c782f94845cd92903ad1094bbfaea080f3 4703 clive_2.1.11-2.diff.gz
 563e7054973763e377e6a2d52c967f025e575e74e16b936d2a39496c2f8e4d24 36052 clive_2.1.11-2_all.deb
Files: 
 0e68539257510085e91b78613e5e0d83 1457 utils optional clive_2.1.11-2.dsc
 2c30d70ed28b8aee78f9df51a033c385 4703 utils optional clive_2.1.11-2.diff.gz
 2010b74a4dd320dcafe59150d1fd4008 36052 utils optional clive_2.1.11-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkoCn0sACgkQHqjlqpcl9jtBRgCfY3RSXv4mdlQKg3FnVSZWCcTi
wQIAn3Pc+XXyhtpCA/CAQp2Mn9EIVH+u
=77A7
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 05 Jun 2009 07:40:11 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 13:10:02 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.