Debian Bug report logs - #525190
Drop perl >= 5.6 from (Build-|)Depends requirements

version graph

Package: debian-policy; Maintainer for debian-policy is Debian Policy List <debian-policy@lists.debian.org>; Source for debian-policy is src:debian-policy.

Reported by: Cyril Brulebois <kibi@debian.org>

Date: Wed, 22 Apr 2009 19:51:01 UTC

Severity: wishlist

Found in version debian-policy/3.8.1.0

Fixed in version debian-policy/3.8.3.0

Done: Russ Allbery <rra@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Wed, 22 Apr 2009 19:51:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Cyril Brulebois <kibi@debian.org>:
New Bug report received and forwarded. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Wed, 22 Apr 2009 19:51:03 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Cyril Brulebois <kibi@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Wed, 22 Apr 2009 21:50:30 +0200
[Message part 1 (text/plain, inline)]
Package: debian-policy
Version: 3.8.1.0
Severity: wishlist
Tags: patch

As discussed on -devel & -policy, here's a patch to stop mentioning perl
5.6 in Depends and Build-Depends.

A reference to 5.6 remains in the “Perl 6” part, though.

Attaching the result of git format-patch against master (git am is your
friend).

Mraw,
KiBi.
[0001-Drop-build-dependencies-on-perl-5.6.0-16.patch (text/plain, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Sat, 20 Jun 2009 04:09:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Russ Allbery <rra@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Sat, 20 Jun 2009 04:09:02 GMT) Full text and rfc822 format available.

Message #10 received at 525190@bugs.debian.org (full text, mbox):

From: Russ Allbery <rra@debian.org>
To: Cyril Brulebois <kibi@debian.org>
Cc: 525190@bugs.debian.org
Subject: Re: Bug#525190: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Fri, 19 Jun 2009 21:03:19 -0700
Cyril Brulebois <kibi@debian.org> writes:

> From: Cyril Brulebois <kibi@debian.org>
> Date: Wed, 22 Apr 2009 21:40:50 +0200
> Subject: [PATCH] Drop (build|) dependencies on perl (>= 5.6.0-16).
>
> This version of perl is so obsolete that dropping any reference to it
> makes sense (even oldstable has perl 5.8).
> ---
>  perl-policy.sgml |   11 -----------
>  1 files changed, 0 insertions(+), 11 deletions(-)
>
> diff --git a/perl-policy.sgml b/perl-policy.sgml
> index 1421b46..1d26df7 100644
> --- a/perl-policy.sgml
> +++ b/perl-policy.sgml
> @@ -319,10 +319,6 @@ $(MAKE) install PREFIX=$(CURDIR)/debian/&lt;tmp&gt;/usr
>  	    (nominally just tmp)</p>
>  	  </footnote>
>  	</p>
> -	<p>
> -	  A <tt>Build-Depends</tt> on <tt>perl (>= 5.6.0-16)</tt> is
> -	  required.
> -	</p>
>        </sect>
>  
>        <sect id="module_deps">
> @@ -342,13 +338,6 @@ $(MAKE) install PREFIX=$(CURDIR)/debian/&lt;tmp&gt;/usr
>  	    the minimum required version, or more simply the current
>  	    version.
>  	  </p>
> -	  <p>
> -	    In the absence of an explicit requirement,
> -	    architecture-independent modules must depend on a minimum
> -	    <package>perl</package> or <package>perl-base</package>
> -	    version of <tt>5.6.0-16</tt> due to the changes in
> -	    <tt>@INC</tt> introduced by that version.
> -	  </p>
>  	</sect1>
>  
>  	<sect1 id="binary_modules">

Seconded.  (Sorry about the long delay in review.)

This patch needs one more second to be queued for the next release of
Policy.

-- 
Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>




Changed Bug title to `Drop perl >= 5.6 from (Build-|)Depends requirements' from `debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements'. Request was from Russ Allbery <rra@debian.org> to control@bugs.debian.org. (Sat, 20 Jun 2009 05:42:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Sat, 20 Jun 2009 11:39:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr>:
Extra info received and forwarded to list. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Sat, 20 Jun 2009 11:39:02 GMT) Full text and rfc822 format available.

Message #17 received at 525190@bugs.debian.org (full text, mbox):

From: Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr>
To: Russ Allbery <rra@debian.org>, 525190@bugs.debian.org
Cc: Cyril Brulebois <kibi@debian.org>
Subject: Re: Bug#525190: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Sat, 20 Jun 2009 13:28:23 +0200
On Fri, Jun 19, 2009 at 09:03:19PM -0700, Russ Allbery wrote:
> Cyril Brulebois <kibi@debian.org> writes:
> 
> > From: Cyril Brulebois <kibi@debian.org>
> > Date: Wed, 22 Apr 2009 21:40:50 +0200
> > Subject: [PATCH] Drop (build|) dependencies on perl (>= 5.6.0-16).
> >
> > This version of perl is so obsolete that dropping any reference to it
> > makes sense (even oldstable has perl 5.8).
> > ---
> >  perl-policy.sgml |   11 -----------
> >  1 files changed, 0 insertions(+), 11 deletions(-)
> >
> > diff --git a/perl-policy.sgml b/perl-policy.sgml
> > index 1421b46..1d26df7 100644
> > --- a/perl-policy.sgml
> > +++ b/perl-policy.sgml
> > @@ -319,10 +319,6 @@ $(MAKE) install PREFIX=$(CURDIR)/debian/&lt;tmp&gt;/usr
> >  	    (nominally just tmp)</p>
> >  	  </footnote>
> >  	</p>
> > -	<p>
> > -	  A <tt>Build-Depends</tt> on <tt>perl (>= 5.6.0-16)</tt> is
> > -	  required.
> > -	</p>
> >        </sect>
> >  
> >        <sect id="module_deps">
> > @@ -342,13 +338,6 @@ $(MAKE) install PREFIX=$(CURDIR)/debian/&lt;tmp&gt;/usr
> >  	    the minimum required version, or more simply the current
> >  	    version.
> >  	  </p>
> > -	  <p>
> > -	    In the absence of an explicit requirement,
> > -	    architecture-independent modules must depend on a minimum
> > -	    <package>perl</package> or <package>perl-base</package>
> > -	    version of <tt>5.6.0-16</tt> due to the changes in
> > -	    <tt>@INC</tt> introduced by that version.
> > -	  </p>
> >  	</sect1>
> >  
> >  	<sect1 id="binary_modules">
> 
> Seconded.  (Sorry about the long delay in review.)

I agree that the requirement for >= 5.6.0-16 should be removed but
probably the requirement for 'Build-Depends: perl' should be kept ?
Or maybe I am missing the big picture ?

Cheers,
-- 
Bill. <ballombe@debian.org>

Imagine a large red swirl here. 




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Sat, 20 Jun 2009 12:45:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Kurt Roeckx <kurt@roeckx.be>:
Extra info received and forwarded to list. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Sat, 20 Jun 2009 12:45:02 GMT) Full text and rfc822 format available.

Message #22 received at 525190@bugs.debian.org (full text, mbox):

From: Kurt Roeckx <kurt@roeckx.be>
To: Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr>, 525190@bugs.debian.org
Cc: Russ Allbery <rra@debian.org>, Cyril Brulebois <kibi@debian.org>
Subject: Re: Bug#525190: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Sat, 20 Jun 2009 14:29:27 +0200
On Sat, Jun 20, 2009 at 01:28:23PM +0200, Bill Allombert wrote:
> On Fri, Jun 19, 2009 at 09:03:19PM -0700, Russ Allbery wrote:
> > Cyril Brulebois <kibi@debian.org> writes:
> > 
> > > From: Cyril Brulebois <kibi@debian.org>
> > > Date: Wed, 22 Apr 2009 21:40:50 +0200
> > > Subject: [PATCH] Drop (build|) dependencies on perl (>= 5.6.0-16).
> > >
> > > This version of perl is so obsolete that dropping any reference to it
> > > makes sense (even oldstable has perl 5.8).
> > > ---
> > >  perl-policy.sgml |   11 -----------
> > >  1 files changed, 0 insertions(+), 11 deletions(-)
> > >
> > > diff --git a/perl-policy.sgml b/perl-policy.sgml
> > > index 1421b46..1d26df7 100644
> > > --- a/perl-policy.sgml
> > > +++ b/perl-policy.sgml
> > > @@ -319,10 +319,6 @@ $(MAKE) install PREFIX=$(CURDIR)/debian/&lt;tmp&gt;/usr
> > >  	    (nominally just tmp)</p>
> > >  	  </footnote>
> > >  	</p>
> > > -	<p>
> > > -	  A <tt>Build-Depends</tt> on <tt>perl (>= 5.6.0-16)</tt> is
> > > -	  required.
> > > -	</p>
> > >        </sect>
> > >  
> > >        <sect id="module_deps">
> > > @@ -342,13 +338,6 @@ $(MAKE) install PREFIX=$(CURDIR)/debian/&lt;tmp&gt;/usr
> > >  	    the minimum required version, or more simply the current
> > >  	    version.
> > >  	  </p>
> > > -	  <p>
> > > -	    In the absence of an explicit requirement,
> > > -	    architecture-independent modules must depend on a minimum
> > > -	    <package>perl</package> or <package>perl-base</package>
> > > -	    version of <tt>5.6.0-16</tt> due to the changes in
> > > -	    <tt>@INC</tt> introduced by that version.
> > > -	  </p>
> > >  	</sect1>
> > >  
> > >  	<sect1 id="binary_modules">
> > 
> > Seconded.  (Sorry about the long delay in review.)
> 
> I agree that the requirement for >= 5.6.0-16 should be removed but
> probably the requirement for 'Build-Depends: perl' should be kept ?
> Or maybe I am missing the big picture ?

perl is build essential.  dpkg-dev depends on it.


Kurt





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Sat, 20 Jun 2009 16:33:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Russ Allbery <rra@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Sat, 20 Jun 2009 16:33:05 GMT) Full text and rfc822 format available.

Message #27 received at 525190@bugs.debian.org (full text, mbox):

From: Russ Allbery <rra@debian.org>
To: 525190@bugs.debian.org, Cyril Brulebois <kibi@debian.org>
Subject: Re: Bug#525190: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Sat, 20 Jun 2009 09:32:08 -0700
Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr> writes:

> I agree that the requirement for >= 5.6.0-16 should be removed but
> probably the requirement for 'Build-Depends: perl' should be kept ?
> Or maybe I am missing the big picture ?

There's earlier text in the same section outside the context range that
requires a dependency on perl if the module uses any of the modules
provided by the perl packages.

-- 
Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Sat, 20 Jun 2009 17:15:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Russ Allbery <rra@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Sat, 20 Jun 2009 17:15:04 GMT) Full text and rfc822 format available.

Message #32 received at 525190@bugs.debian.org (full text, mbox):

From: Russ Allbery <rra@debian.org>
To: 525190@bugs.debian.org
Cc: Cyril Brulebois <kibi@debian.org>
Subject: Re: Bug#525190: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Sat, 20 Jun 2009 10:13:11 -0700
Russ Allbery <rra@debian.org> writes:
> Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr> writes:

>> I agree that the requirement for >= 5.6.0-16 should be removed but
>> probably the requirement for 'Build-Depends: perl' should be kept ?
>> Or maybe I am missing the big picture ?

> There's earlier text in the same section outside the context range that
> requires a dependency on perl if the module uses any of the modules
> provided by the perl packages.

Oh, sorry, I misunderstood your comment.  You're talking about the
build-depend part.  Yeah, this means there's no explicit statement
saying that a Perl module must build-depend on perl, but dpkg-dev
depends on perl so it's pseudo-build-essential.  Plus, I would hope that
would be obvious, since Perl is used during the build process, that a
dependency on perl is required.

-- 
Russ Allbery (rra@debian.org)               <http://www.eyrie.org/~eagle/>




Tags set to: pending Request was from Russ Allbery <rra@debian.org> to control@bugs.debian.org. (Sat, 20 Jun 2009 17:18:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Sat, 20 Jun 2009 19:51:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Steve Langasek <vorlon@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Sat, 20 Jun 2009 19:51:02 GMT) Full text and rfc822 format available.

Message #39 received at 525190@bugs.debian.org (full text, mbox):

From: Steve Langasek <vorlon@debian.org>
To: Kurt Roeckx <kurt@roeckx.be>, 525190@bugs.debian.org
Cc: Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr>, Russ Allbery <rra@debian.org>, Cyril Brulebois <kibi@debian.org>
Subject: Re: Bug#525190: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Sat, 20 Jun 2009 12:47:34 -0700
On Sat, Jun 20, 2009 at 02:29:27PM +0200, Kurt Roeckx wrote:
> perl is build essential.  dpkg-dev depends on it.

dpkg-dev's dependency on perl is an implementation detail, not a guaranteed
build-essential interface.
-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Sat, 20 Jun 2009 20:24:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Kurt Roeckx <kurt@roeckx.be>:
Extra info received and forwarded to list. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Sat, 20 Jun 2009 20:24:04 GMT) Full text and rfc822 format available.

Message #44 received at 525190@bugs.debian.org (full text, mbox):

From: Kurt Roeckx <kurt@roeckx.be>
To: Steve Langasek <vorlon@debian.org>
Cc: 525190@bugs.debian.org, Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr>, Russ Allbery <rra@debian.org>, Cyril Brulebois <kibi@debian.org>
Subject: Re: Bug#525190: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Sat, 20 Jun 2009 22:19:24 +0200
On Sat, Jun 20, 2009 at 12:47:34PM -0700, Steve Langasek wrote:
> On Sat, Jun 20, 2009 at 02:29:27PM +0200, Kurt Roeckx wrote:
> > perl is build essential.  dpkg-dev depends on it.
> 
> dpkg-dev's dependency on perl is an implementation detail, not a guaranteed
> build-essential interface.

That might be, but that doesn't mean alot of packages don't
depend on the current behaviour.


Kurt





Information forwarded to debian-bugs-dist@lists.debian.org, Debian Policy List <debian-policy@lists.debian.org>:
Bug#525190; Package debian-policy. (Sun, 21 Jun 2009 21:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr>:
Extra info received and forwarded to list. Copy sent to Debian Policy List <debian-policy@lists.debian.org>. (Sun, 21 Jun 2009 21:21:03 GMT) Full text and rfc822 format available.

Message #49 received at 525190@bugs.debian.org (full text, mbox):

From: Bill Allombert <Bill.Allombert@math.u-bordeaux1.fr>
To: Russ Allbery <rra@debian.org>, 525190@bugs.debian.org
Cc: Cyril Brulebois <kibi@debian.org>
Subject: Re: Bug#525190: debian-policy: Please drop perl >= 5.6 from (Build-|)Depends requirements
Date: Sun, 21 Jun 2009 23:10:49 +0200
[Message part 1 (text/plain, inline)]
On Fri, Jun 19, 2009 at 09:03:19PM -0700, Russ Allbery wrote:
> Cyril Brulebois <kibi@debian.org> writes:
> 
> > From: Cyril Brulebois <kibi@debian.org>
> > Date: Wed, 22 Apr 2009 21:40:50 +0200
> > Subject: [PATCH] Drop (build|) dependencies on perl (>= 5.6.0-16).
> >
> > This version of perl is so obsolete that dropping any reference to it
> > makes sense (even oldstable has perl 5.8).
> > ---
> >  perl-policy.sgml |   11 -----------
> >  1 files changed, 0 insertions(+), 11 deletions(-)
> >
> > diff --git a/perl-policy.sgml b/perl-policy.sgml
> > index 1421b46..1d26df7 100644
> > --- a/perl-policy.sgml
> > +++ b/perl-policy.sgml
> > @@ -319,10 +319,6 @@ $(MAKE) install PREFIX=$(CURDIR)/debian/&lt;tmp&gt;/usr
> >  	    (nominally just tmp)</p>
> >  	  </footnote>
> >  	</p>
> > -	<p>
> > -	  A <tt>Build-Depends</tt> on <tt>perl (>= 5.6.0-16)</tt> is
> > -	  required.
> > -	</p>
> >        </sect>
> >  
> >        <sect id="module_deps">
> > @@ -342,13 +338,6 @@ $(MAKE) install PREFIX=$(CURDIR)/debian/&lt;tmp&gt;/usr
> >  	    the minimum required version, or more simply the current
> >  	    version.
> >  	  </p>
> > -	  <p>
> > -	    In the absence of an explicit requirement,
> > -	    architecture-independent modules must depend on a minimum
> > -	    <package>perl</package> or <package>perl-base</package>
> > -	    version of <tt>5.6.0-16</tt> due to the changes in
> > -	    <tt>@INC</tt> introduced by that version.
> > -	  </p>
> >  	</sect1>
> >  
> >  	<sect1 id="binary_modules">
> 
> Seconded.  (Sorry about the long delay in review.)

Seconded. I made a comment about the need to Build-Depends on perl, but
the perl policy does not have to mention that since it is required by the
Debian policy anyway.

Cheers,
-- 
Bill. <ballombe@debian.org>

Imagine a large red swirl here. 
[signature.asc (application/pgp-signature, inline)]

Reply sent to Russ Allbery <rra@debian.org>:
You have taken responsibility. (Sun, 16 Aug 2009 01:00:40 GMT) Full text and rfc822 format available.

Notification sent to Cyril Brulebois <kibi@debian.org>:
Bug acknowledged by developer. (Sun, 16 Aug 2009 01:00:41 GMT) Full text and rfc822 format available.

Message #54 received at 525190-close@bugs.debian.org (full text, mbox):

From: Russ Allbery <rra@debian.org>
To: 525190-close@bugs.debian.org
Subject: Bug#525190: fixed in debian-policy 3.8.3.0
Date: Sun, 16 Aug 2009 00:32:08 +0000
Source: debian-policy
Source-Version: 3.8.3.0

We believe that the bug you reported is fixed in the latest version of
debian-policy, which is due to be installed in the Debian FTP archive:

debian-policy_3.8.3.0.dsc
  to pool/main/d/debian-policy/debian-policy_3.8.3.0.dsc
debian-policy_3.8.3.0.tar.gz
  to pool/main/d/debian-policy/debian-policy_3.8.3.0.tar.gz
debian-policy_3.8.3.0_all.deb
  to pool/main/d/debian-policy/debian-policy_3.8.3.0_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 525190@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Russ Allbery <rra@debian.org> (supplier of updated debian-policy package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sat, 15 Aug 2009 17:13:26 -0700
Source: debian-policy
Binary: debian-policy
Architecture: source all
Version: 3.8.3.0
Distribution: unstable
Urgency: low
Maintainer: Debian Policy List <debian-policy@lists.debian.org>
Changed-By: Russ Allbery <rra@debian.org>
Description: 
 debian-policy - Debian Policy Manual and related documents
Closes: 493007 514919 519941 522217 525190 527871 529771 530967 533577 533852 534408 537707 538665 539389 541537
Changes: 
 debian-policy (3.8.3.0) unstable; urgency=low
 .
   * Policy: Bring Architecture description in line with dpkg-source
     Wording: Russ Allbery <rra@debian.org>
     Seconded: Raphael Hertzog <hertzog@debian.org>
     Seconded: Manoj Srivastava <srivasta@debian.org>
     Closes: #530967
   * Policy: Update information about DEB_*_ARCH variables
     Wording: Guillem Jover <guillem@debian.org>
     Seconded: Russ Allbery <rra@debian.org>
     Seconded: Andrew McMillan <andrew@morphoss.com>
     Closes: #527871
   * Policy: Remove support for uploads to multiple distributions
     Wording: Russ Allbery <rra@debian.org>
     Seconded: Raphael Hertzog <hertzog@debian.org>
     Seconded: Manoj Srivastava <srivasta@debian.org>
     Closes: #514919
   * Policy: Remove permission for packages to modify ld.so.conf
     Wording: Steve Langasek <vorlon@debian.org>
     Seconded: Russ Allbery <rra@debian.org>
     Seconded: Kurt Roeckx <kurt@roeckx.be>
     Seconded: Adeodato Simó <dato@net.com.org.es>
     Seconded: Julien Cristau <jcristau@debian.org>
     Closes: #519941
   * Policy: Clarify X installation directory handling
     Wording: Russ Allbery <rra@debian.org>
     Seconded: Julien Cristau <jcristau@debian.org>
     Seconded: Manoj Srivastava <srivasta@debian.org>
     Seconded: Raphaël Hertzog <hertzog@debian.org>
     Closes: #522217
   * Policy: Localized man pages should be up-to-date or warn
     Wording: Russ Allbery <rra@debian.org>
     Seconded: Julien Cristau <jcristau@debian.org>
     Seconded: Raphaël Hertzog <hertzog@debian.org>
     Closes: #493007
   * Policy: Remove restriction on manual page character encoding
     Wording: Colin Watson <cjwatson@debian.org>
     Seconded: Russ Allbery <rra@debian.org>
     Seconded: Manoj Srivastava <srivasta@golden-gryphon.com>
     Closes: #537707
   * Policy: Allow Binary field to span multiple lines
     Wording: Russ Allbery <rra@debian.org>
     Seconded: Julien Cristau <jcristau@debian.org>
     Seconded: Guillem Jover <guillem@debian.org>
     Closes: #533852
   * Policy: Revise info requirements for triggerized install-info
     Wording: Russ Allbery <rra@debian.org>
     Seconded: Guillem Jover <guillem@debian.org>
     Seconded: Raphaël Hertzog <hertzog@debian.org>
     Closes: #538665
   * Perl Policy: Remove obsolete dependency requirements
     Wording: Cyril Brulebois <kibi@debian.org>
     Seconded: Russ Allbery <rra@debian.org>
     Seconded: Manoj Srivastava <srivasta@debian.org>
     Closes: #525190
   * Breaks is now supported by the stable release of dpkg, so drop
     warnings against its use.  Thanks, Steve Langasek.  (Closes: #533577)
   * Add references to the sections on Breaks and Conflicts to the section
     on binary dependencies.  Thanks, Frank Küster.  (Closes: #529771)
   * Clarify the units of Installed-Size and document that it is an
     approximation.  Thanks, Martin Dorey.  (Closes: #534408)
   * Don't suggest calling dpkg-statoverride --remove unconditionally in
     the postrm script.  Thanks, Patrick Schoenfeld.  (Closes: #539389)
   * Explain that the copyright dates are for the original Policy manual
     and that there is no updated list of copyright holders for subsequent
     revisions available.  (Partly addresses #47438)
   * Clarify the description of the Files control field and add examples.
   * Change the wording of the Description and Changes field specifications
     for *.changes files to more closely match the wording for Files and
     add more details about the contents of the Description field in
     a *.changes file.
   * Merge the package name syntax requirements between the Package and
     Source field descriptions.
   * Say that sensible-editor and sensible-pager are provided by the
     sensible-utils package, not by the base system.  Thanks, Clint Adams
     and Steve Langasek.  (Closes: #541537)
   * Document that control field values are case-sensitive unless the field
     description says otherwise.
Checksums-Sha1: 
 55a18b31606a3e4126895c3c1d26ce2b72f34e5d 1194 debian-policy_3.8.3.0.dsc
 5955ff2079fbc7aa700e7c1073ce76cc456633eb 650740 debian-policy_3.8.3.0.tar.gz
 79049f64018b7baa0ef03495b9cd36188849adfc 1607738 debian-policy_3.8.3.0_all.deb
Checksums-Sha256: 
 d4e0a4739ca5851c1099bb657b7c802c6087a5196a914a031149bc6726e25289 1194 debian-policy_3.8.3.0.dsc
 2b9ca60381f16383ff5fc86313b88dc1fc3c8b2c3375dd7eb86dc7d67a2d1722 650740 debian-policy_3.8.3.0.tar.gz
 b4d662ea3b22b81b08bc1334c65c100cd1979ec3976a7f4e66c7d6e06c98f155 1607738 debian-policy_3.8.3.0_all.deb
Files: 
 b7811d713a26d8904ca6160245b5a356 1194 doc optional debian-policy_3.8.3.0.dsc
 24a27ad230f789ef808cd32147e2229b 650740 doc optional debian-policy_3.8.3.0.tar.gz
 f0d3d90b31aa5a0ce230882b81d3fe9c 1607738 doc optional debian-policy_3.8.3.0_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkqHUhwACgkQ+YXjQAr8dHYbcQCgkBMCelcn21KA99jMOjbK/HI/
mToAoK0BWtXtKWBfxiCxCHCdStIszfUm
=swfU
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 23 Sep 2009 07:38:23 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 13:50:31 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.