Debian Bug report logs - #524667
safe-upgrade: unmet dependencies with libgd2-xpm and libgd2-noxpm, apt-get works

version graph

Package: aptitude; Maintainer for aptitude is Aptitude Development Team <aptitude-devel@lists.alioth.debian.org>; Source for aptitude is src:aptitude.

Reported by: Paul Menzel <pm.debian@googlemail.com>

Date: Sat, 18 Apr 2009 21:36:03 UTC

Severity: important

Merged with 522881

Found in versions aptitude/0.4.11.11-1, aptitude/0.5.1-1

Fixed in version aptitude/0.5.2-1

Done: Daniel Burrows <dburrows@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#524667; Package aptitude. (Sat, 18 Apr 2009 21:36:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Paul Menzel <pm.debian@googlemail.com>:
New Bug report received and forwarded. Copy sent to Daniel Burrows <dburrows@debian.org>. (Sat, 18 Apr 2009 21:36:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Paul Menzel <pm.debian@googlemail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: safe-upgrade: unmet dependencies with libgd2-xpm and libgd2-noxpm, apt-get works
Date: Sat, 18 Apr 2009 23:30:13 +0200
[Message part 1 (text/plain, inline)]
Subject: safe-upgrade: unmet dependencies with libgd2-xpm and libgd2-noxpm, apt-get works
Package: aptitude
Version: 0.4.11.11-1+b1
Severity: important

*** Please type your report below this line ***

Dear Debian folks,


since over a week I cannot run aptitude safe-upgrade on a computer.

Could you please provide a hint how to solve this. sudo apt-get upgrade
does not show this problem. Could I run apt-get to upgrade or would that
impose problems?

The output from the commands are attached at the end of this message.

I do not know if this issue is related to the bug reports [1] or [2].


Thanks,

Paul


[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=522881
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=443654

### aptitude ###

Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Reading task descriptions...
The following packages are BROKEN:
  atl2-modules-2.6-686 eeepc-acpi-modules-2.6-686 gnash-common 
  gnome-control-center gnome-settings-daemon imagemagick 
  libauthen-passphrase-perl libcanberra-gtk-module libcanberra-gtk0 
  libcanberra0 libgnome-window-settings1 libslab0 libthai0 
  linux-image-2.6-686 xserver-xorg xserver-xorg-core 
The following packages will be REMOVED:
  gstreamer0.10-alsa{u} libcurl3{u} libdatrie0{u} libgd2-xpm{u} 
  libgnome-desktop-2{u} libgnomekbd-common{u} libgnomekbd2{u} 
  libgnomekbdui2{u} libgraphviz4{u} libilmbase6{u} libltdl3{u} 
  libmagick10{u} libnautilus-extension1{u} libopenexr6{u} 
  libpanel-applet2-0{u} libssh2-1{u} libwmf0.2-7{u} 
The following packages will be upgraded:
  acpi-support-base capplets-data cpp-4.3 desktop-file-utils dpkg dpkg-dev 
  esound-clients esound-common evince fwknop-client g++-4.3 gcc-4.3 
  gcc-4.3-base gconf2 gconf2-common git-core git-email gksu gnash 
  gnome-desktop-data gnome-keyring gvfs hal iptables irssi kernel-package 
  libartsc0 libavahi-client3 libavahi-common-data libavahi-common3 
  libavahi-glib1 libavahi-gobject0 libc6 libc6-dev libc6-i686 libcups2 
  libcupsimage2 libcurl3-gnutls libdes425-3 libdrm-intel1 libdrm2 libesd0 
  libgail-common libgail18 libgcc1 libgconf2-4 libgcr0 libgfortran3 
  libgl1-mesa-dri libgl1-mesa-glx libglib2.0-0 libglu1-mesa 
  libgnome-keyring0 libgnomevfs2-0 libgnomevfs2-common libgnutls26 libgomp1 
  libgp11-0 libgsasl7 libgssapi-krb5-2 libgtk2.0-0 libgtk2.0-bin 
  libgtk2.0-common libgvfscommon0 libhal-storage1 libhal1 libhunspell-1.2-0 
  libimlib2 libk5crypto3 libkpathsea4 libkrb5-3 libkrb53 libkrb5support0 
  libmodplug0c2 libnm-glib-vpn0 libnm-glib0 libnm-util1 libnspr4-0d 
  libnss3-1d libpango1.0-0 libpoppler-glib4 libpoppler4 librarian0 
  libsmbclient libstartup-notification0 libstdc++6 libstdc++6-4.3-dev 
  libthai-data libwbclient0 libwww-curl-perl libx11-6 libxfont1 
  libxklavier12 linux-headers-2.6.29-1-686 linux-headers-2.6.29-1-common 
  linux-image-2.6.29-1-686 linux-libc-dev login mozilla-plugin-gnash 
  network-manager network-manager-gnome passwd pm-utils python-glade2 
  python-gnomekeyring python-gtk2 python-reportbug python-support 
  rarian-compat reportbug screen tex-common texlive-base texlive-base-bin 
  texlive-base-bin-doc texlive-common texlive-doc-base texlive-extra-utils 
  texlive-fonts-recommended texlive-fonts-recommended-doc 
  texlive-generic-extra texlive-generic-recommended texlive-humanities 
  texlive-humanities-doc texlive-lang-german texlive-latex-base 
  texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc 
  texlive-latex-recommended texlive-latex-recommended-doc texlive-pictures 
  texlive-pictures-doc texlive-pstricks texlive-pstricks-doc texlive-xetex 
  wavemon wpasupplicant x11-common x11-xserver-utils xorg xserver-common 
  xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse 
  xserver-xorg-input-synaptics xserver-xorg-video-intel zip 
163 packages upgraded, 0 newly installed, 17 to remove and 0 not upgraded.
Need to get 321MB of archives. After unpacking 19.1MB will be freed.
The following packages have unmet dependencies:
  xserver-xorg: Depends: console-setup (>= 1.29) but it is not installable
  libcanberra-gtk-module: Depends: libltdl7 (>= 2.2.6a) but it is not installable
                          Depends: libtdb1 (>= 1.1.3~git2008122-1) but it is not installable
  gnome-settings-daemon: Depends: libgnome-desktop-2-11 but it is not installable
                         Depends: libgnomekbd3 but it is not installable
  linux-image-2.6-686: Depends: linux-image-2.6.26-2-686 which is a virtual package.
  gnome-control-center: Depends: libgnome-desktop-2-11 but it is not installable
                        Depends: libgnomekbd3 but it is not installable
  libauthen-passphrase-perl: Depends: libauthen-dechpwd-perl (>= 2.003) but 2.002-4 is installed.
  xserver-xorg-core: Depends: libaudit0 but it is not installable
  libslab0: Depends: libgnome-desktop-2-11 but it is not installable
  libthai0: Depends: libdatrie1 (>= 0.2.0) but it is not installable
  libcanberra-gtk0: Depends: libltdl7 (>= 2.2.6a) but it is not installable
                    Depends: libtdb1 (>= 1.1.3~git2008122-1) but it is not installable
  libgnome-window-settings1: Depends: libgnome-desktop-2-11 but it is not installable
  atl2-modules-2.6-686: Depends: atl2-modules-2.6.29-1-686 but it is not installable
                        Depends: linux-latest-modules-2.6.29-1-686 which is a virtual package.
  libcanberra0: Depends: libltdl7 (>= 2.2.6a) but it is not installable
                Depends: libtdb1 (>= 1.1.3~git2008122-1) but it is not installable
  imagemagick: Depends: liblqr-1-0 (>= 0.1.0) but it is not installable
               Depends: libltdl7 (>= 2.2.6a) but it is not installable
               Depends: libmagickcore2 but it is not installable
               Depends: libmagickwand2 but it is not installable
  gnash-common: Depends: libltdl7 (>= 2.2.6a) but it is not installable
  eeepc-acpi-modules-2.6-686: Depends: linux-latest-modules-2.6.26-1-686 which is a virtual package.
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
The following packages have unmet dependencies:
  libgd2-noxpm: Conflicts: libgd2 which is a virtual package.
                Conflicts: libgd2-xpm but 2.0.36~rc1~dfsg-3 is installed.
  libgd2-xpm: Conflicts: libgd2 which is a virtual package.
              Conflicts: libgd2-noxpm but 2.0.36~rc1~dfsg-3 is to be installed.

### apt-get ###

$ LANG=C sudo apt-get upgrade
[sudo] password for paul: 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
The following packages have been kept back:
  atl2-modules-2.6-686 capplets-data gnash gnash-common gnome-control-center gnome-settings-daemon imagemagick libauthen-passphrase-perl libcanberra-gtk-module libcanberra-gtk0
  libcanberra0 libgnome-window-settings1 libgraphviz4 libslab0 libthai-data libthai0 linux-image-2.6-686 mozilla-plugin-gnash xserver-xorg xserver-xorg-core
The following packages will be upgraded:
  acpi-support-base cpp-4.3 desktop-file-utils dpkg dpkg-dev esound-clients esound-common evince fwknop-client g++-4.3 gcc-4.3 gcc-4.3-base gconf2 gconf2-common git-core
  git-email gksu gnome-desktop-data gnome-keyring gvfs hal iptables irssi kernel-package libartsc0 libavahi-client3 libavahi-common-data libavahi-common3 libavahi-glib1
  libavahi-gobject0 libc6 libc6-dev libc6-i686 libcups2 libcupsimage2 libcurl3 libcurl3-gnutls libdes425-3 libdrm-intel1 libdrm2 libesd0 libgail-common libgail18 libgcc1
  libgconf2-4 libgcr0 libgfortran3 libgl1-mesa-dri libgl1-mesa-glx libglib2.0-0 libglu1-mesa libgnome-keyring0 libgnomekbd-common libgnomevfs2-0 libgnomevfs2-common libgnutls26
  libgomp1 libgp11-0 libgsasl7 libgssapi-krb5-2 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgvfscommon0 libhal-storage1 libhal1 libhunspell-1.2-0 libilmbase6 libimlib2
  libk5crypto3 libkpathsea4 libkrb5-3 libkrb53 libkrb5support0 libmodplug0c2 libnautilus-extension1 libnm-glib-vpn0 libnm-glib0 libnm-util1 libnspr4-0d libnss3-1d libopenexr6
  libpanel-applet2-0 libpango1.0-0 libpoppler-glib4 libpoppler4 librarian0 libsmbclient libstartup-notification0 libstdc++6 libstdc++6-4.3-dev libwbclient0 libwww-curl-perl
  libx11-6 libxfont1 libxklavier12 linux-headers-2.6.29-1-686 linux-headers-2.6.29-1-common linux-image-2.6.29-1-686 linux-libc-dev login network-manager network-manager-gnome
  passwd pm-utils python-glade2 python-gnomekeyring python-gtk2 python-reportbug python-support rarian-compat reportbug screen tex-common texlive-base texlive-base-bin
  texlive-base-bin-doc texlive-common texlive-doc-base texlive-extra-utils texlive-fonts-recommended texlive-fonts-recommended-doc texlive-generic-extra
  texlive-generic-recommended texlive-humanities texlive-humanities-doc texlive-lang-german texlive-latex-base texlive-latex-base-doc texlive-latex-extra texlive-latex-extra-doc
  texlive-latex-recommended texlive-latex-recommended-doc texlive-pictures texlive-pictures-doc texlive-pstricks texlive-pstricks-doc texlive-xetex wavemon wpasupplicant
  x11-common x11-xserver-utils xorg xserver-common xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-video-intel
  zip
150 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
Need to get 313MB of archives.
After this operation, 2063kB of additional disk space will be used.
Do you want to continue [Y/n]?

-- Package-specific info:
aptitude 0.4.11.11 kompiliert am Apr 17 2009 21:35:13
Compiler: g++ 4.3.3
Kompiliert gegen:
  apt-Version 4.6.0
  NCurses-Version: 5.7
  libsigc++-Version: 2.0.18
  Ept-Unterstützung aktiviert.

Aktuelle Bibliotheksversion:
  NCurses-Version: ncurses 5.7.20090404
  cwidget-Version: 0.5.12
  Apt-Version: 4.6.0
        linux-gate.so.1 =>  (0xb8009000)
        libapt-pkg-libc6.9-6.so.4.7 => /usr/lib/libapt-pkg-libc6.9-6.so.4.7 (0xb7f3e000)
        libncursesw.so.5 => /lib/libncursesw.so.5 (0xb7f00000)
        libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0xb7ef9000)
        libcwidget.so.3 => /usr/lib/libcwidget.so.3 (0xb7e35000)
        libept.so.0 => /usr/lib/libept.so.0 (0xb7dba000)
        libxapian.so.15 => /usr/lib/libxapian.so.15 (0xb7c62000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb7c4d000)
        libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb7c34000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7b45000)
        libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7b1f000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7b12000)
        libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb79b2000)
        libutil.so.1 => /lib/i686/cmov/libutil.so.1 (0xb79ae000)
        libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xb79a9000)
        /lib/ld-linux.so.2 (0xb800a000)
Terminal: screen
$DISPLAY is set.
`which aptitude`: /usr/bin/aptitude
aptitude version information:

aptitude linkage:

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.29-1-686 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages aptitude depends on:
ii  apt [libapt-pkg-libc6. 0.7.21            Advanced front-end for dpkg
ii  libc6                  2.9-6             GNU C Library: Shared libraries
ii  libcwidget3            0.5.12-4          high-level terminal interface libr
ii  libept0                0.5.26+b1         High-level library for managing De
ii  libgcc1                1:4.3.3-7         GCC support library
ii  libncursesw5           5.7+20090404-1    shared libraries for terminal hand
ii  libsigc++-2.0-0c2a     2.0.18-2          type-safe Signal Framework for C++
ii  libstdc++6             4.3.3-7           The GNU Standard C++ Library v3
ii  libxapian15            1.0.10-2          Search engine library
ii  zlib1g                 1:1.2.3.3.dfsg-13 compression library - runtime

Versions of packages aptitude recommends:
pn  aptitude-doc-en | aptitude-do <none>     (no description available)
pn  libparse-debianchangelog-perl <none>     (no description available)

Versions of packages aptitude suggests:
pn  debtags                       <none>     (no description available)
ii  tasksel                       2.78       Tool for selecting tasks for insta

-- no debconf information
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#524667; Package aptitude. (Sun, 19 Apr 2009 10:27:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sven Joachim <svenjoac@gmx.de>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Sun, 19 Apr 2009 10:27:02 GMT) Full text and rfc822 format available.

Message #10 received at 524667@bugs.debian.org (full text, mbox):

From: Sven Joachim <svenjoac@gmx.de>
To: Paul Menzel <pm.debian@googlemail.com>
Cc: 524667@bugs.debian.org
Subject: Re: Bug#524667: safe-upgrade: unmet dependencies with libgd2-xpm and libgd2-noxpm, apt-get works
Date: Sun, 19 Apr 2009 12:24:44 +0200
On 2009-04-18 23:30 +0200, Paul Menzel wrote:

> since over a week I cannot run aptitude safe-upgrade on a computer.
>
> Could you please provide a hint how to solve this. sudo apt-get upgrade
> does not show this problem. Could I run apt-get to upgrade or would that
> impose problems?

Should be fine as long as you don't have any packages set on hold in
aptitude; apt-get does not know about that and would upgrade them.

> The output from the commands are attached at the end of this message.
>
> I do not know if this issue is related to the bug reports [1] or [2].

It seems to be the same issue that we experienced there.

> [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=522881

Does it help to run "aptitude unmarkauto libgd2-xpm"?  That
(aptitude unmarkauto kdebase-bin-kde3) is how I worked around #522881.

Regards,
        Sven




Merged 522881 524667. Request was from Daniel Burrows <dburrows@debian.org> to control@bugs.debian.org. (Mon, 20 Apr 2009 03:48:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#524667; Package aptitude. (Mon, 20 Apr 2009 16:54:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Burrows <dburrows@debian.org>:
Extra info received and forwarded to list. (Mon, 20 Apr 2009 16:54:05 GMT) Full text and rfc822 format available.

Message #17 received at 524667@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: Sven Joachim <svenjoac@gmx.de>, 522881@bugs.debian.org, Paul Menzel <pm.debian@googlemail.com>, 524667@bugs.debian.org
Subject: Re: Bug#522881: aptitude: safe-upgrade stopped working after kde4 upload
Date: Mon, 20 Apr 2009 09:51:05 -0700
  I've checked a fix for this problem into head.  The fix is the most
brutal one: it just disables package reinstatement.  I have a few ideas
about how to re-enable reinstatement without reintroducing this
problem; it should allow packages to be reinstated except when they
would trigger a conflict.  Hopefully I can get the better fix
implemented for 0.5.2.

  See here for details:

http://lists.alioth.debian.org/pipermail/aptitude-devel/2009-April/001256.html

  Daniel




Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#524667; Package aptitude. (Wed, 22 Apr 2009 11:15:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Paul Menzel <pm.debian@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Wed, 22 Apr 2009 11:15:09 GMT) Full text and rfc822 format available.

Message #22 received at 524667@bugs.debian.org (full text, mbox):

From: Paul Menzel <pm.debian@googlemail.com>
To: Sven Joachim <svenjoac@gmx.de>
Cc: 524667@bugs.debian.org
Subject: »aptitude unmarkauto libgd2-xpm« worked as a workaround.
Date: Wed, 22 Apr 2009 13:12:21 +0200
[Message part 1 (text/plain, inline)]
Am Sonntag, den 19.04.2009, 12:24 +0200 schrieb Sven Joachim:
> On 2009-04-18 23:30 +0200, Paul Menzel wrote:
> 
> > since over a week I cannot run aptitude safe-upgrade on a computer.
> >
> > Could you please provide a hint how to solve this. sudo apt-get upgrade
> > does not show this problem. Could I run apt-get to upgrade or would that
> > impose problems?
> 
> Should be fine as long as you don't have any packages set on hold in
> aptitude; apt-get does not know about that and would upgrade them.
> 
> > The output from the commands are attached at the end of this message.
> >
> > I do not know if this issue is related to the bug reports [1] or [2].
> 
> It seems to be the same issue that we experienced there.
> 
> > [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=522881

Daniel confirmed aftwerwards and merged both reports. Thanks.

> Does it help to run "aptitude unmarkauto libgd2-xpm"?  That
> (aptitude unmarkauto kdebase-bin-kde3) is how I worked around #522881.

Sorry for this late reply. It helped. Thanks, Sven!!!


Thanks,

Paul
[signature.asc (application/pgp-signature, inline)]

Tags added: pending Request was from Daniel Burrows <dburrows@debian.org> to control@bugs.debian.org. (Fri, 24 Apr 2009 02:06:08 GMT) Full text and rfc822 format available.

Tags added: pending Request was from Daniel Burrows <dburrows@debian.org> to control@bugs.debian.org. (Fri, 24 Apr 2009 02:06:20 GMT) Full text and rfc822 format available.

Reply sent to Daniel Burrows <dburrows@debian.org>:
You have taken responsibility. (Fri, 24 Apr 2009 15:35:59 GMT) Full text and rfc822 format available.

Notification sent to Paul Menzel <pm.debian@googlemail.com>:
Bug acknowledged by developer. (Fri, 24 Apr 2009 15:36:00 GMT) Full text and rfc822 format available.

Message #31 received at 524667-close@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: 524667-close@bugs.debian.org
Subject: Bug#524667: fixed in aptitude 0.5.2-1
Date: Fri, 24 Apr 2009 15:02:15 +0000
Source: aptitude
Source-Version: 0.5.2-1

We believe that the bug you reported is fixed in the latest version of
aptitude, which is due to be installed in the Debian FTP archive:

aptitude-dbg_0.5.2-1_i386.deb
  to pool/main/a/aptitude/aptitude-dbg_0.5.2-1_i386.deb
aptitude-doc-cs_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-cs_0.5.2-1_all.deb
aptitude-doc-en_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-en_0.5.2-1_all.deb
aptitude-doc-fi_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-fi_0.5.2-1_all.deb
aptitude-doc-fr_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-fr_0.5.2-1_all.deb
aptitude-doc-ja_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-ja_0.5.2-1_all.deb
aptitude-gtk_0.5.2-1_i386.deb
  to pool/main/a/aptitude/aptitude-gtk_0.5.2-1_i386.deb
aptitude_0.5.2-1.diff.gz
  to pool/main/a/aptitude/aptitude_0.5.2-1.diff.gz
aptitude_0.5.2-1.dsc
  to pool/main/a/aptitude/aptitude_0.5.2-1.dsc
aptitude_0.5.2-1_i386.deb
  to pool/main/a/aptitude/aptitude_0.5.2-1_i386.deb
aptitude_0.5.2.orig.tar.gz
  to pool/main/a/aptitude/aptitude_0.5.2.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 524667@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Burrows <dburrows@debian.org> (supplier of updated aptitude package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 23 Apr 2009 09:08:27 -0700
Source: aptitude
Binary: aptitude aptitude-gtk aptitude-dbg aptitude-doc-cs aptitude-doc-en aptitude-doc-fi aptitude-doc-fr aptitude-doc-ja
Architecture: source i386 all
Version: 0.5.2-1
Distribution: experimental
Urgency: low
Maintainer: Daniel Burrows <dburrows@debian.org>
Changed-By: Daniel Burrows <dburrows@debian.org>
Description: 
 aptitude   - terminal-based package manager (terminal interface only)
 aptitude-dbg - Debug symbols for the aptitude package manager
 aptitude-doc-cs - Czech manual for aptitude, a terminal-based package manager
 aptitude-doc-en - English manual for aptitude, a terminal-based package manager
 aptitude-doc-fi - Finnish manual for aptitude, a terminal-based package manager
 aptitude-doc-fr - French manual for aptitude, a terminal-based package manager
 aptitude-doc-ja - Japanese manual for aptitude, a terminal-based package manager
 aptitude-gtk - terminal-based package manager (GUI and terminal interfaces)
Closes: 473296 482825 510977 511238 512384 513472 514011 514545 514676 514714 514820 514930 516296 516296 516389 516527 517272 518981 519693 521152 521255 522881 524221 524667
Changes: 
 aptitude (0.5.2-1) experimental; urgency=low
 .
   * New upstream release.
 .
     - Support for guaranteed ordering of solutions produced by the
     dependency resolver. (Closes: #514820, #514930, #524221, #473296)
 .
     - The dependency resolver will continue searching for a short time
       after finding a solution, in case a better solution turns up.
       (Closes: #482825)
 .
     - The GTK+ interface should no longer crash while trying to find
       dependency chains. (Closes: #514714)
 .
     - aptitude is now more careful about automatically canceling the
       removal of an unused package, to avoid triggering a conflict with
       other packages (for instance, packages included in a dependency
       solution). (Closes: #522881, #524667)
 .
     - The curses interface no longer warns users when they purge an
       already-removed Essental package. (Closes: #513472)
 .
     - The curses interface no longer computes an excessive amount of
       dependency information every time a package is highlighted.
       (Closes: #516296)
 .
     - Fixed incorrect formatting in some command-line error messages.
       (Closes: #516296, #514676)
 .
     - Fix really stupid column wrapping in "aptitude why".
       (Closes: #516389)
 .
     - Translation updates:
 .
       + Asturian (Closes: #518981, #519693)
       + Danish (Closes: #512384)
       + German
       + Italian
       + Norwegian Bokmål (Closes: #510977)
       + Spanish (Closes: #517272)
       + Swedish (Closes: #511238, #514011)
 .
   * Change the reportbug script to run in the C locale, so program output
     that's inserted doesn't get translated.
 .
   * Change the description of aptitude-gtk to say that it has a GUI
     interface. (Closes: #514545, #521152)
 .
   * Give aptitude-gtk a versioned dependency on aptitude. (Closes: #516527)
 .
   * Include .desktop file contributed by Fabit Greffrath.  I know that
     using su-to-root is not ideal, but since aptitude-gtk can't be used to
     install / remove packages unless it's run as root, this is probably a
     good interim approach.  Eventually we'll hook up the code so that the
     GTK+ frontend can do what the curses frontend does (automagically
     become root and preserve selections). (Closes: #521255)
 .
   * New build-deps: liblog4cxx10-dev, inkscape.
Checksums-Sha1: 
 14f15b10147b5b9572c6937fa6b5949d377b8a94 1470 aptitude_0.5.2-1.dsc
 b138312be6fcc90c81dc4c005717d512f57ea750 7133402 aptitude_0.5.2.orig.tar.gz
 ec7e4ac6bb16106322a92a6f4227bbba6c81ef96 35501 aptitude_0.5.2-1.diff.gz
 6113b0b646e805bd4f3682c345c44fe77025db5d 3330290 aptitude_0.5.2-1_i386.deb
 61d8aba41318a80441fda0fb6e43a443a01c558d 1487680 aptitude-gtk_0.5.2-1_i386.deb
 554f45fe2c4a28ca0496e07326a672dd1b9ca499 16278950 aptitude-dbg_0.5.2-1_i386.deb
 53b100d1d1ea89a350d30365ef7b1a00848bff8f 379860 aptitude-doc-cs_0.5.2-1_all.deb
 6b7d2da18ab7034cdc53fd752ae8d1be794bafb3 377440 aptitude-doc-en_0.5.2-1_all.deb
 b54e2c2bddef79b78295c653459ddf6266728003 271822 aptitude-doc-fi_0.5.2-1_all.deb
 8d5811fd20a918d3a2235e22cb461417e4c26f36 325090 aptitude-doc-fr_0.5.2-1_all.deb
 7a3a746145011cf43915be822b34b0bf83786579 388792 aptitude-doc-ja_0.5.2-1_all.deb
Checksums-Sha256: 
 3fd4c2436207d4e547ef1b834e56f3ed53d064a24086883a355946cb9669a9af 1470 aptitude_0.5.2-1.dsc
 491c7471219addaa7769655837c81206da80cc2f0ef7c510707d1499073715be 7133402 aptitude_0.5.2.orig.tar.gz
 3f8c3535a5903ae2596ec74b5253daaf20d026db4e8e2b78c8bddf832d4a9bc9 35501 aptitude_0.5.2-1.diff.gz
 73d04bfe1a88352a15ed41002d2aea6fd07291e5698c5b885c53648f4597d40e 3330290 aptitude_0.5.2-1_i386.deb
 6207d9746703f729a61d5c8b5a1f58b28c79f656f9fa0520c73a4d41e4b6a15a 1487680 aptitude-gtk_0.5.2-1_i386.deb
 6e0fbc933f99f7360b9d898e03df259bef433510724f67bea28241f4b23eac4d 16278950 aptitude-dbg_0.5.2-1_i386.deb
 acb2168e036b4966eb0bf4957cf5a12281e58350cbaa782efcb0821641bdbc24 379860 aptitude-doc-cs_0.5.2-1_all.deb
 d88bf0bc1c1aa78f1559d1d0752926a3ac5dae8b8eb0e0d1a5744c9b5f965356 377440 aptitude-doc-en_0.5.2-1_all.deb
 cf5a2c2335d7aa390fa024b0746431cafc873b3e1e38f4f8891b82b94056efcc 271822 aptitude-doc-fi_0.5.2-1_all.deb
 efacac86bb4ddf5d883d28449f30cf9f9992ed8f3f4a38e178d3a92753ef40eb 325090 aptitude-doc-fr_0.5.2-1_all.deb
 93b03cd14daa3b1f439e075e56a82ff7dd9d4eec798ba0c9d6abe8b4b55361c2 388792 aptitude-doc-ja_0.5.2-1_all.deb
Files: 
 bcfeb8ecb6ed184a74bd5eaa47b09bf7 1470 admin - aptitude_0.5.2-1.dsc
 074aeb68c570003a58f42d1e6031fa25 7133402 admin - aptitude_0.5.2.orig.tar.gz
 1e5c119f64d2ba7af4ea9c2fa71bf0d3 35501 admin - aptitude_0.5.2-1.diff.gz
 84265fa156faaaeb731a57acab855f9c 3330290 admin important aptitude_0.5.2-1_i386.deb
 f2ecb4df9b8d592c9b690c99ca37c86e 1487680 admin important aptitude-gtk_0.5.2-1_i386.deb
 ec67d6e719d9d3dc79495c62578764be 16278950 devel extra aptitude-dbg_0.5.2-1_i386.deb
 13c8fd668a55fe601d727def826f1167 379860 doc optional aptitude-doc-cs_0.5.2-1_all.deb
 620760f6d415a6c4f6994281e0c98089 377440 doc optional aptitude-doc-en_0.5.2-1_all.deb
 63de5659873f329ec0eb9183fd7c9c11 271822 doc optional aptitude-doc-fi_0.5.2-1_all.deb
 e44fe09a6758a787f5f50074b8056391 325090 doc optional aptitude-doc-fr_0.5.2-1_all.deb
 19d76cd2ebe35d7b5a7490cd9d820c16 388792 doc optional aptitude-doc-ja_0.5.2-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAknxxhMACgkQch6xsM7kSXiFZACgw5tIvOzMjJ+ooOw4sFQttOfI
BAsAoNjJ2rMrw78+q65/SaTeXZvl4xEX
=NIZF
-----END PGP SIGNATURE-----





Reply sent to Daniel Burrows <dburrows@debian.org>:
You have taken responsibility. (Fri, 24 Apr 2009 15:36:01 GMT) Full text and rfc822 format available.

Notification sent to Sven Joachim <svenjoac@gmx.de>:
Bug acknowledged by developer. (Fri, 24 Apr 2009 15:36:01 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 23 Mar 2010 07:41:44 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 06:30:19 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.