Debian Bug report logs - #523514
Compiz fails to load due to wrong ABI version

version graph

Package: compiz; Maintainer for compiz is Debian X Strike Force <debian-x@lists.debian.org>;

Reported by: 0.8.2-5

Date: Fri, 10 Apr 2009 19:15:01 UTC

Severity: serious

Found in version compiz/0.8.2-2

Fixed in version compiz/0.8.2-6

Done: Loic Minier <lool@dooz.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#523514; Package compiz. (Fri, 10 Apr 2009 19:15:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Immolo <immoloism@googlemail.com>:
New Bug report received and forwarded. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. (Fri, 10 Apr 2009 19:15:03 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Immolo <immoloism@googlemail.com>
To: submit@bugs.debian.org
Subject: Compiz fails to load due to wrong ABI version
Date: Fri, 10 Apr 2009 20:07:37 +0100
Package: Compiz
Version: 0.8.2-2
Severity: serious

After upgrading compiz I get the following error on startup:

Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Error: Plugin 'core' has ABI version '20090207', expected ABI version '20080424'.

/usr/bin/compiz.real (ccp) - Error: InitObject failed
/usr/bin/compiz.real (core) - Error: Couldn't activate plugin 'ccp'

-- System Information:
Debian Release: 5.0
APT prefers stable
APT policy: (990, 'stable'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Kernel: Linux 2.6.26-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Versions of packages compiz depends on:
ii  compiz-core                   0.8.2-2    OpenGL window and compositing mana
ii  compiz-gnome                  0.8.2-2    OpenGL window and compositing mana
ii  compiz-gtk                    0.8.2-2    OpenGL window and compositing mana
ii  compiz-plugins                0.8.2-2    OpenGL window and compositing mana
compiz recommends no packages.
Versions of packages compiz suggests:
ii  compizconfig-settings-manager 0.8.2-1    Compizconfig Settings Manager
-- no debconf information








Information forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#523514; Package compiz. (Sun, 12 Apr 2009 18:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Immolo <immoloism@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. (Sun, 12 Apr 2009 18:39:03 GMT) Full text and rfc822 format available.

Message #10 received at 523514@bugs.debian.org (full text, mbox):

From: Immolo <immoloism@googlemail.com>
To: 523514@bugs.debian.org
Subject: compiz
Date: Sun, 12 Apr 2009 19:34:22 +0100
This bug can be fixed by purging compiz and reinstalling so I guess if 
during the upgrade the config file is removed this problem won't happen.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#523514; Package compiz. (Sun, 12 Apr 2009 18:39:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Immolo <immoloism@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. (Sun, 12 Apr 2009 18:39:04 GMT) Full text and rfc822 format available.

Message #15 received at 523514@bugs.debian.org (full text, mbox):

From: Immolo <immoloism@googlemail.com>
To: 523514@bugs.debian.org
Subject: compiz
Date: Sun, 12 Apr 2009 19:36:06 +0100
This bug can be fixed by purging compiz and reinstalling so I guess if 
during the upgrade the config file is removed this problem won't happen.




Reply sent to Brice Goglin <Brice.Goglin@ens-lyon.org>:
You have taken responsibility. (Thu, 16 Apr 2009 06:03:05 GMT) Full text and rfc822 format available.

Notification sent to Immolo <immoloism@googlemail.com>:
Bug acknowledged by developer. (Thu, 16 Apr 2009 06:03:05 GMT) Full text and rfc822 format available.

Message #20 received at 523514-done@bugs.debian.org (full text, mbox):

From: Brice Goglin <Brice.Goglin@ens-lyon.org>
To: 523514-done@bugs.debian.org
Subject: Re: Bug#523514: compiz
Date: Thu, 16 Apr 2009 07:57:18 +0200
On Sun, Apr 12, 2009 at 07:36:06PM +0100, Immolo wrote:
> This bug can be fixed by purging compiz and reinstalling so I guess if  
> during the upgrade the config file is removed this problem won't happen.

Don't know what happened, cannot reproduce, let's just close this...

Brice





Information forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#523514; Package compiz. (Tue, 21 Apr 2009 01:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Adam Dane <adam@diehealthy.org>:
Extra info received and forwarded to list. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. (Tue, 21 Apr 2009 01:00:05 GMT) Full text and rfc822 format available.

Message #25 received at 523514@bugs.debian.org (full text, mbox):

From: Adam Dane <adam@diehealthy.org>
To: 523514@bugs.debian.org
Subject: Conflict with old version of libcompizconfig0
Date: Mon, 20 Apr 2009 19:52:48 -0500
This was caused in my case by having the older version (0.7.6-1) of
libcompizconfig0 installed.  Removing it (as the new version is not yet
built for i386) fixed the problem.

Adam





Information forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#523514; Package compiz. (Fri, 24 Apr 2009 08:57:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Loïc Minier <lool@dooz.org>:
Extra info received and forwarded to list. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. (Fri, 24 Apr 2009 08:57:02 GMT) Full text and rfc822 format available.

Message #30 received at 523514@bugs.debian.org (full text, mbox):

From: Loïc Minier <lool@dooz.org>
To: 523514@bugs.debian.org, control@bugs.debian.org
Subject: Reopening: please add a versionned dep of some sort
Date: Fri, 24 Apr 2009 10:22:26 +0200
reopen 523514 0.8.2-5
stop

        Hi

 Please fix the deps of $package to disallow partial upgrades of
 compiz-* if libcompiz needs to be upgraded at the same time.  e.g.
 Breaks: libcompizconfig << 0.8 or vice-versa.

 In my case I have:
 compiz 0.8.2-5
 compiz-core 0.8.2-5
 compiz-fusion-plugins-main 0.8.2-3
 compiz-gnome 0.8.2-5
 compiz-gtk 0.8.2-5
 compiz-plugins 0.8.2-5
 compizconfig-backend-gconf 0.7.6-1
 compizconfig-settings-manager 0.8.2-1
 libcompizconfig0 0.7.6-1
 python-compizconfig 0.7.6-1

 /usr/bin/compiz.real (core) - Error: Plugin 'core' has ABI version
 '20090207', expected ABI version '20080424'.

   thanks!
-- 
Loïc Minier




Bug reopened, originator set to 0.8.2-5. Request was from Loïc Minier <lool@dooz.org> to control@bugs.debian.org. (Fri, 24 Apr 2009 08:57:04 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#523514; Package compiz. (Fri, 24 Apr 2009 12:15:12 GMT) Full text and rfc822 format available.

Acknowledgement sent to Loïc Minier <lool@dooz.org>:
Extra info received and forwarded to list. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. (Fri, 24 Apr 2009 12:15:12 GMT) Full text and rfc822 format available.

Message #37 received at 523514@bugs.debian.org (full text, mbox):

From: Loïc Minier <lool@dooz.org>
To: 523514@bugs.debian.org
Cc: ,control@bugs.debian.org
Subject: [compiz/debian-unstable] compiz-core Breaks libcompizconfig 0.8.0; #523514
Date: Fri, 24 Apr 2009 12:06:44 +0000
tag 523514 pending
thanks

Date:   Fri Apr 24 14:03:40 2009 +0200
Author: Loïc Minier <lool@dooz.org>
Commit ID: b36c8cf83f0be89c30b691d12c7caf173e16f7dd
Commit URL: http://git.debian.org/?p=pkg-xorg/app/compiz.git;a=commitdiff;h=b36c8cf83f0be89c30b691d12c7caf173e16f7dd
Patch URL: http://git.debian.org/?p=pkg-xorg/app/compiz.git;a=commitdiff_plain;h=b36c8cf83f0be89c30b691d12c7caf173e16f7dd

    compiz-core Breaks libcompizconfig 0.8.0; #523514

    Bump the compiz-core Breaks on libcompizconfig0 to 0.8.0 as the last
    CORE_ABIVERSION bump happened between 0.7.8 and 0.8.0; closes: #523514.
      




Tags added: pending Request was from Loïc Minier <lool@dooz.org> to control@bugs.debian.org. (Fri, 24 Apr 2009 12:15:14 GMT) Full text and rfc822 format available.

Reply sent to Loic Minier <lool@dooz.org>:
You have taken responsibility. (Fri, 24 Apr 2009 15:36:22 GMT) Full text and rfc822 format available.

Notification sent to 0.8.2-5:
Bug acknowledged by developer. (Fri, 24 Apr 2009 15:36:24 GMT) Full text and rfc822 format available.

Message #44 received at 523514-close@bugs.debian.org (full text, mbox):

From: Loic Minier <lool@dooz.org>
To: 523514-close@bugs.debian.org
Subject: Bug#523514: fixed in compiz 0.8.2-6
Date: Fri, 24 Apr 2009 15:02:22 +0000
Source: compiz
Source-Version: 0.8.2-6

We believe that the bug you reported is fixed in the latest version of
compiz, which is due to be installed in the Debian FTP archive:

compiz-core_0.8.2-6_i386.deb
  to pool/main/c/compiz/compiz-core_0.8.2-6_i386.deb
compiz-dev_0.8.2-6_i386.deb
  to pool/main/c/compiz/compiz-dev_0.8.2-6_i386.deb
compiz-gnome_0.8.2-6_i386.deb
  to pool/main/c/compiz/compiz-gnome_0.8.2-6_i386.deb
compiz-gtk_0.8.2-6_i386.deb
  to pool/main/c/compiz/compiz-gtk_0.8.2-6_i386.deb
compiz-kde_0.8.2-6_i386.deb
  to pool/main/c/compiz/compiz-kde_0.8.2-6_i386.deb
compiz-plugins_0.8.2-6_i386.deb
  to pool/main/c/compiz/compiz-plugins_0.8.2-6_i386.deb
compiz_0.8.2-6.diff.gz
  to pool/main/c/compiz/compiz_0.8.2-6.diff.gz
compiz_0.8.2-6.dsc
  to pool/main/c/compiz/compiz_0.8.2-6.dsc
compiz_0.8.2-6_all.deb
  to pool/main/c/compiz/compiz_0.8.2-6_all.deb
libdecoration0-dev_0.8.2-6_i386.deb
  to pool/main/c/compiz/libdecoration0-dev_0.8.2-6_i386.deb
libdecoration0_0.8.2-6_i386.deb
  to pool/main/c/compiz/libdecoration0_0.8.2-6_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 523514@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Loic Minier <lool@dooz.org> (supplier of updated compiz package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 24 Apr 2009 15:15:24 +0200
Source: compiz
Binary: compiz compiz-core compiz-dev compiz-gtk compiz-kde compiz-gnome compiz-plugins libdecoration0 libdecoration0-dev
Architecture: source all i386
Version: 0.8.2-6
Distribution: unstable
Urgency: low
Maintainer: Debian X Strike Force <debian-x@lists.debian.org>
Changed-By: Loic Minier <lool@dooz.org>
Description: 
 compiz     - OpenGL window and compositing manager
 compiz-core - OpenGL window and compositing manager
 compiz-dev - OpenGL window and compositing manager - development files
 compiz-gnome - OpenGL window and compositing manager - GNOME window decorator
 compiz-gtk - OpenGL window and compositing manager - Gtk window decorator
 compiz-kde - OpenGL window and compositing manager - KDE window decorator
 compiz-plugins - OpenGL window and compositing manager - plugins
 libdecoration0 - Compiz window decoration library
 libdecoration0-dev - Compiz window decoration library - development files
Closes: 523514 524943 525240
Changes: 
 compiz (0.8.2-6) unstable; urgency=low
 .
   * Add libxcursor-dev build-dep as required by patch
     ubuntu/013-add-cursor-theme-support; also let compiz-dev pull it as it's
     referenced in the .pc file; closes: #525240, #524943.
   * Add a virtual compiz-core-abiversion-2009xxyy provides to compiz-core to
     allow for strict dependencies of plugins on the compiz-core
     CORE_ABIVERSION they were built with, as read from include/compiz-core.h.
   * Use the new Breaks feature for the compiz-core -> libcompizconfig0 dep.
     This makes upgrades smoother than Conflicts.
   * Bump the compiz-core Breaks on libcompizconfig0 to 0.8.0 as the last
     CORE_ABIVERSION bump happened between 0.7.8 and 0.8.0; closes: #523514.
   * Add a missing libxml2-dev build-dep and update the compiz-dev deps to
     match what compiz.pc requires and use the same versions as the build-deps.
   * Build-dep on libcairo2-dev instead of libcairo-dev.
   * Add missing libstartup-notification0-dev (>= 0.7) bdep and version the
     compiz-dev dep to match.
   * Use the same version in the libdecoration0-dev dep on libxrender-dev as
     in the libxrender-dev bdep.
Checksums-Sha1: 
 d0039a3e07633935849d3ff901557b62e878929d 2052 compiz_0.8.2-6.dsc
 6866bf08253401936ba8ed9b842a402a5956bb4b 28159 compiz_0.8.2-6.diff.gz
 a4b7d1085a625dd0f406ef3d23192cca4c017b62 28294 compiz_0.8.2-6_all.deb
 44209b3b951c2ee2cbcd5a2ed93ef1aa5c214827 1024606 compiz-core_0.8.2-6_i386.deb
 c9d64d122cbecbc1ab43187c7ad041d9f228cb85 57454 compiz-dev_0.8.2-6_i386.deb
 237786e9edcfa89a335e70af308fcd09e1f11c5d 85178 compiz-gtk_0.8.2-6_i386.deb
 adb269032476266254cac06f148ab4caa9ee070a 101948 compiz-kde_0.8.2-6_i386.deb
 b728ab212ced465d7278728e8924b0b7521946aa 39720 compiz-gnome_0.8.2-6_i386.deb
 8cae038fa2b9f74e5a3dc8fa7dba05693fd3f7eb 475540 compiz-plugins_0.8.2-6_i386.deb
 a22cca122d8a6d1cfec0353336318618b6c35077 47352 libdecoration0_0.8.2-6_i386.deb
 515077757440eb1fa03bbb6305aa074badbb2ad9 36886 libdecoration0-dev_0.8.2-6_i386.deb
Checksums-Sha256: 
 904167cdcd7e56b9195dd5e4a280ee5e48b4b1b06a795277ee1f108dd826642e 2052 compiz_0.8.2-6.dsc
 2ce033e3494a0d81587f8e226581d91cefce0340f1b3e4ba7ae6d061dd640297 28159 compiz_0.8.2-6.diff.gz
 bd4867934c30fc659bb432e98048f7671d79d83a0180ef98528cb16035f91ad7 28294 compiz_0.8.2-6_all.deb
 07903c3de3af2088357497a6d4ecdc4b31b7baf1a4446ac31ad6c8371cc4454f 1024606 compiz-core_0.8.2-6_i386.deb
 c44c0bba255a640a684475d66870ad8f1e8f6f04b877e1a50984371f9bec2df2 57454 compiz-dev_0.8.2-6_i386.deb
 c0a9e72dc676bfc1a6a2360bf6e17e66cb5ba5cd4d54a0ff298d1c191b5eade8 85178 compiz-gtk_0.8.2-6_i386.deb
 c252dbc0523493f174c52a6f18fb7a352e16e27678fd79f0fb4601ec9d60af6c 101948 compiz-kde_0.8.2-6_i386.deb
 fdf435030b61acb884d8fb5e507304b19a784a30e2cd3f952963e493688983a8 39720 compiz-gnome_0.8.2-6_i386.deb
 90d779af159d8a468e20b790f71a28486dd545036d82e7c46cc2a788c5da3fbf 475540 compiz-plugins_0.8.2-6_i386.deb
 d77f2123a222355c921f423c3bb1451e321d499abaa71151e005236a25945541 47352 libdecoration0_0.8.2-6_i386.deb
 1226284b27093ebc12479b27ee229f94420b23bb5a7ee08c7f1166ac06a449e0 36886 libdecoration0-dev_0.8.2-6_i386.deb
Files: 
 0c4a161d499ef563e41f0e6265da33e9 2052 x11 optional compiz_0.8.2-6.dsc
 6dfa96ecd5ba371916f5337a87644e22 28159 x11 optional compiz_0.8.2-6.diff.gz
 6b07b8a1787f8f596b187e0528a2ed2f 28294 x11 optional compiz_0.8.2-6_all.deb
 1c1d6df23fb9092f3ddbe5b924824579 1024606 x11 optional compiz-core_0.8.2-6_i386.deb
 233ecba5540714d139d03e86cd8f9278 57454 x11 optional compiz-dev_0.8.2-6_i386.deb
 b120dc39a95c69d00f649b3207dc99d8 85178 x11 optional compiz-gtk_0.8.2-6_i386.deb
 f66e7f5d217d7d424c23b2a237d7cf10 101948 x11 optional compiz-kde_0.8.2-6_i386.deb
 73a6bf92fce27c4c7d47e4df4120fb8d 39720 x11 optional compiz-gnome_0.8.2-6_i386.deb
 3b44f433a54d770153fbf373b45b105b 475540 x11 optional compiz-plugins_0.8.2-6_i386.deb
 896ff4976829ec7c79f15d66f4387336 47352 x11 optional libdecoration0_0.8.2-6_i386.deb
 6a017d3a3c634d51fe1911c689b23a2a 36886 libdevel optional libdecoration0-dev_0.8.2-6_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAknxxC4ACgkQ4VUX8isJIMCU5ACfVgj2cvyBwKVvutB4Z+NaSBy+
Q58AmwT4VHIl38OlQ3tusNWd31aB3Omw
=AGjQ
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 23 May 2009 07:28:23 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 19:42:39 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.