Debian Bug report logs - #522881
aptitude: safe-upgrade stopped working after kde4 upload

version graph

Package: aptitude; Maintainer for aptitude is Aptitude Development Team <aptitude-devel@lists.alioth.debian.org>; Source for aptitude is src:aptitude.

Reported by: Sven Joachim <svenjoac@gmx.de>

Date: Tue, 7 Apr 2009 07:09:02 UTC

Severity: important

Merged with 524667

Found in versions aptitude/0.4.11.11-1, aptitude/0.5.1-1

Fixed in version aptitude/0.5.2-1

Done: Daniel Burrows <dburrows@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Sven Joachim <svenjoac@gmx.de>, Daniel Burrows <dburrows@debian.org>:
Bug#522881; Package aptitude. (Tue, 07 Apr 2009 07:09:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sven Joachim <svenjoac@gmx.de>:
New Bug report received and forwarded. Copy sent to Sven Joachim <svenjoac@gmx.de>, Daniel Burrows <dburrows@debian.org>. (Tue, 07 Apr 2009 07:09:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Sven Joachim <svenjoac@gmx.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: aptitude: safe-upgrade stopped working after kde4 upload
Date: Tue, 07 Apr 2009 09:05:47 +0200
Package: aptitude
Version: 0.5.1-1
Severity: important

The kde4 transition in sid (which I'm not quite ready to accede yet) has
caused the safe-upgrade command to stop functioning:

,----
| % LANG=C aptitude -s -v safe-upgrade
| Reading package lists... Done
| Building dependency tree       
| Reading state information... Done
| Reading extended state information      
| Initializing package states... Done
| Reading task descriptions... Done
| The following packages are BROKEN:
|   gitk kappfinder kate kcharselect kcontrol kdebase-bin kdepasswd kdesktop 
|   kfind kicker klipper kmines kmix knetworkconf konqueror 
|   konqueror-nsplugins konsole kpersonalizer kscreensaver ksnapshot ksplash 
|   ksudoku ksysguard ksysguardd 
| The following packages will be REMOVED:
|   kdebase-bin-kde3{u} 
| The following packages will be upgraded:
|   kdebase-data kdewallpapers lsb-base 
| The following packages are RECOMMENDED but will NOT be installed:
|   dolphin kde-window-manager kscreensaver-xsavers 
| 22 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
| Need to get 21.1MB of archives. After unpacking 8806kB will be freed.
| The following packages have unmet dependencies:
|   kcharselect: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|                Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|                Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|                Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kscreensaver: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|                 Depends: kdebase-workspace-libs4+5 (>= 4:4.2.2) but it is not going to be installed.
|                 Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|                 Depends: libqt4-opengl (>= 4.4.3) but it is not going to be installed.
|                 Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|                 Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|                 Depends: kdebase-workspace-bin but it is not going to be installed.
|   ksnapshot: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|              Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|              Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|              Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|              Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kcontrol: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be installed.
|   konqueror-nsplugins: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|                        Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|                        Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|                        Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|                        Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   klipper: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|            Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|            Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|            Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|            Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kicker: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be installed.
|   ksysguard: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|              Depends: kdebase-workspace-libs4+5 (>= 4:4.2.2) but it is not going to be installed.
|              Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|              Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|              Depends: libqt4-xml (>= 4.4.3) but it is not going to be installed.
|              Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|              Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   ksplash: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be installed.
|   konsole: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|            Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|            Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|            Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|            Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kfind: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|          Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|          Depends: libqt4-qt3support (>= 4.4.3) but it is not going to be installed.
|          Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|          Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kdebase-bin: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|                Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|                Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|                Depends: libqt4-xml (>= 4.4.3) but it is not going to be installed.
|                Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|                Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|                Conflicts: kcontrol but 4:3.5.10.dfsg.1-2 is installed.
|                Conflicts: kdesktop but 4:3.5.10.dfsg.1-2 is installed.
|   ksudoku: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|            Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|            Depends: libkdegames5 (>= 4:4.2.2) but it is not going to be installed.
|            Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|            Depends: libqt4-network (>= 4.4.3) but it is not going to be installed.
|            Depends: libqt4-opengl (>= 4.4.3) but it is not going to be installed.
|            Depends: libqt4-svg (>= 4.4.3) but it is not going to be installed.
|            Depends: libqt4-xml (>= 4.4.3) but it is not going to be installed.
|            Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|            Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kdesktop: Depends: kdebase-bin (= 4:3.5.10.dfsg.1-2) but 4:4.2.2-1 is to be installed.
|   konqueror: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|              Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|              Depends: libkonq5 but it is not going to be installed.
|              Depends: libkonqsidebarplugin4 but it is not going to be installed.
|              Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|              Depends: libqt4-qt3support (>= 4.4.3) but it is not going to be installed.
|              Depends: libqt4-xml (>= 4.4.3) but it is not going to be installed.
|              Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|              Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   knetworkconf: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|                 Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|                 Depends: libqt4-qt3support (>= 4.4.3) but it is not going to be installed.
|                 Depends: libqt4-xml (>= 4.4.3) but it is not going to be installed.
|                 Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|                 Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   gitk: Depends: git-core (> 1:1.6.2.2) but 1:1.6.2.1-1 is installed.
|   ksysguardd: Depends: libsensors3 (>= 1:2.10.3-1) but it is not going to be installed.
|   kpersonalizer: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be installed.
|   kappfinder: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|               Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|               Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|               Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kate: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|         Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|         Depends: libplasma3 (>= 4:4.2.0) but it is not going to be installed.
|         Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|         Depends: libqt4-qt3support (>= 4.4.3) but it is not going to be installed.
|         Depends: libqt4-xml (>= 4.4.3) but it is not going to be installed.
|         Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|         Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kmines: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|           Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|           Depends: libkdegames5 (>= 4:4.2.2) but it is not going to be installed.
|           Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|           Depends: libqt4-network (>= 4.4.3) but it is not going to be installed.
|           Depends: libqt4-svg (>= 4.4.3) but it is not going to be installed.
|           Depends: libqt4-xml (>= 4.4.3) but it is not going to be installed.
|           Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|           Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kdepasswd: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|              Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|              Depends: libkonq5 but it is not going to be installed.
|              Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|              Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
|   kmix: Depends: kdebase-runtime (>= 4:4.2.2) but it is not going to be installed.
|         Depends: kdelibs5 (>= 4:4.2.2) but it is not going to be installed.
|         Depends: libphonon4 (>= 4:4.3.0) but it is not going to be installed.
|         Depends: libqt4-dbus (>= 4.4.3) but it is not going to be installed.
|         Depends: libqt4-xml (>= 4.4.3) but it is not going to be installed.
|         Depends: libqtcore4 (>= 4.4.3) but it is not going to be installed.
|         Depends: libqtgui4 (>= 4.4.3) but it is not going to be installed.
| Resolving dependencies...
| Resolving dependencies...
| Resolving dependencies...
| Resolving dependencies...
| Resolving dependencies...
| The following packages have unmet dependencies:
|   kdebase-bin-kde3: Conflicts: kdebase-runtime-bin-kde4 but 4:4.2.2-1 is to be installed.
|   kdebase-runtime-bin-kde4: Conflicts: kdebase-bin-kde3 but 4:3.5.10.dfsg.1-2 is installed.
`----

Note that the lenny/sid version of aptitude has the same problem (that's
why I tried out the experimental one in the first place).  Marking
kdebase-bin-kde3 as "manually installed" seems to help, though:

,----
| % sudo aptitude unmarkauto kdebase-bin-kde3
| [...]
| % LANG=C aptitude -s safe-upgrade       
| Reading package lists... Done
| Building dependency tree       
| Reading state information... Done
| Reading extended state information      
| Initializing package states... Done
| Reading task descriptions... Done  
| Resolving dependencies...
| The following packages have been kept back:
|   gitk kappfinder kate kcharselect kdebase-bin kdebase-data kdepasswd kfind klipper kmines kmix knetworkconf konqueror 
|   konqueror-nsplugins konsole kscreensaver ksnapshot ksudoku ksysguard ksysguardd 
| The following packages will be upgraded:
|   kdewallpapers lsb-base 
| 2 packages upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
| Need to get 12.2MB of archives. After unpacking 11.3MB will be used.
| Do you want to continue? [Y/n/?] 
| Would download/install/remove packages.
`----


-- Package-specific info:
aptitude 0.5.1 kompiliert am Jan 19 2009 07:18:34
Compiler: g++ 4.3.2
Kompiliert gegen:
  apt-Version 4.6.0
  NCurses-Version: 5.7
  libsigc++-Version: 2.0.18
  Ept-Unterstützung aktiviert.

Aktuelle Bibliotheksversion:
  NCurses-Version: ncurses 5.7.20090404
  cwidget-Version: 0.5.12
  Apt-Version: 4.6.0
	linux-gate.so.1 =>  (0xf7f6f000)
	libapt-pkg-libc6.7-6.so.4.6 => /usr/lib/libapt-pkg-libc6.7-6.so.4.6 (0xf7e9a000)
	libncursesw.so.5 => /lib/libncursesw.so.5 (0xf7e5c000)
	libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0xf7e55000)
	libcwidget.so.3 => /usr/lib/libcwidget.so.3 (0xf7d91000)
	libept.so.0 => /usr/lib/libept.so.0 (0xf7ccd000)
	libxapian.so.15 => /usr/lib/libxapian.so.15 (0xf7b75000)
	libz.so.1 => /usr/lib/libz.so.1 (0xf7b60000)
	libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xf7b47000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf7a58000)
	libm.so.6 => /lib/i686/cmov/libm.so.6 (0xf7a32000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf7a25000)
	libc.so.6 => /lib/i686/cmov/libc.so.6 (0xf78c5000)
	libutil.so.1 => /lib/i686/cmov/libutil.so.1 (0xf78c1000)
	libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xf78bc000)
	/lib/ld-linux.so.2 (0xf7f70000)
Terminal: dumb
$DISPLAY is set.
`which aptitude`: /usr/bin/aptitude
aptitude version information:

aptitude linkage:

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (x86_64)

Kernel: Linux 2.6.28.9-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages aptitude depends on:
ii  apt [libapt-pkg-libc6. 0.7.20.2          Advanced front-end for dpkg
ii  apt-xapian-index       0.18              maintenance tools for a Xapian ind
ii  libc6                  2.9-6             GNU C Library: Shared libraries
ii  libcwidget3            0.5.12-4          high-level terminal interface libr
ii  libept0                0.5.26            High-level library for managing De
ii  libgcc1                1:4.3.3-7         GCC support library
ii  libncursesw5           5.7+20090404-1    shared libraries for terminal hand
ii  libsigc++-2.0-0c2a     2.0.18-2          type-safe Signal Framework for C++
ii  libstdc++6             4.3.3-7           The GNU Standard C++ Library v3
ii  libxapian15            1.0.10-2          Search engine library
ii  zlib1g                 1:1.2.3.3.dfsg-13 compression library - runtime

Versions of packages aptitude recommends:
ii  aptitude-doc-en [aptitude-doc 0.5.1-1    English manual for aptitude, a ter
ii  libparse-debianchangelog-perl 1.1.1-2    parse Debian changelogs and output

Versions of packages aptitude suggests:
pn  debtags                       <none>     (no description available)
ii  tasksel                       2.78       Tool for selecting tasks for insta

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#522881; Package aptitude. (Wed, 08 Apr 2009 09:12:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Paul Menzel <pm.debian@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Wed, 08 Apr 2009 09:12:09 GMT) Full text and rfc822 format available.

Message #10 received at submit@bugs.debian.org (full text, mbox):

From: Paul Menzel <pm.debian@googlemail.com>
To: Sven Joachim <svenjoac@gmx.de>, 522881@bugs.debian.org
Cc: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Re: Bug#522881: aptitude: safe-upgrade stopped working after kde4 upload
Date: Wed, 08 Apr 2009 11:09:32 +0200
[Message part 1 (text/plain, inline)]
Package: aptitude
Version: 0.4.11.11-1


Dear Aptitude folks,


Am Dienstag, den 07.04.2009, 09:05 +0200 schrieb Sven Joachim:

> The kde4 transition in sid (which I'm not quite ready to accede yet) has
> caused the safe-upgrade command to stop functioning:

[…]

I have the same problem. I just want to add that apt-get safe-upgrade is
not showing any problems.

$ LANG=C sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  capplets-data git-gui git-svn gitk gnome gnome-accessibility
  gnome-applets-data gnome-core gnome-dbg gnome-desktop-environment
  gnome-office gnome-panel-data kaddressbook kamera kdebase-bin kdebase-data
  kdemultimedia-kio-plugins libauthen-passphrase-perl libchipcard-tools
  nautilus-data totem totem-common totem-mozilla
The following packages will be upgraded:
  cpp-4.3 cups cups-bsd cups-client cups-common cupsys g++-4.3 gcc-4.3
  gcc-4.3-base gnome-about gnome-desktop-data gnome-volume-manager
  libchipcard-ctapi0 libchipcard-data libchipcard-libgwenhywfar47-plugins
  libchipcardc2 libcups2 libcups2-dev libcupsimage2 libcupsys2 libcupsys2-dev
  libeel2-data libgcc1 libgda3-3 libgda3-3-dbg libgda3-bin libgda3-common
  libgda3-sqlite libgfortran3 libgnomekbd-common libgomp1 libgsf-1-114
  libgsf-1-114-dbg libgsf-1-common libgsf-gnome-1-114 libgsf-gnome-1-114-dbg
  libncurses5 libncurses5-dev libncursesw5 libstdc++6 libstdc++6-4.3-dev
  locales mplayer mplayer-dbg ncurses-base ncurses-bin ncurses-term
  python-feedparser python-qt4-common python-support traceroute tzdata
  tzdata-java
53 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.
Need to get 38.0MB of archives.
After this operation, 6751kB of additional disk space will be used.
Do you want to continue [Y/n]?

Here is the output of the same aptitude command from Sven from the
version in Sid again.

$ LANG=C aptitude -s -v safe-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information       
Initializing package states... Done
Reading task descriptions... Done  
The following packages are BROKEN:
  git-gui git-svn gitk gnome gnome-applets gnome-control-center gnome-core 
  gnome-dbg gnome-desktop-environment gnome-panel kaddressbook kamera 
  kcontrol kdebase-bin kdemultimedia-kio-plugins kicker 
  libauthen-passphrase-perl nautilus totem totem-gstreamer totem-mozilla 
The following packages will be REMOVED:
  bug-buddy{u} file-roller{u} gdb{u} gnome-screensaver{u} 
  kdebase-bin-kde3{u} libalut0{u} libbeecrypt6{u} libchipcardd0{u} 
  libelfg0{u} libglew1.5{u} libgnomevfs2-bin{u} libkcddb1{u} 
  libkleopatra1{u} librpm4.4{u} lzop{u} ncompress{u} p7zip{u} rpm{u} 
  rss-glx{u} unace{u} zip{u} 
The following packages will be upgraded:
  capplets-data cpp-4.3 cups cups-bsd cups-client cups-common cupsys 
  g++-4.3 gcc-4.3 gcc-4.3-base gnome-about gnome-accessibility 
  gnome-applets-data gnome-desktop-data gnome-office gnome-panel-data 
  gnome-volume-manager kdebase-data libchipcard-ctapi0 libchipcard-data 
  libchipcard-libgwenhywfar47-plugins libchipcard-tools libchipcardc2 
  libcups2 libcups2-dev libcupsimage2 libcupsys2 libcupsys2-dev 
  libeel2-data libgcc1 libgda3-3 libgda3-3-dbg libgda3-bin libgda3-common 
  libgda3-sqlite libgfortran3 libgnomekbd-common libgomp1 libgsf-1-114 
  libgsf-1-114-dbg libgsf-1-common libgsf-gnome-1-114 
  libgsf-gnome-1-114-dbg libncurses5 libncurses5-dev libncursesw5 
  libstdc++6 libstdc++6-4.3-dev locales mplayer mplayer-dbg nautilus-data 
  ncurses-base ncurses-bin ncurses-term python-feedparser python-qt4-common 
  python-support totem-common traceroute tzdata tzdata-java 
The following packages are RECOMMENDED but will NOT be installed:
  epiphany-extensions-more libxine2-dbg 
76 packages upgraded, 0 newly installed, 21 to remove and 0 not upgraded.
Need to get 67.4MB of archives. After unpacking 40.5MB will be freed.
The following packages have unmet dependencies:
  gnome-desktop-environment: Depends: empathy (>= 2.24.1) but it is not installable
                             Depends: file-roller (>= 2.24.3) but it is not installable
                             Depends: gnome-screensaver (>= 2.24.1) but it is not installable
                             Depends: gvfs-backends (>= 1.0.3) but it is not installable
                             Depends: hamster-applet (>= 2.24.3) but it is not installable
                             Depends: nautilus-cd-burner (>= 2.24.0) but 2.20.0-1 is installed.
                             Depends: seahorse-plugins (>= 2.24.1) but it is not installable
                             Depends: totem-gstreamer (>= 2.24.3) but 2.22.2-5 is installed. or
                                      totem-xine (>= 2.24.3) but it is not installable
                             Depends: totem-plugins (>= 2.24.3) but 2.22.2-5 is installed.
                             Depends: gnome-mount (>= 0.8) but 0.7-2 is installed.
  nautilus: Depends: nautilus-data (< 2.21) but 2.24.2-3 is to be installed.
  gnome-dbg: Depends: librsvg2-dbg but it is not installable
             Depends: python-gtk2-dbg but it is not installable
  kcontrol: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be installed.
  git-gui: Depends: git-core (> 1:1.6.2.2) but 1:1.6.2.1-1 is installed.
  gnome-control-center: Depends: capplets-data (< 1:2.23) but 1:2.24.0.1-2 is to be installed.
  libauthen-passphrase-perl: Depends: libauthen-dechpwd-perl (>= 2.003) but 2.002-4 is installed.
  kdemultimedia-kio-plugins: Depends: kdebase-runtime (>= 4:4.2.2) but it is not installable
                             Depends: kdelibs5 (>= 4:4.2.2) but it is not installable
                             Depends: libkcddb4 (= 4:4.2.2-1) but it is not installable
  kicker: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be installed.
  git-svn: Depends: git-core (> 1:1.6.2.2) but 1:1.6.2.1-1 is installed.
  kamera: Depends: kdebase-runtime (>= 4:4.2.2) but it is not installable
          Depends: kdelibs5 (>= 4:4.2.2) but it is not installable
  kdebase-bin: Depends: kdebase-runtime (>= 4:4.2.2) but it is not installable
               Depends: kdelibs5 (>= 4:4.2.2) but it is not installable
               Conflicts: kcontrol but 4:3.5.10.dfsg.1-2 is installed.
  totem-gstreamer: Depends: totem-common (< 2.23) but 2.24.3-3 is to be installed.
  kaddressbook: Depends: kdebase-runtime (>= 4:4.2.2) but it is not installable
                Depends: kdelibs5 (>= 4:4.2.2) but it is not installable
                Depends: kdepimlibs5 (>= 4:4.2.2) but it is not installable
                Depends: libgnokii4 but it is not installable
                Depends: libkabcommon4 (= 4:4.2.2-1) but it is not installable
                Depends: libkdepim4 (= 4:4.2.2-1) but it is not installable
                Depends: libkleo4 (= 4:4.2.2-1) but it is not installable
                Depends: libkontactinterfaces4 (= 4:4.2.2-1) but it is not installable
                Depends: libphonon4 (>= 4:4.3.0) but it is not installable
                Depends: phonon (>= 4:4.3.0) but it is not installable
                Depends: akonadi-server (>= 1.1.1) but it is not installable
  gitk: Depends: git-core (> 1:1.6.2.2) but 1:1.6.2.1-1 is installed.
  gnome-core: Depends: gnome-applets (>= 2.24.3.1) but 2.22.3-3 is installed.
              Depends: gnome-control-center (>= 1:2.24.0.1) but 1:2.22.2.1-2+b1 is installed.
              Depends: gnome-panel (>= 2.24.3) but 2.20.3-5+b1 is installed.
              Depends: gnome-settings-daemon (>= 2.24.1) but 2.22.2.1-2 is installed.
              Depends: nautilus (>= 2.24.2) but 2.20.0-7 is installed.
              Depends: rarian-compat but it is not installable
  gnome-applets: Depends: gnome-applets-data (< 2.23) but 2.24.3.1-1 is to be installed.
  gnome-panel: Depends: gnome-panel-data (< 2.21) but 2.24.3-1 is to be installed.
  totem: Depends: totem-plugins (>= 2.24.3-3) but 2.22.2-5 is installed.
         Depends: totem-gstreamer (>= 2.24.3-3) but 2.22.2-5 is installed. or
                  totem-xine (>= 2.24.3-3) but it is not installable
  gnome: Depends: rhythmbox (>= 0.12) but 0.11.6-1.1+b1 is installed.
         Depends: gedit-plugins but it is not installable
         Depends: evolution-webcal (>= 2.24.0) but 2.21.92-1+b1 is installed.
  totem-mozilla: Depends: totem-gstreamer (>= 2.24.3-3) but 2.22.2-5 is installed. or
                          totem-xine (>= 2.24.3-3) but it is not installable
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
The following packages have unmet dependencies:
  kdebase-bin-kde3: Conflicts: kdebase-runtime-bin-kde4 but 4:4.2.2-1 is to be installed.
  kdebase-runtime-bin-kde4: Conflicts: kdebase-bin-kde3 but 4:3.5.10.dfsg.1-2 is installed.


Thanks,

Paul

-- Package-specific info:
aptitude 0.4.11.11 kompiliert am Nov 20 2008 04:02:44
Compiler: g++ 4.3.2
Kompiliert gegen:
  apt-Version 4.6.0
  NCurses-Version: 5.6
  libsigc++-Version: 2.0.18
  Ept-Unterstützung aktiviert.

Aktuelle Bibliotheksversion:
  NCurses-Version: ncurses 5.7.20090328
  cwidget-Version: 0.5.12
  Apt-Version: 4.6.0
        linux-gate.so.1 =>  (0xf7f02000)
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#522881; Package aptitude. (Wed, 08 Apr 2009 09:12:11 GMT) Full text and rfc822 format available.

Acknowledgement sent to Paul Menzel <pm.debian@googlemail.com>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Wed, 08 Apr 2009 09:12:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#522881; Package aptitude. (Thu, 09 Apr 2009 04:15:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Burrows <dburrows@debian.org>:
Extra info received and forwarded to list. (Thu, 09 Apr 2009 04:15:02 GMT) Full text and rfc822 format available.

Message #20 received at 522881@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: Paul Menzel <pm.debian@googlemail.com>, 522881@bugs.debian.org, 522881-submitter@bugs.debian.org
Subject: Re: Bug#522881: aptitude: safe-upgrade stopped working after kde4 upload
Date: Wed, 8 Apr 2009 21:11:41 -0700
  As I wrote to Sven on debian-user, there are really two bugs here:

    (1) aptitude, at least on my machine, takes way too long to compute
        a dependency solution in this case.
    (2) aptitude produces a solution that still has broken dependencies.

  I don't know about (1) yet, although it's suggestive that a rendering
of the search tree has lots of identically-shaped branches, but I have a
diagnosis for (2): the root of this problem is yet another interaction
between the dependency solver and the removal of unused packages. :-(

DEBUG aptitude.apt.cache - aptitudeDepCache::sweep(): Removing kdebase-bin-kde3: it is unused.
(...)
TRACE aptitude.resolver.search - Trying to resolve kdebase-runtime 4:4.2.2-1 -> {kdebase-runtime-bin-kde4 4:4.2.2-1} by installing kdebase-runtime-bin-kde4 4:4.2.2-1
DEBUG aptitude.apt.cache - aptitudeDepCache::sweep(): Cancelling the removal of kdebase-bin-kde3: it is no longer unused.

  I'm not sure yet which package caused kdebase-bin-kde3 to become
"used", but this looks like a generic problem with the dependency
solver at first glance. (or maybe with that logic to reinstate
packages; this isn't the first time it's caused trouble)

  Daniel




Message sent on to Sven Joachim <svenjoac@gmx.de>:
Bug#522881. (Thu, 09 Apr 2009 04:15:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#522881; Package aptitude. (Tue, 14 Apr 2009 11:00:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Ariel Garcia <garcia@iwr.fzk.de>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. (Tue, 14 Apr 2009 11:00:06 GMT) Full text and rfc822 format available.

Message #28 received at 522881@bugs.debian.org (full text, mbox):

From: Ariel Garcia <garcia@iwr.fzk.de>
To: 522881@bugs.debian.org
Subject: Re: Bug#522881: aptitude: safe-upgrade stopped working after kde4 upload
Date: Tue, 14 Apr 2009 12:58:12 +0200
Hello,

same kind of problems here. Most of my apps are now KDE4.2.2 but still no 
safe way to update kdebase/konqueror/kdm... (from 3.5.10)
I just wanted to note that it doesn't only happen with aptitude but with 
apt-get also.

For instance (shorter output) if i try to install konqueror from unstable 
with apt (version 0.7.20.2) i get:

------------------------------------------------------------------------------------------------------------
# apt-get -o=Debug::pkgProblemResolver=true -t unstable -s install 
konqueror

Reading package lists... Done                                                         
Building dependency tree                                                              
Reading state information... Done                                                     
Starting                                                                              
Starting 2                                                                            
Investigating kdebase-runtime-data                                                    
Package kdebase-runtime-data has broken dep on kdebase-runtime-data-common            
  Considering kdebase-runtime-data-common 1 as a solution to 
kdebase-runtime-data 89  
Package kdebase-runtime-data has broken dep on kdebase-data                           
  Considering kdebase-data 23 as a solution to kdebase-runtime-data 89                
  Added kdebase-data to the remove list                                               
  Fixing kdebase-runtime-data via keep of kdebase-data                                
 Try to Re-Instate kdebase-data                                                       
Investigating kdebase-bin                                                             
Package kdebase-bin has broken dep on kdebase-data                                    
  Considering kdebase-data 23 as a solution to kdebase-bin 9                          
  Holding Back kdebase-bin rather than change kdebase-data                            
Investigating libkonq5                                                                
Package libkonq5 has broken dep on libkonq5-templates                                 
  Considering libkonq5-templates 1 as a solution to libkonq5 8                        
Package libkonq5 has broken dep on kdesktop                                           
  Considering kdesktop 1 as a solution to libkonq5 8                                  
  Added kdesktop to the remove list                                                   
  Fixing libkonq5 via keep of kdesktop                                                
Investigating kdebase                                                                 
Package kdebase has broken dep on kappfinder                                          
  Considering kappfinder 2 as a solution to kdebase 0                                 
    Reinst Failed because of kdebase-data                                             
    Reinst Failed because of kappfinder                                               
  Removing kdebase rather than change kappfinder                                      
Investigating kdm                                                                     
Package kdm has broken dep on libck-connector0                                        
  Considering libck-connector0 1 as a solution to kdm 0                               
  Holding Back kdm rather than change libck-connector0                                
Investigating konqueror                                                               
Package konqueror has broken dep on kdebase-data                                      
  Considering kdebase-data 23 as a solution to konqueror 10007                        
Package konqueror has broken dep on kdebase-bin                                       
  Considering kdebase-bin 9 as a solution to konqueror 10007                          
    Reinst Failed because of kdebase-data                                             
 Try to Re-Instate kdebase-bin                                                        
 Try to Re-Instate kdm                                                                
Done                                                                                  
Some packages could not be installed. This may mean that you have                     
requested an impossible situation or if you are using the unstable                    
distribution that some required packages have not yet been created                    
or been moved out of Incoming.                                                        
The following information may help to resolve the situation:                          

The following packages have unmet dependencies:
  konqueror: Depends: kdebase-data (= 4:4.2.2-1) but 4:3.5.10.dfsg.1-2 is 
to be installed
             Depends: kdebase-bin (= 4:4.2.2-1) but 4:3.5.10.dfsg.1-2 is to 
be installed 
E: Broken packages                                                                       

------------------------------------------------------------------------------------------------------------


Aptitude (0.4.11.11-1) gives:
------------------------------------------------------------------------------------------------------------
# aptitude -t unstable -s install konqueror
Reading package lists... Done                        
Building dependency tree                             
Reading state information... Done                    
Reading extended state information                   
Initializing package states... Done                  
The following packages are BROKEN:                   
  kdebase kdebase-runtime-data kdm kicker konqueror-nsplugins kpersonalizer 
ksplash libkonq5 
The following NEW packages will be installed:                                                
  libkonqsidebarplugin4{a}                                                                   
The following packages will be REMOVED:                                                      
  kcontrol{a} kdesktop{a}                                                                    
The following packages will be upgraded:                                                     
  kdebase-bin kdebase-data konqueror                                                         
3 packages upgraded, 1 newly installed, 2 to remove and 249 not upgraded.                    
Need to get 2708kB of archives. After unpacking 31.1MB will be freed.                        
The following packages have unmet dependencies:                                              
  kdebase: Depends: kcontrol (>= 4:3.5.10.dfsg.1-2) but it is not 
installable                
           Depends: kdesktop (>= 4:3.5.10.dfsg.1-2) but it is not 
installable                
  konqueror-nsplugins: Depends: konqueror (= 4:3.5.10.dfsg.1-2) but 
4:4.2.2-1 is to be installed.
  kicker: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be 
installed.            
  ksplash: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be 
installed.           
  libkonq5: Depends: libkonq5-templates but it is not installable or                             
                     kdesktop but it is not installable                                          
  kdm: Depends: kdebase-bin (= 4:3.5.10.dfsg.1-2) but 4:4.2.2-1 is to be 
installed.              
       Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be 
installed.               
  kpersonalizer: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is 
to be installed.     
  kdebase-runtime-data: Depends: kdebase-runtime-data-common (>= 4:4.2.2-1) 
but it is not installable or
                                 kdebase-data (< 4:4.0.0-1) but 4:4.2.2-1 
is to be installed.           
The following actions will resolve these dependencies:                                                  

Remove the following packages:
kdebase                       
kdm                           
kicker                        
kicker-applets                
knewsticker                   
kpersonalizer                 
ksplash                       

Install the following packages:
kdebase-runtime-data-common [4:4.2.2-1 (unstable)]
libkonq5-templates [4:4.2.2-1 (unstable)]         

Upgrade the following packages:
konqueror-nsplugins [4:3.5.10.dfsg.1-2 (testing, now) -> 4:4.2.2-1 
(unstable)]

Score is 585

Accept this solution? [Y/n/q/?]
------------------------------------------------------------------------------------------------------------


And aptitude from experimental (0.5.1-1) actually the same:
------------------------------------------------------------------------------------------------------------
# aptitude -t unstable -s install konqueror
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  kdebase kdebase-runtime-data kdm kicker konqueror-nsplugins kpersonalizer 
ksplash libkonq5
The following NEW packages will be installed:
  libkonqsidebarplugin4{a}
The following packages will be REMOVED:
  kcontrol{a} kdesktop{a}
The following packages will be upgraded:
  kdebase-bin kdebase-data konqueror
3 packages upgraded, 1 newly installed, 2 to remove and 251 not upgraded.
Need to get 2708kB of archives. After unpacking 31.1MB will be freed.
The following packages have unmet dependencies:
  kdebase: Depends: kcontrol (>= 4:3.5.10.dfsg.1-2) but it is not going to 
be installed.
           Depends: kdesktop (>= 4:3.5.10.dfsg.1-2) but it is not going to 
be installed.
  konqueror-nsplugins: Depends: konqueror (= 4:3.5.10.dfsg.1-2) but 
4:4.2.2-1 is to be installed.
  kicker: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be 
installed.
  ksplash: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be 
installed.
  libkonq5: Depends: libkonq5-templates but it is not going to be 
installed. or
                     kdesktop but it is not going to be installed.
  kdm: Depends: kdebase-bin (= 4:3.5.10.dfsg.1-2) but 4:4.2.2-1 is to be 
installed.
       Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is to be 
installed.
  kpersonalizer: Depends: kdebase-data (< 4:3.5.10.dfsg.2) but 4:4.2.2-1 is 
to be installed.
  kdebase-runtime-data: Depends: kdebase-runtime-data-common (>= 4:4.2.2-1) 
but it is not going to be installed. or
                                 kdebase-data (< 4:4.0.0-1) but 4:4.2.2-1 
is to be installed.
The following actions will resolve these dependencies:

Remove the following packages:
kdebase
kdm
kicker
kicker-applets
knewsticker
kpersonalizer
ksplash

Install the following packages:
kdebase-runtime-data-common [4:4.2.2-1 (unstable)]
libkonq5-templates [4:4.2.2-1 (unstable)]

Upgrade the following packages:
konqueror-nsplugins [4:3.5.10.dfsg.1-2 (testing, now) -> 4:4.2.2-1 
(unstable)]

Score is 585

Accept this solution? [Y/n/q/?]
------------------------------------------------------------------------------------------------------------

Is there a way to perform the install without risking breaking the 
system? :-)




Merged 522881 524667. Request was from Daniel Burrows <dburrows@debian.org> to control@bugs.debian.org. (Mon, 20 Apr 2009 03:48:05 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#522881; Package aptitude. (Mon, 20 Apr 2009 16:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Burrows <dburrows@debian.org>:
Extra info received and forwarded to list. (Mon, 20 Apr 2009 16:54:03 GMT) Full text and rfc822 format available.

Message #35 received at 522881@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: Sven Joachim <svenjoac@gmx.de>, 522881@bugs.debian.org, Paul Menzel <pm.debian@googlemail.com>, 524667@bugs.debian.org
Subject: Re: Bug#522881: aptitude: safe-upgrade stopped working after kde4 upload
Date: Mon, 20 Apr 2009 09:51:05 -0700
  I've checked a fix for this problem into head.  The fix is the most
brutal one: it just disables package reinstatement.  I have a few ideas
about how to re-enable reinstatement without reintroducing this
problem; it should allow packages to be reinstated except when they
would trigger a conflict.  Hopefully I can get the better fix
implemented for 0.5.2.

  See here for details:

http://lists.alioth.debian.org/pipermail/aptitude-devel/2009-April/001256.html

  Daniel




Tags added: pending Request was from Daniel Burrows <dburrows@debian.org> to control@bugs.debian.org. (Fri, 24 Apr 2009 02:06:06 GMT) Full text and rfc822 format available.

Tags added: pending Request was from Daniel Burrows <dburrows@debian.org> to control@bugs.debian.org. (Fri, 24 Apr 2009 02:06:21 GMT) Full text and rfc822 format available.

Reply sent to Daniel Burrows <dburrows@debian.org>:
You have taken responsibility. (Fri, 24 Apr 2009 15:35:51 GMT) Full text and rfc822 format available.

Notification sent to Sven Joachim <svenjoac@gmx.de>:
Bug acknowledged by developer. (Fri, 24 Apr 2009 15:35:52 GMT) Full text and rfc822 format available.

Message #44 received at 522881-close@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: 522881-close@bugs.debian.org
Subject: Bug#522881: fixed in aptitude 0.5.2-1
Date: Fri, 24 Apr 2009 15:02:15 +0000
Source: aptitude
Source-Version: 0.5.2-1

We believe that the bug you reported is fixed in the latest version of
aptitude, which is due to be installed in the Debian FTP archive:

aptitude-dbg_0.5.2-1_i386.deb
  to pool/main/a/aptitude/aptitude-dbg_0.5.2-1_i386.deb
aptitude-doc-cs_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-cs_0.5.2-1_all.deb
aptitude-doc-en_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-en_0.5.2-1_all.deb
aptitude-doc-fi_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-fi_0.5.2-1_all.deb
aptitude-doc-fr_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-fr_0.5.2-1_all.deb
aptitude-doc-ja_0.5.2-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-ja_0.5.2-1_all.deb
aptitude-gtk_0.5.2-1_i386.deb
  to pool/main/a/aptitude/aptitude-gtk_0.5.2-1_i386.deb
aptitude_0.5.2-1.diff.gz
  to pool/main/a/aptitude/aptitude_0.5.2-1.diff.gz
aptitude_0.5.2-1.dsc
  to pool/main/a/aptitude/aptitude_0.5.2-1.dsc
aptitude_0.5.2-1_i386.deb
  to pool/main/a/aptitude/aptitude_0.5.2-1_i386.deb
aptitude_0.5.2.orig.tar.gz
  to pool/main/a/aptitude/aptitude_0.5.2.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 522881@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Burrows <dburrows@debian.org> (supplier of updated aptitude package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 23 Apr 2009 09:08:27 -0700
Source: aptitude
Binary: aptitude aptitude-gtk aptitude-dbg aptitude-doc-cs aptitude-doc-en aptitude-doc-fi aptitude-doc-fr aptitude-doc-ja
Architecture: source i386 all
Version: 0.5.2-1
Distribution: experimental
Urgency: low
Maintainer: Daniel Burrows <dburrows@debian.org>
Changed-By: Daniel Burrows <dburrows@debian.org>
Description: 
 aptitude   - terminal-based package manager (terminal interface only)
 aptitude-dbg - Debug symbols for the aptitude package manager
 aptitude-doc-cs - Czech manual for aptitude, a terminal-based package manager
 aptitude-doc-en - English manual for aptitude, a terminal-based package manager
 aptitude-doc-fi - Finnish manual for aptitude, a terminal-based package manager
 aptitude-doc-fr - French manual for aptitude, a terminal-based package manager
 aptitude-doc-ja - Japanese manual for aptitude, a terminal-based package manager
 aptitude-gtk - terminal-based package manager (GUI and terminal interfaces)
Closes: 473296 482825 510977 511238 512384 513472 514011 514545 514676 514714 514820 514930 516296 516296 516389 516527 517272 518981 519693 521152 521255 522881 524221 524667
Changes: 
 aptitude (0.5.2-1) experimental; urgency=low
 .
   * New upstream release.
 .
     - Support for guaranteed ordering of solutions produced by the
     dependency resolver. (Closes: #514820, #514930, #524221, #473296)
 .
     - The dependency resolver will continue searching for a short time
       after finding a solution, in case a better solution turns up.
       (Closes: #482825)
 .
     - The GTK+ interface should no longer crash while trying to find
       dependency chains. (Closes: #514714)
 .
     - aptitude is now more careful about automatically canceling the
       removal of an unused package, to avoid triggering a conflict with
       other packages (for instance, packages included in a dependency
       solution). (Closes: #522881, #524667)
 .
     - The curses interface no longer warns users when they purge an
       already-removed Essental package. (Closes: #513472)
 .
     - The curses interface no longer computes an excessive amount of
       dependency information every time a package is highlighted.
       (Closes: #516296)
 .
     - Fixed incorrect formatting in some command-line error messages.
       (Closes: #516296, #514676)
 .
     - Fix really stupid column wrapping in "aptitude why".
       (Closes: #516389)
 .
     - Translation updates:
 .
       + Asturian (Closes: #518981, #519693)
       + Danish (Closes: #512384)
       + German
       + Italian
       + Norwegian Bokmål (Closes: #510977)
       + Spanish (Closes: #517272)
       + Swedish (Closes: #511238, #514011)
 .
   * Change the reportbug script to run in the C locale, so program output
     that's inserted doesn't get translated.
 .
   * Change the description of aptitude-gtk to say that it has a GUI
     interface. (Closes: #514545, #521152)
 .
   * Give aptitude-gtk a versioned dependency on aptitude. (Closes: #516527)
 .
   * Include .desktop file contributed by Fabit Greffrath.  I know that
     using su-to-root is not ideal, but since aptitude-gtk can't be used to
     install / remove packages unless it's run as root, this is probably a
     good interim approach.  Eventually we'll hook up the code so that the
     GTK+ frontend can do what the curses frontend does (automagically
     become root and preserve selections). (Closes: #521255)
 .
   * New build-deps: liblog4cxx10-dev, inkscape.
Checksums-Sha1: 
 14f15b10147b5b9572c6937fa6b5949d377b8a94 1470 aptitude_0.5.2-1.dsc
 b138312be6fcc90c81dc4c005717d512f57ea750 7133402 aptitude_0.5.2.orig.tar.gz
 ec7e4ac6bb16106322a92a6f4227bbba6c81ef96 35501 aptitude_0.5.2-1.diff.gz
 6113b0b646e805bd4f3682c345c44fe77025db5d 3330290 aptitude_0.5.2-1_i386.deb
 61d8aba41318a80441fda0fb6e43a443a01c558d 1487680 aptitude-gtk_0.5.2-1_i386.deb
 554f45fe2c4a28ca0496e07326a672dd1b9ca499 16278950 aptitude-dbg_0.5.2-1_i386.deb
 53b100d1d1ea89a350d30365ef7b1a00848bff8f 379860 aptitude-doc-cs_0.5.2-1_all.deb
 6b7d2da18ab7034cdc53fd752ae8d1be794bafb3 377440 aptitude-doc-en_0.5.2-1_all.deb
 b54e2c2bddef79b78295c653459ddf6266728003 271822 aptitude-doc-fi_0.5.2-1_all.deb
 8d5811fd20a918d3a2235e22cb461417e4c26f36 325090 aptitude-doc-fr_0.5.2-1_all.deb
 7a3a746145011cf43915be822b34b0bf83786579 388792 aptitude-doc-ja_0.5.2-1_all.deb
Checksums-Sha256: 
 3fd4c2436207d4e547ef1b834e56f3ed53d064a24086883a355946cb9669a9af 1470 aptitude_0.5.2-1.dsc
 491c7471219addaa7769655837c81206da80cc2f0ef7c510707d1499073715be 7133402 aptitude_0.5.2.orig.tar.gz
 3f8c3535a5903ae2596ec74b5253daaf20d026db4e8e2b78c8bddf832d4a9bc9 35501 aptitude_0.5.2-1.diff.gz
 73d04bfe1a88352a15ed41002d2aea6fd07291e5698c5b885c53648f4597d40e 3330290 aptitude_0.5.2-1_i386.deb
 6207d9746703f729a61d5c8b5a1f58b28c79f656f9fa0520c73a4d41e4b6a15a 1487680 aptitude-gtk_0.5.2-1_i386.deb
 6e0fbc933f99f7360b9d898e03df259bef433510724f67bea28241f4b23eac4d 16278950 aptitude-dbg_0.5.2-1_i386.deb
 acb2168e036b4966eb0bf4957cf5a12281e58350cbaa782efcb0821641bdbc24 379860 aptitude-doc-cs_0.5.2-1_all.deb
 d88bf0bc1c1aa78f1559d1d0752926a3ac5dae8b8eb0e0d1a5744c9b5f965356 377440 aptitude-doc-en_0.5.2-1_all.deb
 cf5a2c2335d7aa390fa024b0746431cafc873b3e1e38f4f8891b82b94056efcc 271822 aptitude-doc-fi_0.5.2-1_all.deb
 efacac86bb4ddf5d883d28449f30cf9f9992ed8f3f4a38e178d3a92753ef40eb 325090 aptitude-doc-fr_0.5.2-1_all.deb
 93b03cd14daa3b1f439e075e56a82ff7dd9d4eec798ba0c9d6abe8b4b55361c2 388792 aptitude-doc-ja_0.5.2-1_all.deb
Files: 
 bcfeb8ecb6ed184a74bd5eaa47b09bf7 1470 admin - aptitude_0.5.2-1.dsc
 074aeb68c570003a58f42d1e6031fa25 7133402 admin - aptitude_0.5.2.orig.tar.gz
 1e5c119f64d2ba7af4ea9c2fa71bf0d3 35501 admin - aptitude_0.5.2-1.diff.gz
 84265fa156faaaeb731a57acab855f9c 3330290 admin important aptitude_0.5.2-1_i386.deb
 f2ecb4df9b8d592c9b690c99ca37c86e 1487680 admin important aptitude-gtk_0.5.2-1_i386.deb
 ec67d6e719d9d3dc79495c62578764be 16278950 devel extra aptitude-dbg_0.5.2-1_i386.deb
 13c8fd668a55fe601d727def826f1167 379860 doc optional aptitude-doc-cs_0.5.2-1_all.deb
 620760f6d415a6c4f6994281e0c98089 377440 doc optional aptitude-doc-en_0.5.2-1_all.deb
 63de5659873f329ec0eb9183fd7c9c11 271822 doc optional aptitude-doc-fi_0.5.2-1_all.deb
 e44fe09a6758a787f5f50074b8056391 325090 doc optional aptitude-doc-fr_0.5.2-1_all.deb
 19d76cd2ebe35d7b5a7490cd9d820c16 388792 doc optional aptitude-doc-ja_0.5.2-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAknxxhMACgkQch6xsM7kSXiFZACgw5tIvOzMjJ+ooOw4sFQttOfI
BAsAoNjJ2rMrw78+q65/SaTeXZvl4xEX
=NIZF
-----END PGP SIGNATURE-----





Reply sent to Daniel Burrows <dburrows@debian.org>:
You have taken responsibility. (Fri, 24 Apr 2009 15:35:54 GMT) Full text and rfc822 format available.

Notification sent to Paul Menzel <pm.debian@googlemail.com>:
Bug acknowledged by developer. (Fri, 24 Apr 2009 15:35:54 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 23 Mar 2010 07:41:44 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 00:45:17 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.