Debian Bug report logs - #522581
gcc-4.3: Cross compilers depends on non -cross lib versions

version graph

Package: gcc-4.3; Maintainer for gcc-4.3 is Debian GCC Maintainers <debian-gcc@lists.debian.org>;

Reported by: Hector Oron <hecormar@gmail.com>

Date: Sun, 5 Apr 2009 00:51:02 UTC

Severity: important

Found in version gcc-4.3/4.3.2-1.1

Done: Arthur Loiret <aloiret@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian GCC Maintainers <debian-gcc@lists.debian.org>:
Bug#522581; Package gcc-4.3. (Sun, 05 Apr 2009 00:51:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Hector Oron <hecormar@gmail.com>:
New Bug report received and forwarded. Copy sent to Debian GCC Maintainers <debian-gcc@lists.debian.org>. (Sun, 05 Apr 2009 00:51:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Hector Oron <hecormar@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: gcc-4.3: Cross compilers depends on non -cross lib versions
Date: Sun, 05 Apr 2009 02:48:44 +0200
Package: gcc-4.3
Version: 4.3.2-1.1
Severity: important

Hi,

When building cross compilers,
Depends: gcc-4.3-s390-linux-gnu-base (= 4.3.2-1.1), cpp-4.3-s390-linux-gnu (= 4.3.2-1.1), binutils-s390-linux-gnu (>= 2.17cvs20070426), libgcc1-s390-cross (>= 1:4.3.2-1.1), libgomp1 (>= 4.3.2-1.1), libc6 (>= 2.3)

Crosscompilers should not depend on non -cross lib versions libgomp1 (>= 4.3.2-1.1), libc6 (>= 2.3)

-- System Information:
Debian Release: 5.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: armel (armv5tel)

Kernel: Linux 2.6.26-1-iop32x
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages gcc-4.3 depends on:
ii  binutils            2.18.1~cvs20080103-7 The GNU assembler, linker and bina
ii  cpp-4.3             4.3.2-1.1            The GNU C preprocessor
ii  gcc-4.3-base        4.3.2-1.1            The GNU Compiler Collection (base 
ii  libc6               2.7-18               GNU C Library: Shared libraries
ii  libgcc1             1:4.3.2-1.1          GCC support library
ii  libgomp1            4.3.2-1.1            GCC OpenMP (GOMP) support library

Versions of packages gcc-4.3 recommends:
ii  libc6-dev                     2.7-18     GNU C Library: Development Librari

Versions of packages gcc-4.3 suggests:
pn  gcc-4.3-doc                   <none>     (no description available)
pn  gcc-4.3-locales               <none>     (no description available)
pn  libgcc1-dbg                   <none>     (no description available)
pn  libgomp1-dbg                  <none>     (no description available)
pn  libmudflap0-4.3-dev           <none>     (no description available)
pn  libmudflap0-dbg               <none>     (no description available)

-- no debconf information




Reply sent to aloiret@debian.org:
You have taken responsibility. (Sun, 05 Apr 2009 07:57:04 GMT) Full text and rfc822 format available.

Notification sent to Hector Oron <hecormar@gmail.com>:
Bug acknowledged by developer. (Sun, 05 Apr 2009 07:57:04 GMT) Full text and rfc822 format available.

Message #10 received at 522581-done@bugs.debian.org (full text, mbox):

From: Arthur Loiret <aloiret@debian.org>
To: Hector Oron <hecormar@gmail.com>, 522581-done@bugs.debian.org
Subject: Re: Bug#522581: gcc-4.3: Cross compilers depends on non -cross lib versions
Date: Sun, 5 Apr 2009 09:54:25 +0200
2009/4/5, Hector Oron <hecormar@gmail.com>:
> When building cross compilers,
> Depends: gcc-4.3-s390-linux-gnu-base (= 4.3.2-1.1), cpp-4.3-s390-linux-gnu
> (= 4.3.2-1.1), binutils-s390-linux-gnu (>= 2.17cvs20070426),
> libgcc1-s390-cross (>= 1:4.3.2-1.1), libgomp1 (>= 4.3.2-1.1), libc6 (>= 2.3)
>
> Crosscompilers should not depend on non -cross lib versions libgomp1 (>=
> 4.3.2-1.1), libc6 (>= 2.3)

Of course they should! How do you expect the binaries (which are built
for host, not for target) to run without them? And the libc dependency
is even added by dpkg-shlibdeps...

Closing.




Message #11 received at 522581-done@bugs.debian.org (full text, mbox):

From: Arthur Loiret <aloiret@debian.org>
To: Hector Oron <hecormar@gmail.com>, 522581-done@bugs.debian.org
Subject: Re: Bug#522581: gcc-4.3: Cross compilers depends on non -cross lib versions
Date: Sun, 5 Apr 2009 09:56:32 +0200
2009/4/5, Hector Oron <hecormar@gmail.com>:
> When building cross compilers,
> Depends: gcc-4.3-s390-linux-gnu-base (= 4.3.2-1.1), cpp-4.3-s390-linux-gnu
> (= 4.3.2-1.1), binutils-s390-linux-gnu (>= 2.17cvs20070426),
> libgcc1-s390-cross (>= 1:4.3.2-1.1), libgomp1 (>= 4.3.2-1.1), libc6 (>= 2.3)
>
> Crosscompilers should not depend on non -cross lib versions libgomp1 (>=
> 4.3.2-1.1), libc6 (>= 2.3)

Of course they should! How do you expect the binaries (which are built
for host, not for target) to run without them? And the libc dependency
is even added by dpkg-shlibdeps...

Closing.




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 04 May 2009 07:31:51 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 08:57:12 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.