Debian Bug report logs - #521055
libgimp-perl: (unstable only) lots of "Procedure not found" warnings with Gimp 2.6

version graph

Package: libgimp-perl; Maintainer for libgimp-perl is (unknown);

Reported by: Steve Cotton <steve0001@s.cotton.clara.co.uk>

Date: Tue, 24 Mar 2009 15:18:05 UTC

Severity: serious

Tags: sid, squeeze, wheezy

Found in version libgimp-perl/2.0.dfsg+2.2pre1.dfsg-5

Fixed in version 2.0.dfsg+2.2pre1.dfsg-5+rm

Done: Debian FTP Masters <ftpmaster@ftp-master.debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Ari Pollak <ari@debian.org>:
Bug#521055; Package libgimp-perl. (Tue, 24 Mar 2009 15:18:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Steve Cotton <steve0001@s.cotton.clara.co.uk>:
New Bug report received and forwarded. Copy sent to Ari Pollak <ari@debian.org>. (Tue, 24 Mar 2009 15:18:08 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Steve Cotton <steve0001@s.cotton.clara.co.uk>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libgimp-perl: (unstable only) lots of "Procedure not found" warnings with Gimp 2.6
Date: Tue, 24 Mar 2009 15:14:57 +0000
[Message part 1 (text/plain, inline)]
Package: libgimp-perl
Version: 2.0.dfsg+2.2pre1.dfsg-5
Severity: normal

I'm affected by #520915 gimp: cannot open remote image,
which is why I'm looking for odd stuff that Gimp is doing.
libgimp-perl seems to need an update for Gimp 2.6.


If I start Gimp with an existing ~/.gimp-2.6/pluginrc , I get one error:
noct@tsunami:~$ gimp
GIMP-Error: Calling error for procedure 'gimp-procedural-db-proc-info':
Procedure 'gimp--gimp-append-data' not found


After deleting ~/.gimp-2.6/pluginrc :
noct@tsunami:~$ gimp
GIMP-Error: Calling error for procedure 'gimp-plugin-help-register':
Procedure 'gimp-plugin-help-register' has been called with value '(null)' for argument 'domain-uri' (#2, type gchararray). This value is out of range.

GIMP-Error: Calling error for procedure 'gimp-procedural-db-proc-info':
Procedure 'gimp-gimp-install-procedure' not found

GIMP-Error: Calling error for procedure 'gimp-procedural-db-proc-info':
Procedure 'gimp--gimp-append-data' not found

GIMP-Error: Calling error for procedure 'gimp-procedural-db-proc-info':
Procedure 'gimp-gimp-install-procedure' not found

GIMP-Error: Calling error for procedure 'gimp-procedural-db-proc-info':
Procedure 'gimp--gimp-append-data' not found

And the last two errors are repeated many more times.


The results of "gimp --verbose" after deleting pluginrc are attached.
The one that still appears with an existing pluginrc is from /usr/lib/gimp/2.0/plug-ins/view3d
The single 'gimp-plugin-help-register' error is from the gimp-texturize package.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

gimp 2.6.5-2+b1

Versions of packages gimp depends on:
ii  gimp-data              2.6.5-2           Data files for GIMP
ii  libaa1                 1.4p5-38          ascii art library
ii  libatk1.0-0            1.24.0-2          The ATK accessibility toolkit
ii  libbabl-0.0-0          0.0.22-1          Dynamic, any to any, pixel format 
ii  libc6                  2.9-6             GNU C Library: Shared libraries
ii  libcairo2              1.8.6-2+b1        The Cairo 2D vector graphics libra
ii  libdbus-1-3            1.2.12-1          simple interprocess messaging syst
ii  libdbus-glib-1-2       0.80-3            simple interprocess messaging syst
ii  libexif12              0.6.16-2.1        library to parse EXIF files
ii  libfontconfig1         2.6.0-3           generic font configuration library
ii  libfreetype6           2.3.9-4           FreeType 2 font engine, shared lib
ii  libgegl-0.0-0          0.0.20-1          Generic Graphics Library
ii  libgimp2.0             2.6.5-2+b1        Libraries for the GNU Image Manipu
ii  libglib2.0-0           2.20.0-2          The GLib library of C routines
ii  libgtk2.0-0            2.14.7-4+b1       The GTK+ graphical user interface 
ii  libhal1                0.5.11-8          Hardware Abstraction Layer - share
ii  libjpeg62              6b-14             The Independent JPEG Group's JPEG 
ii  liblcms1               1.17.dfsg-1       Color management library
ii  libmng1                1.0.9-1           Multiple-image Network Graphics li
ii  libpango1.0-0          1.22.4-3          Layout and rendering of internatio
ii  libpng12-0             1.2.35-1          PNG library - runtime
ii  libpoppler-glib4       0.10.4-3          PDF rendering library (GLib-based 
ii  librsvg2-2             2.22.3-2          SAX-based renderer library for SVG
ii  libtiff4               3.8.2-11          Tag Image File Format (TIFF) libra
ii  libwebkit-1.0-1        1.0.1-4+b1        Web content engine library for Gtk
ii  libwmf0.2-7            0.2.8.4-6         Windows metafile conversion librar
ii  libx11-6               2:1.2-1           X11 client-side library
ii  libxext6               2:1.0.4-1         X11 miscellaneous extension librar
ii  libxfixes3             1:4.0.3-2         X11 miscellaneous 'fixes' extensio
ii  libxmu6                2:1.0.4-1         X11 miscellaneous utility library
ii  libxpm4                1:3.5.7-1         X11 pixmap library
ii  python                 2.5.4-2           An interactive high-level object-o
ii  python-gtk2            2.14.1-1          Python bindings for the GTK+ widge
ii  python-support         0.8.7             automated rebuilding support for P
ii  zlib1g                 1:1.2.3.3.dfsg-13 compression library - runtime

gimp recommends no packages.

Versions of packages gimp suggests:
ii  ghostscript      8.64~dfsg-1             The GPL Ghostscript PostScript/PDF
ii  gimp-data-extras 1:2.0.1-3               An extra set of brushes, palettes,
ii  gimp-help-en [gi 2.4.1-1                 Documentation for the GIMP (Englis
ii  gvfs-backends    1.0.3-3                 userspace virtual filesystem - bac
ii  libasound2       1.0.19-1                shared library for ALSA applicatio
ii  libgimp-perl     2.0.dfsg+2.2pre1.dfsg-5 Perl support and plugins for The G

-- no debconf information
[gimp_nopluginrc.txt (text/plain, attachment)]

Severity set to `serious' from `normal' Request was from Ari Pollak <ari@debian.org> to control@bugs.debian.org. (Sun, 03 May 2009 01:12:14 GMT) Full text and rfc822 format available.

Added tag(s) squeeze and sid. Request was from Holger Levsen <holger@layer-acht.org> to control@bugs.debian.org. (Thu, 07 Jan 2010 14:48:21 GMT) Full text and rfc822 format available.

Added tag(s) wheezy. Request was from Kurt Roeckx <kurt@roeckx.be> to control@bugs.debian.org. (Wed, 16 Feb 2011 19:03:21 GMT) Full text and rfc822 format available.

Reply sent to Debian FTP Masters <ftpmaster@ftp-master.debian.org>:
You have taken responsibility. (Tue, 19 Jul 2011 10:40:01 GMT) Full text and rfc822 format available.

Notification sent to Steve Cotton <steve0001@s.cotton.clara.co.uk>:
Bug acknowledged by developer. (Tue, 19 Jul 2011 10:40:03 GMT) Full text and rfc822 format available.

Message #16 received at 521055-done@bugs.debian.org (full text, mbox):

From: Debian FTP Masters <ftpmaster@ftp-master.debian.org>
To: 159461-done@bugs.debian.org,280428-done@bugs.debian.org,404677-done@bugs.debian.org,521055-done@bugs.debian.org,534027-done@bugs.debian.org,623531-done@bugs.debian.org,
Cc: libgimp-perl@packages.debian.org, libgimp-perl@packages.qa.debian.org
Subject: Bug#634349: Removed package(s) from unstable
Date: Tue, 19 Jul 2011 10:37:50 +0000
Version: 2.0.dfsg+2.2pre1.dfsg-5+rm

Dear submitter,

as the package libgimp-perl has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see http://bugs.debian.org/634349

The version of this package that was in Debian prior to this removal
can still be found using http://snapshot.debian.org/.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmaster@debian.org.

Debian distribution maintenance software
pp.
Alexander Reichle-Schmehl (the ftpmaster behind the curtain)




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 17 Aug 2011 07:36:56 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 25 08:49:00 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.