Debian Bug report logs - #520439
xfe requires libcups2

version graph

Package: xfe; Maintainer for xfe is Joachim Wiedorn <ad_debian@joonet.de>; Source for xfe is src:xfe.

Reported by: Brian Sammon <debian-bugs@brisammon.fastmail.fm>

Date: Thu, 19 Mar 2009 19:24:02 UTC

Severity: important

Found in version xfe/1.04-2.1

Fixed in version xfe/1.32.1-1

Done: Joachim Wiedorn <ad_debian@joonet.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Jose Carlos Medeiros <debian@psabs.com.br>:
Bug#520439; Package xfe. (Thu, 19 Mar 2009 19:24:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Brian Sammon <debian-bugs@brisammon.fastmail.fm>:
New Bug report received and forwarded. Copy sent to Jose Carlos Medeiros <debian@psabs.com.br>. (Thu, 19 Mar 2009 19:24:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Brian Sammon <debian-bugs@brisammon.fastmail.fm>
To: submit@bugs.debian.org
Subject: xfe requires libcups2
Date: Thu, 19 Mar 2009 15:20:00 -0400
Package: xfe
Version: 1.04-2.1
Severity: important

The xfe package installs with no error, but then it won't run.

# xfe
xfe: error while loading shared libraries: libcups.so.2: cannot open shared object file: No such file or directory

# ldd /usr/bin/xfe
        linux-gate.so.1 =>  (0xffffe000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb7edd000)
        libFOX-1.6.so.0 => /usr/lib/libFOX-1.6.so.0 (0xb7b8e000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7aa2000)
        libm.so.6 => /lib/libm.so.6 (0xb7a7c000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7a71000)
        libc.so.6 => /lib/libc.so.6 (0xb7924000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb7838000)
        libXft.so.2 => /usr/lib/libXft.so.2 (0xb7825000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb780d000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb77f8000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb77ea000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb77bf000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb77b6000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb77b0000)
        libdl.so.2 => /lib/libdl.so.2 (0xb77ab000)
        librt.so.1 => /lib/librt.so.1 (0xb77a2000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb7784000)
        libtiff.so.4 => /usr/lib/libtiff.so.4 (0xb7737000)
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0xb7727000)
        libcups.so.2 => not found
        libnsl.so.1 => /lib/libnsl.so.1 (0xb770e000)
        libGLU.so.1 => /usr/lib/libGLU.so.1 (0xb768c000)
        libGL.so.1 => /usr/lib/i686/cmov/libGL.so.1 (0xb73df000)
        /lib/ld-linux.so.2 (0xb7f10000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb73dc000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb73d7000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7367000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb735f000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb733f000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb733a000)

-- System Information:
Debian Release: lenny/sid
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-3-686 (SMP w/1 CPU core)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages xfe depends on:
ii  libc6                     2.7-4          GNU C Library: Shared libraries
ii  libfox-1.6-0              1.6.25-1       The FOX C++ GUI Toolkit
ii  libgcc1                   1:4.2.2-3      GCC support library
ii  libpng12-0                1.2.15~beta5-1 PNG library - runtime
ii  libstdc++6                4.2.2-3        The GNU Standard C++ Library v3
ii  libx11-6                  2:1.0.3-7      X11 client-side library
ii  libxft2                   2.1.8.2-8      FreeType-based font drawing librar
ii  ucf                       1.07           Update Configuration File: preserv

Versions of packages xfe recommends:
ii  rpm                           4.0.4-28   Red Hat package manager

-- no debconf information




Message sent on to Brian Sammon <debian-bugs@brisammon.fastmail.fm>:
Bug#520439. (Sun, 07 Jun 2009 10:09:24 GMT) Full text and rfc822 format available.

Message #8 received at 520439-submitter@bugs.debian.org (full text, mbox):

From: Niels Thykier <niels@thykier.net>
To: 520439-submitter@bugs.debian.org
Subject: Re: xfe requires libcups2
Date: Sun, 07 Jun 2009 11:59:21 +0200
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi

I just checked xfe's dependency list:

  xfe depends on libfox-1.6-0
  libfox-1.6-0 depends on libcupsys2 (>= 1.2.7)
  libcupsys2 (1.3.10-2*) depends on libcups2

and libcups2 contains libcups.so.2.

*) 1.3.10-2 is the version installed on my machine.

My apt prefers "testing" - this is probably a "stable only" issue.

~NT
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkorj3YACgkQVCqoiq1YlqxATQCfX9hgjIfNkwUdxkVKVhivWDA+
CzkAoIcHIDEcJ7OzEuFIR8f/C2w/rZyi
=WtEx
-----END PGP SIGNATURE-----





Added tag(s) pending. Request was from Anibal Monsalve Salazar <anibal@debian.org> to control@bugs.debian.org. (Sat, 21 Nov 2009 19:12:19 GMT) Full text and rfc822 format available.

Reply sent to Joachim Wiedorn <ad_debian@joonet.de>:
You have taken responsibility. (Wed, 25 Nov 2009 19:12:32 GMT) Full text and rfc822 format available.

Notification sent to Brian Sammon <debian-bugs@brisammon.fastmail.fm>:
Bug acknowledged by developer. (Wed, 25 Nov 2009 19:12:32 GMT) Full text and rfc822 format available.

Message #15 received at 520439-close@bugs.debian.org (full text, mbox):

From: Joachim Wiedorn <ad_debian@joonet.de>
To: 520439-close@bugs.debian.org
Subject: Bug#520439: fixed in xfe 1.32.1-1
Date: Wed, 25 Nov 2009 19:06:12 +0000
Source: xfe
Source-Version: 1.32.1-1

We believe that the bug you reported is fixed in the latest version of
xfe, which is due to be installed in the Debian FTP archive:

xfe-i18n_1.32.1-1_all.deb
  to main/x/xfe/xfe-i18n_1.32.1-1_all.deb
xfe-themes_1.32.1-1_all.deb
  to main/x/xfe/xfe-themes_1.32.1-1_all.deb
xfe_1.32.1-1.debian.tar.gz
  to main/x/xfe/xfe_1.32.1-1.debian.tar.gz
xfe_1.32.1-1.dsc
  to main/x/xfe/xfe_1.32.1-1.dsc
xfe_1.32.1-1_amd64.deb
  to main/x/xfe/xfe_1.32.1-1_amd64.deb
xfe_1.32.1.orig.tar.gz
  to main/x/xfe/xfe_1.32.1.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 520439@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Joachim Wiedorn <ad_debian@joonet.de> (supplier of updated xfe package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 16 Nov 2009 09:32:10 +0100
Source: xfe
Binary: xfe xfe-i18n xfe-themes
Architecture: source all amd64
Version: 1.32.1-1
Distribution: unstable
Urgency: low
Maintainer: Joachim Wiedorn <ad_debian@joonet.de>
Changed-By: Joachim Wiedorn <ad_debian@joonet.de>
Description: 
 xfe        - A lightweight file manager for X11
 xfe-i18n   - A lightweight file manager for X11 (i18n support)
 xfe-themes - A lightweight file manager for X11 (themes)
Closes: 311019 355617 362224 368767 445721 469572 471578 475940 500670 505855 520439 529693 529855 530431
Changes: 
 xfe (1.32.1-1) unstable; urgency=low
 .
   * New upstream release. (Closes: #529693, #529855, #311019, #530431, #500670)
       (Closes: #362224, #505855, #355617, #368767, #469572, #475940, #471578)
   * debian/control:
     - Update to debhelper (>= 7).
     - Change to Standards-Version: 3.8.3.
     - Add dependency libcups2 to package xfe. (Closes: #520439)
     - Add build dependency libcups2-dev and intltool.
   * Change to Debian source format 3.0 (quilt).
   * Split into three packages: xfe, xfe-i18n and xfe-themes
       and set links to the doc directory of xfe package.
   * Using application names: xfimage, xfview, xfwrite, xfpack
       and set preferences to right application names. (Closes: #445721)
   * Add some new suffixes to xferc.
   * Add minor update to german translation (mk, asc, mp4).
Checksums-Sha1: 
 8f6e22e000dc77311f48d271338348f0abd7f83d 1215 xfe_1.32.1-1.dsc
 e3a1dd5a58406bd007365f97581dd418d77cf1d0 2112854 xfe_1.32.1.orig.tar.gz
 053347e47b5c5eebf440433ec693dfd100ee0307 37245 xfe_1.32.1-1.debian.tar.gz
 d2e0829ff3eb6cb93b1a5a7232e2d8080cd4d1e4 295446 xfe-i18n_1.32.1-1_all.deb
 cdb61ff2341e4a677b52ef92b454894bcd9e8a4a 513266 xfe-themes_1.32.1-1_all.deb
 33947aa49cee5e4767a6c1ea9f191ace99aa9f79 1776872 xfe_1.32.1-1_amd64.deb
Checksums-Sha256: 
 c742e0926cc348b46916a11b80bd85d0f183e0fd2d3386ccd9629568b3c98b98 1215 xfe_1.32.1-1.dsc
 d859be0f2fe7fc35d0ae6b1f353479073d4d083eb2d67e5ad59c24f979b37e47 2112854 xfe_1.32.1.orig.tar.gz
 b24e25a393d687dd3addece28da08f074e8fb3613a4e00f5293f38c2b159f7e7 37245 xfe_1.32.1-1.debian.tar.gz
 58e03f9219ca6b827a50408fdb48829d440e4980849272587131518ef43fc6ff 295446 xfe-i18n_1.32.1-1_all.deb
 684c2f36212c36a33baa95497a4f82d16b2e3af2b5966bc6cfaa00ae1e2c9190 513266 xfe-themes_1.32.1-1_all.deb
 7988039b2c2c25131f368664e52c0bfe70cf57cee7949d529912995f7945d72d 1776872 xfe_1.32.1-1_amd64.deb
Files: 
 6f6b394d07bc6a5c48d41d365347372a 1215 x11 optional xfe_1.32.1-1.dsc
 fb619876f78661f925b3123aeceeb4a8 2112854 x11 optional xfe_1.32.1.orig.tar.gz
 55ca42ebc684792b6a02356e4a89132e 37245 x11 optional xfe_1.32.1-1.debian.tar.gz
 8d0cafdd89a713a4c90c36fea1276cf7 295446 x11 optional xfe-i18n_1.32.1-1_all.deb
 fc37250dd61c6ad9985c7f2feaecc305 513266 x11 optional xfe-themes_1.32.1-1_all.deb
 a34e97f19f9bc026761f6be1eb188263 1776872 x11 optional xfe_1.32.1-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAksHzKcACgkQeBwlBDLsbz7I5wCfU2bvHa8E1sSrKmY5b4O/A9SA
MD4An0YEKGUoPiVbAGRh4PU72zj9J5hP
=mQaN
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 19 Feb 2010 07:31:08 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 10:31:54 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.