Debian Bug report logs - #520285
installation-reports: The squeeze netinst dosn't configure DHCP

Package: debian-installer; Maintainer for debian-installer is Debian Install System Team <debian-boot@lists.debian.org>; Source for debian-installer is src:debian-installer.

Reported by: "Alexander V.Inyakin" <Alexandre.Inyakin@cern.ch>

Date: Wed, 18 Mar 2009 16:54:01 UTC

Severity: grave

Merged with 517231, 520442, 520711, 528929

Done: Pierre Bauduin <pierre@baudu.in>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Alexandre.Inyakin@cern.ch, Debian Install Team <debian-boot@lists.debian.org>:
Bug#520285; Package installation-reports. (Wed, 18 Mar 2009 16:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Alexander V.Inyakin" <Alexandre.Inyakin@cern.ch>:
New Bug report received and forwarded. Copy sent to Alexandre.Inyakin@cern.ch, Debian Install Team <debian-boot@lists.debian.org>. (Wed, 18 Mar 2009 16:54:03 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "Alexander V.Inyakin" <Alexandre.Inyakin@cern.ch>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: installation-reports: The squeeze netinst dosn't configure DHCP
Date: Wed, 18 Mar 2009 17:50:45 +0100
Package: installation-reports
Severity: critical
Justification: breaks the whole installation



-- Package-specific info:

Boot method: cd
Image version: debian-testing-i386-netinst.iso                 18-Mar-2009 10:32  152M
Date: <17:00 18.03.2009>

Machine: Compaq Presario CQ60

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O ]
Detect network card:    [O ]
Configure network:      [E ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Install base system:    [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ ]

Comments/Problems:

The network card (Realtek RTL8102E) detected.
The DHCP configuration failed.
Being loaded at the same hw the lenny netinst configure DHCP without problems

Architecture: i386 (i686)




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Install Team <debian-boot@lists.debian.org>:
Bug#520285; Package installation-reports. (Tue, 14 Apr 2009 10:48:12 GMT) Full text and rfc822 format available.

Acknowledgement sent to Dinyar Rabady <dinyar.rabady@univie.ac.at>:
Extra info received and forwarded to list. Copy sent to Debian Install Team <debian-boot@lists.debian.org>. (Tue, 14 Apr 2009 10:48:12 GMT) Full text and rfc822 format available.

Message #10 received at 520285@bugs.debian.org (full text, mbox):

From: Dinyar Rabady <dinyar.rabady@univie.ac.at>
To: 520285@bugs.debian.org
Subject: Re: installation-reports: The squeeze netinst dosn't configure DHCP
Date: Tue, 14 Apr 2009 12:38:28 +0200
I can reproduce this error with the daily image from Monday, April 13.
I used the amd64 images netinstall per usb-stick method on a Lenovo
x61s and the configuration of the network failed both with DHCP aswell
as manually. The console output indicates that the configuaration
doesn't actually fail, as the NIC is bound to the correct IP-adress
after the network configuration. The installer just doesn't seem to be
able to see this.

-- 
Please avoid sending me Word, Excel or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html

Unite against human rights abuse in the 'war on terror'
http://www.unsubscribe-me.org

Amnesty International




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Install Team <debian-boot@lists.debian.org>:
Bug#520285; Package installation-reports. (Tue, 14 Apr 2009 16:18:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Glenn Saberton <gsaberton@foomagic.org>:
Extra info received and forwarded to list. Copy sent to Debian Install Team <debian-boot@lists.debian.org>. (Tue, 14 Apr 2009 16:18:07 GMT) Full text and rfc822 format available.

Message #15 received at 520285@bugs.debian.org (full text, mbox):

From: Glenn Saberton <gsaberton@foomagic.org>
To: Dinyar Rabady <dinyar.rabady@univie.ac.at>, 520285@bugs.debian.org
Subject: Re: Bug#520285: installation-reports: The squeeze netinst dosn't configure DHCP
Date: Wed, 15 Apr 2009 00:15:45 +0800
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Dinyar Rabady wrote:
> I can reproduce this error with the daily image from Monday, April 13.
> I used the amd64 images netinstall per usb-stick method on a Lenovo
> x61s and the configuration of the network failed both with DHCP aswell
> as manually. The console output indicates that the configuaration
> doesn't actually fail, as the NIC is bound to the correct IP-adress
> after the network configuration. The installer just doesn't seem to be
> able to see this.
> 
The timeout for dhcp configuration in with the debconf display is 15
seconds. Sometimes dhcp can take longer than this to get a lease and
then succeed after the debconf display has indicated an error,
particularly with wireless. I have seen this a few times, but i'm not
sure what the original thoughts were irt the timeout for dhcp configuration.

Cheers

Glenn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEUEARECAAYFAknktrEACgkQV8GyuTwyskOBbQCgsl3uCPknGIMgjs/oqKQOYIBG
ZpoAli+SsJQyCzt4Dvt9vVF1KYGBjYY=
=NGBP
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Install Team <debian-boot@lists.debian.org>:
Bug#520285; Package installation-reports. (Fri, 08 May 2009 22:54:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Matt H <hayden760@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Install Team <debian-boot@lists.debian.org>. (Fri, 08 May 2009 22:54:03 GMT) Full text and rfc822 format available.

Message #20 received at 520285@bugs.debian.org (full text, mbox):

From: Matt H <hayden760@gmail.com>
To: 520285@bugs.debian.org
Subject: Re: installation-reports: The squeeze netinst dosn't configure DHCP
Date: Fri, 8 May 2009 15:53:13 -0700
[Message part 1 (text/plain, inline)]
I can reproduce this error on the testing iso for may 4th.

debian-testing-amd64-CD-1.iso
<http://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/debian-testing-amd64-CD-1.iso>
          04-May-2009 09:44  645M

My NIC is an onboard nvidia card, on a p5n-d motherboard. I've tried
installing by burning to a CD, and using a USB stick with the latest
debian installer files.
If I choose to manually configure the IP address I still get an error
message saying that network configuration failed. Furthermore, if I
countinue the install, I end up having no network connection when I
log in once installation is finished.
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Install Team <debian-boot@lists.debian.org>:
Bug#520285; Package installation-reports. (Sat, 09 May 2009 06:54:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to Christian Perrier <bubulle@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Install Team <debian-boot@lists.debian.org>. (Sat, 09 May 2009 06:54:08 GMT) Full text and rfc822 format available.

Message #25 received at 520285@bugs.debian.org (full text, mbox):

From: Christian Perrier <bubulle@debian.org>
To: Matt H <hayden760@gmail.com>, 520285@bugs.debian.org
Subject: Re: Bug#520285: installation-reports: The squeeze netinst dosn't configure DHCP
Date: Sat, 9 May 2009 08:51:20 +0200
[Message part 1 (text/plain, inline)]
Quoting Matt H (hayden760@gmail.com):
> I can reproduce this error on the testing iso for may 4th.
> 
> debian-testing-amd64-CD-1.iso
> <http://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/debian-testing-amd64-CD-1.iso>
>           04-May-2009 09:44  645M
> 
> My NIC is an onboard nvidia card, on a p5n-d motherboard. I've tried
> installing by burning to a CD, and using a USB stick with the latest
> debian installer files.
> If I choose to manually configure the IP address I still get an error
> message saying that network configuration failed. Furthermore, if I
> countinue the install, I end up having no network connection when I
> log in once installation is finished.

In the original bug report, it was said that the IP was indeed setup
and thus the problem was apparently some timeout problem.

Could you retry and, when you get the DHCP failure message, swith to
console 2 and check whether the IP address is indeed assigned to your
NIC card or not?

-- 


[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Install Team <debian-boot@lists.debian.org>:
Bug#520285; Package installation-reports. (Sat, 09 May 2009 09:03:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Matt H <hayden760@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Install Team <debian-boot@lists.debian.org>. (Sat, 09 May 2009 09:03:08 GMT) Full text and rfc822 format available.

Message #30 received at 520285@bugs.debian.org (full text, mbox):

From: Matt H <hayden760@gmail.com>
To: 520285@bugs.debian.org
Subject: Re: Bug#520285: installation-reports: The squeeze netinst dosn't configure DHCP
Date: Sat, 9 May 2009 02:00:16 -0700
[Message part 1 (text/plain, inline)]
At a glance it does look like dhcp assigns an address. I've attached my
syslog from the installation if you want a look at the full thing, I'll post
what I think is relevant below. When the installer is setting up the
network, it actually says autoconfiguration of the network successful, and
then about 1 second later it comes up with the error screen saying network
setup failed. Also like I said earlier, when I just went ahead and installed
despite the error, once installation was complete and I booted into squeeze,
I had no internet connection. I'll confirm this later today again.
As for the log, I know that mac address is the address of my ethernet card,
so all should be well. The thing that stands out is the segfault in
libresolv-2.9.so though.

May  9 01:23:06 main-menu[1868]: INFO: Menu item 'netcfg' selected
May  9 01:23:06 netcfg[8955]: INFO: eth0 is connected.
May  9 01:23:07 dhclient: Internet Systems Consortium DHCP Client V3.1.1
May  9 01:23:07 dhclient: Copyright 2004-2008 Internet Systems Consortium.
May  9 01:23:07 dhclient: All rights reserved.
May  9 01:23:07 dhclient: For info, please visit http://www.isc.org/sw/dhcp/
May  9 01:23:07 dhclient:
May  9 01:23:08 dhclient: Listening on LPF/eth0/00:1f:c6:66:dd:e2
May  9 01:23:08 dhclient: Sending on   LPF/eth0/00:1f:c6:66:dd:e2
May  9 01:23:08 dhclient: Sending on   Socket/fallback
May  9 01:23:08 dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67
interval 4
May  9 01:23:08 dhclient: DHCPOFFER from 192.168.1.1
May  9 01:23:08 dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
May  9 01:23:08 dhclient: DHCPACK from 192.168.1.1
May  9 01:23:08 dhclient: bound to 192.168.1.106 -- renewal in 33146
seconds.
May  9 01:23:10 kernel: [   44.548370] __ratelimit: 79 messages suppressed
May  9 01:23:10 kernel: [   44.548370] netcfg[8955]: segfault at
7ffb6ff13436 ip 7ffb6ef87719 sp 7fff7811f080 error 7 in libresolv-2.9.so
[7ffb6ef7e000+13000]
May  9 01:23:10 main-menu[1868]: (process:8954): Internet Systems Consortium
DHCP Client V3.1.1
May  9 01:23:10 main-menu[1868]: (process:8954): Copyright 2004-2008
Internet Systems Consortium.
May  9 01:23:10 main-menu[1868]: (process:8954): All rights reserved.
May  9 01:23:10 main-menu[1868]: (process:8954): For info, please visit
http://www.isc.org/sw/dhcp/
May  9 01:23:10 main-menu[1868]: (process:8954):
May  9 01:23:10 main-menu[1868]: (process:8954): Listening on
LPF/eth0/00:1f:c6:66:dd:e2
May  9 01:23:10 main-menu[1868]: (process:8954): Sending on
LPF/eth0/00:1f:c6:66:dd:e2
May  9 01:23:10 main-menu[1868]: (process:8954): Sending on
Socket/fallback
May  9 01:23:10 main-menu[1868]: (process:8954): DHCPDISCOVER on eth0 to
255.255.255.255 port 67 interval 4
May  9 01:23:10 main-menu[1868]: (process:8954): DHCPOFFER from 192.168.1.1
May  9 01:23:10 main-menu[1868]: (process:8954): DHCPREQUEST on eth0 to
255.255.255.255 port 67
May  9 01:23:10 main-menu[1868]: (process:8954): DHCPACK from 192.168.1.1
May  9 01:23:10 main-menu[1868]: (process:8954): bound to 192.168.1.106 --
renewal in 33146 seconds.
May  9 01:23:10 main-menu[1868]: WARNING **: Configuring 'netcfg' failed
with error code 139
May  9 01:23:10 main-menu[1868]: WARNING **: Menu item 'netcfg' failed.
[Message part 2 (text/html, inline)]
[syslog.zip (application/zip, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Install Team <debian-boot@lists.debian.org>:
Bug#520285; Package installation-reports. (Mon, 01 Jun 2009 06:36:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julian Hughes <julianhughes@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Install Team <debian-boot@lists.debian.org>. (Mon, 01 Jun 2009 06:36:03 GMT) Full text and rfc822 format available.

Message #35 received at 520285@bugs.debian.org (full text, mbox):

From: Julian Hughes <julianhughes@gmail.com>
To: 520285@bugs.debian.org
Subject: Re: installation-reports: The squeeze netinst dosn't configure DHCP
Date: Mon, 1 Jun 2009 07:33:45 +0100
I can reproduce this bug exactly using squeeze i386 netinstaller of 31
May.

hardware Asus M5N laptop, wired network interface Realtek
8139/8139c/8139c+ (rev 10). Laptop is essentially Intel ICH4.

DHCP works and the expected IP address is allocated by the router but
then netcfg fails error code 139.  I checked using static IP and netcfg
fails as well but also libresolve segfaults. 

The network interface and the router are both proven good by the fact
that the Lenny installer works, as do others such as BSDs. And in vtty2
dhclient works fine.




Bug reassigned from package `installation-reports' to `debian-installer'. Request was from Max Vozeler <xam@debian.org> to control@bugs.debian.org. (Sat, 18 Jul 2009 18:09:11 GMT) Full text and rfc822 format available.

Forcibly Merged 517231 520285 520442 520711 528929. Request was from Max Vozeler <xam@debian.org> to control@bugs.debian.org. (Sat, 18 Jul 2009 18:09:13 GMT) Full text and rfc822 format available.

Bug archived. Request was from Max Vozeler <xam@debian.org> to control@bugs.debian.org. (Sat, 18 Jul 2009 18:09:15 GMT) Full text and rfc822 format available.

Message sent on to "Alexander V.Inyakin" <Alexandre.Inyakin@cern.ch>:
Bug#520285. (Sat, 18 Jul 2009 18:09:24 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 16:19:25 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.