Debian Bug report logs - #519005
suphp and phpmyadmin

version graph

Package: libapache2-mod-suphp; Maintainer for libapache2-mod-suphp is Emmanuel Lacour <elacour@home-dn.net>; Source for libapache2-mod-suphp is src:suphp.

Reported by: Stephane Leclerc <sleclerc@actionweb.fr>

Date: Mon, 9 Mar 2009 20:42:02 UTC

Severity: normal

Found in version suphp/0.6.2-3

Fixed in version suphp/0.7.1-1

Done: Emmanuel Lacour <elacour@home-dn.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Emmanuel Lacour <elacour@home-dn.net>:
Bug#519005; Package libapache2-mod-suphp. (Mon, 09 Mar 2009 20:42:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Stephane Leclerc <sleclerc@actionweb.fr>:
New Bug report received and forwarded. Copy sent to Emmanuel Lacour <elacour@home-dn.net>. (Mon, 09 Mar 2009 20:42:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Stephane Leclerc <sleclerc@actionweb.fr>
To: Bug Debian <submit@bugs.debian.org>
Subject: suphp and phpmyadmin
Date: Mon, 09 Mar 2009 21:40:28 +0100
Package: libapache2-mod-suphp
Version: 0.6.2-3
Severity: normal


Hi!

phpMyAdmin (debian package) is not running with suphp.

http://vhost/phpmyadmin/ don't want to be php executed (firefox ask to save
as...).

I tried with an "Alias /phpMyAdmin /usr/share/phpmyadmin" in the vhost or
directly with an ln -s inside the root vhost. No success.

I also tried the old way of configure suphp.conf and
/mods-available/suphp.conf, without success too.

I've an old Lenny testing uptodate working well with phpmyadmin, but the 2
last dist-upgraded servers with the final Lenny release, don't work.

Don't work with the "default" vhost shipped with Apache2.

Anny idea of a bug or a miss use from me?

best regards

Stéphane


ii  libapache2-mod-fastcgi                       2.4.6-1
ii  libapache2-mod-suphp                         0.6.2-3
ii  apache2-mpm-prefork                          2.2.9-10+lenny2
ii  suphp-common                                 0.6.2-3
ii  php5-cgi                                     5.2.6.dfsg.1-1+lenny2
ii  phpmyadmin                                   4:2.11.8.1-5

libapache2-mod-php5 is not installed.


Abonnez-vous à la newsletter technique.
http://liste.actionweb.fr/mailman/listinfo/client-aweb

...............................................................
.  Linux - Debian - php5 - JAVA/Tomcat - MySQL - Infogerance  .
.   email: support@actionweb.fr - http://www.actionweb.fr/    .
.      Tel: (0)141 906 100    -    Fax: (0)141 906 101        .
...............................................................






Information forwarded to debian-bugs-dist@lists.debian.org, Emmanuel Lacour <elacour@home-dn.net>:
Bug#519005; Package libapache2-mod-suphp. (Tue, 07 Apr 2009 09:12:13 GMT) Full text and rfc822 format available.

Acknowledgement sent to Stephane Leclerc <sleclerc@actionweb.fr>:
Extra info received and forwarded to list. Copy sent to Emmanuel Lacour <elacour@home-dn.net>. (Tue, 07 Apr 2009 09:12:13 GMT) Full text and rfc822 format available.

Message #10 received at 519005@bugs.debian.org (full text, mbox):

From: Stephane Leclerc <sleclerc@actionweb.fr>
To: <519005@bugs.debian.org>
Subject: suphp and phpmyadmin
Date: Tue, 07 Apr 2009 11:04:51 +0200
Package: libapache2-mod-suphp
Version: 0.6.2-3
Severity: important

Hello!

I'm back on this bug with last suphp and phpmyadmin.

The curent configuration shipped with suphp-common doesn't work with
external program outside doc root (as http://vhost/phpmyadmin).

The changes below permit to really use external program and use both
php5-cgi and mod_php5 (just need to use suPHP_Engine off somewhere in the
vhost).

For /etc/suphp/suphp.conf

Change:

  application/x-httpd-php="php:/usr/bin/php-cgi"

to:

  application/x-httpd-suphp="php:/usr/bin/php-cgi"

(add of "su")

And for /etc/apache2/mods-available/suphp.conf

Change:

 AddType application/x-httpd-php .php .php3 .php4 .php5 .phtml
 suPHP_AddHandler application/x-httpd-php

to:

 AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
 suPHP_AddHandler application/x-httpd-suphp

(add of "su")

That's all!

This has been tested with both suphp 0.6.2 and 0.7.1.

It will be great to have suphp 0.7.1 packaged.

Cheers,

Stéphane







Reply sent to Emmanuel Lacour <elacour@home-dn.net>:
You have taken responsibility. (Fri, 07 Aug 2009 12:30:07 GMT) Full text and rfc822 format available.

Notification sent to Stephane Leclerc <sleclerc@actionweb.fr>:
Bug acknowledged by developer. (Fri, 07 Aug 2009 12:30:08 GMT) Full text and rfc822 format available.

Message #15 received at 519005-close@bugs.debian.org (full text, mbox):

From: Emmanuel Lacour <elacour@home-dn.net>
To: 519005-close@bugs.debian.org
Subject: Bug#519005: fixed in suphp 0.7.1-1
Date: Fri, 07 Aug 2009 12:18:22 +0000
Source: suphp
Source-Version: 0.7.1-1

We believe that the bug you reported is fixed in the latest version of
suphp, which is due to be installed in the Debian FTP archive:

libapache2-mod-suphp_0.7.1-1_i386.deb
  to pool/main/s/suphp/libapache2-mod-suphp_0.7.1-1_i386.deb
suphp-common_0.7.1-1_i386.deb
  to pool/main/s/suphp/suphp-common_0.7.1-1_i386.deb
suphp_0.7.1-1.diff.gz
  to pool/main/s/suphp/suphp_0.7.1-1.diff.gz
suphp_0.7.1-1.dsc
  to pool/main/s/suphp/suphp_0.7.1-1.dsc
suphp_0.7.1.orig.tar.gz
  to pool/main/s/suphp/suphp_0.7.1.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 519005@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Emmanuel Lacour <elacour@home-dn.net> (supplier of updated suphp package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 03 Aug 2009 15:15:38 +0200
Source: suphp
Binary: suphp-common libapache2-mod-suphp
Architecture: source i386
Version: 0.7.1-1
Distribution: unstable
Urgency: low
Maintainer: fpeters@debian.org
Changed-By: Emmanuel Lacour <elacour@home-dn.net>
Description: 
 libapache2-mod-suphp - Apache2 module to run php scripts with the owner permissions
 suphp-common - Common files for mod suphp
Closes: 514725 517805 519005 520182 528379
Changes: 
 suphp (0.7.1-1) unstable; urgency=low
 .
   * New upstream release (closes: #528379, #520182)
   * debian/NEWS: add information about AddHandler -> AddType change introduced
     in 0.6.2-2 (closes: #517805)
   * debian/conf/suphp.conf, debian/patches/01_debian.dpatch: switch from
     application/x-httpd-php to application/x-httpd-suphp to allow
     simultaneous use of mod_suphp and mod_php (closes: #519005, #514725)
Checksums-Sha1: 
 3fad68ea503a1194a536e4f93eb04583f7f8a6b2 1106 suphp_0.7.1-1.dsc
 9f228e5737d389e84ded51efdc11add5fe0089d6 383926 suphp_0.7.1.orig.tar.gz
 2b91bb7c3afd3b28ea9a50f083f80a1ca6adbf34 66831 suphp_0.7.1-1.diff.gz
 9308abed6c4b03508eb4b305ec9a7b0ec3cbd67f 79940 suphp-common_0.7.1-1_i386.deb
 204c077dc0bb75e1f8dcac7228943bed767bda18 19156 libapache2-mod-suphp_0.7.1-1_i386.deb
Checksums-Sha256: 
 bc194e3f8f507602c195a1072aaa1f54eab72bf804652c758fd716c7952f8acc 1106 suphp_0.7.1-1.dsc
 d1f3eb091c0c588fdb7b5ae0e1e993af9a02a0242dd7d5d47d326b1911ee546c 383926 suphp_0.7.1.orig.tar.gz
 a4ea7b82f63c07b26fc97935f207b3147eef48dbbd12662b8bd8d28336374d04 66831 suphp_0.7.1-1.diff.gz
 2d59256a0dad1b2c3962f12295353f560a2bbafa2f45a24b8b5156b3192981e4 79940 suphp-common_0.7.1-1_i386.deb
 bcc0b60b664d8c1fb6f4a8685a2a72dff0f61b3a4a7e2f7f5b1a903b4cb800ce 19156 libapache2-mod-suphp_0.7.1-1_i386.deb
Files: 
 4f9138f1643f8dfa7f148b9439c5381d 1106 web optional suphp_0.7.1-1.dsc
 dc41fb75b93595d6663c444c3ddd9e1d 383926 web optional suphp_0.7.1.orig.tar.gz
 6b51b235551eebec9aa1b78d3ed4e9dd 66831 web optional suphp_0.7.1-1.diff.gz
 05958222b6e31621770698bfc6aca823 79940 web optional suphp-common_0.7.1-1_i386.deb
 cc7384ce8d17f3bbf8493e197d70a605 19156 web optional libapache2-mod-suphp_0.7.1-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkp8GhgACgkQoR3LsWeD7V4VTACfdXyk7pYFQv8seVSvC7W71yGc
c5AAnAvGkvZfsGSw6X3YhufXUD+PfZ/7
=YGWj
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 23 Sep 2009 07:27:50 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 05:14:53 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.