Debian Bug report logs - #516669
files owned by !root

version graph

Package: git-core; Maintainer for git-core is Gerrit Pape <pape@smarden.org>; Source for git-core is src:git.

Reported by: Peter Palfrader <weasel@debian.org>

Date: Sun, 22 Feb 2009 23:48:01 UTC

Severity: serious

Tags: patch, security

Found in version git-core/1:1.5.6.5-3

Fixed in versions git-core/1:1.5.6.5-3+lenny1, git-core/1:1.4.4.4-4+etch2, 1:1.6.1.3-2

Done: Thomas Viehmann <tv@beamnet.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Security Team <team@security.debian.org>, Debian Testing Security Team <secure-testing-team@lists.alioth.debian.org>, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Sun, 22 Feb 2009 23:48:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Peter Palfrader <weasel@debian.org>:
New Bug report received and forwarded. Copy sent to Debian Security Team <team@security.debian.org>, Debian Testing Security Team <secure-testing-team@lists.alioth.debian.org>, Gerrit Pape <pape@smarden.org>. (Sun, 22 Feb 2009 23:48:05 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Peter Palfrader <weasel@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: files owned by !root
Date: Mon, 23 Feb 2009 00:43:39 +0100
Package: git-core
Version: 1:1.5.6.5-3
Severity: serious
Tags: security

Files in /usr/share/git-core are not owned by root on lenny/alpha.

weasel@intrepid:~/tmp$ wget -nv http://ftp.at.debian.org/debian/pool/main/g/git-core/git-core_1.5.6.5-3_alpha.deb
2009-02-23 00:40:33 URL:http://ftp.at.debian.org/debian/pool/main/g/git-core/git-core_1.5.6.5-3_alpha.deb [3819436/3819436] -> "git-core_1.5.6.5-3_alpha.deb" [1]
weasel@intrepid:~/tmp$ ar x git-core_1.5.6.5-3_alpha.deb
weasel@intrepid:~/tmp$ tar tzvf data.tar.gz | grep share/git-core
drwxr-xr-x root/root         0 2009-02-12 08:19 ./usr/share/git-core/
drwxr-xr-x buildd/buildd     0 2009-02-12 08:14 ./usr/share/git-core/templates/
drwxr-xr-x buildd/buildd     0 2009-02-12 08:14 ./usr/share/git-core/templates/branches/
-rw-r--r-- buildd/buildd    58 2008-08-07 01:38 ./usr/share/git-core/templates/description
drwxr-xr-x buildd/buildd     0 2009-02-12 08:14 ./usr/share/git-core/templates/hooks/
-rw-r--r-- buildd/buildd   207 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/post-update
-rw-r--r-- buildd/buildd   441 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/applypatch-msg
-rw-r--r-- buildd/buildd  1196 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/prepare-commit-msg
-rw-r--r-- buildd/buildd   887 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/commit-msg
-rw-r--r-- buildd/buildd  4262 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/pre-rebase
-rw-r--r-- buildd/buildd   510 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/post-receive
-rw-r--r-- buildd/buildd   387 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/pre-applypatch
-rw-r--r-- buildd/buildd   152 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/post-commit
-rw-r--r-- buildd/buildd  1706 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/pre-commit
-rw-r--r-- buildd/buildd  2910 2008-08-07 01:38 ./usr/share/git-core/templates/hooks/update
drwxr-xr-x buildd/buildd     0 2009-02-12 08:14 ./usr/share/git-core/templates/info/
-rw-r--r-- buildd/buildd   240 2008-08-07 01:38 ./usr/share/git-core/templates/info/exclude
weasel@intrepid:~/tmp$ 




Information forwarded to debian-bugs-dist@lists.debian.org, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Mon, 23 Feb 2009 14:12:12 GMT) Full text and rfc822 format available.

Acknowledgement sent to Peter Palfrader <weasel@debian.org>, 516669@bugs.debian.org:
Extra info received and forwarded to list. Copy sent to Gerrit Pape <pape@smarden.org>. (Mon, 23 Feb 2009 14:12:12 GMT) Full text and rfc822 format available.

Message #10 received at 516669@bugs.debian.org (full text, mbox):

From: Gerrit Pape <pape@dbnbgs.smarden.org>
To: Peter Palfrader <weasel@debian.org>, 516669@bugs.debian.org
Cc: team@security.debian.org
Subject: Re: Bug#516669: files owned by !root
Date: Mon, 23 Feb 2009 14:10:01 +0000
[Message part 1 (text/plain, inline)]
tags 516669 + patch
quit

On Mon, Feb 23, 2009 at 12:43:39AM +0100, Peter Palfrader wrote:
> Files in /usr/share/git-core are not owned by root on lenny/alpha.

Thanks for catching this.  Here's a patch for stable, unstable already
contains the fix, although there seems to be another similar permissions
problem I'm investigating right now.

The bug only has an impact if the package is build with -rsudo, the
files are properly owned by root with -rfakeroot.  The alpha, mips, and
mipsel autobuilders seem to use -rsudo.

team@security, if there's anything more I can do, such as providing a
signed package for stable, please let me know.

Regards, Gerrit.
[commit (text/plain, attachment)]

Tags added: patch Request was from Gerrit Pape <pape@dbnbgs.smarden.org> to control@bugs.debian.org. (Mon, 23 Feb 2009 14:12:13 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Mon, 23 Feb 2009 15:39:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thijs Kinkhorst <thijs@debian.org>:
Extra info received and forwarded to list. Copy sent to Gerrit Pape <pape@smarden.org>. (Mon, 23 Feb 2009 15:39:11 GMT) Full text and rfc822 format available.

Message #17 received at 516669@bugs.debian.org (full text, mbox):

From: Thijs Kinkhorst <thijs@debian.org>
To: 516669@bugs.debian.org
Cc: Peter Palfrader <weasel@debian.org>, team@security.debian.org
Subject: Re: Bug#516669: files owned by !root
Date: Mon, 23 Feb 2009 16:37:29 +0100
[Message part 1 (text/plain, inline)]
Hi,

On moandei 23 Febrewaris 2009, Gerrit Pape wrote:
> tags 516669 + patch
> quit
>
> On Mon, Feb 23, 2009 at 12:43:39AM +0100, Peter Palfrader wrote:
> > Files in /usr/share/git-core are not owned by root on lenny/alpha.
>
> Thanks for catching this.  Here's a patch for stable, unstable already
> contains the fix, although there seems to be another similar permissions
> problem I'm investigating right now.
>
> The bug only has an impact if the package is build with -rsudo, the
> files are properly owned by root with -rfakeroot.  The alpha, mips, and
> mipsel autobuilders seem to use -rsudo.
>
> team@security, if there's anything more I can do, such as providing a
> signed package for stable, please let me know.

Thanks Peter for the report and Gerrit for the quick patch.

As I understand it, these files are not usually executed directly, but do 
serve as templates for scripts that are executed, so someone could edit their 
content and hope that an administrator copies the script without noticing the 
change. That seems reason enough for me for a stable security update.

We need a sourceful update to prevent the problem from reappearing if someone 
rebuilds the package themselves or a subsequent security upload is made. Your 
patch seems fine. The issue also affects oldstable.

Gerrit, it would be great if you could provide updated packages for 
stable-security and oldstable-security. Please upload them to 
security-master, and make sure you build with full source ("-sa") at least 
for the stable-security one.

thanks,
Thijs
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Mon, 23 Feb 2009 16:18:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to team@security.debian.org, 516669@bugs.debian.org:
Extra info received and forwarded to list. Copy sent to Gerrit Pape <pape@smarden.org>. (Mon, 23 Feb 2009 16:18:06 GMT) Full text and rfc822 format available.

Message #22 received at 516669@bugs.debian.org (full text, mbox):

From: Gerrit Pape <pape@smarden.org>
To: team@security.debian.org, 516669@bugs.debian.org
Subject: Re: Bug#516669: files owned by !root
Date: Mon, 23 Feb 2009 16:14:44 +0000
On Mon, Feb 23, 2009 at 04:37:29PM +0100, Thijs Kinkhorst wrote:
> As I understand it, these files are not usually executed directly, but do 
> serve as templates for scripts that are executed, so someone could edit their 
> content and hope that an administrator copies the script without noticing the 
> change. That seems reason enough for me for a stable security update.

Yes, they are copied by 'git init', and need to be activated manually
through chmod +x by the repository owner.

> We need a sourceful update to prevent the problem from reappearing if someone 
> rebuilds the package themselves or a subsequent security upload is made. Your 
> patch seems fine. The issue also affects oldstable.

> Gerrit, it would be great if you could provide updated packages for 
> stable-security and oldstable-security. Please upload them to 
> security-master, and make sure you build with full source ("-sa") at least 
> for the stable-security one.

Ok.  I not yet understand why we need a sourceful upload.  Doesn't this
require bumping the upstream version (version of the orig.tar.gz)?  And
if so, why is this necessary?

Regards, Gerrit.




Information forwarded to debian-bugs-dist@lists.debian.org, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Mon, 23 Feb 2009 16:21:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thijs Kinkhorst <thijs@debian.org>:
Extra info received and forwarded to list. Copy sent to Gerrit Pape <pape@smarden.org>. (Mon, 23 Feb 2009 16:21:09 GMT) Full text and rfc822 format available.

Message #27 received at 516669@bugs.debian.org (full text, mbox):

From: Thijs Kinkhorst <thijs@debian.org>
To: 516669@bugs.debian.org
Subject: Re: Bug#516669: files owned by !root
Date: Mon, 23 Feb 2009 17:17:56 +0100
[Message part 1 (text/plain, inline)]
On moandei 23 Febrewaris 2009, Gerrit Pape wrote:
> > Gerrit, it would be great if you could provide updated packages for
> > stable-security and oldstable-security. Please upload them to
> > security-master, and make sure you build with full source ("-sa") at
> > least for the stable-security one.
>
> Ok.  I not yet understand why we need a sourceful upload.  Doesn't this
> require bumping the upstream version (version of the orig.tar.gz)?  And
> if so, why is this necessary?

Perhaps we're talking about different things. I mean you need to include the 
patch in your package and upload it, just like any other upload. This as 
opposed to a binary-only upload, where we could rebuild just the affected 
archs in a different environment that doesn't cause the ownership issue. The 
latter is a too short term solution.


Thijs
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Tue, 24 Mar 2009 10:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to team@security.debian.org, 516669@bugs.debian.org:
Extra info received and forwarded to list. Copy sent to Gerrit Pape <pape@smarden.org>. (Tue, 24 Mar 2009 10:45:03 GMT) Full text and rfc822 format available.

Message #32 received at 516669@bugs.debian.org (full text, mbox):

From: Gerrit Pape <pape@smarden.org>
To: team@security.debian.org, 516669@bugs.debian.org
Subject: Re: Bug#516669: files owned by !root
Date: Tue, 24 Mar 2009 10:34:14 +0000
On Mon, Feb 23, 2009 at 04:37:29PM +0100, Thijs Kinkhorst wrote:
> Gerrit, it would be great if you could provide updated packages for 
> stable-security and oldstable-security. Please upload them to 
> security-master, and make sure you build with full source ("-sa") at least 
> for the stable-security one.

Hi, fixed packages are available for quite some time now, what's
stopping them from being published?  Can I help with anything to get
them out?

Regards, Gerrit.




Bug no longer marked as found in version 1:1.6.0-1. Request was from Gerrit Pape <pape@dbnbgs.smarden.org> to control@bugs.debian.org. (Tue, 24 Mar 2009 10:48:06 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Tue, 24 Mar 2009 11:18:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Thijs Kinkhorst" <thijs@debian.org>:
Extra info received and forwarded to list. Copy sent to Gerrit Pape <pape@smarden.org>. (Tue, 24 Mar 2009 11:18:04 GMT) Full text and rfc822 format available.

Message #39 received at 516669@bugs.debian.org (full text, mbox):

From: "Thijs Kinkhorst" <thijs@debian.org>
To: team@security.debian.org, 516669@bugs.debian.org
Subject: Re: Bug#516669: files owned by !root
Date: Tue, 24 Mar 2009 12:15:45 +0100 (CET)
On Tue, March 24, 2009 11:34, Gerrit Pape wrote:
> On Mon, Feb 23, 2009 at 04:37:29PM +0100, Thijs Kinkhorst wrote:
>
>> Gerrit, it would be great if you could provide updated packages for
>> stable-security and oldstable-security. Please upload them to
>> security-master, and make sure you build with full source ("-sa") at
>> least for the stable-security one.
>
> Hi, fixed packages are available for quite some time now, what's
> stopping them from being published?  Can I help with anything to get them
> out?

We're having a missing build from alpha, because that's one of the
affected architectures, releasing is not very useful. I'm getting no
response yet from the alpha maintainers... if you can get a build for
git-core for on alpha or can otherwise help get this resolved that would
be useful.


Thijs





Information forwarded to debian-bugs-dist@lists.debian.org, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Tue, 24 Mar 2009 18:54:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luk Claes <luk@debian.org>:
Extra info received and forwarded to list. Copy sent to Gerrit Pape <pape@smarden.org>. (Tue, 24 Mar 2009 18:54:02 GMT) Full text and rfc822 format available.

Message #44 received at 516669@bugs.debian.org (full text, mbox):

From: Luk Claes <luk@debian.org>
To: Thijs Kinkhorst <thijs@debian.org>, 516669@bugs.debian.org
Cc: team@security.debian.org
Subject: Re: Bug#516669: files owned by !root
Date: Tue, 24 Mar 2009 19:51:44 +0100
Thijs Kinkhorst wrote:
> On Tue, March 24, 2009 11:34, Gerrit Pape wrote:
>> On Mon, Feb 23, 2009 at 04:37:29PM +0100, Thijs Kinkhorst wrote:
>>
>>> Gerrit, it would be great if you could provide updated packages for
>>> stable-security and oldstable-security. Please upload them to
>>> security-master, and make sure you build with full source ("-sa") at
>>> least for the stable-security one.
>> Hi, fixed packages are available for quite some time now, what's
>> stopping them from being published?  Can I help with anything to get them
>> out?
> 
> We're having a missing build from alpha, because that's one of the
> affected architectures, releasing is not very useful. I'm getting no
> response yet from the alpha maintainers... if you can get a build for
> git-core for on alpha or can otherwise help get this resolved that would
> be useful.

Given back, lets see if it works this time.

Cheers

Luk




Information forwarded to debian-bugs-dist@lists.debian.org, Gerrit Pape <pape@smarden.org>:
Bug#516669; Package git-core. (Wed, 25 Mar 2009 09:51:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Thijs Kinkhorst" <thijs@debian.org>:
Extra info received and forwarded to list. Copy sent to Gerrit Pape <pape@smarden.org>. (Wed, 25 Mar 2009 09:51:04 GMT) Full text and rfc822 format available.

Message #49 received at 516669@bugs.debian.org (full text, mbox):

From: "Thijs Kinkhorst" <thijs@debian.org>
To: "Luk Claes" <luk@debian.org>
Cc: 516669@bugs.debian.org, team@security.debian.org
Subject: Re: Bug#516669: files owned by !root
Date: Wed, 25 Mar 2009 10:39:15 +0100 (CET)
On Tue, March 24, 2009 19:51, Luk Claes wrote:
> Thijs Kinkhorst wrote:
>
>> On Tue, March 24, 2009 11:34, Gerrit Pape wrote:
>>
>>> On Mon, Feb 23, 2009 at 04:37:29PM +0100, Thijs Kinkhorst wrote:
>>>
>>>
>>>> Gerrit, it would be great if you could provide updated packages for
>>>>  stable-security and oldstable-security. Please upload them to
>>>> security-master, and make sure you build with full source ("-sa")
>>>> at least for the stable-security one.
>>> Hi, fixed packages are available for quite some time now, what's
>>> stopping them from being published?  Can I help with anything to get
>>> them out?
>>
>> We're having a missing build from alpha, because that's one of the
>> affected architectures, releasing is not very useful. I'm getting no
>> response yet from the alpha maintainers... if you can get a build for
>> git-core for on alpha or can otherwise help get this resolved that
>> would be useful.
>
> Given back, lets see if it works this time.

Thanks, but it failed once again, I'm afraid.


Thijs





Reply sent to Gerrit Pape <pape@smarden.org>:
You have taken responsibility. (Tue, 21 Apr 2009 20:09:12 GMT) Full text and rfc822 format available.

Notification sent to Peter Palfrader <weasel@debian.org>:
Bug acknowledged by developer. (Tue, 21 Apr 2009 20:09:12 GMT) Full text and rfc822 format available.

Message #54 received at 516669-close@bugs.debian.org (full text, mbox):

From: Gerrit Pape <pape@smarden.org>
To: 516669-close@bugs.debian.org
Subject: Bug#516669: fixed in git-core 1:1.5.6.5-3+lenny1
Date: Tue, 21 Apr 2009 19:53:56 +0000
Source: git-core
Source-Version: 1:1.5.6.5-3+lenny1

We believe that the bug you reported is fixed in the latest version of
git-core, which is due to be installed in the Debian FTP archive:

git-arch_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-arch_1.5.6.5-3+lenny1_all.deb
git-core_1.5.6.5-3+lenny1.diff.gz
  to pool/main/g/git-core/git-core_1.5.6.5-3+lenny1.diff.gz
git-core_1.5.6.5-3+lenny1.dsc
  to pool/main/g/git-core/git-core_1.5.6.5-3+lenny1.dsc
git-core_1.5.6.5-3+lenny1_powerpc.deb
  to pool/main/g/git-core/git-core_1.5.6.5-3+lenny1_powerpc.deb
git-cvs_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-cvs_1.5.6.5-3+lenny1_all.deb
git-daemon-run_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-daemon-run_1.5.6.5-3+lenny1_all.deb
git-doc_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-doc_1.5.6.5-3+lenny1_all.deb
git-email_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-email_1.5.6.5-3+lenny1_all.deb
git-gui_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-gui_1.5.6.5-3+lenny1_all.deb
git-svn_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-svn_1.5.6.5-3+lenny1_all.deb
gitk_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/gitk_1.5.6.5-3+lenny1_all.deb
gitweb_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/gitweb_1.5.6.5-3+lenny1_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 516669@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Gerrit Pape <pape@smarden.org> (supplier of updated git-core package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 23 Feb 2009 13:50:14 +0000
Source: git-core
Binary: git-core git-doc git-arch git-cvs git-svn git-email git-daemon-run git-gui gitk gitweb
Architecture: source powerpc all
Version: 1:1.5.6.5-3+lenny1
Distribution: stable-security
Urgency: high
Maintainer: Gerrit Pape <pape@smarden.org>
Changed-By: Gerrit Pape <pape@smarden.org>
Description: 
 git-arch   - fast, scalable, distributed revision control system (arch interop
 git-core   - fast, scalable, distributed revision control system
 git-cvs    - fast, scalable, distributed revision control system (cvs interope
 git-daemon-run - fast, scalable, distributed revision control system (git-daemon s
 git-doc    - fast, scalable, distributed revision control system (documentatio
 git-email  - fast, scalable, distributed revision control system (email add-on
 git-gui    - fast, scalable, distributed revision control system (GUI)
 git-svn    - fast, scalable, distributed revision control system (svn interope
 gitk       - fast, scalable, distributed revision control system (revision tre
 gitweb     - fast, scalable, distributed revision control system (web interfac
Closes: 516669
Changes: 
 git-core (1:1.5.6.5-3+lenny1) stable-security; urgency=high
 .
   * debian/diff/0006-Install-templates-with-the-user-and-group...diff:
     new, cherry-picked from 71f4637: Install templates with the user and
     group of the installing personality (closes: #516669).
Checksums-Sha1: 
 c79ccf9a94bc0d5cd251f61180b25ded1df59d4b 1331 git-core_1.5.6.5-3+lenny1.dsc
 d7b87cb10409023fee38f869036bd7115c76b4a7 2103619 git-core_1.5.6.5.orig.tar.gz
 c6ba45a2ca1012eb848afc20c91d35c3fb98d9c0 226400 git-core_1.5.6.5-3+lenny1.diff.gz
 3813e6bf51afaaee96c13c9c90568b1bb52f3e93 3473356 git-core_1.5.6.5-3+lenny1_powerpc.deb
 d0afe84e2cb5af9679b2fd3647df6346b6264b11 1076590 git-doc_1.5.6.5-3+lenny1_all.deb
 09fd39cc7eed97eff39ea53f4b090823ca0a7eff 230864 git-arch_1.5.6.5-3+lenny1_all.deb
 3cef79e89e01afbf2ac9fdc82f6764778edaba99 267052 git-cvs_1.5.6.5-3+lenny1_all.deb
 eb8f0fe47d62739063f65666675b038b30fe77a1 268096 git-svn_1.5.6.5-3+lenny1_all.deb
 dd77deaf8964d7d4c41e23bc191558ac2fe16784 217632 git-daemon-run_1.5.6.5-3+lenny1_all.deb
 702d4503ca89bc62ab605b4292645c1e9ddd4ee0 229144 git-email_1.5.6.5-3+lenny1_all.deb
 fc9187f139bee8c446ab8705ce38f885669a62c2 401374 git-gui_1.5.6.5-3+lenny1_all.deb
 6bc2a198c712715213852767ce5c924ab877a64c 298458 gitk_1.5.6.5-3+lenny1_all.deb
 1b12282ef811f6abca8057aea50e5fa0b5baf46b 267878 gitweb_1.5.6.5-3+lenny1_all.deb
Checksums-Sha256: 
 d85bf37e5ccae45869d76da836d8f5e89bdbfa54334c1465dc334080b4219589 1331 git-core_1.5.6.5-3+lenny1.dsc
 bde21d33632a1e16e4d1e75e53795c0fec2cd7160574eee2fa00a755edc53d2c 2103619 git-core_1.5.6.5.orig.tar.gz
 a2668b3a989e8d96b523e8d19a32b5ce9ae1e2faaa8763c88d1e0ee7e6a111f3 226400 git-core_1.5.6.5-3+lenny1.diff.gz
 16d63ae4a7cd5133a445131deb2a8986ff759cd3bf52d391b75130d3a3355614 3473356 git-core_1.5.6.5-3+lenny1_powerpc.deb
 051c545e6480541b48ad8b5e9095c30aed93a9b65c1aba18c86101fcab1318c5 1076590 git-doc_1.5.6.5-3+lenny1_all.deb
 81fe621a51d54e712f8cff9262664ae3d35da6e5e38e9d1aef687e4874a029b0 230864 git-arch_1.5.6.5-3+lenny1_all.deb
 70e7baf394a30f5bd24036ac85e09e9bb87661281b7d6e0b0dc999ef5126f6db 267052 git-cvs_1.5.6.5-3+lenny1_all.deb
 d84aa8a2d9fc6ae6a6bf05b8756c34e644a31fa8ac013f530d56b0da83920a44 268096 git-svn_1.5.6.5-3+lenny1_all.deb
 89cb7da11a72d8b211880a431d622ed18517bddd90eb60a2109a179478b8abbf 217632 git-daemon-run_1.5.6.5-3+lenny1_all.deb
 414f64204a1b26716a12be735bac435ecc0f3f62cffb9facbfeb91dc3eaa7c59 229144 git-email_1.5.6.5-3+lenny1_all.deb
 e41baa13084b2e00e0cd6b393ae39e6edaefad15263b43b93ee7ff8c506405e4 401374 git-gui_1.5.6.5-3+lenny1_all.deb
 dd6246847aa568cc5b029bf27c857c9e84a3452328764eb2fa68d45fe15c60e7 298458 gitk_1.5.6.5-3+lenny1_all.deb
 52061ef3c968a5f59a822fb91c6210ee1fd597a933444cb319b6ada379da2f6f 267878 gitweb_1.5.6.5-3+lenny1_all.deb
Files: 
 d71b5b45cf6267c99294e91f6991a11b 1331 devel optional git-core_1.5.6.5-3+lenny1.dsc
 c22da91c913a02305fd8a1a2298f75c9 2103619 devel optional git-core_1.5.6.5.orig.tar.gz
 b448283f2944fb6908594ba8f55a5f41 226400 devel optional git-core_1.5.6.5-3+lenny1.diff.gz
 6ffb59e850de883cfaa581f6b7caef19 3473356 devel optional git-core_1.5.6.5-3+lenny1_powerpc.deb
 9cc1a31a802041e55ab3f7560acbf547 1076590 doc optional git-doc_1.5.6.5-3+lenny1_all.deb
 c7853c3b4d671d79b4a0fb25289236bf 230864 devel optional git-arch_1.5.6.5-3+lenny1_all.deb
 b9053e17ea5473d642f4307e5dc8a320 267052 devel optional git-cvs_1.5.6.5-3+lenny1_all.deb
 6d6c2c3e675885f0b958103983fd7446 268096 devel optional git-svn_1.5.6.5-3+lenny1_all.deb
 f06add8050805c4e59be0c7bd59c50d2 217632 devel optional git-daemon-run_1.5.6.5-3+lenny1_all.deb
 f545c11bf21e4e4069a5197da7c2c48f 229144 devel optional git-email_1.5.6.5-3+lenny1_all.deb
 a1511118ee3c1c379dfb98be35899514 401374 devel optional git-gui_1.5.6.5-3+lenny1_all.deb
 e0aebaff07db768f83d81ec9fa143847 298458 devel optional gitk_1.5.6.5-3+lenny1_all.deb
 fac3a5791789b1fec762ff32ac073a8b 267878 devel optional gitweb_1.5.6.5-3+lenny1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkmjSmEACgkQGJoyQbxwpv/B/wCcCWfddvuZWhh8fh81uMKG6iBO
KYkAnjefZgk26/WNdPrME6nbOnRN2m9Y
=fKBI
-----END PGP SIGNATURE-----





Reply sent to Gerrit Pape <pape@smarden.org>:
You have taken responsibility. (Sat, 02 May 2009 20:27:05 GMT) Full text and rfc822 format available.

Notification sent to Peter Palfrader <weasel@debian.org>:
Bug acknowledged by developer. (Sat, 02 May 2009 20:27:05 GMT) Full text and rfc822 format available.

Message #59 received at 516669-close@bugs.debian.org (full text, mbox):

From: Gerrit Pape <pape@smarden.org>
To: 516669-close@bugs.debian.org
Subject: Bug#516669: fixed in git-core 1:1.4.4.4-4+etch2
Date: Sat, 02 May 2009 19:54:26 +0000
Source: git-core
Source-Version: 1:1.4.4.4-4+etch2

We believe that the bug you reported is fixed in the latest version of
git-core, which is due to be installed in the Debian FTP archive:

git-arch_1.4.4.4-4+etch2_all.deb
  to pool/main/g/git-core/git-arch_1.4.4.4-4+etch2_all.deb
git-core_1.4.4.4-4+etch2.diff.gz
  to pool/main/g/git-core/git-core_1.4.4.4-4+etch2.diff.gz
git-core_1.4.4.4-4+etch2.dsc
  to pool/main/g/git-core/git-core_1.4.4.4-4+etch2.dsc
git-core_1.4.4.4-4+etch2_powerpc.deb
  to pool/main/g/git-core/git-core_1.4.4.4-4+etch2_powerpc.deb
git-cvs_1.4.4.4-4+etch2_all.deb
  to pool/main/g/git-core/git-cvs_1.4.4.4-4+etch2_all.deb
git-daemon-run_1.4.4.4-4+etch2_all.deb
  to pool/main/g/git-core/git-daemon-run_1.4.4.4-4+etch2_all.deb
git-doc_1.4.4.4-4+etch2_all.deb
  to pool/main/g/git-core/git-doc_1.4.4.4-4+etch2_all.deb
git-email_1.4.4.4-4+etch2_all.deb
  to pool/main/g/git-core/git-email_1.4.4.4-4+etch2_all.deb
git-svn_1.4.4.4-4+etch2_all.deb
  to pool/main/g/git-core/git-svn_1.4.4.4-4+etch2_all.deb
gitk_1.4.4.4-4+etch2_all.deb
  to pool/main/g/git-core/gitk_1.4.4.4-4+etch2_all.deb
gitweb_1.4.4.4-4+etch2_all.deb
  to pool/main/g/git-core/gitweb_1.4.4.4-4+etch2_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 516669@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Gerrit Pape <pape@smarden.org> (supplier of updated git-core package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 23 Feb 2009 23:43:55 +0000
Source: git-core
Binary: git-email git-core git-daemon-run git-doc git-cvs git-svn gitk gitweb git-arch
Architecture: source all powerpc
Version: 1:1.4.4.4-4+etch2
Distribution: oldstable-security
Urgency: high
Maintainer: Gerrit Pape <pape@smarden.org>
Changed-By: Gerrit Pape <pape@smarden.org>
Description: 
 git-arch   - content addressable filesystem (arch interoperability)
 git-core   - content addressable filesystem
 git-cvs    - content addressable filesystem (cvs interoperability)
 git-daemon-run - content addressable filesystem (git-daemon service)
 git-doc    - content addressable filesystem (documentation)
 git-email  - content addressable filesystem (email add-on)
 git-svn    - content addressable filesystem (svn interoperability)
 gitk       - content addressable filesystem (revision tree visualizer)
 gitweb     - content addressable filesystem (web interface)
Closes: 516669
Changes: 
 git-core (1:1.4.4.4-4+etch2) oldstable-security; urgency=high
 .
   * debian/diff/install-templates-with-the-user-and-group-of-the...diff:
     new, cherry-picked from 71f4637: Install templates with the user and
     group of the installing personality (closes: #516669).
Files: 
 2693d7024a52e175ea62eaff3c07a61a 805 devel optional git-core_1.4.4.4-4+etch2.dsc
 34ad45133052ce77f2f803554aa9dda1 71107 devel optional git-core_1.4.4.4-4+etch2.diff.gz
 1cac055c562efeb9283dd86d5393c1a5 2639158 devel optional git-core_1.4.4.4-4+etch2_powerpc.deb
 3a557c1e51a90e0278d5d1a249f5da57 466672 doc optional git-doc_1.4.4.4-4+etch2_all.deb
 6ceed58c872080f324ca8a662fefda8c 68960 devel optional git-arch_1.4.4.4-4+etch2_all.deb
 8470e1691d1733cb7b172b1ad68bfe6a 94168 devel optional git-cvs_1.4.4.4-4+etch2_all.deb
 896a41a4a8c301e47e584617ea1c2f4e 101018 devel optional git-svn_1.4.4.4-4+etch2_all.deb
 c31f96adaa78b22f0066c936909f75c8 55782 devel optional git-daemon-run_1.4.4.4-4+etch2_all.deb
 3bc6980242c54684b97918195cb04420 63252 devel optional git-email_1.4.4.4-4+etch2_all.deb
 ac00ea6de16a1aa34539f2381d02722e 99756 devel optional gitk_1.4.4.4-4+etch2_all.deb
 d4f2fe54f9fa94ac65ad23bcd0a262d1 88466 devel optional gitweb_1.4.4.4-4+etch2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkmj5XMACgkQGJoyQbxwpv/JbgCfaeSf987JfwhjecPHdh0tUc70
SWEAnic2DRPf6fFeazwEw18IHyj8vGWj
=2MYg
-----END PGP SIGNATURE-----





Reply sent to Gerrit Pape <pape@smarden.org>:
You have taken responsibility. (Sat, 27 Jun 2009 16:45:09 GMT) Full text and rfc822 format available.

Notification sent to Peter Palfrader <weasel@debian.org>:
Bug acknowledged by developer. (Sat, 27 Jun 2009 16:45:09 GMT) Full text and rfc822 format available.

Message #64 received at 516669-close@bugs.debian.org (full text, mbox):

From: Gerrit Pape <pape@smarden.org>
To: 516669-close@bugs.debian.org
Subject: Bug#516669: fixed in git-core 1:1.5.6.5-3+lenny1
Date: Sat, 27 Jun 2009 16:04:26 +0000
Source: git-core
Source-Version: 1:1.5.6.5-3+lenny1

We believe that the bug you reported is fixed in the latest version of
git-core, which is due to be installed in the Debian FTP archive:

git-arch_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-arch_1.5.6.5-3+lenny1_all.deb
git-core_1.5.6.5-3+lenny1.diff.gz
  to pool/main/g/git-core/git-core_1.5.6.5-3+lenny1.diff.gz
git-core_1.5.6.5-3+lenny1.dsc
  to pool/main/g/git-core/git-core_1.5.6.5-3+lenny1.dsc
git-core_1.5.6.5-3+lenny1_powerpc.deb
  to pool/main/g/git-core/git-core_1.5.6.5-3+lenny1_powerpc.deb
git-cvs_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-cvs_1.5.6.5-3+lenny1_all.deb
git-daemon-run_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-daemon-run_1.5.6.5-3+lenny1_all.deb
git-doc_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-doc_1.5.6.5-3+lenny1_all.deb
git-email_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-email_1.5.6.5-3+lenny1_all.deb
git-gui_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-gui_1.5.6.5-3+lenny1_all.deb
git-svn_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/git-svn_1.5.6.5-3+lenny1_all.deb
gitk_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/gitk_1.5.6.5-3+lenny1_all.deb
gitweb_1.5.6.5-3+lenny1_all.deb
  to pool/main/g/git-core/gitweb_1.5.6.5-3+lenny1_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 516669@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Gerrit Pape <pape@smarden.org> (supplier of updated git-core package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 23 Feb 2009 13:50:14 +0000
Source: git-core
Binary: git-core git-doc git-arch git-cvs git-svn git-email git-daemon-run git-gui gitk gitweb
Architecture: source powerpc all
Version: 1:1.5.6.5-3+lenny1
Distribution: stable-security
Urgency: high
Maintainer: Gerrit Pape <pape@smarden.org>
Changed-By: Gerrit Pape <pape@smarden.org>
Description: 
 git-arch   - fast, scalable, distributed revision control system (arch interop
 git-core   - fast, scalable, distributed revision control system
 git-cvs    - fast, scalable, distributed revision control system (cvs interope
 git-daemon-run - fast, scalable, distributed revision control system (git-daemon s
 git-doc    - fast, scalable, distributed revision control system (documentatio
 git-email  - fast, scalable, distributed revision control system (email add-on
 git-gui    - fast, scalable, distributed revision control system (GUI)
 git-svn    - fast, scalable, distributed revision control system (svn interope
 gitk       - fast, scalable, distributed revision control system (revision tre
 gitweb     - fast, scalable, distributed revision control system (web interfac
Closes: 516669
Changes: 
 git-core (1:1.5.6.5-3+lenny1) stable-security; urgency=high
 .
   * debian/diff/0006-Install-templates-with-the-user-and-group...diff:
     new, cherry-picked from 71f4637: Install templates with the user and
     group of the installing personality (closes: #516669).
Checksums-Sha1: 
 c79ccf9a94bc0d5cd251f61180b25ded1df59d4b 1331 git-core_1.5.6.5-3+lenny1.dsc
 d7b87cb10409023fee38f869036bd7115c76b4a7 2103619 git-core_1.5.6.5.orig.tar.gz
 c6ba45a2ca1012eb848afc20c91d35c3fb98d9c0 226400 git-core_1.5.6.5-3+lenny1.diff.gz
 3813e6bf51afaaee96c13c9c90568b1bb52f3e93 3473356 git-core_1.5.6.5-3+lenny1_powerpc.deb
 d0afe84e2cb5af9679b2fd3647df6346b6264b11 1076590 git-doc_1.5.6.5-3+lenny1_all.deb
 09fd39cc7eed97eff39ea53f4b090823ca0a7eff 230864 git-arch_1.5.6.5-3+lenny1_all.deb
 3cef79e89e01afbf2ac9fdc82f6764778edaba99 267052 git-cvs_1.5.6.5-3+lenny1_all.deb
 eb8f0fe47d62739063f65666675b038b30fe77a1 268096 git-svn_1.5.6.5-3+lenny1_all.deb
 dd77deaf8964d7d4c41e23bc191558ac2fe16784 217632 git-daemon-run_1.5.6.5-3+lenny1_all.deb
 702d4503ca89bc62ab605b4292645c1e9ddd4ee0 229144 git-email_1.5.6.5-3+lenny1_all.deb
 fc9187f139bee8c446ab8705ce38f885669a62c2 401374 git-gui_1.5.6.5-3+lenny1_all.deb
 6bc2a198c712715213852767ce5c924ab877a64c 298458 gitk_1.5.6.5-3+lenny1_all.deb
 1b12282ef811f6abca8057aea50e5fa0b5baf46b 267878 gitweb_1.5.6.5-3+lenny1_all.deb
Checksums-Sha256: 
 d85bf37e5ccae45869d76da836d8f5e89bdbfa54334c1465dc334080b4219589 1331 git-core_1.5.6.5-3+lenny1.dsc
 bde21d33632a1e16e4d1e75e53795c0fec2cd7160574eee2fa00a755edc53d2c 2103619 git-core_1.5.6.5.orig.tar.gz
 a2668b3a989e8d96b523e8d19a32b5ce9ae1e2faaa8763c88d1e0ee7e6a111f3 226400 git-core_1.5.6.5-3+lenny1.diff.gz
 16d63ae4a7cd5133a445131deb2a8986ff759cd3bf52d391b75130d3a3355614 3473356 git-core_1.5.6.5-3+lenny1_powerpc.deb
 051c545e6480541b48ad8b5e9095c30aed93a9b65c1aba18c86101fcab1318c5 1076590 git-doc_1.5.6.5-3+lenny1_all.deb
 81fe621a51d54e712f8cff9262664ae3d35da6e5e38e9d1aef687e4874a029b0 230864 git-arch_1.5.6.5-3+lenny1_all.deb
 70e7baf394a30f5bd24036ac85e09e9bb87661281b7d6e0b0dc999ef5126f6db 267052 git-cvs_1.5.6.5-3+lenny1_all.deb
 d84aa8a2d9fc6ae6a6bf05b8756c34e644a31fa8ac013f530d56b0da83920a44 268096 git-svn_1.5.6.5-3+lenny1_all.deb
 89cb7da11a72d8b211880a431d622ed18517bddd90eb60a2109a179478b8abbf 217632 git-daemon-run_1.5.6.5-3+lenny1_all.deb
 414f64204a1b26716a12be735bac435ecc0f3f62cffb9facbfeb91dc3eaa7c59 229144 git-email_1.5.6.5-3+lenny1_all.deb
 e41baa13084b2e00e0cd6b393ae39e6edaefad15263b43b93ee7ff8c506405e4 401374 git-gui_1.5.6.5-3+lenny1_all.deb
 dd6246847aa568cc5b029bf27c857c9e84a3452328764eb2fa68d45fe15c60e7 298458 gitk_1.5.6.5-3+lenny1_all.deb
 52061ef3c968a5f59a822fb91c6210ee1fd597a933444cb319b6ada379da2f6f 267878 gitweb_1.5.6.5-3+lenny1_all.deb
Files: 
 d71b5b45cf6267c99294e91f6991a11b 1331 devel optional git-core_1.5.6.5-3+lenny1.dsc
 c22da91c913a02305fd8a1a2298f75c9 2103619 devel optional git-core_1.5.6.5.orig.tar.gz
 b448283f2944fb6908594ba8f55a5f41 226400 devel optional git-core_1.5.6.5-3+lenny1.diff.gz
 6ffb59e850de883cfaa581f6b7caef19 3473356 devel optional git-core_1.5.6.5-3+lenny1_powerpc.deb
 9cc1a31a802041e55ab3f7560acbf547 1076590 doc optional git-doc_1.5.6.5-3+lenny1_all.deb
 c7853c3b4d671d79b4a0fb25289236bf 230864 devel optional git-arch_1.5.6.5-3+lenny1_all.deb
 b9053e17ea5473d642f4307e5dc8a320 267052 devel optional git-cvs_1.5.6.5-3+lenny1_all.deb
 6d6c2c3e675885f0b958103983fd7446 268096 devel optional git-svn_1.5.6.5-3+lenny1_all.deb
 f06add8050805c4e59be0c7bd59c50d2 217632 devel optional git-daemon-run_1.5.6.5-3+lenny1_all.deb
 f545c11bf21e4e4069a5197da7c2c48f 229144 devel optional git-email_1.5.6.5-3+lenny1_all.deb
 a1511118ee3c1c379dfb98be35899514 401374 devel optional git-gui_1.5.6.5-3+lenny1_all.deb
 e0aebaff07db768f83d81ec9fa143847 298458 devel optional gitk_1.5.6.5-3+lenny1_all.deb
 fac3a5791789b1fec762ff32ac073a8b 267878 devel optional gitweb_1.5.6.5-3+lenny1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkmjSmEACgkQGJoyQbxwpv/B/wCcCWfddvuZWhh8fh81uMKG6iBO
KYkAnjefZgk26/WNdPrME6nbOnRN2m9Y
=fKBI
-----END PGP SIGNATURE-----





Reply sent to Thomas Viehmann <tv@beamnet.de>:
You have taken responsibility. (Thu, 30 Jul 2009 20:15:07 GMT) Full text and rfc822 format available.

Notification sent to Peter Palfrader <weasel@debian.org>:
Bug acknowledged by developer. (Thu, 30 Jul 2009 20:15:07 GMT) Full text and rfc822 format available.

Message #69 received at 516669-done@bugs.debian.org (full text, mbox):

From: Thomas Viehmann <tv@beamnet.de>
To: 516669-done@bugs.debian.org
Subject: forgotten fixed bug
Date: Thu, 30 Jul 2009 22:13:25 +0200
Version: 1:1.6.1.3-2

Hi Gerrit,

I think you forgot to close this bug for unstable, so I'm doing this now.

Kind regards

T.
-- 
Thomas Viehmann, http://thomas.viehmann.net/




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 28 Aug 2009 07:34:59 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 19:11:11 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.