Debian Bug report logs - #508764
perl: Lots of locale warnings during libc upgrade

version graph

Package: perl; Maintainer for perl is Niko Tyni <ntyni@debian.org>; Source for perl is src:perl.

Reported by: Michael Biebl <biebl@debian.org>

Date: Mon, 15 Dec 2008 03:18:01 UTC

Severity: wishlist

Found in versions 5.8.2-2, perl/5.10.0-16

Fixed in versions perl/5.10.1-15, perl/5.12.2-2

Done: Niko Tyni <ntyni@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#508764; Package libc6. (Mon, 15 Dec 2008 03:18:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
New Bug report received and forwarded. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Mon, 15 Dec 2008 03:18:03 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libc6: Lots of locale warnings during upgrade
Date: Mon, 15 Dec 2008 04:15:16 +0100
Package: libc6
Version: 2.7-16
Severity: important

Hi,

I did a test upgrade from etch -> lenny. As soon as the new libc6 has
been unpacked, I get lots of those warnings:

perl: warning: Setting locale faile
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset)
	LC_ALL = (unset)
	LANG = "de_DE.UTF-8"
    are support and installed on your system.
perl: warning: Falling back to the standard locale ("C").


The sheer amount of those warnings, makes it hard to spot any real
important messages.

Michael


-- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (300, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.27.9
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libc6 depends on:
ii  libgcc1                       1:4.3.2-1  GCC support library

libc6 recommends no packages.

Versions of packages libc6 suggests:
pn  glibc-doc                     <none>     (no description available)
ii  libc6-i686                    2.7-16     GNU C Library: Shared libraries [i
ii  locales                       2.7-16     GNU C Library: National Language (

-- debconf information excluded




Information forwarded to debian-bugs-dist@lists.debian.org, GNU Libc Maintainers <debian-glibc@lists.debian.org>:
Bug#508764; Package libc6. (Mon, 15 Dec 2008 08:33:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Sven Joachim <svenjoac@gmx.de>:
Extra info received and forwarded to list. Copy sent to GNU Libc Maintainers <debian-glibc@lists.debian.org>. (Mon, 15 Dec 2008 08:33:02 GMT) Full text and rfc822 format available.

Message #10 received at 508764@bugs.debian.org (full text, mbox):

From: Sven Joachim <svenjoac@gmx.de>
To: Michael Biebl <biebl@debian.org>
Cc: 508764@bugs.debian.org
Subject: Re: Bug#508764: libc6: Lots of locale warnings during upgrade
Date: Mon, 15 Dec 2008 09:26:49 +0100
reassign 508764 perl
forcemerge 221790 508764
thanks

On 2008-12-15 04:15 +0100, Michael Biebl wrote:

> Package: libc6
> Version: 2.7-16
> Severity: important
>
> Hi,
>
> I did a test upgrade from etch -> lenny. As soon as the new libc6 has
> been unpacked, I get lots of those warnings:
>
> perl: warning: Setting locale faile
> perl: warning: Please check that your locale settings:
>         LANGUAGE = (unset)
> 	LC_ALL = (unset)
> 	LANG = "de_DE.UTF-8"
>     are support and installed on your system.
> perl: warning: Falling back to the standard locale ("C").

You see this because the old locales package is not compatible with the
new libc6 and has been auto-deconfigured.  These messages go away after
the new locales package has been configured, which unfortunately does
happen rather late during dist-upgrades.

> The sheer amount of those warnings, makes it hard to spot any real
> important messages.

The warning messages come from Perl, it should really stop this
chattering IMHO.  See #221790.

Sven




Bug reassigned from package `libc6' to `perl'. Request was from Sven Joachim <svenjoac@gmx.de> to control@bugs.debian.org. (Mon, 15 Dec 2008 08:33:03 GMT) Full text and rfc822 format available.

Forcibly Merged 221790 508764. Request was from Sven Joachim <svenjoac@gmx.de> to control@bugs.debian.org. (Mon, 15 Dec 2008 08:33:04 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#508764; Package perl. (Fri, 17 Sep 2010 20:21:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. (Fri, 17 Sep 2010 20:21:03 GMT) Full text and rfc822 format available.

Message #19 received at 508764@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: Sven Joachim <svenjoac@gmx.de>
Cc: Michael Biebl <biebl@debian.org>, 508764@bugs.debian.org, dpkg@packages.debian.org
Subject: Re: Bug#508764: perl: Lots of locale warnings during upgrade
Date: Fri, 17 Sep 2010 23:18:20 +0300
unmerge 508764
retitle 508764 perl: Lots of locale warnings during libc upgrade
thanks

On Mon, Dec 15, 2008 at 09:26:49AM +0100, Sven Joachim wrote:
> On 2008-12-15 04:15 +0100, Michael Biebl wrote:

> > I did a test upgrade from etch -> lenny. As soon as the new libc6 has
> > been unpacked, I get lots of those warnings:
> >
> > perl: warning: Setting locale faile
> > perl: warning: Please check that your locale settings:
> >         LANGUAGE = (unset)
> > 	LC_ALL = (unset)
> > 	LANG = "de_DE.UTF-8"
> >     are support and installed on your system.
> > perl: warning: Falling back to the standard locale ("C").
> 
> You see this because the old locales package is not compatible with the
> new libc6 and has been auto-deconfigured.  These messages go away after
> the new locales package has been configured, which unfortunately does
> happen rather late during dist-upgrades.
> 
> > The sheer amount of those warnings, makes it hard to spot any real
> > important messages.
> 
> The warning messages come from Perl, it should really stop this
> chattering IMHO.  See #221790.

Sorry for the delay. I believe the same issue affects lenny->squeeze
upgrades.

While I don't think the chattering should be disabled in the general
case (which is what #221790 is about, so unmerging), I certainly see the
point for silencing it during package upgrades where the locale problem
is very often transient.

I only now noticed that setting the environment variable PERL_BADLANG=0
will disable these messages. See 'perldoc perllocale' for more
information; quoting:

   Perl's moaning about locale problems can be silenced by setting the
   environment variable PERL_BADLANG to a zero value, for example "0".
   This method really just sweeps the problem under the carpet: you
   tell Perl to shut up even when Perl sees that something is wrong.
   Do not be surprised if later something locale-dependent misbehaves.

Cc'ing the dpkg maintainers. What do you think about making dpkg set
PERL_BADLANG=0 when running maintainer scripts? I think that's the only
place where it could be done.
-- 
Niko Tyni   ntyni@debian.org




Disconnected #508764 from all other report(s). Request was from Niko Tyni <ntyni@debian.org> to control@bugs.debian.org. (Fri, 17 Sep 2010 20:21:06 GMT) Full text and rfc822 format available.

Changed Bug title to 'perl: Lots of locale warnings during libc upgrade' from 'libc6: Lots of locale warnings during upgrade' Request was from Niko Tyni <ntyni@debian.org> to control@bugs.debian.org. (Fri, 17 Sep 2010 20:21:07 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#508764; Package perl. (Wed, 22 Sep 2010 11:06:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. (Wed, 22 Sep 2010 11:06:03 GMT) Full text and rfc822 format available.

Message #28 received at 508764@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: Sven Joachim <svenjoac@gmx.de>
Cc: Michael Biebl <biebl@debian.org>, 508764@bugs.debian.org, dpkg@packages.debian.org
Subject: Re: Bug#508764: perl: Lots of locale warnings during upgrade
Date: Wed, 22 Sep 2010 14:04:22 +0300
On Fri, Sep 17, 2010 at 11:18:20PM +0300, Niko Tyni wrote:
> On Mon, Dec 15, 2008 at 09:26:49AM +0100, Sven Joachim wrote:
> > On 2008-12-15 04:15 +0100, Michael Biebl wrote:

> > > perl: warning: Setting locale faile
> > > perl: warning: Please check that your locale settings:
> > >         LANGUAGE = (unset)
> > > 	LC_ALL = (unset)
> > > 	LANG = "de_DE.UTF-8"
> > >     are support and installed on your system.
> > > perl: warning: Falling back to the standard locale ("C").
> > 
> > You see this because the old locales package is not compatible with the
> > new libc6 and has been auto-deconfigured.  These messages go away after
> > the new locales package has been configured, which unfortunately does
> > happen rather late during dist-upgrades.

> While I don't think the chattering should be disabled in the general
> case (which is what #221790 is about, so unmerging), I certainly see the
> point for silencing it during package upgrades where the locale problem
> is very often transient.

> Cc'ing the dpkg maintainers. What do you think about making dpkg set
> PERL_BADLANG=0 when running maintainer scripts? I think that's the only
> place where it could be done.

Alternatively, I suppose I could patch perl to also quelch the warnings
when DPKG_RUNNING_VERSION is set (or should it rather be one of the
DPKG_MAINTSCRIPT_* variables ?).

This seems somewhat cleaner to me, but opinions would be welcome.

FWIW, I see mandb outputs similar warnings so the issue isn't limited
to just perl.
-- 
Niko Tyni   ntyni@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Niko Tyni <ntyni@debian.org>:
Bug#508764; Package perl. (Wed, 22 Sep 2010 12:36:10 GMT) Full text and rfc822 format available.

Acknowledgement sent to Raphael Hertzog <hertzog@debian.org>:
Extra info received and forwarded to list. Copy sent to Niko Tyni <ntyni@debian.org>. (Wed, 22 Sep 2010 12:36:10 GMT) Full text and rfc822 format available.

Message #33 received at 508764@bugs.debian.org (full text, mbox):

From: Raphael Hertzog <hertzog@debian.org>
To: Niko Tyni <ntyni@debian.org>
Cc: Sven Joachim <svenjoac@gmx.de>, Michael Biebl <biebl@debian.org>, 508764@bugs.debian.org, dpkg@packages.debian.org, vorlon@debian.org
Subject: Re: Bug#508764: perl: Lots of locale warnings during upgrade
Date: Wed, 22 Sep 2010 14:09:07 +0200
On Wed, 22 Sep 2010, Niko Tyni wrote:
> > Cc'ing the dpkg maintainers. What do you think about making dpkg set
> > PERL_BADLANG=0 when running maintainer scripts? I think that's the only
> > place where it could be done.

I have not replied to this but it did not please me at all. dpkg is not
the proper place for such hacks.

> Alternatively, I suppose I could patch perl to also quelch the warnings
> when DPKG_RUNNING_VERSION is set (or should it rather be one of the
> DPKG_MAINTSCRIPT_* variables ?).

DPKG_RUNNING_VERSION is best, it will only be set by dpkg, the others
might be set by dpkg-reconfigure too when it calls the postinst manually
and dpkg-reconfigure is called outside of upgrades obviously and you might
want to see the warning.

> This seems somewhat cleaner to me, but opinions would be welcome.

+1

> FWIW, I see mandb outputs similar warnings so the issue isn't limited
> to just perl.

The release notes might document to upgrade locales at the start of the
upgrade anyway.

Cheers,
-- 
Raphaël Hertzog ◈ Debian Developer ◈ [Flattr=20693]

Follow my Debian News ▶ http://RaphaelHertzog.com (English)
                      ▶ http://RaphaelHertzog.fr (Français)




Reply sent to Niko Tyni <ntyni@debian.org>:
You have taken responsibility. (Thu, 07 Oct 2010 08:51:06 GMT) Full text and rfc822 format available.

Notification sent to Michael Biebl <biebl@debian.org>:
Bug acknowledged by developer. (Thu, 07 Oct 2010 08:51:06 GMT) Full text and rfc822 format available.

Message #38 received at 508764-close@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: 508764-close@bugs.debian.org
Subject: Bug#508764: fixed in perl 5.10.1-15
Date: Thu, 07 Oct 2010 08:47:51 +0000
Source: perl
Source-Version: 5.10.1-15

We believe that the bug you reported is fixed in the latest version of
perl, which is due to be installed in the Debian FTP archive:

libcgi-fast-perl_5.10.1-15_all.deb
  to main/p/perl/libcgi-fast-perl_5.10.1-15_all.deb
libperl-dev_5.10.1-15_amd64.deb
  to main/p/perl/libperl-dev_5.10.1-15_amd64.deb
libperl5.10_5.10.1-15_amd64.deb
  to main/p/perl/libperl5.10_5.10.1-15_amd64.deb
perl-base_5.10.1-15_amd64.deb
  to main/p/perl/perl-base_5.10.1-15_amd64.deb
perl-debug_5.10.1-15_amd64.deb
  to main/p/perl/perl-debug_5.10.1-15_amd64.deb
perl-doc_5.10.1-15_all.deb
  to main/p/perl/perl-doc_5.10.1-15_all.deb
perl-modules_5.10.1-15_all.deb
  to main/p/perl/perl-modules_5.10.1-15_all.deb
perl-suid_5.10.1-15_amd64.deb
  to main/p/perl/perl-suid_5.10.1-15_amd64.deb
perl_5.10.1-15.debian.tar.gz
  to main/p/perl/perl_5.10.1-15.debian.tar.gz
perl_5.10.1-15.dsc
  to main/p/perl/perl_5.10.1-15.dsc
perl_5.10.1-15_amd64.deb
  to main/p/perl/perl_5.10.1-15_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 508764@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Niko Tyni <ntyni@debian.org> (supplier of updated perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 06 Oct 2010 21:45:00 +0300
Source: perl
Binary: perl-base libcgi-fast-perl perl-doc perl-modules perl-debug perl-suid libperl5.10 libperl-dev perl
Architecture: source all amd64
Version: 5.10.1-15
Distribution: unstable
Urgency: low
Maintainer: Niko Tyni <ntyni@debian.org>
Changed-By: Niko Tyni <ntyni@debian.org>
Description: 
 libcgi-fast-perl - CGI::Fast Perl module
 libperl-dev - Perl library: development files
 libperl5.10 - shared Perl library
 perl       - Larry Wall's Practical Extraction and Report Language
 perl-base  - minimal Perl system
 perl-debug - debug-enabled Perl interpreter
 perl-doc   - Perl documentation
 perl-modules - Core Perl modules
 perl-suid  - runs setuid Perl scripts
Closes: 508764 595121 596734 596844
Changes: 
 perl (5.10.1-15) unstable; urgency=low
 .
   * Include the Text::Tabs license in debian/copyright. Thanks to "v.nix.is".
     (Closes: #596844)
   * Downgrade the 'make' recommendation to a suggestion to avoid pulling
     it in by default after all. (Closes: #596734) (Reopens: #293908)
   * Put the libfile-spec-perl conflict version in line with the separate
     package, which uses four digits. (Closes: #595121)
   * Squelch useless locale warnings during package maintainer scripts.
     (Closes: #508764)
Checksums-Sha1: 
 51d6f3aac87cb6da9b3fd771de752187c528a2f7 1388 perl_5.10.1-15.dsc
 55ef726151849a2b9ef3eac9d0c12f743dc99fe5 111060 perl_5.10.1-15.debian.tar.gz
 66524e570bc2a37c770f6b1a7635f657012fcf2f 52956 libcgi-fast-perl_5.10.1-15_all.deb
 3ccc71c15e19be0eaf864c7e65e8efc2d7cf9bc0 7188414 perl-doc_5.10.1-15_all.deb
 e1011aa2140df49e58dbc6b36e6f76c6174ed502 3481270 perl-modules_5.10.1-15_all.deb
 195d7c3d9abf41ecce1d9c96314cb63fdc3976cb 1065584 perl-base_5.10.1-15_amd64.deb
 5e4e88a4335689dae537a9af74743121e4c74b33 5835698 perl-debug_5.10.1-15_amd64.deb
 718360f774988675ba0fdace0093dfb2b8176499 34750 perl-suid_5.10.1-15_amd64.deb
 4b800914b668a76c3e8cdbf5d2363bd5a02bf31e 1148 libperl5.10_5.10.1-15_amd64.deb
 37c80894d3c2c03062a6f79d0421e8d33e831092 2562204 libperl-dev_5.10.1-15_amd64.deb
 b1d62cb74b8b9a3ab2775c7da401ea718e627e92 4461012 perl_5.10.1-15_amd64.deb
Checksums-Sha256: 
 61f1d4a5bfb093f7da5d01ef5258c1ad601dcb6e56cdf75e7393389caa0fc287 1388 perl_5.10.1-15.dsc
 0116e7e844cf7143f01e9482b0573a8f71c32251330850679dfb025542af8514 111060 perl_5.10.1-15.debian.tar.gz
 2438a58d096d01ae8a52814cc8d24677ac3b02ec2f833a2d02484d22b30989fd 52956 libcgi-fast-perl_5.10.1-15_all.deb
 0a81001576e7c5dae86b08bee1132027efd5a55a6359fb2a6791f104a80613f0 7188414 perl-doc_5.10.1-15_all.deb
 9c6851b0b67e6ea7b449b7267d6e21973a3b6a7c7306958a1821b009dda4582a 3481270 perl-modules_5.10.1-15_all.deb
 5a791081416b0b9c5a2d22feefc6920ff18834cba807330170e5da55c0efd4e5 1065584 perl-base_5.10.1-15_amd64.deb
 fc395de3f1e8baf8a8f61a862017c5e503cd7cad366f05123dc14f0e1883b288 5835698 perl-debug_5.10.1-15_amd64.deb
 4b10e98bb1ab4c297a88362e4955e1f6ab10208ec602af33e7b8b6473a6eef6c 34750 perl-suid_5.10.1-15_amd64.deb
 454c34687aa5218c4a2cfb3846d77babf6edd0a19d823aacd2065e95535bfd41 1148 libperl5.10_5.10.1-15_amd64.deb
 8eb3798efc12490165ebc570e7d032930dde3f46b17e3381252fac311e5f2605 2562204 libperl-dev_5.10.1-15_amd64.deb
 e11ba43dab29a564b5d2a3dcfffd8afb8a03df398fb539871651083b38338095 4461012 perl_5.10.1-15_amd64.deb
Files: 
 bbe5ce8e4a5e3819beecd925d34e8145 1388 perl standard perl_5.10.1-15.dsc
 9bec50f54eea121bf48e0d04808c8fc5 111060 perl standard perl_5.10.1-15.debian.tar.gz
 d678fb23327174e06b4175ef15fca2f1 52956 perl optional libcgi-fast-perl_5.10.1-15_all.deb
 4952f4f8c6a11217ad9e549f3edb3005 7188414 doc optional perl-doc_5.10.1-15_all.deb
 448a28bffe7f1e34974a93259b529c14 3481270 perl standard perl-modules_5.10.1-15_all.deb
 02d946e2a6777da96e31a0e0cc78e6b2 1065584 perl required perl-base_5.10.1-15_amd64.deb
 df0846e2811eba2b9927226674327ace 5835698 debug extra perl-debug_5.10.1-15_amd64.deb
 25af8a4189f65b83ea80faa95820ca4a 34750 perl optional perl-suid_5.10.1-15_amd64.deb
 793ca492c9b963c0182b849d6682a511 1148 libs optional libperl5.10_5.10.1-15_amd64.deb
 d93afc564dd7aadd8aba312af7435f85 2562204 libdevel optional libperl-dev_5.10.1-15_amd64.deb
 6a5d32ab6a442ba1322dbf88a632f5f5 4461012 perl standard perl_5.10.1-15_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkyszFoACgkQiyizGWoHLTk8ZACfcTS2uE8wIZsPpB59xVQ/0LI6
VIwAoKGKPifr8gU5sbX/Yxvn4jWSCtzs
=wxiy
-----END PGP SIGNATURE-----





Reply sent to Niko Tyni <ntyni@debian.org>:
You have taken responsibility. (Tue, 02 Nov 2010 11:36:10 GMT) Full text and rfc822 format available.

Notification sent to Michael Biebl <biebl@debian.org>:
Bug acknowledged by developer. (Tue, 02 Nov 2010 11:36:10 GMT) Full text and rfc822 format available.

Message #43 received at 508764-close@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: 508764-close@bugs.debian.org
Subject: Bug#508764: fixed in perl 5.12.2-2
Date: Tue, 02 Nov 2010 11:32:34 +0000
Source: perl
Source-Version: 5.12.2-2

We believe that the bug you reported is fixed in the latest version of
perl, which is due to be installed in the Debian FTP archive:

libcgi-fast-perl_5.12.2-2_all.deb
  to main/p/perl/libcgi-fast-perl_5.12.2-2_all.deb
libperl-dev_5.12.2-2_amd64.deb
  to main/p/perl/libperl-dev_5.12.2-2_amd64.deb
libperl5.12_5.12.2-2_amd64.deb
  to main/p/perl/libperl5.12_5.12.2-2_amd64.deb
perl-base_5.12.2-2_amd64.deb
  to main/p/perl/perl-base_5.12.2-2_amd64.deb
perl-debug_5.12.2-2_amd64.deb
  to main/p/perl/perl-debug_5.12.2-2_amd64.deb
perl-doc_5.12.2-2_all.deb
  to main/p/perl/perl-doc_5.12.2-2_all.deb
perl-modules_5.12.2-2_all.deb
  to main/p/perl/perl-modules_5.12.2-2_all.deb
perl_5.12.2-2.debian.tar.gz
  to main/p/perl/perl_5.12.2-2.debian.tar.gz
perl_5.12.2-2.dsc
  to main/p/perl/perl_5.12.2-2.dsc
perl_5.12.2-2_amd64.deb
  to main/p/perl/perl_5.12.2-2_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 508764@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Niko Tyni <ntyni@debian.org> (supplier of updated perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 02 Nov 2010 11:34:32 +0200
Source: perl
Binary: perl-base libcgi-fast-perl perl-doc perl-modules perl-debug libperl5.12 libperl-dev perl
Architecture: source all amd64
Version: 5.12.2-2
Distribution: experimental
Urgency: low
Maintainer: Niko Tyni <ntyni@debian.org>
Changed-By: Niko Tyni <ntyni@debian.org>
Description: 
 libcgi-fast-perl - CGI::Fast Perl module
 libperl-dev - Perl library: development files
 libperl5.12 - shared Perl library
 perl       - Larry Wall's Practical Extraction and Report Language
 perl-base  - minimal Perl system
 perl-debug - debug-enabled Perl interpreter
 perl-doc   - Perl documentation
 perl-modules - Core Perl modules
Closes: 379329 508764 596105 596734 596844 599933 601549
Changes: 
 perl (5.12.2-2) experimental; urgency=low
 .
   * Merge 5.10.1-15 and -16 from unstable:
     + Include the Text::Tabs license in debian/copyright. Thanks to "v.nix.is".
       (Closes: #596844)
     + Downgrade the 'make' recommendation to a suggestion to avoid pulling
       it in by default after all. (Closes: #596734) (Reopens: #293908)
     + Squelch useless locale warnings during package maintainer scripts.
       (Closes: #508764)
     + Improve LC_NUMERIC documentation. (Closes: #379329)
     + Fix sprintf not to ignore LC_NUMERIC with constants. (Closes: #601549)
     + Fix stack pointer corruption in pp_concat() with "use encoding".
       (Closes: #596105)
   * Unapply the debian/use_gdbm patch, obsolete since 5.8.4.
   * Fix h2ph header generation with GCC 4.5. Upstream patch by Robin Barker.
     (Closes: #599933)
Checksums-Sha1: 
 be804c5a49e9b63f76857fedce3c922df9957700 1423 perl_5.12.2-2.dsc
 19a022f64138edf6adcf2d50db1c1e3ee0f31d90 87572 perl_5.12.2-2.debian.tar.gz
 e06525a6fdc0635b84cc8c3bfd89fdcb85f7bccf 54260 libcgi-fast-perl_5.12.2-2_all.deb
 ee1c3e2859cf46b2f9bdbcee44266569edefb6bd 7506772 perl-doc_5.12.2-2_all.deb
 6439ebf9319ff7ae46333d63c9d78b51c3919cd0 4754640 perl-modules_5.12.2-2_all.deb
 f298e4dcbe6d70d624b0ee0c47aace19e388e1fa 1483584 perl-base_5.12.2-2_amd64.deb
 637245f29dac6dc071a7c1e0a8d385021f35c1e9 5895258 perl-debug_5.12.2-2_amd64.deb
 a6861a26609a771fdc85d4213f39dfca59f7d7d6 1150 libperl5.12_5.12.2-2_amd64.deb
 f1cea8b566f42816c85f784120d36a95ecffed4f 2573502 libperl-dev_5.12.2-2_amd64.deb
 5cfd5fe5dd6b30555d3905ff39ecdce64cbe07e3 4221210 perl_5.12.2-2_amd64.deb
Checksums-Sha256: 
 0e15780cd0b91b9e3f94c0131dadd86d8f54fbac67fe6f6d71110a520b568af9 1423 perl_5.12.2-2.dsc
 c6aee7bf9b70caa662a5bdc3cc4d4a4d2c2f1a833f04d75b0347835f9b544232 87572 perl_5.12.2-2.debian.tar.gz
 a6499b7f391f94142a30396ba1c9231e8c81cc552b4868f3f6de01194ae1f0c6 54260 libcgi-fast-perl_5.12.2-2_all.deb
 dbf876032f70ee45271e66e8aaec97fd55374bbbf65bbddf722467b8bdf3e987 7506772 perl-doc_5.12.2-2_all.deb
 c2c914a2be2fd07c31d209bab92e04bb582e29ae3cd95d32104e0c519509af64 4754640 perl-modules_5.12.2-2_all.deb
 e7ee0aa1fe64a964b66ec6ddb77ed40a44822ced78cd11b7a1bcd8fe1d4cace5 1483584 perl-base_5.12.2-2_amd64.deb
 61a2bda261b4d25e44a49fa1e57fa8cd438faf8ade378d6b8b1fd3cf82cdf60e 5895258 perl-debug_5.12.2-2_amd64.deb
 cba09404b8e60078953868740398a07dcff8d3d0f8eae0bdb539b1e4109cb730 1150 libperl5.12_5.12.2-2_amd64.deb
 4472cdf3ea8d003873c965aaada267b192d273cb0697f618272e5615d4a065e7 2573502 libperl-dev_5.12.2-2_amd64.deb
 7af1ad3685eeec13ed2750b92ff190ac272e65fb44b94da7cfc8ab17a928762a 4221210 perl_5.12.2-2_amd64.deb
Files: 
 be3df9a17d91f2f9fd3690f35513024f 1423 perl standard perl_5.12.2-2.dsc
 2c5ef80f180743ee342c15486a29c66d 87572 perl standard perl_5.12.2-2.debian.tar.gz
 8bfa31025e78fea891a33c0a19033740 54260 perl optional libcgi-fast-perl_5.12.2-2_all.deb
 c944d25183a3a99128d74b26852e650c 7506772 doc optional perl-doc_5.12.2-2_all.deb
 89af65e54e3af5cb8b40c161216f6142 4754640 perl standard perl-modules_5.12.2-2_all.deb
 09b99bbc17cf6277adffdafb47021710 1483584 perl required perl-base_5.12.2-2_amd64.deb
 f614a4e2b20da365f698cf3a77f927fe 5895258 debug extra perl-debug_5.12.2-2_amd64.deb
 25c16c05cf1972ee1d28e2b2fa779cab 1150 libs optional libperl5.12_5.12.2-2_amd64.deb
 4fb5cd7e834cb555e2286d81ad3a7eeb 2573502 libdevel optional libperl-dev_5.12.2-2_amd64.deb
 d547be35d28a4220474371d74e892913 4221210 perl standard perl_5.12.2-2_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkzP8twACgkQiyizGWoHLTmeNgCglhd8FKXF89s+IwEEqBgARQIR
8DQAn3Axo5TuVu8xy72Wv06pzZmpcLQr
=Tn2n
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 01 Dec 2010 07:34:49 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 06:33:16 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.