Debian Bug report logs - #507579
Package installation results in license violation

version graph

Package: yocto-reader; Maintainer for yocto-reader is Loic Dachary (OuoU) <loic@debian.org>; Source for yocto-reader is src:yocto-reader.

Reported by: Florian Weimer <fw@deneb.enyo.de>

Date: Tue, 2 Dec 2008 18:24:01 UTC

Severity: serious

Found in version yocto-reader/0.9.3

Fixed in version yocto-reader/0.9.4

Done: bkuhn@ebb.org (Bradley M. Kuhn)

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Tue, 02 Dec 2008 18:24:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Florian Weimer <fw@deneb.enyo.de>:
New Bug report received and forwarded. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Tue, 02 Dec 2008 18:24:04 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Florian Weimer <fw@deneb.enyo.de>
To: submit@bugs.debian.org
Subject: Package installation results in license violation
Date: Tue, 02 Dec 2008 19:19:07 +0100
Package: yocto-reader
Version: 0.9.3
Severity: serious

The HTML documents contained in the package do not include a download
link to the Debian-modified sources, which are the Corresponding
Source for this modification of yocto-reader.  This means that
directly after installation, the user is not compliant with Section 13
of the AGPL.




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Tue, 02 Dec 2008 18:42:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Florian Weimer <fw@deneb.enyo.de>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Tue, 02 Dec 2008 18:42:08 GMT) Full text and rfc822 format available.

Message #10 received at 507579@bugs.debian.org (full text, mbox):

From: Florian Weimer <fw@deneb.enyo.de>
To: 507579@bugs.debian.org
Subject: Links to non-free code, hence illegal to redistribute
Date: Tue, 02 Dec 2008 19:37:01 +0100
/usr/share/yocto-reader/feedread.html links to some compiled Google
code:

<!-- No google feeds in dummy mode -->
<script type="text/javascript" src="http://www.google.com/jsapi?key=ABQIAAAANKNUZ1d_R2qvgZ
_jpzKFKBT2yXp_ZAY8_ufC3CFXhHIE1NvwkxTitlqvQ1wYezL084RhjNaPkSXCpQ"></script>

We need to provide source code for that, too, because it does not fall
under the System Libraries exception in the AGPL.

The Google terms for that API key are somewhat funny, too, and seem to
conflict with DFSG requirements (provided that they extend to the
downloaded Javascript):

| 5.6 You agree that if you use the Feed API to develop a service for
| other users, it must be made accessible to your end users without
| charge.

| 10.1 Google gives you a personal, worldwide, royalty-free,
| non-assignable and non-exclusive license to use the software
| provided to you by Google as part of the Services as provided to you
| by Google (referred to as the "Software" below). This license is for
| the sole purpose of enabling you to use and enjoy the benefit of the
| Services as provided by Google, in the manner permitted by the
| Terms.

| 10.2 You may not (and you may not permit anyone else to) copy,
| modify, create a derivative work of, reverse engineer, decompile or
| otherwise attempt to extract the source code of the Software or any
| part thereof, unless this is expressly permitted or required by law,
| or unless you have been specifically told that you may do so by
| Google, in writing.

| 10.3 Unless Google has given you specific written permission to do
| so, you may not assign (or grant a sub-license of) your rights to
| use the Software, grant a security interest in or over your rights
| to use the Software, or otherwise transfer any part of your rights
| to use the Software.

| 11.2 You agree that Google, in its sole discretion, may use your
| trade names, trademarks, service marks, logos, domain names and
| other distinctive brand features in presentations, marketing
| materials, customer lists, financial reports and Web site listings
| (including links to your website) for the purpose of advertising or
| publicizing your use of the Services.

<http://code.google.com/apis/ajaxfeeds/signup.html>




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Wed, 03 Dec 2008 15:54:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Charles Plessy <plessy@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Wed, 03 Dec 2008 15:54:03 GMT) Full text and rfc822 format available.

Message #15 received at 507579@bugs.debian.org (full text, mbox):

From: Charles Plessy <plessy@debian.org>
To: 507579@bugs.debian.org, Florian Weimer <fw@deneb.enyo.de>
Subject: Can you elaborate on this bug (yocto-reader violating the AGPL).
Date: Thu, 4 Dec 2008 00:51:26 +0900
Hi Florian,

you have filed a release-critical bug against yocto-reader, arguing that:

A) The AGPL is violated because the program does not permit to download
   Debian's modifications.

B) The AGPL is violated because yocto-reader links against
   http://www.google.com/jsapi?key=ABQIAAAANKNUZ1d_R2qvgZ_jpzKFKBT2yXp_ZAY8_ufC3CFXhHIE1NvwkxTitlqvQ1wYezL084RhjNaPkSXCpQ

I think that A) and B) are incorrect for the following reasons:

A) No patch is applied to the AGPLed program, and the debian directory of the
   source package (native format) is a mere juxtaposition, that is released under
   the GPL, not the AGPL.

B) In the case of the javascript included:
   - The inclusion happens on the remote browser in a private context, not on the
     server where the Debian package is included.
   - The FAQ of the GPL clearly underlines that the clause 13 of the AGPL is
     for server programs. In the case you stated, the program acts as a client
     of Google.
     http://www.fsf.org/licensing/licenses/gpl-faq.html#AGPLv3InteractingRemotely

I hope that my arguments convinced you to close the bug. If not, I recommend to
contact debian-legal to gather more opinions in order to decide if the package
must be removed of Debian or if the bug should be closed. This will save some
time from the people monitoring RC bugs in Lenny.

Have a nice day,

-- 
Charles Plessy
Tsurumi, Kanagawa, Japan




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Wed, 03 Dec 2008 15:57:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Florian Weimer <fw@deneb.enyo.de>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Wed, 03 Dec 2008 15:57:02 GMT) Full text and rfc822 format available.

Message #20 received at 507579@bugs.debian.org (full text, mbox):

From: Florian Weimer <fw@deneb.enyo.de>
To: Charles Plessy <plessy@debian.org>
Cc: 507579@bugs.debian.org
Subject: Re: Can you elaborate on this bug (yocto-reader violating the AGPL).
Date: Wed, 03 Dec 2008 16:54:27 +0100
* Charles Plessy:

> you have filed a release-critical bug against yocto-reader, arguing that:

Thanks for reviewing the bug report.

> A) The AGPL is violated because the program does not permit to download
>    Debian's modifications.
>
> B) The AGPL is violated because yocto-reader links against
>    http://www.google.com/jsapi?key=ABQIAAAANKNUZ1d_R2qvgZ_jpzKFKBT2yXp_ZAY8_ufC3CFXhHIE1NvwkxTitlqvQ1wYezL084RhjNaPkSXCpQ
>
> I think that A) and B) are incorrect for the following reasons:
>
> A) No patch is applied to the AGPLed program, and the debian directory of the
>    source package (native format) is a mere juxtaposition, that is released under
>    the GPL, not the AGPL.

The AGPL requires that the build environment is provided.  The package
currently does not do this.  On top of that, the source download link
is simply broken.

> B) In the case of the javascript included:
>    - The inclusion happens on the remote browser in a private context, not on the
>      server where the Debian package is included.
>    - The FAQ of the GPL clearly underlines that the clause 13 of the AGPL is
>      for server programs. In the case you stated, the program acts as a client
>      of Google.
>      http://www.fsf.org/licensing/licenses/gpl-faq.html#AGPLv3InteractingRemotely

This does not address my follow-up message and Google's obnoxious terms & services.

> I hope that my arguments convinced you to close the bug.

Nope.




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Thu, 04 Dec 2008 06:57:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Charles Plessy <plessy@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Thu, 04 Dec 2008 06:57:02 GMT) Full text and rfc822 format available.

Message #25 received at 507579@bugs.debian.org (full text, mbox):

From: Charles Plessy <plessy@debian.org>
To: Florian Weimer <fw@deneb.enyo.de>
Cc: 507579@bugs.debian.org
Subject: Re: Can you elaborate on this bug (yocto-reader violating the AGPL).
Date: Thu, 4 Dec 2008 15:50:28 +0900
Hi Florian,

Le Wed, Dec 03, 2008 at 04:54:27PM +0100, Florian Weimer a écrit :
> 
> The AGPL requires that the build environment is provided.  The package
> currently does not do this.

I have diffed the GPL and the AGPL, and this provision is not AGPL-specific.
Aren't you interpreting the licence too strictly? With your interpretation,
wouldn't the same problem affect all our GPLed packages.


> On top of that, the source download link
> is simply broken.

That is annoying indeed (can you point at the broken link in the code to help
fixing it), but it infringes the AGPL only if the program is modified, which
does not seem the case: not only no patch is applied, but I just realised that
the debian directory is part of the upstream sources as well.

http://yocto-reader.flouzo.net/yocto-reader.zip


> > B) In the case of the javascript included:
> >    - The inclusion happens on the remote browser in a private context, not on the
> >      server where the Debian package is included.
> >    - The FAQ of the GPL clearly underlines that the clause 13 of the AGPL is
> >      for server programs. In the case you stated, the program acts as a client
> >      of Google.
> >      http://www.fsf.org/licensing/licenses/gpl-faq.html#AGPLv3InteractingRemotely
> 
> This does not address my follow-up message and Google's obnoxious terms & services.

We do not distribute this code, nor is it dowlnloaded on the machines where the
packages is installed. Can you re-explain why it is a problem for Debian?

 
> > I hope that my arguments convinced you to close the bug.
> 
> Nope.

How do you suggest to fix this bug, and what is your timeline?

Have a nice day,

-- 
Charles Plessy
Tsurumi, Kanagawa, Japan




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Fri, 05 Dec 2008 01:39:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Charles Plessy <plessy@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Fri, 05 Dec 2008 01:39:02 GMT) Full text and rfc822 format available.

Message #30 received at 507579@bugs.debian.org (full text, mbox):

From: Charles Plessy <plessy@debian.org>
To: debian-legal@lists.debian.org
Cc: 507579@bugs.debian.org, Florian Weimer <fw@deneb.enyo.de>
Subject: Help needed for bug 507579 (AGPL issue).
Date: Fri, 5 Dec 2008 10:36:53 +0900
Dear debian-legal,

yocto-reader is a package licenced under the AGPL, and due to the novelties of
this license there is divergence of interpretation on wether this package is
fit for the release or not.

Can you have a look to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507579
and help to resolve the issue?

The bug is quite short so I hope there is no need to make a summary. The main
issues are:

 - Wether the Debian package is a modification of upstream work that fails to
   provide access to the diff and the build environment.

 - Wether it is acceptable to have html pages that include a link to a remote
   non-free Google javascript.

Thanks a lot for your help !
(and please CC me)

Have a nice day,

-- 
Charles Plessy
Tsurumi, Kanagawa, Japan




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Fri, 05 Dec 2008 06:18:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Walter Landry <wlandry@caltech.edu>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Fri, 05 Dec 2008 06:18:02 GMT) Full text and rfc822 format available.

Message #35 received at 507579@bugs.debian.org (full text, mbox):

From: Walter Landry <wlandry@caltech.edu>
To: plessy@debian.org
Cc: debian-legal@lists.debian.org, 507579@bugs.debian.org, fw@deneb.enyo.de
Subject: Re: Help needed for bug 507579 (AGPL issue).
Date: Thu, 04 Dec 2008 22:12:30 -0800 (PST)
Charles Plessy <plessy@debian.org> wrote:
> Dear debian-legal,
> 
> yocto-reader is a package licenced under the AGPL, and due to the novelties of
> this license there is divergence of interpretation on wether this package is
> fit for the release or not.
> 
> Can you have a look to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507579
> and help to resolve the issue?
> 
> The bug is quite short so I hope there is no need to make a summary. The main
> issues are:
> 
>  - Wether the Debian package is a modification of upstream work that fails to
>    provide access to the diff and the build environment.

Upstream is also the Debian maintainer.  So the question of whether
Debian is modifying the code is sufficiently fuzzy that I do not feel
comfortable saying anything definite.  If someone else takes over
maintenance (e.g. QA), then they would have more work on their hands.

>  - Wether it is acceptable to have html pages that include a link to a remote
>    non-free Google javascript.

If I understand correctly, the Google javascript is required in order
for the page to work properly.  In Debian parlance, this means that
yocto-reader depends on the Google javascript.  So at a minimum
yocto-reader would have to go into contrib.

Now, it also seems like the Google javascript implements an API that
yocto-reader uses.  This makes the javascript more like a library, and
the AGPL requires the source of all of the libraries that it uses.

In summary, I am unsure about the first point, but I agree with
Florian Weimer about the second point.  Unfortunately, this means that
the code can not be packaged unless it is relicensed.

Cheers,
Walter Landry
wlandry@caltech.edu




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Sun, 07 Dec 2008 04:21:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Charles Plessy <plessy@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Sun, 07 Dec 2008 04:21:05 GMT) Full text and rfc822 format available.

Message #40 received at 507579@bugs.debian.org (full text, mbox):

From: Charles Plessy <plessy@debian.org>
To: debian-release@lists.debian.org
Cc: plessy@debian.org, debian-legal@lists.debian.org, 507579@bugs.debian.org, fw@deneb.enyo.de
Subject: Suggested removal: yocto-reader (RC bug, depends on remote scripts).
Date: Sun, 7 Dec 2008 13:17:25 +0900
Dear release team,

yocto-reader has a RC bug that was filed for multiple licensing issues. After
discussing with the bug reporter and getting advice from debian-legal (thanks
for the input), it seems that at least one of the issues is a clear violation
of our Policy (I will not discuss others in this email, you can read
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507579 for more details).

Le Thu, Dec 04, 2008 at 10:12:30PM -0800, Walter Landry a écrit :
> Charles Plessy <plessy@debian.org> wrote:
> > Can you have a look to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507579
> > and help to resolve the issue?
(…)
> >  - Wether it is acceptable to have html pages that include a link to a remote
> >    non-free Google javascript.
> 
> If I understand correctly, the Google javascript is required in order
> for the page to work properly.  In Debian parlance, this means that
> yocto-reader depends on the Google javascript.  So at a minimum
> yocto-reader would have to go into contrib.

My first objection was that if yocto-reader is a server, then the dependance of
the Google javascript happens privatley on a remote computer and is not an
issue for Debian. However, people may also want to install yocto-reader on
their machine through the Debian package to use it locally. In that case,
relying on the download of a remote component makes the package unfit for
Debian. I checked that commenting the <script> section that downloads the
Google javascript breaks yocto-reader.

Since yocto-reader was not distributed in Etch, is a leaf package and has a
Popcon score of 5, I suggest to remove the pakcage from Lenny in the absence its
the maintainer.

Have a nice day,

-- 
Charles Plessy
Tsurumi, Kanagawa, Japan




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Mon, 08 Dec 2008 15:18:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Bradley M. Kuhn" <bkuhn@ebb.org>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Mon, 08 Dec 2008 15:18:02 GMT) Full text and rfc822 format available.

Message #45 received at 507579@bugs.debian.org (full text, mbox):

From: "Bradley M. Kuhn" <bkuhn@ebb.org>
To: 507579@bugs.debian.org
Subject: Concerns raised on this ticket re: yocto-reader licensing issues
Date: Mon, 08 Dec 2008 10:11:01 -0500
Hello,

I am not a debian developer, but I have been working with the upstream
maintainer (who is also the Debian developer of this package), Loic
Dachary.  I am working toward debian developer status and am maintaining
this package by proxy through Loic.

First, please be aware that Yocto-Reader is a proof of concept
application waiting for a backend application.  We put it into Debian in
the hopes that it would be discovered by more people who might be
inspired to develop and improve this application.  I think everyone in
the Free Software world probably agrees that a Free Software replacement
for Google Reader  would be a good thing.

Regarding what Charles Plessy calls "Florian's Point (B)": The link to
the Google API is there for manual testing purposes, and can be removed.
It doesn't actually provide any real functionality.  yocto-reader isn't
compatible with Google's backend anyway.  I plan to repackage
yocto-reader this weekend without the Google API link.  I will note the
progress on that issue one week from today on this ticket.

In addition, I will also add something that automatically presents a
C&CS download link in the installation of yocto-reader itself.  This
should address what Charles Plessy calls "Florian's Point (A)".

I apologize I cannot get to this item quicker, but I have three jobs and
yocto-reader packaging is something I'm working on as a volunteer, so
weekends are the only time I have to spare to work on it, and sadly I
had already booked this weekend for other work   before I saw this bug
ticket.
-- 

   -- bkuhn




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Wed, 10 Dec 2008 23:00:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Thomas Viehmann <tv@beamnet.de>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Wed, 10 Dec 2008 23:00:05 GMT) Full text and rfc822 format available.

Message #50 received at 507579@bugs.debian.org (full text, mbox):

From: Thomas Viehmann <tv@beamnet.de>
To: 507579@bugs.debian.org
Subject: linking to the Debian sources, dependence on external JavaScript
Date: Wed, 10 Dec 2008 23:58:03 +0100
Hi,

this bug report raises two distinct issues
a) whether the program should display a link to the Debian package's
   source,
b) whether the linking to external JavaScript is acceptable for main.

The FTP team considers a) to be a bug. While it technically seems to be
an important bug, the implications are grave enough that this should be
treated as if it was serious. Please link to
http://packages.debian.org/$package .

Regarding b), per the Social Contract and the Debian policy if the
dependency on an external library cannot be avoided, the package needs
to be removed from main. Furthermore, this could become tricky with the
AGPL if the library does not have a compatible license.

Kind regards

Thomas
for the FTP team




Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Wed, 10 Dec 2008 23:51:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Loic Dachary <loic@dachary.org>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Wed, 10 Dec 2008 23:51:04 GMT) Full text and rfc822 format available.

Message #55 received at 507579@bugs.debian.org (full text, mbox):

From: Loic Dachary <loic@dachary.org>
To: Thomas Viehmann <tv@beamnet.de>, 507579@bugs.debian.org
Cc: "Bradley M. Kuhn" <bkuhn@ebb.org>
Subject: Re: Bug#507579: linking to the Debian sources, dependence on external JavaScript
Date: Thu, 11 Dec 2008 00:47:49 +0100
[Message part 1 (text/plain, inline)]
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thomas Viehmann wrote:
> Hi,
>
> this bug report raises two distinct issues a) whether the program
> should display a link to the Debian package's source, b) whether
> the linking to external JavaScript is acceptable for main.
>
> The FTP team considers a) to be a bug. While it technically seems
> to be an important bug, the implications are grave enough that this
> should be treated as if it was serious. Please link to
> http://packages.debian.org/$package .
Ok.
>
> Regarding b), per the Social Contract and the Debian policy if the
> dependency on an external library cannot be avoided, the package
> needs to be removed from main. Furthermore, this could become
> tricky with the AGPL if the library does not have a compatible
> license.
The external link is a left over from tests and will be removed. It is
by no mean a requirement to run the software.

Cheers

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAklAVSUACgkQ8dLMyEl6F20BHgCeOis5L5KqpJNr99vJg5QZBGmg
cBEAoLnFapapqUGH09dcIlHnDQt+y5GU
=A0C1
-----END PGP SIGNATURE-----

[loic.vcf (text/x-vcard, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Wed, 17 Dec 2008 11:57:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Neil McGovern <neilm@debian.org>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Wed, 17 Dec 2008 11:57:02 GMT) Full text and rfc822 format available.

Message #60 received at 507579@bugs.debian.org (full text, mbox):

From: Neil McGovern <neilm@debian.org>
To: Charles Plessy <plessy@debian.org>
Cc: debian-release@lists.debian.org, debian-legal@lists.debian.org, 507579@bugs.debian.org, fw@deneb.enyo.de
Subject: Re: Suggested removal: yocto-reader (RC bug, depends on remote scripts).
Date: Wed, 17 Dec 2008 11:49:33 +0000
[Message part 1 (text/plain, inline)]
On Sun, Dec 07, 2008 at 01:17:25PM +0900, Charles Plessy wrote:
> yocto-reader has a RC bug that was filed for multiple licensing issues.

As there has been no progress on this report, removal hint added.

Neil
-- 
<gwolf> bah.... Germans. You just put 100 DDs in one country and then they all
	become friends of each other.
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Loic Dachary (OuoU) <loic@debian.org>:
Bug#507579; Package yocto-reader. (Wed, 17 Dec 2008 15:09:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Bradley M. Kuhn" <bkuhn@ebb.org>:
Extra info received and forwarded to list. Copy sent to Loic Dachary (OuoU) <loic@debian.org>. (Wed, 17 Dec 2008 15:09:05 GMT) Full text and rfc822 format available.

Message #65 received at 507579@bugs.debian.org (full text, mbox):

From: "Bradley M. Kuhn" <bkuhn@ebb.org>
To: 507579@bugs.debian.org
Subject: Re: Bug#507579: Suggested removal: yocto-reader (RC bug, depends on remote scripts).
Date: Wed, 17 Dec 2008 09:47:22 -0500
> On Sun, Dec 07, 2008 at 01:17:25PM +0900, Charles Plessy wrote:
>> yocto-reader has a RC bug that was filed for multiple licensing issues.

Neil McGovern wrote at 06:49 (EST):

> As there has been no progress on this report, removal hint added.

Due to a crisis, I did not get the time this weekend I had hoped to fix
the problems, which I still believe can be fixed straightforwardly.  I
understand the need for suggested removal, but I believe this bug can be
closed as soon as I can spare three hours to work on it.  If you need to
remove it before I get to that, I understand, but I hope it can be put
back into main once this bug is closed, since all substantive issues can
be addressed.
-- 

   -- bkuhn




Reply sent to bkuhn@ebb.org (Bradley M. Kuhn):
You have taken responsibility. (Mon, 22 Dec 2008 18:09:07 GMT) Full text and rfc822 format available.

Notification sent to Florian Weimer <fw@deneb.enyo.de>:
Bug acknowledged by developer. (Mon, 22 Dec 2008 18:09:07 GMT) Full text and rfc822 format available.

Message #70 received at 507579-close@bugs.debian.org (full text, mbox):

From: bkuhn@ebb.org (Bradley M. Kuhn)
To: 507579-close@bugs.debian.org
Subject: Bug#507579: fixed in yocto-reader 0.9.4
Date: Mon, 22 Dec 2008 17:47:02 +0000
Source: yocto-reader
Source-Version: 0.9.4

We believe that the bug you reported is fixed in the latest version of
yocto-reader, which is due to be installed in the Debian FTP archive:

yocto-reader_0.9.4.dsc
  to pool/main/y/yocto-reader/yocto-reader_0.9.4.dsc
yocto-reader_0.9.4.tar.gz
  to pool/main/y/yocto-reader/yocto-reader_0.9.4.tar.gz
yocto-reader_0.9.4_all.deb
  to pool/main/y/yocto-reader/yocto-reader_0.9.4_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 507579@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Bradley M. Kuhn <bkuhn@ebb.org> (supplier of updated yocto-reader package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sat, 20 Dec 2008 15:15:31 -0500
Source: yocto-reader
Binary: yocto-reader
Architecture: source all
Version: 0.9.4
Distribution: unstable
Urgency: medium
Maintainer: Loic Dachary (OuoU) <loic@debian.org>
Changed-By: Bradley M. Kuhn <bkuhn@ebb.org>
Description: 
 yocto-reader - web based RSS reader
Closes: 507579
Changes: 
 yocto-reader (0.9.4) unstable; urgency=medium
 .
   * Removed link to proprietary Google javascript and added source
     installation. (closes: #507579)
Checksums-Sha1: 
 b7dbfa17a15b6d1feede5e626755551cdf0d9b2b 757 yocto-reader_0.9.4.dsc
 6bd30439256aeb316b5b9ff1773d3f7cbdbcfe8c 293678 yocto-reader_0.9.4.tar.gz
 219b039f73c2efc2a9f959c31145496c291fc7b3 536498 yocto-reader_0.9.4_all.deb
Checksums-Sha256: 
 bd8007cabe302af4ce6c79beb04919b1cb9293c5be84399facb8d891d5eb7de2 757 yocto-reader_0.9.4.dsc
 7f87428a68dd6f3acdf1b9010f3d251cb88dbedf4c4378bd6101933238fdaa71 293678 yocto-reader_0.9.4.tar.gz
 68004ab4c616ac9a06a84b837726bac1eee8e82cebe3b614557ed5d067984cec 536498 yocto-reader_0.9.4_all.deb
Files: 
 23a840723ea76f663e2243cee12ede40 757 web extra yocto-reader_0.9.4.dsc
 d426a62411692dc3169760ea02658b26 293678 web extra yocto-reader_0.9.4.tar.gz
 79075e673a8a669b791090d79adf0989 536498 web extra yocto-reader_0.9.4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAklP0BUACgkQ8dLMyEl6F23beQCcCVt2rJ2uUmdZgcTkvUAdWk23
FB4AoKIVDbhi6iAh6iFRVuSCam36o4SK
=A7c8
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 20 Jan 2009 07:28:27 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 12:59:46 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.