Debian Bug report logs - #496571
konqueror: configures javascript incorrectly for sourceforge.net domain

version graph

Package: konqueror; Maintainer for konqueror is Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>; Source for konqueror is src:kde-baseapps.

Reported by: "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>

Date: Mon, 25 Aug 2008 18:51:01 UTC

Severity: normal

Found in version kdebase/4:3.5.9.dfsg.1-5

Done: "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#496571; Package konqueror. Full text and rfc822 format available.

Acknowledgement sent to "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>:
New Bug report received and forwarded. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: konqueror: configures javascript incorrectly for sourceforge.net domain
Date: Mon, 25 Aug 2008 11:43:06 -0700
Package: konqueror
Version: 4:3.5.9.dfsg.1-5
Severity: normal

This happens for all SourceForge project sites I have tried, 
but just to be specific I report the problem for
http://sourceforge.net/projects/plplot.  That web page works fine if
you configure javascript globally with the default policies:

Open new window: smart
Resize window: allow
Move window: allow
Focus window: allow
Modify status bar text: allow

However, if I don't enable javascript globally (preferred if you are
security conscious) and enable those same policies just for the
sourceforge.net domain the webpage is rendered quite differently with all
javascript parts (e.g., the adds and the menus for Details, Public, Related,
and News) disabled. I tried setting the above policies specifically or
copied from global, and in desperation (since they are not domains) I also
tried sourceforge.net/ and sourceforge/net/projects/plplot. Note, I also
had cookies set for confirmation (in case some of the ads needed cookies),
but that made no difference, and in any case if there was a cookie problem,
it would have been found by the "enable javascript globally" workaround.

If you can find a way to render http://sourceforge.net/projects/plplot
(or any SourceForge project page) properly using domain-specific javascript
policy settings, that would be great, and I will close this bug report, but
I have tried everything I can think of so I think it must be some konqueror
bug in setting javascript policy for specific domains since
"enable javascript globally" works without problems.

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.25-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages konqueror depends on:
ii  kcontrol                4:3.5.9.dfsg.1-5 control center for KDE
ii  kdebase-kio-plugins     4:3.5.9.dfsg.1-5 core I/O slaves for KDE
ii  kdelibs4c2a             4:3.5.9.dfsg.1-6 core libraries and binaries for al
ii  kdesktop                4:3.5.9.dfsg.1-5 miscellaneous binaries and files f
ii  kfind                   4:3.5.9.dfsg.1-5 file-find utility for KDE
ii  libc6                   2.7-13           GNU C Library: Shared libraries
ii  libgcc1                 1:4.3.1-2        GCC support library
ii  libkonq4                4:3.5.9.dfsg.1-5 core libraries for Konqueror
ii  libqt3-mt               3:3.3.8b-5       Qt GUI Library (Threaded runtime v
ii  libstdc++6              4.3.1-2          The GNU Standard C++ Library v3
ii  libx11-6                2:1.1.4-2        X11 client-side library

konqueror recommends no packages.

Versions of packages konqueror suggests:
pn  gij-4.1    <none>                        (no description available)
ii  khelpcente 4:4.0.0.really.3.5.9.dfsg.1-5 help center for KDE
ii  konq-plugi 4:3.5.9-2                     plugins for Konqueror, the KDE fil
ii  ksvg       4:3.5.9-3                     SVG viewer for KDE
pn  libgcj7-aw <none>                        (no description available)
pn  libjessie- <none>                        (no description available)

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#496571; Package konqueror. Full text and rfc822 format available.

Acknowledgement sent to Josh Metzler <joshdeb@metzlers.org>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. Full text and rfc822 format available.

Message #10 received at 496571@bugs.debian.org (full text, mbox):

From: Josh Metzler <joshdeb@metzlers.org>
To: "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>, 496571@bugs.debian.org
Subject: Re: Bug#496571: konqueror: configures javascript incorrectly for sourceforge.net domain
Date: Tue, 26 Aug 2008 18:40:44 -0400
Alan,

I can get the content part of the site (the menus, etc) to work by adding your 
policy for static.sourceforge.net (looking at the page source, this is where 
they keep their javascript).  The ads are a harder problem.  I'm not sure 
that you need them, but if you do, you need to at least ad an Accept policy 
for ads.doubleclick.net.  That still doesn't make them all show up - 
apparently doubleclick writes some more <script> tags for different ad 
services (google adsense, triblefusion, etc), so you would also need to add 
Accept policies for all of those ad servers.  Note that this would make the 
ads show up on any page with ads from those servers.

Josh

On Monday 25 August 2008 02:43:06 pm Alan W. Irwin wrote:
> Package: konqueror
> Version: 4:3.5.9.dfsg.1-5
> Severity: normal
>
> This happens for all SourceForge project sites I have tried,
> but just to be specific I report the problem for
> http://sourceforge.net/projects/plplot.  That web page works fine if
> you configure javascript globally with the default policies:
>
> Open new window: smart
> Resize window: allow
> Move window: allow
> Focus window: allow
> Modify status bar text: allow
>
> However, if I don't enable javascript globally (preferred if you are
> security conscious) and enable those same policies just for the
> sourceforge.net domain the webpage is rendered quite differently with all
> javascript parts (e.g., the adds and the menus for Details, Public,
> Related, and News) disabled. I tried setting the above policies
> specifically or copied from global, and in desperation (since they are not
> domains) I also tried sourceforge.net/ and sourceforge/net/projects/plplot.
> Note, I also had cookies set for confirmation (in case some of the ads
> needed cookies), but that made no difference, and in any case if there was
> a cookie problem, it would have been found by the "enable javascript
> globally" workaround.
>
> If you can find a way to render http://sourceforge.net/projects/plplot
> (or any SourceForge project page) properly using domain-specific javascript
> policy settings, that would be great, and I will close this bug report, but
> I have tried everything I can think of so I think it must be some konqueror
> bug in setting javascript policy for specific domains since
> "enable javascript globally" works without problems.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#496571; Package konqueror. Full text and rfc822 format available.

Acknowledgement sent to "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. Full text and rfc822 format available.

Message #15 received at 496571@bugs.debian.org (full text, mbox):

From: "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>
To: 496571@bugs.debian.org
Subject: konqueror: configures javascript incorrectly for sourceforge.net domain
Date: Thu, 28 Aug 2008 13:24:38 -0700 (PDT)
Hi Josh:

Thanks for your konqueror javascript configuration help.  You are right, I
don't want the ads so configuring the combination of static.sourceforge.net
and sourceforge.net domains is perfect for my needs.

I am experienced enough with html that I should have looked at the html
source code myself to figure out the javascript configuration. However, that
is not a viable option for those konqueror users who are not that familiar
with html.  Therefore, I will close this bug but open another wish-list one
to ask for a "confirm" option (similar to what happens now for cookies)
for javascript. That option would help those users who don't have sufficient
html expertise to figure out which domains to configure from the html
source to get javascript to work.

Alan
__________________________
Alan W. Irwin

Astronomical research affiliation with Department of Physics and Astronomy,
University of Victoria (astrowww.phys.uvic.ca).

Programming affiliations with the FreeEOS equation-of-state implementation
for stellar interiors (freeeos.sf.net); PLplot scientific plotting software
package (plplot.org); the libLASi project (unifont.org/lasi); the Loads of
Linux Links project (loll.sf.net); and the Linux Brochure Project
(lbproject.sf.net).
__________________________

Linux-powered Science
__________________________




Reply sent to "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #20 received at 496571-done@bugs.debian.org (full text, mbox):

From: "Alan W. Irwin" <irwin@beluga.phys.uvic.ca>
To: 496571-done@bugs.debian.org
Subject: Re: konqueror: configures javascript incorrectly for sourceforge.net domain
Date: Thu, 28 Aug 2008 13:34:27 -0700 (PDT)
On 2008-08-28 13:24-0700 Alan W. Irwin wrote:

> Hi Josh:
>
> Thanks for your konqueror javascript configuration help.  You are right, I
> don't want the ads so configuring the combination of static.sourceforge.net
> and sourceforge.net domains is perfect for my needs.
>
> I am experienced enough with html that I should have looked at the html
> source code myself to figure out the javascript configuration. However, that
> is not a viable option for those konqueror users who are not that familiar
> with html.  Therefore, I will close this bug ....

OOPS, I sent the above to the wrong address.  This time to
496571-done@bugs.debian.org to properly close it.

Alan
__________________________
Alan W. Irwin

Astronomical research affiliation with Department of Physics and Astronomy,
University of Victoria (astrowww.phys.uvic.ca).

Programming affiliations with the FreeEOS equation-of-state implementation
for stellar interiors (freeeos.sf.net); PLplot scientific plotting software
package (plplot.org); the libLASi project (unifont.org/lasi); the Loads of
Linux Links project (loll.sf.net); and the Linux Brochure Project
(lbproject.sf.net).
__________________________

Linux-powered Science
__________________________




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 26 Sep 2008 07:31:17 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 12:56:24 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.