Debian Bug report logs - #495600
deborphan: Package `"some_package_name"' is not installed and no info is available. - when asking for Help

version graph

Package: deborphan; Maintainer for deborphan is deborphan devel team <deborphan-devel@lists.alioth.debian.org>; Source for deborphan is src:deborphan.

Reported by: Michal Pokrywka <wolfmoon@o2.pl>

Date: Mon, 18 Aug 2008 20:30:05 UTC

Severity: normal

Fixed in version dialog/1.1-20080819-1

Done: Santiago Vila <sanvila@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Carsten Hey <c.hey@web.de>:
Bug#495600; Package deborphan. Full text and rfc822 format available.

Acknowledgement sent to Michal Pokrywka <wolfmoon@o2.pl>:
New Bug report received and forwarded. Copy sent to Carsten Hey <c.hey@web.de>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Michal Pokrywka <wolfmoon@o2.pl>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: deborphan: Package `"some_package_name"' is not installed and no info is available. - when asking for Help
Date: Mon, 18 Aug 2008 22:27:45 +0200
Package: deborphan
Version: 1.7.26
Severity: normal


Hi,

When asking for help in orphaner, the program quits with message in
the subject. For example when I ask for help on 'acpid` package it shows:

Package `"acpid"' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

It this a problem with quotation marks?

It quits with this error on every package on my desktop system and on my
laptop too.

Michal Pokrywka

-- System Information:
Debian Release: lenny/sid
  APT prefers stable
  APT policy: (500, 'stable'), (100, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/2 CPU cores)
Locale: LANG=pl_PL.UTF8, LC_CTYPE=pl_PL.UTF8 (charmap=UTF-8) (ignored: LC_ALL set to pl_PL.UTF8)
Shell: /bin/sh linked to /bin/bash

Versions of packages deborphan depends on:
ii  libc6                         2.7-13     GNU C Library: Shared libraries

Versions of packages deborphan recommends:
ii  apt                       0.7.14+b1      Advanced front-end for dpkg
ii  dialog                    1.1-20080727-1 Displays user-friendly dialog boxe
ii  gettext-base              0.17-3         GNU Internationalization utilities

deborphan suggests no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#495600; Package deborphan. Full text and rfc822 format available.

Message #8 received at 495600@bugs.debian.org (full text, mbox):

From: Carsten Hey <c.hey@web.de>
To: Michal Pokrywka <wolfmoon@o2.pl>, 495600@bugs.debian.org
Cc: sanvila@debian.org
Subject: dialog/sid breaks orphaner (was: Bug#495600: deborphan: Package `"some_package_name"' is not installed and no info is available. - when asking for Help)
Date: Tue, 19 Aug 2008 00:00:15 +0200
Hi,

On Mon, Aug 18, 2008 at 10:27:45PM +0200, Michal Pokrywka wrote:
> When asking for help in orphaner, the program quits with message in
> the subject. For example when I ask for help on 'acpid` package it shows:
>
> Package `"acpid"' is not installed and no info is available.
> Use dpkg --info (= dpkg-deb --info) to examine archive files,
> and dpkg --contents (= dpkg-deb --contents) to list their contents.
>
> It this a problem with quotation marks?

yes, the error message looks like it is caused through problem with
quotation marks.

This bug does not occur with dialog 1.1-20080316-1 which is currently in
testing but it is reproducible with dialog 1.1-20080727-1 which is
currently in unstable, so I guess it is a bug in dialog

I will file an additional bug against dialog after I created a minimized
test case which might take some time.  I will not close or reassign this
bug since I want people to see this bug before they submit an additional
bug report against deborphan.

>   APT policy: (500, 'stable'), (100, 'unstable')

Mixing stable and unstable isn't a very good idea.  Mixing testing, unstable
and maybe even experimental _OR_ stable and backports.org is normally
a better choice when you feel the need to mix something.


Regards,
Carsten




Information forwarded to debian-bugs-dist@lists.debian.org, Carsten Hey <c.hey@web.de>:
Bug#495600; Package deborphan. Full text and rfc822 format available.

Acknowledgement sent to dickey@his.com:
Extra info received and forwarded to list. Copy sent to Carsten Hey <c.hey@web.de>. Full text and rfc822 format available.

Message #13 received at 495600@bugs.debian.org (full text, mbox):

From: Thomas Dickey <dickey@his.com>
To: 495600@bugs.debian.org
Subject: re: #495600 - deborphan: Package `"some_package_name"' is not installed and no info is
Date: Tue, 19 Aug 2008 20:47:07 -0400
[Message part 1 (text/plain, inline)]
The apparent issue is a minor incompatibility (quoting) of output for the
checklist widget from the 20080727 changes.  I've uploaded a fix for dialog,
which will presumably address this (reassigning the bug report is better
than adding reports).

-- 
Thomas E. Dickey <dickey@invisible-island.net>
http://invisible-island.net
ftp://invisible-island.net
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#495600; Package deborphan. Full text and rfc822 format available.

Message #16 received at 495600@bugs.debian.org (full text, mbox):

From: Carsten Hey <c.hey@web.de>
To: dickey@his.com, 495600@bugs.debian.org
Subject: Re: Bug#495600: #495600 - deborphan: Package `"some_package_name"' is not installed and no info is
Date: Wed, 20 Aug 2008 03:03:12 +0200
On Tue, Aug 19, 2008 at 08:47:07PM -0400, Thomas Dickey wrote:
> The apparent issue is a minor incompatibility (quoting) of output for the
> checklist widget from the 20080727 changes.  I've uploaded a fix for dialog,
> which will presumably address this

Thanks, I'll test it when it has hit unstable.

> (reassigning the bug report is better than adding reports).

Yes, but leaving one bug report in the package where user expect the bug
is less wor^W^Wbetter that reassigning and merging many bugs :)


Thanks for the quick fix,
Carsten




Bug 495600 cloned as bug 495725. Request was from Carsten Hey <c.hey@web.de> to control@bugs.debian.org. (Wed, 20 Aug 2008 01:27:02 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Carsten Hey <c.hey@web.de>:
Bug#495600; Package deborphan. Full text and rfc822 format available.

Acknowledgement sent to Santiago Vila <sanvila@unex.es>:
Extra info received and forwarded to list. Copy sent to Carsten Hey <c.hey@web.de>. Full text and rfc822 format available.

Message #23 received at 495600@bugs.debian.org (full text, mbox):

From: Santiago Vila <sanvila@unex.es>
To: Carsten Hey <c.hey@web.de>, 495600@bugs.debian.org
Cc: dickey@his.com
Subject: Re: Bug#495600: #495600 - deborphan: Package `"some_package_name"' is not installed and no info is
Date: Wed, 20 Aug 2008 11:24:31 +0200 (CEST)
On Wed, 20 Aug 2008, Carsten Hey wrote:

> On Tue, Aug 19, 2008 at 08:47:07PM -0400, Thomas Dickey wrote:
> > The apparent issue is a minor incompatibility (quoting) of output for the
> > checklist widget from the 20080727 changes.  I've uploaded a fix for dialog,
> > which will presumably address this
> 
> Thanks, I'll test it when it has hit unstable.
> 
> > (reassigning the bug report is better than adding reports).
> 
> Yes, but leaving one bug report in the package where user expect the bug
> is less wor^W^Wbetter that reassigning and merging many bugs :)

This is up to you on the deborphan side, but please note that it's
also more work for me on the dialog side, as I have to read more pages
of bug logs to guess the new bug number coming from the cloning process.
Also, you will have to close the bug in deborphan using a simple
message, not the changelog, and the message would say something like
"fixed in dialog version foo", which has nothing to do with deborphan.

To summarize, for bugs which are fixed quickly like this, I think
cloning is bad.

Anyway, I'm going to package the new dialog today.

Thanks.




Information forwarded to debian-bugs-dist@lists.debian.org, Carsten Hey <c.hey@web.de>:
Bug#495600; Package deborphan. Full text and rfc822 format available.

Acknowledgement sent to Santiago Vila <sanvila@unex.es>:
Extra info received and forwarded to list. Copy sent to Carsten Hey <c.hey@web.de>. Full text and rfc822 format available.

Message #28 received at 495600@bugs.debian.org (full text, mbox):

From: Santiago Vila <sanvila@unex.es>
To: Carsten Hey <c.hey@web.de>
Cc: dialog@packages.debian.org, 495600@bugs.debian.org
Subject: Re: cloning 495600, reassign -1 to dialog
Date: Wed, 20 Aug 2008 11:52:00 +0200 (CEST)
FYI: I've also closed this bug (495600) in the dialog changelog, since
I believe it's the right thing to do.

Thanks.




Reply sent to Santiago Vila <sanvila@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Michal Pokrywka <wolfmoon@o2.pl>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #33 received at 495600-close@bugs.debian.org (full text, mbox):

From: Santiago Vila <sanvila@debian.org>
To: 495600-close@bugs.debian.org
Subject: Bug#495600: fixed in dialog 1.1-20080819-1
Date: Wed, 20 Aug 2008 10:02:22 +0000
Source: dialog
Source-Version: 1.1-20080819-1

We believe that the bug you reported is fixed in the latest version of
dialog, which is due to be installed in the Debian FTP archive:

dialog_1.1-20080819-1.diff.gz
  to pool/main/d/dialog/dialog_1.1-20080819-1.diff.gz
dialog_1.1-20080819-1.dsc
  to pool/main/d/dialog/dialog_1.1-20080819-1.dsc
dialog_1.1-20080819-1_i386.deb
  to pool/main/d/dialog/dialog_1.1-20080819-1_i386.deb
dialog_1.1-20080819.orig.tar.gz
  to pool/main/d/dialog/dialog_1.1-20080819.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 495600@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Santiago Vila <sanvila@debian.org> (supplier of updated dialog package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 20 Aug 2008 11:45:16 +0200
Source: dialog
Binary: dialog
Architecture: source i386
Version: 1.1-20080819-1
Distribution: unstable
Urgency: low
Maintainer: Santiago Vila <sanvila@debian.org>
Changed-By: Santiago Vila <sanvila@debian.org>
Description: 
 dialog     - Displays user-friendly dialog boxes from shell scripts
Closes: 495600 495725
Changes: 
 dialog (1.1-20080819-1) unstable; urgency=low
 .
   * New upstream release to address problem with deborphan.
     The checklist widget, by default, no longer quotes its output
     if --separate-output is used. Closes: #495600, #495725.
Checksums-Sha1: 
 57fcdeb7f632c730085d569b5f2e4d4b87a8bee0 993 dialog_1.1-20080819-1.dsc
 068a46aa1ffbfe96fdbf5cedd480b795a4f6321a 378814 dialog_1.1-20080819.orig.tar.gz
 16c99be0ed64815c6b3e958749f0329daf4a17cc 9453 dialog_1.1-20080819-1.diff.gz
 9425437e9a4720e88c655098b795ec31970e2e19 270486 dialog_1.1-20080819-1_i386.deb
Checksums-Sha256: 
 a2e197c19d14d3d4049cb2f62200bd5635ad927baf52de1916a86ad707862653 993 dialog_1.1-20080819-1.dsc
 c5d49b39c5998bcecd124c05cc6f096d22ccdc378ad455214611ae41a2f4b7d9 378814 dialog_1.1-20080819.orig.tar.gz
 1275fcbadd65460de48fadd514f64c97e2f34146ca5921036096f080a7c9eeb5 9453 dialog_1.1-20080819-1.diff.gz
 31e39c30c88622cbb91ae602f14930bce9ea05ef08cc069f5e428870a595a96f 270486 dialog_1.1-20080819-1_i386.deb
Files: 
 e4cb5b0c2b18b384b4f1459319f029c6 993 misc optional dialog_1.1-20080819-1.dsc
 3caebd641a9f337b980becb4444336c5 378814 misc optional dialog_1.1-20080819.orig.tar.gz
 5eb9d6fe45cc2d0537f28e81788ce583 9453 misc optional dialog_1.1-20080819-1.diff.gz
 bc80c72f73fae8ff0500af6fa13d9c29 270486 misc optional dialog_1.1-20080819-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFIq+gZd9Uuvj7yPNYRAoF/AJ9AJOHny7DktUxY8fCJblkY2vBimgCgqy9t
5cKWviJRoUAHwfmimls7SEo=
=TDbO
-----END PGP SIGNATURE-----





Information forwarded to debian-bugs-dist@lists.debian.org, Carsten Hey <c.hey@web.de>:
Bug#495600; Package deborphan. Full text and rfc822 format available.

Acknowledgement sent to Thomas Dickey <dickey@his.com>:
Extra info received and forwarded to list. Copy sent to Carsten Hey <c.hey@web.de>. Full text and rfc822 format available.

Message #38 received at 495600@bugs.debian.org (full text, mbox):

From: Thomas Dickey <dickey@his.com>
To: Carsten Hey <c.hey@web.de>
Cc: 495600@bugs.debian.org
Subject: Re: Bug#495600: #495600 - deborphan: Package `"some_package_name"' is not installed and no info is
Date: Wed, 20 Aug 2008 06:57:50 -0400 (EDT)
On Wed, 20 Aug 2008, Carsten Hey wrote:

> On Tue, Aug 19, 2008 at 08:47:07PM -0400, Thomas Dickey wrote:
>> The apparent issue is a minor incompatibility (quoting) of output for the
>> checklist widget from the 20080727 changes.  I've uploaded a fix for dialog,
>> which will presumably address this
>
> Thanks, I'll test it when it has hit unstable.
>
>> (reassigning the bug report is better than adding reports).
>
> Yes, but leaving one bug report in the package where user expect the bug
> is less wor^W^Wbetter that reassigning and merging many bugs :)
>
>
> Thanks for the quick fix,

no problem (report bugs)

-- 
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net




Bug no longer marked as found in version 1.7.26. Request was from Carsten Hey <c.hey@web.de> to control@bugs.debian.org. (Thu, 18 Sep 2008 17:12:12 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 17 Oct 2008 07:26:32 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 20:31:45 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.