Debian Bug report logs - #495131
read-edid: Switch to use lib86 instead of embedded LRMI

version graph

Package: read-edid; Maintainer for read-edid is Dariusz Dwornikowski <dariusz.dwornikowski@cs.put.poznan.pl>; Source for read-edid is src:read-edid.

Reported by: Guillem Jover <guillem@debian.org>

Date: Thu, 14 Aug 2008 18:42:01 UTC

Severity: important

Tags: patch, security

Found in version read-edid/1.4.1-2.1

Fixed in version read-edid/2.0.0-1

Done: LIU Qi <liuqi82@gmail.com>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Branden Robinson <branden@debian.org>:
Bug#495131; Package read-edid. Full text and rfc822 format available.

Acknowledgement sent to Guillem Jover <guillem@debian.org>:
New Bug report received and forwarded. Copy sent to Branden Robinson <branden@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Guillem Jover <guillem@debian.org>
To: submit@bugs.debian.org
Subject: read-edid: Switch to use lib86 instead of embedded LRMI
Date: Thu, 14 Aug 2008 21:38:45 +0300
[Message part 1 (text/plain, inline)]
Source: read-edid
Source-Version: 1.4.1-2.1
Severity: important
Tags: patch security

Hi,

This packages has embedded copies of lrmi, please switch to use libx86
instead. As a side effect allows this package to build on any-amd64
and any-i386 (including hurd and kfreebsd systems).

Attached a patch fixing this, you might need to run “autoreconf -f -i”,
after applying it.

regards,
guillem
[0001-Use-external-libx86-instead-of-embedded-lrmi.patch (text/x-diff, attachment)]

Reply sent to LIU Qi <liuqi82@gmail.com>:
You have taken responsibility. (Sat, 30 May 2009 12:15:16 GMT) Full text and rfc822 format available.

Notification sent to Guillem Jover <guillem@debian.org>:
Bug acknowledged by developer. (Sat, 30 May 2009 12:15:16 GMT) Full text and rfc822 format available.

Message #10 received at 495131-close@bugs.debian.org (full text, mbox):

From: LIU Qi <liuqi82@gmail.com>
To: 495131-close@bugs.debian.org
Subject: Bug#495131: fixed in read-edid 2.0.0-1
Date: Sat, 30 May 2009 11:54:11 +0000
Source: read-edid
Source-Version: 2.0.0-1

We believe that the bug you reported is fixed in the latest version of
read-edid, which is due to be installed in the Debian FTP archive:

read-edid_2.0.0-1.diff.gz
  to pool/main/r/read-edid/read-edid_2.0.0-1.diff.gz
read-edid_2.0.0-1.dsc
  to pool/main/r/read-edid/read-edid_2.0.0-1.dsc
read-edid_2.0.0-1_amd64.deb
  to pool/main/r/read-edid/read-edid_2.0.0-1_amd64.deb
read-edid_2.0.0.orig.tar.gz
  to pool/main/r/read-edid/read-edid_2.0.0.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 495131@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
LIU Qi <liuqi82@gmail.com> (supplier of updated read-edid package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 11 May 2009 13:14:40 +0800
Source: read-edid
Binary: read-edid
Architecture: source amd64
Version: 2.0.0-1
Distribution: unstable
Urgency: low
Maintainer: LIU Qi <liuqi82@gmail.com>
Changed-By: LIU Qi <liuqi82@gmail.com>
Description: 
 read-edid  - hardware information-gathering tool for VESA PnP monitors
Closes: 231307 395741 406736 433713 495131 502125 502126
Changes: 
 read-edid (2.0.0-1) unstable; urgency=low
 .
   * new upstream version and maintainer (Closes: #502125)
     - the new version uses libx86 instead of LRMI (Closes: #495131)
     - libx86 will build on new kernel (Closes: #502126)
   * add missing binary-indep in debian/rules (Closes: #395741)
   * new version is modified to build on any architecture
     - fixed the powerpc build problem (Closes: #406736)
     - fixed the rebuild problem (Closes: #433713)
   * install the read-edid in usr/sbin directory (Closes: #231307)
Checksums-Sha1: 
 67a43dce679379140dea8844b7320cf0ff53c44f 1050 read-edid_2.0.0-1.dsc
 8605a242c0a104a70ab1a5cdd616fffbac52d6c8 82282 read-edid_2.0.0.orig.tar.gz
 e158026b04c964fcd3ee57aad70121fcc3d5c8ba 4109 read-edid_2.0.0-1.diff.gz
 bb8074e53260921d591a37182ffae0742861a5fd 9048 read-edid_2.0.0-1_amd64.deb
Checksums-Sha256: 
 83d428f596f2f9a823bbeed30f68422662128a896355d790c1cd45fa94698f6c 1050 read-edid_2.0.0-1.dsc
 246ec14ec509e09ac26fe6862b120481b2cc881e2f142ba40886d6eec15e77e8 82282 read-edid_2.0.0.orig.tar.gz
 405512685288849c5eb51499e25f23c321ef94d9f98d5cb737446fcdc04503ed 4109 read-edid_2.0.0-1.diff.gz
 7890f8bf26fa75344dccfffe66143a444faa7c1a9f43bf1fee408fdba2437108 9048 read-edid_2.0.0-1_amd64.deb
Files: 
 9281ed7fbff7768bdab6cfdf14c07e09 1050 utils optional read-edid_2.0.0-1.dsc
 586e7fa1167773b27f4e505edc93274b 82282 utils optional read-edid_2.0.0.orig.tar.gz
 4cbe7b546b673015fead6579603eb41f 4109 utils optional read-edid_2.0.0-1.diff.gz
 083c215563cf76658261ef4add115912 9048 utils optional read-edid_2.0.0-1_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkohE28ACgkQgY5NIXPNpFWNWgCgnJFjSKHTUXJ34zBoSvAQraqp
0/QAn2g6UrymiOIK2NoEcYLbFEJJWyGn
=Yaq5
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 13 Jul 2009 07:38:39 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 23:43:35 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.