Debian Bug report logs - #490819
release.debian.org: section 5(m) of lenny RC policy out of date

Package: release.debian.org; Maintainer for release.debian.org is Debian Release Team <debian-release@lists.debian.org>;

Reported by: Julien Cristau <jcristau@debian.org>

Date: Mon, 14 Jul 2008 13:33:01 UTC

Severity: normal

Done: Luk Claes <luk@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#490819; Package release.debian.org. Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
New Bug report received and forwarded. Copy sent to Debian Release Team <debian-release@lists.debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: release.debian.org: section 5(m) of lenny RC policy out of date
Date: Mon, 14 Jul 2008 15:31:13 +0200
Package: release.debian.org

Quoting from http://release.debian.org/lenny/rc_policy.txt:

5. General
[...]
  (m) X support

[...]

        Packages must not install files in to /usr/{bin,include,lib}/X11,
        however, they should reference the files by these names in preference
        to the corresponding /usr/X11R6/ directories.

This paragraph should be removed, I think (it was already wrong for etch).
Nowadays, packages must not install files in to /usr/X11R6, and if they
install files in /usr/{include,lib}/X11 they must pre-depend on
x11-common (>= 1:7.0.0).

Cheers,
Julien




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#490819; Package release.debian.org. Full text and rfc822 format available.

Acknowledgement sent to Steve Langasek <vorlon@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. Full text and rfc822 format available.

Message #10 received at 490819@bugs.debian.org (full text, mbox):

From: Steve Langasek <vorlon@debian.org>
To: Julien Cristau <jcristau@debian.org>, 490819@bugs.debian.org
Subject: Re: Bug#490819: release.debian.org: section 5(m) of lenny RC policy out of date
Date: Mon, 14 Jul 2008 16:03:44 +0100
On Mon, Jul 14, 2008 at 03:31:13PM +0200, Julien Cristau wrote:
> Package: release.debian.org

> Quoting from http://release.debian.org/lenny/rc_policy.txt:

> 5. General
> [...]
>   (m) X support
> 
> [...]
> 
>         Packages must not install files in to /usr/{bin,include,lib}/X11,
>         however, they should reference the files by these names in preference
>         to the corresponding /usr/X11R6/ directories.

> This paragraph should be removed, I think (it was already wrong for etch).
> Nowadays, packages must not install files in to /usr/X11R6, and if they
> install files in /usr/{include,lib}/X11 they must pre-depend on
> x11-common (>= 1:7.0.0).

I think the pre-depends is also unnecessary for lenny since this version of
x11-common was in etch and skipping releases is not supported, so we should
not need to encourage maintainers to add this field anywhere that it isn't
already present.

-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Debian Release Team <debian-release@lists.debian.org>:
Bug#490819; Package release.debian.org. (Sun, 16 Aug 2009 13:45:06 GMT) Full text and rfc822 format available.

Acknowledgement sent to Julien Cristau <jcristau@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian Release Team <debian-release@lists.debian.org>. (Sun, 16 Aug 2009 13:45:06 GMT) Full text and rfc822 format available.

Message #15 received at 490819@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: Steve Langasek <vorlon@debian.org>, 490819@bugs.debian.org
Subject: Re: Bug#490819: release.debian.org: section 5(m) of lenny RC policy out of date
Date: Sun, 16 Aug 2009 15:40:06 +0200
On Mon, Jul 14, 2008 at 16:03:44 +0100, Steve Langasek wrote:

> On Mon, Jul 14, 2008 at 03:31:13PM +0200, Julien Cristau wrote:
> > Package: release.debian.org
> 
> > Quoting from http://release.debian.org/lenny/rc_policy.txt:
> 
> > 5. General
> > [...]
> >   (m) X support
> > 
> > [...]
> > 
> >         Packages must not install files in to /usr/{bin,include,lib}/X11,
> >         however, they should reference the files by these names in preference
> >         to the corresponding /usr/X11R6/ directories.
> 
> > This paragraph should be removed, I think (it was already wrong for etch).
> > Nowadays, packages must not install files in to /usr/X11R6, and if they
> > install files in /usr/{include,lib}/X11 they must pre-depend on
> > x11-common (>= 1:7.0.0).
> 
> I think the pre-depends is also unnecessary for lenny since this version of
> x11-common was in etch and skipping releases is not supported, so we should
> not need to encourage maintainers to add this field anywhere that it isn't
> already present.
> 
This paragraph is still present at
http://release.debian.org/squeeze/rc_policy.txt
Can somebody please remove it?

Cheers,
Julien




Reply sent to Luk Claes <luk@debian.org>:
You have taken responsibility. (Sun, 16 Aug 2009 14:33:10 GMT) Full text and rfc822 format available.

Notification sent to Julien Cristau <jcristau@debian.org>:
Bug acknowledged by developer. (Sun, 16 Aug 2009 14:33:10 GMT) Full text and rfc822 format available.

Message #20 received at 490819-done@bugs.debian.org (full text, mbox):

From: Luk Claes <luk@debian.org>
To: 490819-done@bugs.debian.org
Subject: Re: Bug#490819: release.debian.org: section 5(m) of lenny RC policy out of date
Date: Sun, 16 Aug 2009 16:31:58 +0200
Julien Cristau wrote:
> On Mon, Jul 14, 2008 at 16:03:44 +0100, Steve Langasek wrote:
> 
>> On Mon, Jul 14, 2008 at 03:31:13PM +0200, Julien Cristau wrote:
>>> Package: release.debian.org
>>> Quoting from http://release.debian.org/lenny/rc_policy.txt:
>>> 5. General
>>> [...]
>>>   (m) X support
>>>
>>> [...]
>>>
>>>         Packages must not install files in to /usr/{bin,include,lib}/X11,
>>>         however, they should reference the files by these names in preference
>>>         to the corresponding /usr/X11R6/ directories.
>>> This paragraph should be removed, I think (it was already wrong for etch).
>>> Nowadays, packages must not install files in to /usr/X11R6, and if they
>>> install files in /usr/{include,lib}/X11 they must pre-depend on
>>> x11-common (>= 1:7.0.0).
>> I think the pre-depends is also unnecessary for lenny since this version of
>> x11-common was in etch and skipping releases is not supported, so we should
>> not need to encourage maintainers to add this field anywhere that it isn't
>> already present.
>>
> This paragraph is still present at
> http://release.debian.org/squeeze/rc_policy.txt
> Can somebody please remove it?

Removed.

Cheers

Luk




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 14 Sep 2009 07:29:50 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 11:54:45 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.