Debian Bug report logs - #490816
linux-image-2.6-686: tulip has no detection under VirtualPC and Hyper-V

Package: linux-2.6; Maintainer for linux-2.6 is Debian Kernel Team <debian-kernel@lists.debian.org>;

Reported by: Franklin Piat <fpiat@bigfoot.com>

Date: Mon, 14 Jul 2008 13:24:01 UTC

Severity: normal

Tags: moreinfo

Done: Jonathan Nieder <jrnieder@gmail.com>

Bug is archived. No further changes may be made.

Forwarded to http://bugzilla.kernel.org/show_bug.cgi?id=11092

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#490816; Package network-manager. Full text and rfc822 format available.

Acknowledgement sent to Franklin Piat <fpiat@bigfoot.com>:
New Bug report received and forwarded. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Franklin Piat <fpiat@bigfoot.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: network-manager: Disconnects wired interface when started, under VirtualPC and Hyper-V
Date: Mon, 14 Jul 2008 11:22:13 -0400
Package: network-manager
Version: 0.6.6-1
Severity: normal


Please describe the problem:
 When I boot Debian under Microsoft VirtualPC 2007 or WindowsServer Hyper-V,
 the network is "disconnected".

 The network interface is has PCI id =1011:0009
 "Digital Equipment Corporation DECchip 21140 [FasterNet]" 
 The Linux kernel module to handle it is "tulip".

Steps to reproduce:
 1.  Boot Debian (stable or Testing) under VirtualPC 2007 or Hyper-V
 2a. Open a session in a console, type "ifconfig" : The interface
     isn't configured
 3a. Type "ifup eth0" : the interface get configured.
or
 2b. Open a session under gnome : the NM applet says the link is down.
     (click on the icon, the "Wired Networking" isn't ticked in !).
 3b. Click on the NM applet, tick-in "Wired Networking" : the interface
     get configured.

Actual results:
 We notice that the interface is down.

Expected results:
 The interface should be up and configured.

Does this happen every time?
 Yes.
 Under Debian stable (kernel 2.6.18 + NM 0.6.4) and Debian Testing
 (kernel 2.6.25 + NM 0.6.6)

I've opened a bug upstream :
 http://bugzilla.gnome.org/show_bug.cgi?id=542916

Franklin


-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.25-2-686 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages network-manager depends on:
ii  adduser                     3.108        add and remove users and groups
ii  dbus                        1.2.1-2      simple interprocess messaging syst
ii  dhcdbd                      3.0-4        D-Bus interface to the ISC DHCP cl
ii  hal                         0.5.11-2     Hardware Abstraction Layer
ii  ifupdown                    0.6.8+nmu1   high level tools to configure netw
ii  iproute                     20080417-1   networking and traffic control too
ii  iputils-arping              3:20071127-1 Tool to send ICMP echo requests to
ii  libc6                       2.7-10       GNU C Library: Shared libraries
ii  libdbus-1-3                 1.2.1-2      simple interprocess messaging syst
ii  libdbus-glib-1-2            0.76-1       simple interprocess messaging syst
ii  libgcrypt11                 1.4.1-1      LGPL Crypto library - runtime libr
ii  libglib2.0-0                2.16.3-2     The GLib library of C routines
ii  libgpg-error0               1.4-2        library for common error values an
ii  libhal1                     0.5.11-2     Hardware Abstraction Layer - share
ii  libiw29                     29-1         Wireless tools - library
ii  libnl1                      1.1-2        library for dealing with netlink s
ii  libnm-util0                 0.6.6-1      network management framework (shar
ii  lsb-base                    3.2-12       Linux Standard Base 3.2 init scrip
ii  wpasupplicant               0.6.3-2      Client support for WPA and WPA2 (I

Versions of packages network-manager recommends:
ii  network-manager-gnome         0.6.6-2    network management framework (GNOM

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#490816; Package network-manager. Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #10 received at 490816@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Franklin Piat <fpiat@bigfoot.com>, 490816@bugs.debian.org
Subject: Re: [Pkg-utopia-maintainers] Bug#490816: network-manager: Disconnects wired interface when started, under VirtualPC and Hyper-V
Date: Mon, 14 Jul 2008 15:34:23 +0200
[Message part 1 (text/plain, inline)]
Franklin Piat schrieb:
> Package: network-manager
> Version: 0.6.6-1
> Severity: normal
> 
> 
> Please describe the problem:
>  When I boot Debian under Microsoft VirtualPC 2007 or WindowsServer Hyper-V,
>  the network is "disconnected".
> 
>  The network interface is has PCI id =1011:0009
>  "Digital Equipment Corporation DECchip 21140 [FasterNet]" 
>  The Linux kernel module to handle it is "tulip".
> 
> Steps to reproduce:
>  1.  Boot Debian (stable or Testing) under VirtualPC 2007 or Hyper-V
>  2a. Open a session in a console, type "ifconfig" : The interface
>      isn't configured
>  3a. Type "ifup eth0" : the interface get configured.
> or
>  2b. Open a session under gnome : the NM applet says the link is down.
>      (click on the icon, the "Wired Networking" isn't ticked in !).
>  3b. Click on the NM applet, tick-in "Wired Networking" : the interface
>      get configured.
> 
> Actual results:
>  We notice that the interface is down.
> 
> Expected results:
>  The interface should be up and configured.
> 
> Does this happen every time?
>  Yes.
>  Under Debian stable (kernel 2.6.18 + NM 0.6.4) and Debian Testing
>  (kernel 2.6.25 + NM 0.6.6)
> 
> I've opened a bug upstream :
>  http://bugzilla.gnome.org/show_bug.cgi?id=542916
> 

Looking through the upstream bug report, it seems as if the tulip driver
/ or the emulated hardware doesn't support link beat detection.
That's why NM doesn't activate the connection.

This is not a but in NM itself but rather a driver problem.

If you prefer, I can reassign the bug report to the kernel, otherwise
I'm simply going to close this bug report.

Cheers,
Michael



-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#490816; Package network-manager. Full text and rfc822 format available.

Acknowledgement sent to Franklin PIAT <fpiat@bigfoot.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #15 received at 490816@bugs.debian.org (full text, mbox):

From: Franklin PIAT <fpiat@bigfoot.com>
To: 490816@bugs.debian.org
Subject: Re: [Pkg-utopia-maintainers] Bug#490816: network-manager: Disconnects wired interface when started, under VirtualPC and Hyper-V
Date: Mon, 14 Jul 2008 23:50:52 +0200
On Mon, 2008-07-14 at 15:34 +0200, Michael Biebl wrote:
> It seems as if the tulip driver or the emulated hardware doesn't
> support link beat detection. That's why NM doesn't activate the
> connection.
> 
> This is not a bug in NM itself but rather a driver problem.


I don't understand what's the exact problem. Is it :

A.The driver sends inaccurate information about the link detection
  capability and/or the current link state. In which case the driver
  should be fixed (i.e forward this bug the kernel).

or

B.The driver sends information that accurately describe the 
  link detection capability and link state. But NM don't 
  handle it properly (for example if NM don't handle the case 
  where the card can't do link detection).

I digged a little bit with "nm-tool" and in /sys/class/net/eth0/ but I
couldn't find the documentation on how to interpret the results...



### BEFORE clicking on "Wired connection" ###
$nm-tools state

NetworkManager Tool

State: disconnected

- Device: eth0
----------------------------------------------------------------
  NM Path:           /org/freedesktop/NetworkManager/Devices/eth0
  Type:              Wired
  Driver:            tulip
  Active:            no
  HW Address:        40:00:50:00:40:50

  Capabilities:
    Supported:       yes

  Wired Settings
    Hardware Link:   yes


### AFTER clicking on "Wired connection" ###
$nm-tools state
NetworkManager Tool

State: connected

- Device: eth0
----------------------------------------------------------------
  NM Path:           /org/freedesktop/NetworkManager/Devices/eth0
  Type:              Wired
  Driver:            tulip
  Active:            yes
  HW Address:        40:00:50:00:40:50

  Capabilities:
    Supported:       yes

  Wired Settings
    Hardware Link:   yes

  IP Settings:
    IP Address:      192.168.0.144
    Subnet Mask:     255.255.255.0
    Broadcast:       192.168.0.255
    Gateway:         192.168.0.1
    Primary DNS:     192.168.0.33
    Secondary DNS:   0.0.0.0



> If you prefer, I can reassign the bug report to the kernel, otherwise
> I'm simply going to close this bug report.

If it is really a driver bug, yes please reassign.





Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#490816; Package network-manager. Full text and rfc822 format available.

Acknowledgement sent to Michael Biebl <biebl@debian.org>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #20 received at 490816@bugs.debian.org (full text, mbox):

From: Michael Biebl <biebl@debian.org>
To: Franklin PIAT <fpiat@bigfoot.com>, 490816@bugs.debian.org
Subject: Re: [Pkg-utopia-maintainers] Bug#490816: Bug#490816: network-manager: Disconnects wired interface when started, under VirtualPC and Hyper-V
Date: Tue, 15 Jul 2008 00:15:43 +0200
[Message part 1 (text/plain, inline)]
Franklin PIAT wrote:
> On Mon, 2008-07-14 at 15:34 +0200, Michael Biebl wrote:
>> It seems as if the tulip driver or the emulated hardware doesn't
>> support link beat detection. That's why NM doesn't activate the
>> connection.
>>
>> This is not a bug in NM itself but rather a driver problem.
> 
> 
> I don't understand what's the exact problem. Is it :
> 
> A.The driver sends inaccurate information about the link detection
>   capability and/or the current link state. In which case the driver
>   should be fixed (i.e forward this bug the kernel).
> 
> or
> 
> B.The driver sends information that accurately describe the 
>   link detection capability and link state. But NM don't 
>   handle it properly (for example if NM don't handle the case 
>   where the card can't do link detection).

I was referring to this log snippet:

NetworkManager: <info>  eth0: Driver 'tulip' does not support carrier
detection.        You must switch to it manually.

So it's A) afaict.

It this is a driver bug or hardware limitation, I don't know.

Cheers,
Michael


-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>:
Bug#490816; Package network-manager. Full text and rfc822 format available.

Acknowledgement sent to Franklin PIAT <fpiat@bigfoot.com>:
Extra info received and forwarded to list. Copy sent to Utopia Maintenance Team <pkg-utopia-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #25 received at 490816@bugs.debian.org (full text, mbox):

From: Franklin PIAT <fpiat@bigfoot.com>
To: 490816@bugs.debian.org
Subject: Bug#490816: tulip has no link detection, under VirtualPC and Hyper-V)
Date: Tue, 15 Jul 2008 21:13:09 +0200
notforwarded 490816 
retitle 490816 linux-image-2.6-686: tulip has no detection under VirtualPC and Hyper-V
reassign 490816 linux-image-2.6-686
thanks

This bug was closed upstream by the maintainer :
http://bugzilla.gnome.org/show_bug.cgi?id=542916

I'm reassigning the bug to the kernel, and I open a bug upstream.

Thanks,

Franklin





Changed Bug title to `linux-image-2.6-686: tulip has no detection under VirtualPC and Hyper-V' from `network-manager: Disconnects wired interface when started, under VirtualPC and Hyper-V'. Request was from Franklin PIAT <fpiat@bigfoot.com> to control@bugs.debian.org. (Tue, 15 Jul 2008 19:21:49 GMT) Full text and rfc822 format available.

Bug reassigned from package `network-manager' to `linux-image-2.6-686'. Request was from Franklin PIAT <fpiat@bigfoot.com> to control@bugs.debian.org. (Tue, 15 Jul 2008 19:21:55 GMT) Full text and rfc822 format available.

Noted your statement that Bug has been forwarded to http://bugzilla.kernel.org/show_bug.cgi?id=11092. Request was from Franklin PIAT <fpiat@bigfoot.com> to control@bugs.debian.org. (Tue, 15 Jul 2008 21:18:01 GMT) Full text and rfc822 format available.

Bug reassigned from package `linux-image-2.6-686' to `linux-2.6'. Request was from Bastian Blank <waldi@debian.org> to control@bugs.debian.org. (Sat, 13 Sep 2008 23:06:04 GMT) Full text and rfc822 format available.

Added tag(s) fixed-upstream. Request was from bts-link-upstream@lists.alioth.debian.org to control@bugs.debian.org. (Thu, 24 May 2012 21:20:52 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Kernel Team <debian-kernel@lists.debian.org>:
Bug#490816; Package linux-2.6. (Thu, 24 May 2012 21:27:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Nieder <jrnieder@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Kernel Team <debian-kernel@lists.debian.org>. (Thu, 24 May 2012 21:27:03 GMT) Full text and rfc822 format available.

Message #40 received at 490816@bugs.debian.org (full text, mbox):

From: Jonathan Nieder <jrnieder@gmail.com>
To: Frank Lin PIAT <fpiat@klabs.be>
Cc: 490816@bugs.debian.org
Subject: Re: tulip has no link detection, under VirtualPC and Hyper-V
Date: Thu, 24 May 2012 16:18:45 -0500
Hi Franklin,

In 2008, Franklin PIAT wrote:

> When I boot Debian under Microsoft VirtualPC 2007 or WindowsServer Hyper-V,
> the network is "disconnected".

Michael Biebl wrote:

> Looking through the upstream bug report, it seems as if the tulip driver
> / or the emulated hardware doesn't support link beat detection.
> That's why NM doesn't activate the connection.
>
> This is not a but in NM itself but rather a driver problem.
[...]
> NetworkManager: <info>  eth0: Driver 'tulip' does not support carrier
> detection.        You must switch to it manually.

Any news?  I see from the upstream bug that Grant Grundler asked some
questions in 2008 but the bugtracker doesn't seem to have any
followups.  Did you make any progress with the help of Grant?  Do you
still have access to this hardware, and if so, can you still reproduce
the bug?

Sorry for the trouble,
Jonathan




Removed tag(s) fixed-upstream. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Thu, 24 May 2012 21:30:10 GMT) Full text and rfc822 format available.

Added tag(s) moreinfo. Request was from Jonathan Nieder <jrnieder@gmail.com> to control@bugs.debian.org. (Thu, 24 May 2012 21:30:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Kernel Team <debian-kernel@lists.debian.org>:
Bug#490816; Package linux-2.6. (Thu, 24 May 2012 21:33:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Jonathan Nieder <jrnieder@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Kernel Team <debian-kernel@lists.debian.org>. (Thu, 24 May 2012 21:33:04 GMT) Full text and rfc822 format available.

Message #49 received at 490816@bugs.debian.org (full text, mbox):

From: Jonathan Nieder <jrnieder@gmail.com>
To: Frank Lin PIAT <fpiat@klabs.be>
Cc: 490816@bugs.debian.org
Subject: Re: tulip has no link detection, under VirtualPC and Hyper-V
Date: Thu, 24 May 2012 16:31:17 -0500
Jonathan Nieder wrote:
> In 2008, Franklin PIAT wrote:

>> When I boot Debian under Microsoft VirtualPC 2007 or WindowsServer Hyper-V,
>> the network is "disconnected".
[...]
> Any news?  I see from the upstream bug that Grant Grundler asked some
> questions in 2008 but the bugtracker doesn't seem to have any
> followups.  Did you make any progress with the help of Grant?  Do you
> still have access to this hardware, and if so, can you still reproduce
> the bug?

By "hardware" I mean setup/virtual hardware, of course. ;-)




Reply sent to Jonathan Nieder <jrnieder@gmail.com>:
You have taken responsibility. (Sun, 30 Sep 2012 19:45:03 GMT) Full text and rfc822 format available.

Notification sent to Franklin Piat <fpiat@bigfoot.com>:
Bug acknowledged by developer. (Sun, 30 Sep 2012 19:45:04 GMT) Full text and rfc822 format available.

Message #54 received at 490816-done@bugs.debian.org (full text, mbox):

From: Jonathan Nieder <jrnieder@gmail.com>
To: Frank Lin PIAT <fpiat@klabs.be>
Cc: 490816-done@bugs.debian.org
Subject: Re: tulip has no link detection, under VirtualPC and Hyper-V
Date: Sun, 30 Sep 2012 12:39:58 -0700
In May, Jonathan Nieder wrote:
> In 2008, Franklin PIAT wrote:

>> When I boot Debian under Microsoft VirtualPC 2007 or WindowsServer Hyper-V,
>> the network is "disconnected".
[...]
>             Did you make any progress with the help of Grant?  Do you
> still have access to this [setup], and if so, can you still reproduce
> the bug?

Closing due to lack of response.  If you have more information, please
don't hesitate to write, though, and we can pick up where we left off.



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 29 Oct 2012 07:26:23 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 06:35:00 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.