Debian Bug report logs - #483920
aptitude: suggest downgrade when keeping current version would do

version graph

Package: aptitude; Maintainer for aptitude is Aptitude Development Team <aptitude-devel@lists.alioth.debian.org>; Source for aptitude is src:aptitude.

Reported by: Raphael Hertzog <hertzog@debian.org>

Date: Sun, 1 Jun 2008 09:30:09 UTC

Severity: normal

Found in version aptitude/0.4.11.3-1

Fixed in version aptitude/0.4.11.4-1

Done: Daniel Burrows <dburrows@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#483920; Package aptitude. Full text and rfc822 format available.

Acknowledgement sent to Raphael Hertzog <hertzog@debian.org>:
New Bug report received and forwarded. Copy sent to Daniel Burrows <dburrows@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Raphael Hertzog <hertzog@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: aptitude: suggest downgrade when keeping current version would do
Date: Sun, 01 Jun 2008 11:26:56 +0200
Package: aptitude
Version: 0.4.11.3-1
Severity: normal

Every time there's an upload of some hplip related packages they are
broken for a few days in sid until the buildd catch up and every time
aptitude wants to downgrade hpijs-ppds:
| $ LANG=C sudo aptitude dist-upgrade
| [sudo] password for rhertzog: 
| Reading package lists... Done
| Building dependency tree       
| Reading state information... Done
| Reading extended state information       
| Initializing package states... Done
| Reading task descriptions... Done  
| The following packages are BROKEN:
|   gnome-system-tools hpijs-ppds hplip 
| The following NEW packages will be installed:
|   libauthen-dechpwd-perl{a} libauthen-passphrase-perl{a} libcrypt-blowfish-perl{a} 
|   libcrypt-des-perl{a} libcrypt-eksblowfish-perl{a} libcrypt-mysql-perl{a} 
|   libcrypt-passwdmd5-perl{a} libcrypt-rijndael-perl{a} libcrypt-unixcrypt-xs-perl{a} 
|   libdata-entropy-perl{a} libdata-float-perl{a} libdata-integer-perl{a} libdigest-md4-perl{a} 
|   libdigest-perl{a} libmodule-runtime-perl{a} libparams-classify-perl{a} libscalar-number-perl{a} 
| The following packages will be REMOVED:
|   liboobs-1-3{a} 
| The following packages will be upgraded:
|   apt-file debian-maintainers g-wrap grub-common grub-pc guile-g-wrap hplip-data hplip-gui ikiwiki 
|   libgwrap-runtime-dev libgwrap-runtime2 libsmbclient po-debconf python-sqlobject samba-common 
|   smbclient smbfs system-tools-backends tzdata 
| The following packages are RECOMMENDED but will NOT be installed:
|   libnet-openid-consumer-perl 
| 20 packages upgraded, 17 newly installed, 1 to remove and 0 not upgraded.
| Need to get 22.2MB of archives. After unpacking 1717kB will be used.
| The following packages have unmet dependencies:
|   hplip: Depends: hplip-data (< 2.8.4.1) but 2.8.5-1 is to be installed.
|   gnome-system-tools: Depends: liboobs-1-3 (>= 2.19.91) but it is not installable
|   hpijs-ppds: Depends: hpijs (>= 2.8.5+2.8.5-1) but 2.8.4+2.8.4-1 is installed.
| The following actions will resolve these dependencies:
| 
| Keep the following packages at their current version:
| hplip-data [2.8.4-1 (testing, now)]
| liboobs-1-3 [2.20.0-1 (unstable, testing, now)]
| system-tools-backends [2.4.2-1 (testing, now)]
| 
| Downgrade the following packages:
| hpijs-ppds [2.8.4+2.8.4-1 (testing, now) -> 2.6.10+1.6.10-4.2+lenny1 (testing)]
| 
| Score is 2171
| 
| Accept this solution? [Y/n/q/?] 

Responding "n" to see alternative scenario leads to more downgrades... while
typing ": hpijs-ppds" works perfectly well:

| Accept this solution? [Y/n/q/?] : hpijs-ppds
| The following packages have unmet dependencies:
|   hplip: Depends: hplip-data (< 2.8.4.1) but 2.8.5-1 is to be installed.
|   gnome-system-tools: Depends: liboobs-1-3 (>= 2.19.91) but it is not installable
| The following actions will resolve these dependencies:
| 
| Keep the following packages at their current version:
| hplip-data [2.8.4-1 (testing, now)]
| liboobs-1-3 [2.20.0-1 (unstable, testing, now)]
| system-tools-backends [2.4.2-1 (testing, now)]
| 
| Score is 141
| 
| Accept this solution? [Y/n/q/?] 


Aptitude should really only suggest downgrade as a last solution and ideally
only when the current system is already broken. 

To duplicate the problem I've put my dpkg status file and the /var/lib/apt
lists (and sources.list) in http://people.debian.org/~hertzog/aptitude-downgrade.tar.bz2

Cheers,

PS: BTW looking at the info below, you might want to add a LC_ALL=C in the
script that gathers those infos ;-)

-- Package-specific info:
aptitude 0.4.11.3 compilé le May 27 2008 04:52:17
Compilateur : g++ 4.2.4 (Debian 4.2.4-1)
Compilé avec :
  version d'APT : 4 6 0
  version de NCurses : 5.6
  version de libsigc++ : 2.0.18
  gestion d'Ept activée.

versions des bibliothèques :
  version de NCurses : ncurses 5.6.20080503
  version de cwidget : 0.5.11
  version d'APT : 4.6.0
	linux-gate.so.1 =>  (0xffffe000)
	libapt-pkg-libc6.7-6.so.4.6 => /usr/lib/libapt-pkg-libc6.7-6.so.4.6 (0xb7e67000)
	libncursesw.so.5 => /lib/libncursesw.so.5 (0xb7e2b000)
	libsigc-2.0.so.0 => /usr/lib/libsigc-2.0.so.0 (0xb7e24000)
	libcwidget.so.3 => /usr/lib/libcwidget.so.3 (0xb7d34000)
	libept.so.0 => /usr/lib/libept.so.0 (0xb7cbc000)
	libxapian.so.15 => /usr/lib/libxapian.so.15 (0xb7b49000)
	libz.so.1 => /usr/lib/libz.so.1 (0xb7b34000)
	libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb7b1c000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7a2e000)
	libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7a09000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb79fc000)
	libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb78ae000)
	libutil.so.1 => /lib/i686/cmov/libutil.so.1 (0xb78aa000)
	libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xb78a5000)
	/lib/ld-linux.so.2 (0xb7f4c000)
Terminal: xterm
$DISPLAY is set.
`which aptitude`: /usr/bin/aptitude
aptitude version information:

aptitude linkage:

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.24-1-686 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages aptitude depends on:
ii  apt [libapt-pkg-libc6. 0.7.14            Advanced front-end for dpkg
ii  libc6                  2.7-11            GNU C Library: Shared libraries
ii  libcwidget3            0.5.11-1          high-level terminal interface libr
ii  libept0                0.5.17            High-level library for managing De
ii  libgcc1                1:4.3.0-5         GCC support library
ii  libncursesw5           5.6+20080503-1    Shared libraries for terminal hand
ii  libsigc++-2.0-0c2a     2.0.18-2          type-safe Signal Framework for C++
ii  libstdc++6             4.3.0-5           The GNU Standard C++ Library v3
ii  libxapian15            1.0.5-1           Search engine library
ii  zlib1g                 1:1.2.3.3.dfsg-12 compression library - runtime

Versions of packages aptitude recommends:
ii  aptitude-doc-en [aptitude-doc 0.4.11.3-1 English manual for aptitude, a ter
ii  aptitude-doc-fr [aptitude-doc 0.4.11.3-1 French manual for aptitude, a term
ii  libparse-debianchangelog-perl 1.1.1-2    parse Debian changelogs and output

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#483920; Package aptitude. Full text and rfc822 format available.

Acknowledgement sent to Daniel Burrows <dburrows@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #10 received at 483920@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: Raphael Hertzog <hertzog@debian.org>, 483920@bugs.debian.org
Subject: Re: Bug#483920: aptitude: suggest downgrade when keeping current version would do
Date: Mon, 2 Jun 2008 21:43:47 -0700
[Message part 1 (text/plain, inline)]
  It looks like the problem is a bug in the new code to fix
conflicts/provides/replaces.  This tries to force the resolver to
resolve conflicts between a package and its replacement in favor of the
replacement by giving a rather large bonus to the score of solutions
that do so.  You can verify that this is the cause of the problem by
passing "-o Aptitude::ProblemResolver::FullReplacementScore=0" and
"-o Aptitude::ProblemResolver::UndoFullReplacement=0" to the program at
the command-line: it will avoid the downgrades and produce the solution
that keeps the packages at the current version first instead.

  What's happening is that apparently I forgot to screen out self-conflicts
from this test.  So the resolver thinks that, since hpijs-ppds
conflicts, provides, and replaces the virtual package "hplip-ppds", some
arbitrary versions of hpijs-ppds are treated as "full replacements"
of the current version in the sense of Policy 7.5.2, and hence get the
bonus.  Obviously this is not correct.

  The attached patch should fix this problem for good and has been
committed to aptitude head.  I may want to take a look at the rest of
this scoring code tomorrow, there are some things that look a little
suspicious and should either be fixed or get comments explaining why
they're the right thing to do.


  Although I haven't had any other complaints about this, I think it's
probably serious enough to warrant another bugfix upload if I can
squeeze the current one into lenny, since it will cause the resolver to
randomly do inexplicably stupid things.

  Daniel
[aptitude-no-self-replacement.patch (text/x-diff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#483920; Package aptitude. Full text and rfc822 format available.

Acknowledgement sent to Raphael Hertzog <hertzog@debian.org>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. Full text and rfc822 format available.

Message #15 received at 483920@bugs.debian.org (full text, mbox):

From: Raphael Hertzog <hertzog@debian.org>
To: Daniel Burrows <dburrows@debian.org>
Cc: 483920@bugs.debian.org
Subject: Re: Bug#483920: aptitude: suggest downgrade when keeping current version would do
Date: Tue, 3 Jun 2008 08:27:01 +0200
On Mon, 02 Jun 2008, Daniel Burrows wrote:
>   It looks like the problem is a bug in the new code to fix
> conflicts/provides/replaces.  This tries to force the resolver to
> resolve conflicts between a package and its replacement in favor of the
> replacement by giving a rather large bonus to the score of solutions
> that do so.  You can verify that this is the cause of the problem by
> passing "-o Aptitude::ProblemResolver::FullReplacementScore=0" and
> "-o Aptitude::ProblemResolver::UndoFullReplacement=0" to the program at
> the command-line: it will avoid the downgrades and produce the solution
> that keeps the packages at the current version first instead.

Thanks for the quick response and analysis! I can't check it any more as
the temporary problem of twe two packages being not in sync disappeared on my
machine.

>   Although I haven't had any other complaints about this, I think it's
> probably serious enough to warrant another bugfix upload if I can
> squeeze the current one into lenny, since it will cause the resolver to
> randomly do inexplicably stupid things.

I agree that we should push this fix to lenny.

Cheers,
-- 
Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :
http://www.ouaza.com/livre/admin-debian/




Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#483920; Package aptitude. Full text and rfc822 format available.

Acknowledgement sent to Raphael Hertzog <hertzog@debian.org>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. Full text and rfc822 format available.

Message #20 received at 483920@bugs.debian.org (full text, mbox):

From: Raphael Hertzog <hertzog@debian.org>
To: Daniel Burrows <dburrows@debian.org>
Cc: 483920@bugs.debian.org
Subject: Re: Bug#483920: aptitude: suggest downgrade when keeping current version would do
Date: Wed, 4 Jun 2008 08:11:16 +0200
On Mon, 02 Jun 2008, Daniel Burrows wrote:
>   It looks like the problem is a bug in the new code to fix
> conflicts/provides/replaces.  This tries to force the resolver to
> resolve conflicts between a package and its replacement in favor of the
> replacement by giving a rather large bonus to the score of solutions
> that do so.  You can verify that this is the cause of the problem by
> passing "-o Aptitude::ProblemResolver::FullReplacementScore=0" and
> "-o Aptitude::ProblemResolver::UndoFullReplacement=0" to the program at
> the command-line: it will avoid the downgrades and produce the solution
> that keeps the packages at the current version first instead.

Confirmed today with a similar problem with gnupg. Passing those two
options made it select the right solution.

Cheers,
-- 
Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :
http://www.ouaza.com/livre/admin-debian/




Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#483920; Package aptitude. Full text and rfc822 format available.

Acknowledgement sent to Daniel Burrows <dburrows@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #25 received at 483920@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: Raphael Hertzog <hertzog@debian.org>, 483920@bugs.debian.org
Subject: Re: Bug#483920: aptitude: suggest downgrade when keeping current version would do
Date: Wed, 4 Jun 2008 06:36:01 -0700
On Wed, Jun 04, 2008 at 08:11:16AM +0200, Raphael Hertzog <hertzog@debian.org> was heard to say:
> On Mon, 02 Jun 2008, Daniel Burrows wrote:
> >   It looks like the problem is a bug in the new code to fix
> > conflicts/provides/replaces.  This tries to force the resolver to
> > resolve conflicts between a package and its replacement in favor of the
> > replacement by giving a rather large bonus to the score of solutions
> > that do so.  You can verify that this is the cause of the problem by
> > passing "-o Aptitude::ProblemResolver::FullReplacementScore=0" and
> > "-o Aptitude::ProblemResolver::UndoFullReplacement=0" to the program at
> > the command-line: it will avoid the downgrades and produce the solution
> > that keeps the packages at the current version first instead.
> 
> Confirmed today with a similar problem with gnupg. Passing those two
> options made it select the right solution.

  Does the patch I sent fix the problem as well?  (passing those two
options just disables the new code; my patch actually fixes it)

  Daniel




Information forwarded to debian-bugs-dist@lists.debian.org, Daniel Burrows <dburrows@debian.org>:
Bug#483920; Package aptitude. Full text and rfc822 format available.

Acknowledgement sent to Raphael Hertzog <hertzog@debian.org>:
Extra info received and forwarded to list. Copy sent to Daniel Burrows <dburrows@debian.org>. Full text and rfc822 format available.

Message #30 received at 483920@bugs.debian.org (full text, mbox):

From: Raphael Hertzog <hertzog@debian.org>
To: Daniel Burrows <dburrows@debian.org>
Cc: 483920@bugs.debian.org
Subject: Re: Bug#483920: aptitude: suggest downgrade when keeping current version would do
Date: Wed, 4 Jun 2008 16:04:47 +0200
On Wed, 04 Jun 2008, Daniel Burrows wrote:
> On Wed, Jun 04, 2008 at 08:11:16AM +0200, Raphael Hertzog <hertzog@debian.org> was heard to say:
> > Confirmed today with a similar problem with gnupg. Passing those two
> > options made it select the right solution.
> 
>   Does the patch I sent fix the problem as well?  (passing those two
> options just disables the new code; my patch actually fixes it)

I did not recompile aptitude to check. Sorry. (And the gnupg inconsistency
is gone with the last mirror pulse).

Cheers,
-- 
Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :
http://www.ouaza.com/livre/admin-debian/




Reply sent to Daniel Burrows <dburrows@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Raphael Hertzog <hertzog@debian.org>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #35 received at 483920-close@bugs.debian.org (full text, mbox):

From: Daniel Burrows <dburrows@debian.org>
To: 483920-close@bugs.debian.org
Subject: Bug#483920: fixed in aptitude 0.4.11.4-1
Date: Sun, 08 Jun 2008 01:32:04 +0000
Source: aptitude
Source-Version: 0.4.11.4-1

We believe that the bug you reported is fixed in the latest version of
aptitude, which is due to be installed in the Debian FTP archive:

aptitude-dbg_0.4.11.4-1_i386.deb
  to pool/main/a/aptitude/aptitude-dbg_0.4.11.4-1_i386.deb
aptitude-doc-cs_0.4.11.4-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-cs_0.4.11.4-1_all.deb
aptitude-doc-en_0.4.11.4-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-en_0.4.11.4-1_all.deb
aptitude-doc-fi_0.4.11.4-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-fi_0.4.11.4-1_all.deb
aptitude-doc-fr_0.4.11.4-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-fr_0.4.11.4-1_all.deb
aptitude-doc-ja_0.4.11.4-1_all.deb
  to pool/main/a/aptitude/aptitude-doc-ja_0.4.11.4-1_all.deb
aptitude_0.4.11.4-1.diff.gz
  to pool/main/a/aptitude/aptitude_0.4.11.4-1.diff.gz
aptitude_0.4.11.4-1.dsc
  to pool/main/a/aptitude/aptitude_0.4.11.4-1.dsc
aptitude_0.4.11.4-1_i386.deb
  to pool/main/a/aptitude/aptitude_0.4.11.4-1_i386.deb
aptitude_0.4.11.4.orig.tar.gz
  to pool/main/a/aptitude/aptitude_0.4.11.4.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 483920@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Burrows <dburrows@debian.org> (supplier of updated aptitude package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sat, 07 Jun 2008 17:05:21 -0700
Source: aptitude
Binary: aptitude aptitude-dbg aptitude-doc-cs aptitude-doc-en aptitude-doc-fi aptitude-doc-fr aptitude-doc-ja
Architecture: source all i386
Version: 0.4.11.4-1
Distribution: unstable
Urgency: low
Maintainer: Daniel Burrows <dburrows@debian.org>
Changed-By: Daniel Burrows <dburrows@debian.org>
Description: 
 aptitude   - terminal-based package manager
 aptitude-dbg - Debug symbols for the aptitude package manager
 aptitude-doc-cs - Czech manual for aptitude, a terminal-based package manager
 aptitude-doc-en - English manual for aptitude, a terminal-based package manager
 aptitude-doc-fi - Finnish manual for aptitude, a terminal-based package manager
 aptitude-doc-fr - French manual for aptitude, a terminal-based package manager
 aptitude-doc-ja - Japanese manual for aptitude, a terminal-based package manager
Closes: 136874 473580 473829 483620 483920 483943
Changes: 
 aptitude (0.4.11.4-1) unstable; urgency=low
 .
   * New upstream release.
 .
     - Fixed a nasty resolver bug that would cause solutions to be chosen
       poorly in some cases involving self-conflicts. (Closes: #483920)
 .
     - "aptitude search" now takes a command-line argument
       "--disable-columns" that prevents aptitude from padding or
       truncating strings to line text up into columns.  This makes
       the output much more script-friendly.  (Closes: #136874)
 .
     - Fixed the formatting of literal elements in the manpage.
       (Closes: #473580)
 .
     - Defaults files for locales that contain an underscore (such as pt_BR
       or zh_CN) should get installed now. (Closes: #483620)
 .
     - Translation update for Russian. (Closes: #483943)
 .
   * aptitude-dbg recommends libcwidget3-dbg now, not libcwidget1-dbg.
     (Closes: #473829)
 .
   * Bring the Standards-Version up-to-date.  No other changes were needed;
     the only change to Policy lately that affects aptitude was the
     restructuring of the menu hierarchy, and aptitude is already
     up-to-date with that.
 .
   * Bring README.Debian up-to-date regarding the location of the upstream
     and Debian repositories.
Checksums-Sha1: 
 4ef9235ac164d7a7b0085128182359d3ad02b294 1382 aptitude_0.4.11.4-1.dsc
 4b1a407f1541882f8590787c425c3d7d7762ff7f 5713470 aptitude_0.4.11.4.orig.tar.gz
 91ba9e7d6537bc62bcaac9a097aff86b7c064fea 34871 aptitude_0.4.11.4-1.diff.gz
 0ccf6e47038433a9917e41169a343297d3bde4b7 345082 aptitude-doc-cs_0.4.11.4-1_all.deb
 b84976f5c03272cc0ec098efb8807a22626f5a7e 353208 aptitude-doc-en_0.4.11.4-1_all.deb
 bc8ebc7e890ba9a1ebea58c685f4344724ded5f4 263570 aptitude-doc-fi_0.4.11.4-1_all.deb
 20156c7604775bac3bfbd490cebeac517d32d8f7 297996 aptitude-doc-fr_0.4.11.4-1_all.deb
 af3b6c89446a7d82f78bc4634b04c4d9f27b4f1f 363622 aptitude-doc-ja_0.4.11.4-1_all.deb
 0e1ce88d03d224f76d0af5748661a92e7c19e265 2771074 aptitude_0.4.11.4-1_i386.deb
 6032927d0102adf46970e3c01defc7974a183c77 5905982 aptitude-dbg_0.4.11.4-1_i386.deb
Checksums-Sha256: 
 a54ed4c3424263338976beec1f4fb4506e889cf7d8a0e6e0159a1a590c57cc5f 1382 aptitude_0.4.11.4-1.dsc
 2a2cd488c2397e6b1fb02e035854addfbe0fec2253726d7f294d1ab2c08d4aeb 5713470 aptitude_0.4.11.4.orig.tar.gz
 6fbbecec0750ff4f3a764f0e0855b3c6dcf451c9e608694a6fa0d1c576dbeee3 34871 aptitude_0.4.11.4-1.diff.gz
 d483942e6488eec2746cf0f8780ab19e9f2dc70ab5644e12176f1a6a6ce221da 345082 aptitude-doc-cs_0.4.11.4-1_all.deb
 2910704fa5bb510316ec268d0aefaf84868d57c85b339669574f0633a6ff5e7a 353208 aptitude-doc-en_0.4.11.4-1_all.deb
 1ba5f4736f9d2345c50a36c43f9afc42ed9db4736a1d7062d29d9f0cff246167 263570 aptitude-doc-fi_0.4.11.4-1_all.deb
 264969bb307bbd77d6be1e8776ee606a4e459247ecccbbafb7f7844ab9c161bc 297996 aptitude-doc-fr_0.4.11.4-1_all.deb
 654b963ad6f6ed67cd73bbd04bbabfb182544c72e568368823f0d3d7eed12902 363622 aptitude-doc-ja_0.4.11.4-1_all.deb
 15534535b87a555cd2f6219408c76d4cabf86071719f3503a89e66ac40263486 2771074 aptitude_0.4.11.4-1_i386.deb
 a475875c6b93b9a180e5ef7229cd8e2423f9d5266fec8309cb5f8711b002cd99 5905982 aptitude-dbg_0.4.11.4-1_i386.deb
Files: 
 3e5f49cf581b06b0d1153b77405ae9af 1382 admin - aptitude_0.4.11.4-1.dsc
 85ed892ac7f8fa8784e873a1f691c322 5713470 admin - aptitude_0.4.11.4.orig.tar.gz
 69b22d0a110e430fd60c24114078c248 34871 admin - aptitude_0.4.11.4-1.diff.gz
 db45dcae83cbba11434a0a00d59a8cfe 345082 doc optional aptitude-doc-cs_0.4.11.4-1_all.deb
 8ad7bc4cd80d0a45826dc1c038cebe92 353208 doc optional aptitude-doc-en_0.4.11.4-1_all.deb
 13cceb5a5d2b883378bcc63c44110b91 263570 doc optional aptitude-doc-fi_0.4.11.4-1_all.deb
 c60ad2a243e00d8151249071b7873b63 297996 doc optional aptitude-doc-fr_0.4.11.4-1_all.deb
 55ce7fc800c89d1c5dacba741e56bff9 363622 doc optional aptitude-doc-ja_0.4.11.4-1_all.deb
 a3c693b9129c2276804642453f190257 2771074 admin important aptitude_0.4.11.4-1_i386.deb
 1892777129b6dc5b9c2e319581e71fbf 5905982 devel extra aptitude-dbg_0.4.11.4-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFISzQZch6xsM7kSXgRAoPwAJ4vMeFXxYO/BRXuiJ9AbH4H/4Sv9QCg2K8I
iVxebK6KRHSkWXiGBvlW/pA=
=fJEy
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 17 Jul 2008 07:28:23 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 23 07:39:42 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.