Debian Bug report logs - #482140
docbook-xml: Package does not install: update-xmlcatalog: error: entity already registered

version graph

Package: docbook-xml; Maintainer for docbook-xml is Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>; Source for docbook-xml is src:docbook-xml.

Reported by: Sami Liedes <sliedes@cc.hut.fi>

Date: Tue, 20 May 2008 23:15:02 UTC

Severity: serious

Tags: help

Merged with 502781

Found in version docbook-xml/4.5-5

Fixed in version docbook-xml/4.5-6

Done: Daniel Leidert (dale) <daniel.leidert@wgdd.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Sami Liedes <sliedes@cc.hut.fi>:
New Bug report received and forwarded. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Sami Liedes <sliedes@cc.hut.fi>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: docbook-xml: Package does not install: update-xmlcatalog: error: entity already registered
Date: Wed, 21 May 2008 05:11:34 +0300
Package: docbook-xml
Version: 4.5-5
Severity: serious

When configuring docbook-xml after installation, I get the error

----------
update-xmlcatalog: error: entity already registered
dpkg: error processing docbook-xml (--configure):
 subprocess post-installation script returned error exit status 1
----------

This happened on a just installed box, upgrading from stable -> testing 
-> unstable.

	Sami


-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.18-6-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages docbook-xml depends on:
ii  sgml-base                     1.26       SGML infrastructure and SGML catal
ii  sgml-data                     2.0.3      common SGML and XML data
ii  xml-core                      0.11       XML infrastructure and XML catalog

docbook-xml recommends no packages.

-- no debconf information




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Christofer C. Bell" <christofer.c.bell@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #10 received at 482140@bugs.debian.org (full text, mbox):

From: "Christofer C. Bell" <christofer.c.bell@gmail.com>
To: 482140@bugs.debian.org
Subject: The error is when update-xmlcatalog is run "entity already registered"
Date: Sat, 24 May 2008 02:56:26 -0500
The error that update-xmlcatalog seems to give is the following:

update-xmlcatalog: error: entity already registered

This is upgrading from etch -> lenny with the following procedure:

1. Install basic Etch + Desktop + Standard System using netinst
2. Edit /etc/apt/sources.list to change references to etch to lenny,
commenting out netinst CD lines
3. aptitude update
4. aptitude dist-upgrade
5. accept the first (and only) dependancy conflict resolution
question's solution

-- 
Chris




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #15 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: "Christofer C. Bell" <christofer.c.bell@gmail.com>, 482140@bugs.debian.org
Cc: 482140-submitter@bugs.debian.org
Subject: Re: [xml/sgml-pkgs] Bug#482140: The error is when update-xmlcatalog is run "entity already registered"
Date: Sat, 24 May 2008 16:47:14 +0200
Am Samstag, den 24.05.2008, 02:56 -0500 schrieb Christofer C. Bell:
> The error that update-xmlcatalog seems to give is the following:
> 
> update-xmlcatalog: error: entity already registered
[snip]

Yes, two entities cannot be registered for different packages. In this
case, update-xmlcatalog will error out.

Can you send me your /etc/xml/catalog file from *Etch*?

Regards, Daniel





Message sent on to Sami Liedes <sliedes@cc.hut.fi>:
Bug#482140. Full text and rfc822 format available.

Information stored:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Sami Liedes <sliedes@cc.hut.fi>:
Extra info received and filed, but not forwarded. Full text and rfc822 format available.

Message #23 received at 482140-quiet@bugs.debian.org (full text, mbox):

From: Sami Liedes <sliedes@cc.hut.fi>
To: Daniel Leidert <daniel.leidert@wgdd.de>, 482140-quiet@bugs.debian.org
Subject: Re: Bug#482140: [xml/sgml-pkgs] Bug#482140: The error is when update-xmlcatalog is run "entity already registered"
Date: Sat, 24 May 2008 18:45:48 +0300
On Sat, May 24, 2008 at 04:47:14PM +0200, Daniel Leidert wrote:
> Am Samstag, den 24.05.2008, 02:56 -0500 schrieb Christofer C. Bell:
> > The error that update-xmlcatalog seems to give is the following:
> > 
> > update-xmlcatalog: error: entity already registered
> [snip]
> 
> Yes, two entities cannot be registered for different packages. In this
> case, update-xmlcatalog will error out.
> 
> Can you send me your /etc/xml/catalog file from *Etch*?

Sorry, I don't have it any more. I tried if removing the package and
reinstalling it helps (it did). It was a fairly standard etch
installation with the desktop components chosen by installer.

	Sami




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Christofer C. Bell" <christofer.c.bell@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #28 received at 482140@bugs.debian.org (full text, mbox):

From: "Christofer C. Bell" <christofer.c.bell@gmail.com>
To: "Daniel Leidert" <daniel.leidert@wgdd.de>
Cc: 482140@bugs.debian.org, 482140-submitter@bugs.debian.org
Subject: Re: [xml/sgml-pkgs] Bug#482140: The error is when update-xmlcatalog is run "entity already registered"
Date: Sat, 24 May 2008 18:26:45 -0500
[Message part 1 (text/plain, inline)]
On Sat, May 24, 2008 at 9:47 AM, Daniel Leidert <daniel.leidert@wgdd.de> wrote:
> Am Samstag, den 24.05.2008, 02:56 -0500 schrieb Christofer C. Bell:
>> The error that update-xmlcatalog seems to give is the following:
>>
>> update-xmlcatalog: error: entity already registered
> [snip]
>
> Yes, two entities cannot be registered for different packages. In this
> case, update-xmlcatalog will error out.
>
> Can you send me your /etc/xml/catalog file from *Etch*?

Yes, absolutely.  Please find the file attached.  This is
/etc/xml/catalog from an Etch system with zero software installed
outside of main (ie; /etc/apt/sources.list is unmodified and the only
additional software installed are things like mdadm, ntp, and the
like).

-- 
Chris
[catalog (application/octet-stream, attachment)]

Message sent on to Sami Liedes <sliedes@cc.hut.fi>:
Bug#482140. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #36 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: "Christofer C. Bell" <christofer.c.bell@gmail.com>
Cc: 482140@bugs.debian.org, 482140-submitter@bugs.debian.org
Subject: Re: [xml/sgml-pkgs] Bug#482140: The error is when update-xmlcatalog is run "entity already registered"
Date: Sun, 25 May 2008 12:47:02 +0200
Am Samstag, den 24.05.2008, 18:26 -0500 schrieb Christofer C. Bell:
> On Sat, May 24, 2008 at 9:47 AM, Daniel Leidert <daniel.leidert@wgdd.de> wrote:
> > Am Samstag, den 24.05.2008, 02:56 -0500 schrieb Christofer C. Bell:
> >> The error that update-xmlcatalog seems to give is the following:
> >>
> >> update-xmlcatalog: error: entity already registered
> > [snip]
> >
> > Yes, two entities cannot be registered for different packages. In this
> > case, update-xmlcatalog will error out.
> >
> > Can you send me your /etc/xml/catalog file from *Etch*?
> 
> Yes, absolutely.  Please find the file attached.

And with this file, you get the error? I checked it and I didn't found
something related. It is a vanilla Etch catalog file, registering the
catalog, docbook-xml and sgml-data entities. If you receive the reported
issue with this system, please package /etc/xml and send me the tarball.

> This is
> /etc/xml/catalog from an Etch system with zero software installed
> outside of main (ie; /etc/apt/sources.list is unmodified and the only
> additional software installed are things like mdadm, ntp, and the
> like).

Hm. I used a clean Etch installation with docbook-xml and deps installed
and upgraded it to Sid. No problems.

Regards, Daniel





Message sent on to Sami Liedes <sliedes@cc.hut.fi>:
Bug#482140. Full text and rfc822 format available.

Tags added: unreproducible, help Request was from Daniel Leidert (dale) <daniel.leidert@wgdd.de> to control@bugs.debian.org. (Sun, 25 May 2008 11:03:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Christofer C. Bell" <christofer.c.bell@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #46 received at 482140@bugs.debian.org (full text, mbox):

From: "Christofer C. Bell" <christofer.c.bell@gmail.com>
To: "Daniel Leidert" <daniel.leidert@wgdd.de>
Cc: 482140@bugs.debian.org, 482140-submitter@bugs.debian.org
Subject: Re: [xml/sgml-pkgs] Bug#482140: The error is when update-xmlcatalog is run "entity already registered"
Date: Tue, 27 May 2008 10:20:51 -0500
On Sun, May 25, 2008 at 5:47 AM, Daniel Leidert <daniel.leidert@wgdd.de> wrote:
>
> And with this file, you get the error? I checked it and I didn't found
> something related. It is a vanilla Etch catalog file, registering the
> catalog, docbook-xml and sgml-data entities. If you receive the reported
> issue with this system, please package /etc/xml and send me the tarball.
>
>> This is
>> /etc/xml/catalog from an Etch system with zero software installed
>> outside of main (ie; /etc/apt/sources.list is unmodified and the only
>> additional software installed are things like mdadm, ntp, and the
>> like).
>
> Hm. I used a clean Etch installation with docbook-xml and deps installed
> and upgraded it to Sid. No problems.

I should be clear, I'm upgrading from Etch to Lenny.  I'm attaching a
tarball of /etc/xml.  I will try another upgrade from Etch to Lenny
here soon and report my findings.  Since I'm upgrading a cloned VM of
Etch, I'm able to restart the process at any time.

-- 
Chris




Message sent on to Sami Liedes <sliedes@cc.hut.fi>:
Bug#482140. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Xavi Drudis Ferran" <xdrudis@tinet.cat>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #54 received at 482140@bugs.debian.org (full text, mbox):

From: "Xavi Drudis Ferran" <xdrudis@tinet.cat>
To: 482140@bugs.debian.org
Subject: Confirming bug
Date: Wed, 28 May 2008 14:49:41 +0200 (CEST)
Hi.

This exact problem happened to me last night.
I installed etch (amd64) on a new laptop, wasn't happy with the support
of the intel GM965 graphics board, and decided to upgrade to lenny
for the intel Xorg driver. I selected "printing server", "desktop environment",
and "standard system", in the etch installer.

Then it complained of this error.

I can't send the file now, because I'm not at that computer, I'll try to send it
asap, (in some 6 or 7 hours hopefully, else in a couple of days :( )

I'm just replying since I see the bug marked as unreproducible, and it just
hit me.

Thanks all for your great work.





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Xavi Drudis Ferran" <xdrudis@tinet.cat>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #59 received at 482140@bugs.debian.org (full text, mbox):

From: "Xavi Drudis Ferran" <xdrudis@tinet.cat>
To: 482140@bugs.debian.org
Subject: /etc/xml tarball
Date: Wed, 28 May 2008 21:11:21 +0200 (CEST)
[Message part 1 (text/plain, inline)]
Here's my /etc/xml diretory in a tarball.

My catalog file is the same as postedby Christofer C. Bell, just with the lines
in different order (I guess it doesn't matter)

I'll try to have a look before removing and reinstalling the package, just in case I see
ehat may be happening...

[xml.tgz (application/x-compressed-tar, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Xavi Drudis Ferran" <xdrudis@tinet.cat>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #64 received at 482140@bugs.debian.org (full text, mbox):

From: "Xavi Drudis Ferran" <xdrudis@tinet.cat>
To: 482140@bugs.debian.org
Subject: must be /etc/sgml
Date: Wed, 28 May 2008 22:34:11 +0200 (CEST)
[Message part 1 (text/plain, inline)]
Hi.

I'm sending my /var/lib/dpkg/info/docbook-xml.postinst

The line that's failing is the one after the initial for loop:

update-catalog  --add --super /etc/sgml/docbook-xml.cat

In my /etc/sgml/catalog I already have a line with /etc/sgml/docbook-xml.cat

and it's also in /etc/sgml/catalog.old

I'm attaching a tarball of /etc/sgml (before playing with the scripts)

But the .prerm script looks like it should have removed the docbook-xml.cat entry.
In fact it does if I run it with "upgrade" as an argument

In my /var/log/dpkg.log it looks like docbook-xml 4.4-5 was installed, and afterwards
and upgrade to 4.5-5 was attempted but it was left half-configured

So my only guess is that maybe the prerm script in docbook-xml 4.4-5 did not
run update-catalog --quiet --remove --super /etc/sgml/docbook-xml.cat
for some reason ?

Maybe the bug is in etch, not lenny, but it can be worked around in lenny ?

I can't seem to understand anything more, so I'm removing and installing the package to
continue the instalation.

Hope this helps somehow...
[sgml.tgz (application/x-compressed-tar, attachment)]
[docbook-xml.postinst (application/octet-stream, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Xavi Drudis Ferran" <xdrudis@tinet.cat>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #69 received at 482140@bugs.debian.org (full text, mbox):

From: "Xavi Drudis Ferran" <xdrudis@tinet.cat>
To: 482140@bugs.debian.org
Subject: sorry, different bug
Date: Wed, 28 May 2008 22:42:14 +0200 (CEST)
I have lost the error message now, but I guess in my case
it must have been update-catalog complaining, and not
update-xmlcatalog, so my bug must be a different one,
although possibly related. Something didn't work right
in docbook-xml.prerm for 4.4-5, I guess





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #74 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: Xavi Drudis Ferran <xdrudis@tinet.cat>, 482140@bugs.debian.org
Subject: Re: [xml/sgml-pkgs] Bug#482140: Confirming bug
Date: Thu, 29 May 2008 14:00:25 +0200
Am Mittwoch, den 28.05.2008, 14:49 +0200 schrieb Xavi Drudis Ferran:

> This exact problem happened to me last night.
> I installed etch (amd64) on a new laptop, wasn't happy with the support
> of the intel GM965 graphics board, and decided to upgrade to lenny
> for the intel Xorg driver. I selected "printing server", "desktop environment",
> and "standard system", in the etch installer.
> 
> Then it complained of this error.

Thanks for this information. I will try to reproduce it in a CHROOT.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #79 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: 482140@bugs.debian.org
Cc: Xavi Drudis Ferran <xdrudis@tinet.cat>
Subject: Re: [xml/sgml-pkgs] Bug#482140: must be /etc/sgml
Date: Fri, 30 May 2008 01:45:40 +0200
Am Mittwoch, den 28.05.2008, 22:34 +0200 schrieb Xavi Drudis Ferran:

> I'm sending my /var/lib/dpkg/info/docbook-xml.postinst

Please set -ex at the top of the script to get more output and then just
configure the package (dpkg -a docbook-xml). This should show, which
command fails.

> The line that's failing is the one after the initial for loop:
> 
> update-catalog  --add --super /etc/sgml/docbook-xml.cat
> 
> In my /etc/sgml/catalog I already have a line with /etc/sgml/docbook-xml.cat
> 
> and it's also in /etc/sgml/catalog.old

But update-catalog will not fail in this case. Try it yourself by
running the command as root again and again.

> I'm attaching a tarball of /etc/sgml (before playing with the scripts)
> 
> But the .prerm script looks like it should have removed the docbook-xml.cat entry.
> In fact it does if I run it with "upgrade" as an argument
> 
> In my /var/log/dpkg.log it looks like docbook-xml 4.4-5 was installed, and afterwards
> and upgrade to 4.5-5 was attempted but it was left half-configured
> 
> So my only guess is that maybe the prerm script in docbook-xml 4.4-5 did not
> run update-catalog --quiet --remove --super /etc/sgml/docbook-xml.cat
> for some reason ?

The postinst script removes this file during the "configure" task.
Further it will not fail, even if the file still exists.

> Maybe the bug is in etch, not lenny, but it can be worked around in lenny ?

I really have no clue about the issue atm. For me everything works (I
now ran 3 upgrades in a CHROOT - all successful) and I currently have no
idea, which part could fail/fails.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Andres Salomon <dilinger@queued.net>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #84 received at 482140@bugs.debian.org (full text, mbox):

From: Andres Salomon <dilinger@queued.net>
To: 482140@bugs.debian.org
Subject: docbook-xml error
Date: Fri, 30 May 2008 17:45:02 -0400
Hi,

The same thing just occurred for me.  I installed etch on an x86 laptop
(iirc, the tasks that were installed were desktop, laptop, and standard), and
then dist-upgraded to lenny.  I'll leave it broken for a little, so if you
have any suggestions for debugging, let me know.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Alan Somers" <asomers@alesis.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #89 received at 482140@bugs.debian.org (full text, mbox):

From: "Alan Somers" <asomers@alesis.com>
To: <482140@bugs.debian.org>
Subject: Re: [xml/sgml-pkgs] Bug#482140: must be /etc/sgml
Date: Fri, 30 May 2008 14:42:06 -0700
I have the same problem.  I have a computer that originally ran Sarge, that
I upgraded to Etch when that became stable, and that I now attempted to
upgrade to unstable.  The upgrade failed when configuring docbook-xml.  By
Daniel's suggestion, here is the output of dpkg  --configure docbook-xml
when run with set -ex in vim /var/lib/dpkg/info/docbook-xml.postinst

Setting up docbook-xml (4.5-5) ...
+ '[' configure = configure ']'
+ rm -f /etc/sgml/docbook-xml.cat
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.0/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.2/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.3/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.4/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add --super /etc/sgml/docbook-xml.cat
+ '[' configure = configure ']'
+ update-xmlcatalog --add --type system --id
http://www.oasis-open.org/docbook/xml/4.1/docbookx.dtd --package docbook-xml
--local /usr/share/xml/docbook/schema/dtd/catalog.xml
+ update-xmlcatalog --add --type system --id
http://docbook.org/xml/4.1/docbookx.dtd --package docbook-xml --local
/usr/share/xml/docbook/schema/dtd/catalog.xml
+ update-xmlcatalog --add --type public --id '-//OASIS//DTD DocBook XML
V4.1//EN' --package docbook-xml --local
/usr/share/xml/docbook/schema/dtd/catalog.xml
update-xmlcatalog: error: entity already registered
dpkg: error processing docbook-xml (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 docbook-xml


-Alan Somers

Alesis, LLC 
300 Corporate Pointe, Suite 500
Culver City, CA 90230
Tel: 310-693-7005 Ext. 7027






Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #94 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: 482140@bugs.debian.org
Cc: Andres Salomon <dilinger@queued.net>, Alan Somers <asomers@alesis.com>, Xavi Drudis Ferran <xdrudis@tinet.cat>
Subject: Re: [xml/sgml-pkgs] Bug#482140: Bug#482140: must be /etc/sgml
Date: Sat, 31 May 2008 02:10:22 +0200
Am Freitag, den 30.05.2008, 14:42 -0700 schrieb Alan Somers:
> I have the same problem.  I have a computer that originally ran Sarge, that
> I upgraded to Etch when that became stable, and that I now attempted to
> upgrade to unstable.  The upgrade failed when configuring docbook-xml.  By
> Daniel's suggestion, here is the output of dpkg  --configure docbook-xml
> when run with set -ex in vim /var/lib/dpkg/info/docbook-xml.postinst
> 
> Setting up docbook-xml (4.5-5) ...
[snip]
> + update-xmlcatalog --add --type public --id '-//OASIS//DTD DocBook XML
> V4.1//EN' --package docbook-xml --local
> /usr/share/xml/docbook/schema/dtd/catalog.xml
> update-xmlcatalog: error: entity already registered

Well, the tool is not really verbose. Please do me a favour and
edit /usr/sbin/update-xmlcatalog. Add the following lines (the first
line I write is already in the file - it should just help to find the
correct place):

use vars qw( $verbose );
$verbose = 1; # add this line

And in the function add_entry(), please add:

print STDERR "$name: error: entity already registered\n";
print "DEBUG: entry=$entry, key=$key, catalog=$catalog, catalog{key}=" .
$catalog{$key} . "\n"; # add this line

print "$name: adding entity to catalog data $catalog_data\n"
      if $verbose;
print "DEBUG: entry=$entry, key=$key, catalog=$catalog\n"; # add this line

And send me the complete output you get. E.g. with

... > /tmp/dblog 2>&1

I hope this will help me to understand, what's happening on your
systems.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Andres Salomon <dilinger@queued.net>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #99 received at 482140@bugs.debian.org (full text, mbox):

From: Andres Salomon <dilinger@queued.net>
To: Daniel Leidert <daniel.leidert@wgdd.de>
Cc: 482140@bugs.debian.org, Alan Somers <asomers@alesis.com>, Xavi Drudis Ferran <xdrudis@tinet.cat>
Subject: Re: [xml/sgml-pkgs] Bug#482140: Bug#482140: must be /etc/sgml
Date: Fri, 30 May 2008 22:19:16 -0400
On Sat, 31 May 2008 02:10:22 +0200
Daniel Leidert <daniel.leidert@wgdd.de> wrote:

> Am Freitag, den 30.05.2008, 14:42 -0700 schrieb Alan Somers:
> > I have the same problem.  I have a computer that originally ran
> > Sarge, that I upgraded to Etch when that became stable, and that I
> > now attempted to upgrade to unstable.  The upgrade failed when
> > configuring docbook-xml.  By Daniel's suggestion, here is the
> > output of dpkg  --configure docbook-xml when run with set -ex in
> > vim /var/lib/dpkg/info/docbook-xml.postinst
> > 
> > Setting up docbook-xml (4.5-5) ...
> [snip]
> > + update-xmlcatalog --add --type public --id '-//OASIS//DTD DocBook
> > XML V4.1//EN' --package docbook-xml --local
> > /usr/share/xml/docbook/schema/dtd/catalog.xml
> > update-xmlcatalog: error: entity already registered
> 
> Well, the tool is not really verbose. Please do me a favour and
> edit /usr/sbin/update-xmlcatalog. Add the following lines (the first
> line I write is already in the file - it should just help to find the
> correct place):
> 
> use vars qw( $verbose );
> $verbose = 1; # add this line
> 
> And in the function add_entry(), please add:
> 
> print STDERR "$name: error: entity already registered\n";
> print "DEBUG: entry=$entry, key=$key, catalog=$catalog,
> catalog{key}=" . $catalog{$key} . "\n"; # add this line
> 
> print "$name: adding entity to catalog data $catalog_data\n"
>       if $verbose;
> print "DEBUG: entry=$entry, key=$key, catalog=$catalog\n"; # add this
> line
> 
> And send me the complete output you get. E.g. with
> 
> ... > /tmp/dblog 2>&1
> 
> I hope this will help me to understand, what's happening on your
> systems.
> 
> Regards, Daniel
> 


Here's the output from a dist-upgrade.  I added multiple DEBUG lines; one
after the line you suggested, and an additional two after each "already
registered" error line.




Reading package lists...
Building dependency tree...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
26 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up docbook-xml (4.5-5) ...
update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: notice: entity already registered
DEBUG(notice already registered): entry=catalog="file:///usr/share/xml/docbook/schema/dtd/catalog.xml", key=delegateSystem systemIdStartString="http://www.oasis-open.org/docbook/xml/4.1/docbookx.dtd", catalog=/etc/xml/docbook-xml.xml
update-xmlcatalog: removing backup /etc/xml/docbook-xml.xml.old
update-xmlcatalog: moving catalog /etc/xml/docbook-xml.xml to backup /etc/xml/docbook-xml.xml.old
update-xmlcatalog: writing catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: writing catalog /etc/xml/docbook-xml.xml
update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: notice: entity already registered
DEBUG(notice already registered): entry=catalog="file:///usr/share/xml/docbook/schema/dtd/catalog.xml", key=delegateSystem systemIdStartString="http://docbook.org/xml/4.1/docbookx.dtd", catalog=/etc/xml/docbook-xml.xml
update-xmlcatalog: removing backup /etc/xml/docbook-xml.xml.old
update-xmlcatalog: moving catalog /etc/xml/docbook-xml.xml to backup /etc/xml/docbook-xml.xml.old
update-xmlcatalog: writing catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: writing catalog /etc/xml/docbook-xml.xml
update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: error: entity already registered
DEBUG(error already registered): entry=catalog="file:///usr/share/xml/docbook/schema/dtd/catalog.xml", key=delegatePublic publicIdStartString="-//OASIS//DTD DocBook XML V4.1//EN", catalog=/etc/xml/docbook-xml.xml
dpkg: error processing docbook-xml (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of scrollkeeper:
 scrollkeeper depends on docbook-xml (>= 4.2-11); however:
  Package docbook-xml is not configured yet.
dpkg: error processing scrollkeeper (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of capplets-data:
 capplets-data depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing capplets-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-control-center:
 gnome-control-center depends on capplets-data (>= 1:2.22); however:
  Package capplets-data is not configured yet.
 gnome-control-center depends on capplets-data (<< 1:2.23); however:
  Package capplets-data is not configured yet.
dpkg: error processing gnome-control-center (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel-data:
 gnome-panel-data depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-panel-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-control-center (>= 1:2.8.2-3); however:
  Package gnome-control-center is not configured yet.
 gnome-panel depends on gnome-panel-data (>= 2.20); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 2.21); however:
  Package gnome-panel-data is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of alacarte:
 alacarte depends on gnome-panel; however:
  Package gnome-panel is not configured yet.
dpkg: error processing alacarte (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bug-buddy:
 bug-buddy depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing bug-buddy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fast-user-switch-applet:
 fast-user-switch-applet depends on gnome-panel; however:
  Package gnome-panel is not configured yet.
dpkg: error processing fast-user-switch-applet (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gedit:
 gedit depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gedit (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-applets-data:
 gnome-applets-data depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-applets-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-applets:
 gnome-applets depends on gnome-applets-data (>= 2.20); however:
  Package gnome-applets-data is not configured yet.
 gnome-applets depends on gnome-applets-data (<< 2.21); however:
  Package gnome-applets-data is not configured yet.
 gnome-applets depends on gnome-panel (>= 2.13.4); however:
  Package gnome-panel is not configured yet.
dpkg: error processing gnome-applets (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-session:
 gnome-session depends on gnome-control-center (>= 1:2.22); however:
  Package gnome-control-center is not configured yet.
dpkg: error processing gnome-session (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-terminal:
 gnome-terminal depends on gnome-control-center (>= 1:2.8.0); however:
  Package gnome-control-center is not configured yet.
 gnome-terminal depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-terminal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus-data:
 nautilus-data depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing nautilus-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus:
 nautilus depends on gnome-control-center (>= 2.6); however:
  Package gnome-control-center is not configured yet.
 nautilus depends on nautilus-data (>= 2.20); however:
  Package nautilus-data is not configured yet.
 nautilus depends on nautilus-data (<< 2.21); however:
  Package nautilus-data is not configured yet.
dpkg: error processing nautilus (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of yelp:
 yelp depends on docbook-xml (>= 4.1.2); however:
  Package docbook-xml is not configured yet.
dpkg: error processing yelp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-core:
 gnome-core depends on gedit (>= 2.20.4); however:
  Package gedit is not configured yet.
 gnome-core depends on gnome-applets (>= 2.20.0); however:
  Package gnome-applets is not configured yet.
 gnome-core depends on gnome-control-center (>= 1:2.20.1); however:
  Package gnome-control-center is not configured yet.
 gnome-core depends on gnome-panel (>= 2.20.2); however:
  Package gnome-panel is not configured yet.
 gnome-core depends on gnome-session (>= 2.20.2); however:
  Package gnome-session is not configured yet.
 gnome-core depends on gnome-terminal (>= 2.18.3); however:
  Package gnome-terminal is not configured yet.
 gnome-core depends on nautilus (>= 2.20.0); however:
  Package nautilus is not configured yet.
 gnome-core depends on scrollkeeper | rarian-compat; however:
  Package scrollkeeper is not configured yet.
  Package rarian-compat is not installed.
 gnome-core depends on yelp (>= 2.20.0); however:
  Package yelp is not configured yet.
dpkg: error processing gnome-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-system-monitor:
 gnome-system-monitor depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-system-monitor (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-user-guide:
 gnome-user-guide depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
 gnome-user-guide depends on yelp; however:
  Package yelp is not configured yet.
dpkg: error processing gnome-user-guide (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-utils:
 gnome-utils depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gucharmap:
 gucharmap depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gucharmap (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus-cd-burner:
 nautilus-cd-burner depends on nautilus; however:
  Package nautilus is not configured yet.
dpkg: error processing nautilus-cd-burner (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of synaptic:
 synaptic depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing synaptic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xorg:
 xorg depends on xterm | x-terminal-emulator; however:
  Package xterm is not installed.
  Package x-terminal-emulator is not installed.
  Package gnome-terminal which provides x-terminal-emulator is not configured yet.
dpkg: error processing xorg (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of zenity:
 zenity depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing zenity (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 docbook-xml
 scrollkeeper
 capplets-data
 gnome-control-center
 gnome-panel-data
 gnome-panel
 alacarte
 bug-buddy
 fast-user-switch-applet
 gedit
 gnome-applets-data
 gnome-applets
 gnome-session
 gnome-terminal
 nautilus-data
 nautilus
 yelp
 gnome-core
 gnome-system-monitor
 gnome-user-guide
 gnome-utils
 gucharmap
 nautilus-cd-burner
 synaptic
 xorg
 zenity
E: Sub-process /usr/bin/dpkg returned an error code (1)




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #104 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: Andres Salomon <dilinger@queued.net>
Cc: 482140@bugs.debian.org, Alan Somers <asomers@alesis.com>, Xavi Drudis Ferran <xdrudis@tinet.cat>, Sami Liedes <sliedes@cc.hut.fi>
Subject: Re: [xml/sgml-pkgs] Bug#482140: Bug#482140: must be /etc/sgml
Date: Sat, 31 May 2008 15:07:51 +0200
Am Freitag, den 30.05.2008, 22:19 -0400 schrieb Andres Salomon:
> On Sat, 31 May 2008 02:10:22 +0200
> Daniel Leidert <daniel.leidert@wgdd.de> wrote:

[·.]
> Here's the output from a dist-upgrade.  I added multiple DEBUG lines; one
> after the line you suggested, and an additional two after each "already
> registered" error line.
> 
> 
> 
> 
> Reading package lists...
> Building dependency tree...
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
> 26 not fully installed or removed.
> After this operation, 0B of additional disk space will be used.
> Setting up docbook-xml (4.5-5) ...
> update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
> update-xmlcatalog: notice: entity already registered
                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> DEBUG(notice already registered): entry=catalog="file:///usr/share/xml/docbook/schema/dtd/catalog.xml", key=delegateSystem systemIdStartString="http://www.oasis-open.org/docbook/xml/4.1/docbookx.dtd", catalog=/etc/xml/docbook-xml.xml
> update-xmlcatalog: removing backup /etc/xml/docbook-xml.xml.old
> update-xmlcatalog: moving catalog /etc/xml/docbook-xml.xml to backup /etc/xml/docbook-xml.xml.old
> update-xmlcatalog: writing catalog data /var/lib/xml-core/docbook-xml
> update-xmlcatalog: writing catalog /etc/xml/docbook-xml.xml
> update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
> update-xmlcatalog: notice: entity already registered
                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> DEBUG(notice already registered): entry=catalog="file:///usr/share/xml/docbook/schema/dtd/catalog.xml", key=delegateSystem systemIdStartString="http://docbook.org/xml/4.1/docbookx.dtd", catalog=/etc/xml/docbook-xml.xml
> update-xmlcatalog: removing backup /etc/xml/docbook-xml.xml.old
> update-xmlcatalog: moving catalog /etc/xml/docbook-xml.xml to backup /etc/xml/docbook-xml.xml.old
> update-xmlcatalog: writing catalog data /var/lib/xml-core/docbook-xml
> update-xmlcatalog: writing catalog /etc/xml/docbook-xml.xml
> update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
> update-xmlcatalog: error: entity already registered
                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> DEBUG(error already registered): entry=catalog="file:///usr/share/xml/docbook/schema/dtd/catalog.xml", key=delegatePublic publicIdStartString="-//OASIS//DTD DocBook XML V4.1//EN", catalog=/etc/xml/docbook-xml.xml
> dpkg: error processing docbook-xml (--configure):
>  subprocess post-installation script returned error exit status 1

Thanks for this information. Now this result is some kind of surprising.
The prerm script of the docbook-xml Etch package should remove those
entries. Indeed it says:

> update-xmlcatalog --del --type system --id "http://www.oasis-open.org/docbook/xml/4.1" --package docbook-xml || true
> update-xmlcatalog --del --type system --id "http://docbook.org/xml/4.1" --package docbook-xml || true
> update-xmlcatalog --del --type public --id "-//OASIS//DTD DocBook XML V4.1//EN" --package docbook-xml || true

Now all I can imagine is, that the removal fails. But in this case, the
script will not error out, because of the '|| true' expression. So if
you have the time, you could do me a favour and edit the prerm script of
the Etch package of docbook-xml and remove the '|| true' expressions and
run the script or try to upgrade the packages. Alternatively you may
also do this for the package installed and simply try to remove/purge
it. Maybe this will throw some error (if I'm right with my guess) and
maybe there is just a problem with Perl 5.10 and update-xmlcatalog
trying to remove the entities.

Unfortunately I'm not able to reproduce the problem on my i386 system (I
even checked one of my productive systems). They all run an upgrade
without any problems. So I can just ask you to edit the files and send
me the results. I'm really sorry.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Andres Salomon <dilinger@queued.net>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #109 received at 482140@bugs.debian.org (full text, mbox):

From: Andres Salomon <dilinger@queued.net>
To: Daniel Leidert <daniel.leidert@wgdd.de>
Cc: 482140@bugs.debian.org, Alan Somers <asomers@alesis.com>, Xavi Drudis Ferran <xdrudis@tinet.cat>, Sami Liedes <sliedes@cc.hut.fi>
Subject: Re: [xml/sgml-pkgs] Bug#482140: Bug#482140: must be /etc/sgml
Date: Sat, 31 May 2008 12:06:33 -0400
On Sat, 31 May 2008 15:07:51 +0200
Daniel Leidert <daniel.leidert@wgdd.de> wrote:

[...]
> Now all I can imagine is, that the removal fails. But in this case,
> the script will not error out, because of the '|| true' expression.
> So if you have the time, you could do me a favour and edit the prerm
> script of the Etch package of docbook-xml and remove the '|| true'
> expressions and run the script or try to upgrade the packages.
> Alternatively you may also do this for the package installed and
> simply try to remove/purge it. Maybe this will throw some error (if
> I'm right with my guess) and maybe there is just a problem with Perl
> 5.10 and update-xmlcatalog trying to remove the entities.

Ok, I edited the prerm and then dist-upgraded again; as expected, it
didn't attempt to run the prerm script because docbook-xml had already
been unpacked.

I then did an 'apt-get install docbook-xml=4.4-5', installing the version
from etch; there were no errors (and the rest of the packages that
depended upon docbook-xml finished configuring).

I edited 4.4-5's prerm script (removing the ||true's), and did another
dist-upgrade; docbook-xml upgraded from 4.4-5 to 4.5-5, with no errors.

At this point, I fear that I can't reproduce it.  Considering that
you can't reproduce it in a chroot, I suspect it can only be
reproduced on a fresh etch install with a dist-upgrade to lenny.


> 
> Unfortunately I'm not able to reproduce the problem on my i386 system
> (I even checked one of my productive systems). They all run an upgrade
> without any problems. So I can just ask you to edit the files and send
> me the results. I'm really sorry.
> 
> Regards, Daniel
> 




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Xavi Drudis Ferran <xdrudis@tinet.cat>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #114 received at 482140@bugs.debian.org (full text, mbox):

From: Xavi Drudis Ferran <xdrudis@tinet.cat>
To: Daniel Leidert <daniel.leidert@wgdd.de>
Cc: 482140@bugs.debian.org, Xavi Drudis Ferran <xdrudis@tinet.cat>
Subject: Re: [xml/sgml-pkgs] Bug#482140: must be /etc/sgml
Date: Sun, 1 Jun 2008 11:28:17 +0200
On Fri, May 30, 2008 at 01:45:40AM +0200, Daniel Leidert wrote:
> Am Mittwoch, den 28.05.2008, 22:34 +0200 schrieb Xavi Drudis Ferran:
> 
> > I'm sending my /var/lib/dpkg/info/docbook-xml.postinst
> 
> Please set -ex at the top of the script to get more output and then just
> configure the package (dpkg -a docbook-xml). This should show, which
> command fails.
> 

Just one quick note, I must leave. I no longer have that amd64 laptop with 
me. I was installing it for a friend and gave it back to her today.
(I could fix the problem by removing and installing the package, but 
of course this is not the solution we want). 
I'll see what I can do to try to reproduce it though.


> 
> I really have no clue about the issue atm. For me everything works (I
> now ran 3 upgrades in a CHROOT - all successful) and I currently have no
> idea, which part could fail/fails.
> 

I see. I don't have much clue either. 

I'll try to think a little more on what can I do later. 

-- 
xdrudis@tinet.cat
Signa per fer Collserola parc natural com cal
http://www.collserola.org/salvemelparcnatural/




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Alan Somers" <asomers@alesis.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #119 received at 482140@bugs.debian.org (full text, mbox):

From: "Alan Somers" <asomers@alesis.com>
To: <482140@bugs.debian.org>
Subject: Re: [xml/sgml-pkgs] Bug#482140: Bug#482140: must be /etc/sgml
Date: Mon, 2 Jun 2008 09:16:41 -0700
I added debugging statements as suggested by Daniel on Sat, 31 May 2008
02:10:22 +0200 .  Unlike Andres, I had no problem with
"http://www.oasis-open.org/docbook/xml/4.1" or "http://docbook.org/xml/4.1".
I only had a problem with "-//OASIS//DTD DocBook XML V4.1//EN".  I then
removed the 

|| true 

from 
update-xmlcatalog --del --type public --id "-//OASIS//DTD DocBook XML
V4.1//EN" --package docbook-xml || true

and ran 

dpkg --configure docbook-xml 

again.  However, as with Andres the prerm script did not get run at all.
Considering that Andres can no longer reproduce the bug, I'm not going to
attempt reinstall docbook-xml until I get a suggestion from Daniel.  Here is
the output of dpkg with the debugging statements added




Setting up docbook-xml (5.5-5) ...
+ '[' configure = configure ']'
+ rm -f /etc/sgml/docbook-xml.cat
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.0/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.2/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.3/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.4/catalog
+ for ordcat in /usr/share/xml/docbook/schema/dtd/catalog
/usr/share/xml/docbook/schema/dtd/4.0/catalog
/usr/share/xml/docbook/schema/dtd/4.1.2/catalog
/usr/share/xml/docbook/schema/dtd/4.2/catalog
/usr/share/xml/docbook/schema/dtd/4.3/catalog
/usr/share/xml/docbook/schema/dtd/4.4/catalog
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add /etc/sgml/docbook-xml.cat
/usr/share/xml/docbook/schema/dtd/4.5/catalog
+ update-catalog --quiet --add --super /etc/sgml/docbook-xml.cat
+ '[' configure = configure ']'
+ update-xmlcatalog --add --type system --id
http://www.oasis-open.org/docbook/xml/4.1/docbookx.dtd --package docbook-xml
--local /usr/share/xml/docbook/schema/dtd/catalog.xml
update-xmlcatalog: notice: entity already registered
update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: removing backup /etc/xml/docbook-xml.xml.old
update-xmlcatalog: moving catalog /etc/xml/docbook-xml.xml to backup
/etc/xml/docbook-xml.xml.old
update-xmlcatalog: writing catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: writing catalog /etc/xml/docbook-xml.xml
+ update-xmlcatalog --add --type system --id
http://docbook.org/xml/4.1/docbookx.dtd --package docbook-xml --local
/usr/share/xml/docbook/schema/dtd/catalog.xml
update-xmlcatalog: notice: entity already registered
update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: removing backup /etc/xml/docbook-xml.xml.old
update-xmlcatalog: moving catalog /etc/xml/docbook-xml.xml to backup
/etc/xml/docbook-xml.xml.old
update-xmlcatalog: writing catalog data /var/lib/xml-core/docbook-xml
update-xmlcatalog: writing catalog /etc/xml/docbook-xml.xml
+ update-xmlcatalog --add --type public --id '-//OASIS//DTD DocBook XML
V4.1//EN' --package docbook-xml --local
/usr/share/xml/docbook/schema/dtd/catalog.xml
update-xmlcatalog: error: entity already registered
update-xmlcatalog: reading catalog data /var/lib/xml-core/docbook-xml
DEBUG: entry=catalog="file:///usr/share/xml/docbook/schema/dtd/catalog.xml",
key=delegatePublic publicIdStartString="-//OASIS//DTD DocBook XML V4.1//EN",
catalog=/etc/xml/docbook-xml.xml,
catalog{key}=catalog="file:///usr/share/xml/docbook/schema/dtd/4.1.2/catalog
.xml"
dpkg: error processing docbook-xml (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 docbook-xml



-Alan Somers

Alesis, LLC 
300 Corporate Pointe, Suite 500
Culver City, CA 90230
Tel: 310-693-7005 Ext. 7027






Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Eugene I. Mogilevsky" <eugeneim@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #124 received at 482140@bugs.debian.org (full text, mbox):

From: "Eugene I. Mogilevsky" <eugeneim@gmail.com>
To: 482140@bugs.debian.org
Subject: Re: docbook-xml: Package does not install
Date: Tue, 3 Jun 2008 22:33:44 +0400
Got the same bug on my Core2 Duo laptop. 100% reproduceable.

To reproduce
 - install Debian from installation DVD
 - roll on the latest updates for default etch packages
 - change etch to lenny in lst file
 - update, dist-upgrade




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Akira <public@raideen.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #129 received at 482140@bugs.debian.org (full text, mbox):

From: Akira <public@raideen.org>
To: 482140@bugs.debian.org
Subject: docbook-xml: Package does not install: update-xmlcatalog: error: entity, already registered
Date: Tue, 10 Jun 2008 04:05:01 -0400
Same error upgrading from Etch to Lenny on i686 (Core2 Duo). Worked around the issue by running the following two commands.

update-xmlcatalog --del --type public --id '-//OASIS//DTD DocBook XML V4.1//EN' --package docbook-xml
update-xmlcatalog --del --type public --id '-//OASIS//DTD XML Exchange Table Model 19990315//EN' --package docbook-xml




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert.spam@gmx.net>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #134 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert.spam@gmx.net>
To: Akira <public@raideen.org>, 482140@bugs.debian.org
Cc: ml_debian-release <debian-release@lists.debian.org>, ml_debian-developers <debian-devel@lists.debian.org>
Subject: Re: [xml/sgml-pkgs] Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity, already registered
Date: Tue, 10 Jun 2008 13:38:31 +0200
Am Dienstag, den 10.06.2008, 04:05 -0400 schrieb Akira:
> Same error upgrading from Etch to Lenny on i686 (Core2 Duo). Worked around the issue by running the following two commands.
> 
> update-xmlcatalog --del --type public --id '-//OASIS//DTD DocBook XML V4.1//EN' --package docbook-xml
> update-xmlcatalog --del --type public --id '-//OASIS//DTD XML Exchange Table Model 19990315//EN' --package docbook-xml

These commands are part of the prerm script of the docbook-xml etch
package (4.4-5). So this shouldn't be necessary.

I clearly need help and I get the impression, that the problem only
appears on the amd64 architecture.

CCing debian-release, debian-devel for help

Hello guys,

Some users reported an issue upgrading docbook-xml from Etch to
Lenny/Sid. I'm unable to reproduce it and I currently have no idea,
what's going on. From reading the reports it might be an amd64-specific
issue - which is some kind of surprising, because docbook-xml is
Arch:all. But maybe the package has been corrupted on the amd64
installation CD/DVDs. The fact, that after a reinstallation of the
docbook-xml package, the issue seems to disappear could be a hint, that
this is the case. I really have no clue (and not much time till the end
of next week). So I hereby request your help.

I really appreciate any information, which helps to track down the issue
and fix it. An NMU is of course allowed if you find the cause.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to "Alan Somers" <asomers@alesis.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #139 received at 482140@bugs.debian.org (full text, mbox):

From: "Alan Somers" <asomers@alesis.com>
To: <482140@bugs.debian.org>
Subject: Re: [xml/sgml-pkgs] Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity, already registered
Date: Tue, 10 Jun 2008 09:52:42 -0700
I can confirm that this is not amd64 specific.  I am running 32-bit on a
pentium-4 2.4GHz.  It is also not specific to the Etch install CDs, because
I did not use them.  I installed with Sarge, upgraded to Etch, then tried to
upgrade to Sid.

Unfortunetely I suffered a hard drive crash yesterday so I can't help test
this bug any longer. 

-Alan Somers

Alesis, LLC 
300 Corporate Pointe, Suite 500
Culver City, CA 90230
Tel: 310-693-7005 Ext. 7027






Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to astrange@ithinksw.com:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #144 received at 482140@bugs.debian.org (full text, mbox):

From: Alexander Strange <astrange@ithinksw.com>
To: 482140@bugs.debian.org
Subject: Re: [xml/sgml-pkgs] Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity, already registered
Date: Mon, 23 Jun 2008 02:57:45 -0400
I experienced the same thing going from a freshly-installed etch to
lenny on ppc, so it's not limited to amd64. 

Running:
update-xmlcatalog --del --type public --id '-//OASIS//DTD DocBook XML
V4.1//EN' --package docbook-xml
update-xmlcatalog --del --type public --id '-//OASIS//DTD XML Exchange Table Model 19990315//EN' --package docbook-xml

did in fact fix it.

This wasn't on a VM, so unfortunately I can't go back and reproduce it.





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to marvil07 <marvil07@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #149 received at 482140@bugs.debian.org (full text, mbox):

From: marvil07 <marvil07@gmail.com>
To: 482140@bugs.debian.org
Subject: Re: [xml/sgml-pkgs] Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity, already registered
Date: Thu, 3 Jul 2008 23:49:03 -0500
I'm also on a freshly-installed etch upgrading to lenny on i686 and
running the both commands:

update-xmlcatalog --del --type public --id '-//OASIS//DTD DocBook XML
V4.1//EN' --package docbook-xml
update-xmlcatalog --del --type public --id '-//OASIS//DTD XML Exchange
Table Model 19990315//EN' --package docbook-xml

solve the problem.
___________________________

Marco Antonio Villegas Vega
http://blog.pucp.edu.pe/marvil07




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Charles Plessy <plessy@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #154 received at 482140@bugs.debian.org (full text, mbox):

From: Charles Plessy <plessy@debian.org>
To: 482140@bugs.debian.org
Subject: Not reproduced on a ppc chroot.
Date: Fri, 11 Jul 2008 15:42:06 +0900
Hi all,

I created an etch chroot by the command `debootstrap etch etch',
chrooted in, installed docbook-xml and upgraded it to lenny, and did not
reproduce the bug.

I then reverted docbook-xml to etch and did a full aptitude upgrade, and
did not reproduce the bug either.

Hope this helps,

-- 
Charles Plessy
Debian-Med packaging team,
Tsurumi, Kanagawa, Japan




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Raúl Sánchez Siles <rss@barracuda.es>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #159 received at 482140@bugs.debian.org (full text, mbox):

From: Raúl Sánchez Siles <rss@barracuda.es>
To: 482140@bugs.debian.org
Subject: [Broken] Catalog file
Date: Thu, 17 Jul 2008 14:18:04 +0200
[Message part 1 (text/plain, inline)]
Hello:

  I'm sending the /etc/xml/catalog file from a guy I helped upgrading from 
etch to lenny. HTH


/etc/xml/catalog :

<?xml version="1.0"?>
<!DOCTYPE catalog PUBLIC "-//OASIS//DTD XML Catalogs V1.0//EN"
  "file:///usr/share/xml/schema/xml-core/catalog.dtd">
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
<delegateURI 
uriStartString="http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/" 
catalog="file:///etc/xml/scrollkeeper.xml"/>
<delegatePublic publicIdStartString="ISO 8879:1986//ENTITIES" 
catalog="file:///etc/xml/sgml-data.xml"/>
<delegateSystem systemIdStartString="/usr/share/sgml/dtd/svg" 
catalog="file:///etc/xml/sgml-data.xml"/>
<delegatePublic publicIdStartString="-//W3C//ENTITIES XHTML 1.1" 
catalog="file:///etc/xml/w3c-dtd-xhtml.xml"/>
<delegatePublic publicIdStartString="-//W3C//ENTITIES Latin 1 for XHTML//EN" 
catalog="file:///etc/xml/w3c-dtd-xhtml.xml"/>
<delegatePublic publicIdStartString="+//IDN faq.org//DTD Frequently Asked 
Questions" catalog="file:///etc/xml/sgml-data.xml"/>
<delegateSystem systemIdStartString="http://www.w3.org/Graphics/SVG/1.1/" 
catalog="file:///etc/xml/sgml-data.xml"/>
<delegateSystem systemIdStartString="/usr/share/sgml/dtd/qaml-xml.dtd" 
catalog="file:///etc/xml/sgml-data.xml"/>
<delegatePublic publicIdStartString="-//W3C//DTD XHTML 1.1" 
catalog="file:///etc/xml/w3c-dtd-xhtml.xml"/>
<delegatePublic publicIdStartString="-//W3C//DTD XHTML 1.0" 
catalog="file:///etc/xml/w3c-dtd-xhtml.xml"/>
<delegatePublic publicIdStartString="-//OASIS//DTD XML Exchange Table Model 
19990310//EN" catalog="file:///etc/xml/docbook-xml.xml"/>
<delegatePublic publicIdStartString="-//OASIS//DTD XML Catalogs V1.0//EN" 
catalog="file:///etc/xml/xml-core.xml"/>
<delegatePublic publicIdStartString="-//W3C//ENTITIES Special for XHTML//EN" 
catalog="file:///etc/xml/w3c-dtd-xhtml.xml"/>
<delegatePublic publicIdStartString="-//W3C//DTD SVG" 
catalog="file:///etc/xml/sgml-data.xml"/>
<delegateSystem 
systemIdStartString="http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd" 
catalog="file:///etc/xml/xml-core.xml"/>
<delegateSystem 
systemIdStartString="http://xml.ascc.net/xml/resource/qaml-xml" 
catalog="file:///etc/xml/sgml-data.xml"/>
<delegatePublic publicIdStartString="-//W3C//DTD XHTML Basic 1.0" 
catalog="file:///etc/xml/w3c-dtd-xhtml.xml"/>
<delegateSystem 
systemIdStartString="http://www.w3.org/TR/2001/REC-SVG-20010904/" 
catalog="file:///etc/xml/sgml-data.xml"/>
<delegatePublic publicIdStartString="-//W3C//ENTITIES Symbols for XHTML//EN" 
catalog="file:///etc/xml/w3c-dtd-xhtml.xml"/>
<delegatePublic publicIdStartString="+//ISBN 82-7640-023//DTD Frequently Asked 
Questions//EN" catalog="file:///etc/xml/sgml-data.xml"/>
</catalog>

-- 
Raúl Sánchez Siles
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to 01 <fabuzz@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #164 received at 482140@bugs.debian.org (full text, mbox):

From: 01 <fabuzz@gmail.com>
To: 482140@bugs.debian.org
Subject: (pas de sujet)
Date: Wed, 27 Aug 2008 15:54:22 +0200
I experienced the same problem with my notebook.

Using Etch Stable (installed from the CD), then upgrading to Lenny (to 
get my Intel GMA965 chipset working well with 3D).
I've got a 32 bits Intel architecture (CPU = pentium M)

I solved the problem by :
- editing my /etc/apt/sources.list to switch back to etch
- apt-get remove docbook-xml (complains many times about 
update-xmlcatalog: error: entity not registered )
- apt-get update
- apt-get install docbook-xml
- editing /etc/apt/sources.list to update to lenny
- apt-get update
- apt-get dist-upgrade

That did it ;-)

Hope that helps.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. Full text and rfc822 format available.

Acknowledgement sent to Witold Baryluk <baryluk@smp.if.uj.edu.pl>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #169 received at 482140@bugs.debian.org (full text, mbox):

From: Witold Baryluk <baryluk@smp.if.uj.edu.pl>
To: 482140@bugs.debian.org
Subject: More information
Date: Sat, 13 Sep 2008 19:11:07 +0200
[Message part 1 (text/plain, inline)]
I reproduced this error (more than serious).

Two update-xmlcatalog commands given in marvil07 message
resolved problem.

Intel Pentium 3, latest Etch -> Lenny

-- 
Witold Baryluk
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Fri, 19 Sep 2008 13:45:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to mathias@teikari.net:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Fri, 19 Sep 2008 13:45:04 GMT) Full text and rfc822 format available.

Message #174 received at 482140@bugs.debian.org (full text, mbox):

From: Mathias Teikari <mathias.teikari@swiftdsl.com.au>
To: 482140@bugs.debian.org
Subject: Re: docbook-xml breaks etch->lenny dist-upgrade, another occurrence
Date: Fri, 19 Sep 2008 22:41:32 +1000
[Message part 1 (text/plain, inline)]
Another repeat of this bug when dist-upgrade etch->lenny on i386
machine. Not on a VM so can't run it again to reproduce, but the upgrade
log, the /etc/xml/catalog.old and /etc/xml/docbook-xml.xml.old files are
attached in case it may be helpful.

My etch system was not newly installed, but had been running for about 7
months and kept up-to-date.

Brute force workaround saved the day:
dpkg --purge docbook-xml

then run
apt-get dist-upgrade
again.

Regards,
-- 

Mathias Teikari
--
Email:  mathias@teikari.net
--
SIP: mathiasteikari@ekiga.net
--
MSN:    mathiasteikari@hotmail.com
Jabber: mathiasteikari@jabber.com.au
ICQ:    21144560
--
PGP public key ID: 1024D/1DBB514D 2005-01-02
PGP key fingerprint: 230E 0C0D DBA2 D05A 59DA  3BDA 7010 2939 1DBB 514D
Keyserver: http://www.keyserver.net./
[catalog.old (application/xml, attachment)]
[docbook-xml.xml.old (application/xml, attachment)]
[term.log (text/x-log, attachment)]

Tags removed: unreproducible Request was from Luk Claes <luk@debian.org> to control@bugs.debian.org. (Sun, 05 Oct 2008 17:36:08 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Sun, 05 Oct 2008 19:09:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Sun, 05 Oct 2008 19:09:02 GMT) Full text and rfc822 format available.

Message #181 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: 482140@bugs.debian.org
Cc: Luk Claes <luk@debian.org>, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>
Subject: Re: [xml/sgml-pkgs] Processed: tagging 482140
Date: Sun, 05 Oct 2008 21:06:22 +0200
Am Sonntag, den 05.10.2008, 17:36 +0000 schrieb Debian Bug Tracking
System:
> Processing commands for control@bugs.debian.org:
> 
> > tags 482140 - unreproducible
> Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity already registered
> Tags were: help unreproducible
> Tags removed: unreproducible

Would you be so kind to explain, why you removed the tag? If you know of
a way to reproduce it, I would really love to hear it, because I cannot
reproduce the problem. If you remove the tag you seem to know a way to
reproduce it.

Thanks.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Sun, 05 Oct 2008 20:33:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luk Claes <luk@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Sun, 05 Oct 2008 20:33:07 GMT) Full text and rfc822 format available.

Message #186 received at 482140@bugs.debian.org (full text, mbox):

From: Luk Claes <luk@debian.org>
To: Daniel Leidert <daniel.leidert@wgdd.de>
Cc: 482140@bugs.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>
Subject: Re: [xml/sgml-pkgs] Processed: tagging 482140
Date: Sun, 05 Oct 2008 22:29:17 +0200
Daniel Leidert wrote:
> Am Sonntag, den 05.10.2008, 17:36 +0000 schrieb Debian Bug Tracking
> System:
>> Processing commands for control@bugs.debian.org:
>>
>>> tags 482140 - unreproducible
>> Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity already registered
>> Tags were: help unreproducible
>> Tags removed: unreproducible
> 
> Would you be so kind to explain, why you removed the tag? If you know of
> a way to reproduce it, I would really love to hear it, because I cannot
> reproduce the problem. If you remove the tag you seem to know a way to
> reproduce it.

If lots of people complain about the same problem, it is reproducible.
You seem to tag it unreproducible to not have to solve it or find a way
to reproduce it which is not the use case of the tag AFAIK.

Cheers

Luk




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Sun, 05 Oct 2008 21:06:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Sun, 05 Oct 2008 21:06:05 GMT) Full text and rfc822 format available.

Message #191 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: 482140@bugs.debian.org, control@bugs.debian.org
Cc: Luk Claes <luk@debian.org>
Subject: Re: [xml/sgml-pkgs] Processed: tagging 482140
Date: Sun, 05 Oct 2008 23:04:19 +0200
tags 482140 + unreproducible
thanks

Am Sonntag, den 05.10.2008, 22:29 +0200 schrieb Luk Claes:
> Daniel Leidert wrote:
> > Am Sonntag, den 05.10.2008, 17:36 +0000 schrieb Debian Bug Tracking
> > System:
> >> Processing commands for control@bugs.debian.org:
> >>
> >>> tags 482140 - unreproducible
> >> Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity already registered
> >> Tags were: help unreproducible
> >> Tags removed: unreproducible
> > 
> > Would you be so kind to explain, why you removed the tag? If you know of
> > a way to reproduce it, I would really love to hear it, because I cannot
> > reproduce the problem. If you remove the tag you seem to know a way to
> > reproduce it.
> 
> If lots of people complain about the same problem, it is reproducible.

Oh really? Even those, who observed the issue were *not* able to
reproduce it! Why do you change bug tags, when you even did not read the
whole report?!

> You seem to tag it unreproducible to not have to solve it

WTF are you trying to say?! I spent several days trying to reproduce it!
I again repeat it: Even people who observed the issue were not able to
reproduce it! Downgrading and again upgrading worked perfectly! And
everything which is now attached to this report is: "Oh yes, I also had
this." Yeah, this is the information I need.

Two entities are not removed. But the maintainer scripts *remove* them.
So there must be a reason, why these two entities are not removed and I
cannot reproduce this behaviour. I think, that the Perl upgrade maybe
leave the system in a broken state, so the removal command fails. But I
cannot reproduce it and I tried several upgrade orders! Another
possibility is, that the package was shipped wih a CD and was broken on
this CD. But reporters told me, that the maintainer scripts on their
system were ok. However, re-installing the package also seems to solve
the problem.

And now you better shut up and try to reproduce it yourself instead
trying to teach me about things, I already examined! I gave you a lot of
information, which all did not help me to reproduce it. If you think, I
try to *not* solve it: Well show me, how bad I maintain the package!

> or find a way
> to reproduce it which is not the use case of the tag AFAIK.

I spent hours over hours and the tags meaning is: "This bug can't be
reproduced on the maintainer's system. Assistance from third parties is
needed in diagnosing the cause of the problem." This is exactly, what
I'm looking for!

Find a way to reproduce it and then I will remove this tag. And now stop
your insulting behaviour!

Daniel





Tags added: unreproducible Request was from Daniel Leidert <daniel.leidert@wgdd.de> to control@bugs.debian.org. (Sun, 05 Oct 2008 21:06:06 GMT) Full text and rfc822 format available.

Severity set to `important' from `serious' Request was from Luk Claes <luk@debian.org> to control@bugs.debian.org. (Sun, 05 Oct 2008 21:09:02 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Sun, 05 Oct 2008 21:18:41 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luk Claes <luk@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Sun, 05 Oct 2008 21:18:41 GMT) Full text and rfc822 format available.

Message #200 received at 482140@bugs.debian.org (full text, mbox):

From: Luk Claes <luk@debian.org>
To: Daniel Leidert <daniel.leidert@wgdd.de>, 482140@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Re: Bug#482140: [xml/sgml-pkgs] Processed: tagging 482140
Date: Sun, 05 Oct 2008 23:16:57 +0200
Daniel Leidert wrote:
> tags 482140 + unreproducible
> thanks
> 
> Am Sonntag, den 05.10.2008, 22:29 +0200 schrieb Luk Claes:
>> Daniel Leidert wrote:
>>> Am Sonntag, den 05.10.2008, 17:36 +0000 schrieb Debian Bug Tracking
>>> System:
>>>> Processing commands for control@bugs.debian.org:
>>>>
>>>>> tags 482140 - unreproducible
>>>> Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity already registered
>>>> Tags were: help unreproducible
>>>> Tags removed: unreproducible
>>> Would you be so kind to explain, why you removed the tag? If you know of
>>> a way to reproduce it, I would really love to hear it, because I cannot
>>> reproduce the problem. If you remove the tag you seem to know a way to
>>> reproduce it.
>> If lots of people complain about the same problem, it is reproducible.
> 
> Oh really? Even those, who observed the issue were *not* able to
> reproduce it! Why do you change bug tags, when you even did not read the
> whole report?!

I did read it.

>> You seem to tag it unreproducible to not have to solve it
> 
> WTF are you trying to say?! I spent several days trying to reproduce it!
> I again repeat it: Even people who observed the issue were not able to
> reproduce it! Downgrading and again upgrading worked perfectly! And
> everything which is now attached to this report is: "Oh yes, I also had
> this." Yeah, this is the information I need.

Which proves that it does not work when downgrading first.

> Two entities are not removed. But the maintainer scripts *remove* them.
> So there must be a reason, why these two entities are not removed and I
> cannot reproduce this behaviour. I think, that the Perl upgrade maybe
> leave the system in a broken state, so the removal command fails. But I
> cannot reproduce it and I tried several upgrade orders! Another
> possibility is, that the package was shipped wih a CD and was broken on
> this CD. But reporters told me, that the maintainer scripts on their
> system were ok. However, re-installing the package also seems to solve
> the problem.

If downgrading does not reproduce it, it certainly looks like the
removal command fails for some reason.

> And now you better shut up and try to reproduce it yourself instead
> trying to teach me about things, I already examined! I gave you a lot of
> information, which all did not help me to reproduce it. If you think, I
> try to *not* solve it: Well show me, how bad I maintain the package!

Well, it's you who doesn't downgrade the severity even if you are sure
most people are not affected and you're not able to reproduce the bug.

>> or find a way
>> to reproduce it which is not the use case of the tag AFAIK.
> 
> I spent hours over hours and the tags meaning is: "This bug can't be
> reproduced on the maintainer's system. Assistance from third parties is
> needed in diagnosing the cause of the problem." This is exactly, what
> I'm looking for!
> 
> Find a way to reproduce it and then I will remove this tag. And now stop
> your insulting behaviour!

It was not meant as insulting at all, it just looked to me that you were
giving the wrong message by not downgrading the bug.

Btw, I downgraded the severity to important.

Cheers

Luk




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Mon, 06 Oct 2008 21:33:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Mon, 06 Oct 2008 21:33:02 GMT) Full text and rfc822 format available.

Message #205 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: 482140@bugs.debian.org
Cc: "Eugene I. Mogilevsky" <eugeneim@gmail.com>
Subject: Re: docbook-xml: Package does not install
Date: Mon, 06 Oct 2008 23:31:37 +0200
Hello,

Do you remember from where you got the installation DVD? Do you still
have it? Can you send me the docbook-xml binary package (.deb) from this
DVD?

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Mon, 06 Oct 2008 21:39:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Mon, 06 Oct 2008 21:39:03 GMT) Full text and rfc822 format available.

Message #210 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: 482140@bugs.debian.org, control@bugs.debian.org
Cc: Luk Claes <luk@debian.org>
Subject: Re: Bug#482140: [xml/sgml-pkgs] Processed: tagging 482140
Date: Mon, 06 Oct 2008 23:35:32 +0200
severity 482140 serious
thanks

Am Sonntag, den 05.10.2008, 23:16 +0200 schrieb Luk Claes:
> Daniel Leidert wrote:

[..]
> > Two entities are not removed. But the maintainer scripts *remove* them.
> > So there must be a reason, why these two entities are not removed and I
> > cannot reproduce this behaviour. I think, that the Perl upgrade maybe
> > leave the system in a broken state, so the removal command fails. But I
> > cannot reproduce it and I tried several upgrade orders! Another
> > possibility is, that the package was shipped wih a CD and was broken on
> > this CD. But reporters told me, that the maintainer scripts on their
> > system were ok. However, re-installing the package also seems to solve
> > the problem.
> 
> If downgrading does not reproduce it, it certainly looks like the
> removal command fails for some reason.

But why does it fail for 2 entities out of >20? I still think, that
there are maybe broken packages on the installation media the reporters
used. The 2 entities are not at the beginning nor the end of the long
list of commands. 

> > And now you better shut up and try to reproduce it yourself instead
> > trying to teach me about things, I already examined! I gave you a lot of
> > information, which all did not help me to reproduce it. If you think, I
> > try to *not* solve it: Well show me, how bad I maintain the package!
> 
> Well, it's you who doesn't downgrade the severity even if you are sure
> most people are not affected and you're not able to reproduce the bug.

When did I say, that "most people are not affected"? I simply cannot
reproduce it and I did not yet get any useful information. Downgrading
is like "not having to solve it".

> Btw, I downgraded the severity to important.

Sorry, I cannot agree to this. If I don't get useful information I still
have the choice to add the two removal commands manually to the preinst
script to try to workaround it. Because I don't have the necessary
information I don't know, if this will workaround the issue, but it's
better than nothing.

Setting severity back.

Regards, Daniel





Severity set to `serious' from `important' Request was from Daniel Leidert <daniel.leidert@wgdd.de> to control@bugs.debian.org. (Mon, 06 Oct 2008 21:39:04 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 07 Oct 2008 07:51:08 GMT) Full text and rfc822 format available.

Acknowledgement sent to alci <alci@mecadu.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 07 Oct 2008 07:51:08 GMT) Full text and rfc822 format available.

Message #217 received at 482140@bugs.debian.org (full text, mbox):

From: alci <alci@mecadu.org>
To: 482140@bugs.debian.org
Subject: I could reproduce it
Date: Tue, 07 Oct 2008 09:48:07 +0200
Hi,

if this can help, here is how I encountered this bug:

- downloaded
http://cdimage.debian.org/debian-cd/4.0_r4a/i386/iso-cd/debian-40r4a-i386-businesscard.iso

- installed debian in a virtualbox (Ubuntu Intrepid guest), with minimal
system + graphical environment (default choices)

- logged in gnome

- in /etc/apt/sources.list, changed any etch occurence with lenny

- apt-get update / apt-get dsit-upgrade

- configuration of packages fails on docbook-xml with error:

update-xmlcatalog: error: entity already registered
dpkg: error processing docbook-xml (--configure):
 subprocess post-installation script returned error exit status 1

- consequently, scrollkeeper and other gnome componentns are not configured. Default gnome session does not work.

- dpkg --purge docbook-xml / apt-get -f dist-upgrade works around the problem

Hope this can help,

Franck






Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 07 Oct 2008 07:57:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luca Capello <luca@pca.it>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 07 Oct 2008 07:57:03 GMT) Full text and rfc822 format available.

Message #222 received at 482140@bugs.debian.org (full text, mbox):

From: Luca Capello <luca@pca.it>
To: 482140@bugs.debian.org
Cc: Luk Claes <luk@debian.org>, Daniel Leidert <daniel.leidert@wgdd.de>
Subject: Reproducible and playing machine available
Date: Tue, 07 Oct 2008 09:53:07 +0200
[Message part 1 (text/plain, inline)]
Hi there!

Some notes before starting:

1) IMHO this bug is Severity: important, it leaves GNOME in an not
   usable state (see attached log)

2) I found this bug around one and a half week ago, but I performed more
   tests before replying (yes, I'm quite maniac with bugs...)

I reproduced the error on three different installations: two plain etch
on powerpc (where "plain" means "Dekstop + Standard tasks, no more") and
another etch on i386 which I installed on May and then left there,
without never upgrading.

One of the two powerpc installation is still in the error state,
i.e. `apt-get dist-upgrade` produces an error.  I can put it online and
accessible via SSH only if you need it, it's a playing machine (the same
used for bug #501367 [1]), thus you can do whatever you want.  IIRC [2]
I still have the whole etch /etc folder, in case you want to analyze it.

I'm now installing etch on a QEMU image to check *again* if I can
reproduce this bug: the advantage of QEMU is that you've the -snapshot
option, thus you can test it whatever times you need.  I'll report back
as soon as the installation has finished.

Thx, bye,
Gismo / Luca

Footnotes: 
[1] http://bugs.debian.org/501367
[2] it was last week, then I worked on other stuff

[etch-i386_dist-upgrade.log.gz (application/octet-stream, attachment)]
[Message part 3 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 07 Oct 2008 13:18:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 07 Oct 2008 13:18:02 GMT) Full text and rfc822 format available.

Message #227 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: Luca Capello <luca@pca.it>
Cc: 482140@bugs.debian.org
Subject: Re: Reproducible and playing machine available
Date: Tue, 07 Oct 2008 15:17:24 +0200
Am Dienstag, den 07.10.2008, 09:53 +0200 schrieb Luca Capello:

> Some notes before starting:
> 
> 1) IMHO this bug is Severity: important, it leaves GNOME in an not
>    usable state (see attached log)

It breaks the upgrade, not GNOME. It needs manual intervention. IMHO
seeverity > important is correct.

> I reproduced the error on three different installations: two plain etch
> on powerpc (where "plain" means "Dekstop + Standard tasks, no more") and
> another etch on i386 which I installed on May and then left there,
> without never upgrading.

All installations from an Etch installation media (CD/DVD)?

> One of the two powerpc installation is still in the error state,
> i.e. `apt-get dist-upgrade` produces an error.  I can put it online and
> accessible via SSH only if you need it, it's a playing machine (the same
> used for bug #501367 [1]), thus you can do whatever you want.

I would indeed like to take a look at it.

> IIRC [2]
> I still have the whole etch /etc folder, in case you want to analyze it.

Not sure, if it is necessary. Maybe it will help.

> I'm now installing etch on a QEMU image to check *again* if I can
> reproduce this bug: the advantage of QEMU is that you've the -snapshot
> option, thus you can test it whatever times you need.  I'll report back
> as soon as the installation has finished.

Thanks. Please tell, if you can reproduce it with QEMU.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 07 Oct 2008 15:57:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert.spam@gmx.net>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 07 Oct 2008 15:57:03 GMT) Full text and rfc822 format available.

Message #232 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert.spam@gmx.net>
To: debian-perl@lists.debian.org
Cc: 482140@bugs.debian.org
Subject: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Tue, 07 Oct 2008 17:51:20 +0200
Hi all,

Examining bug #482140 I found, that update-xmlcatalog fails during
dist-upgrade from Etch to Lenny with an Error, that Functions.pm cannot
be found in @INC (the same goes for defoma-app, IIRC there Copy.pm was
not found). The paths in @INC were only the generic paths and the 5.8
paths, but the 5.10 paths were missing.

I wonder, how to solve the problem. The problem is reprosucible in my
pbuilder (Etch-)CHROOT doing:

apt-get install docbook-xml vim
apt-get install gnome

(unfortunately I cannot yet reproduce it with a smaller subset of
packages)

vim /etc/apt/sources.list (etch -> lenny)
apt-get update

Remove the `|| true' statements in /var/lib/dpkg/info/docbook-xml.prerm
and add an `set -ex' at the top and you will get the error doing:

apt-get dist-upgrade

Unfortunately I removed the log. But I will produce a new one and send
relevant parts in a second mail. I hope, I understood the log correctly.

ATM I think of using a

Pre-Depends: perl, perl-modules

for xml-core and I hope, it works. But I'm not sure. What is your
opinion?

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 07 Oct 2008 17:21:21 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert.spam@gmx.net>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 07 Oct 2008 17:21:22 GMT) Full text and rfc822 format available.

Message #237 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert.spam@gmx.net>
To: debian-perl@lists.debian.org
Cc: 482140@bugs.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Tue, 07 Oct 2008 19:18:50 +0200
Am Dienstag, den 07.10.2008, 17:51 +0200 schrieb Daniel Leidert:

> Examining bug #482140 I found, that update-xmlcatalog fails during
> dist-upgrade from Etch to Lenny with an Error, that Functions.pm cannot
> be found in @INC (the same goes for defoma-app, IIRC there Copy.pm was
> not found). The paths in @INC were only the generic paths and the 5.8
> paths, but the 5.10 paths were missing.

Here the log output:

> Preparing to replace fontconfig 2.4.2-1.2 (using .../fontconfig_2.6.0-1_i386.deb) ...
> Can't locate File/Copy.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share
> /perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/bin/defoma-app line 7.
> BEGIN failed--compilation aborted at /usr/bin/defoma-app line 7.
> dpkg: warning - old pre-removal script returned error exit status 2
> dpkg - trying script from the new package instead ...
> dpkg: ... it looks like that went OK.

and for update-xmlcatalog:

> Preparing to replace docbook-xml 4.4-5 (using .../docbook-xml_4.5-5_all.deb) ...
> Can't locate File/Spec/Functions.pm in @INC (@INC
> contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/sbin/update-xmlcatalog line 124.
> BEGIN failed--compilation aborted at /usr/sbin/update-xmlcatalog line 124.

I guess, update-xmlcatalog still fails by trying the prerm script from
the new version - we just don't see it because of the `|| true'
statements in it. And thus the bug #482140 is observed. The issue does
not occur, if perl and perl-modules are updated/installed before I try
to update docbook-xml. In this case, everything works fine.

Ideas are appreciated.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 07 Oct 2008 22:48:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Agustin Martin <agustin.martin@hispalinux.es>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 07 Oct 2008 22:48:02 GMT) Full text and rfc822 format available.

Message #242 received at 482140@bugs.debian.org (full text, mbox):

From: Agustin Martin <agustin.martin@hispalinux.es>
To: 482140@bugs.debian.org
Cc: debian-perl@lists.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Wed, 8 Oct 2008 00:45:30 +0200
[Message part 1 (text/plain, inline)]
On Tue, Oct 07, 2008 at 05:51:20PM +0200, Daniel Leidert wrote:
> Hi all,
> 
> Examining bug #482140 I found, that update-xmlcatalog fails during
> dist-upgrade from Etch to Lenny with an Error, that Functions.pm cannot
> be found in @INC (the same goes for defoma-app, IIRC there Copy.pm was
> not found). The paths in @INC were only the generic paths and the 5.8
> paths, but the 5.10 paths were missing.
> 
> I wonder, how to solve the problem. The problem is reprosucible in my
> pbuilder (Etch-)CHROOT doing:
> 
> apt-get install docbook-xml vim
> apt-get install gnome
> 
> (unfortunately I cannot yet reproduce it with a smaller subset of
> packages)

This is another thing, why this sometimes appear and sometimes not. But that
is at least something to start with. Jump to the bottom of the message if
short of time.

One for the not found score. I tried from a pbuilder (Etch-)CHROOT, installing

apt-get install w3c-dtd-xhtml docbook-xml scrollkeeper

just to try reproducing one of the contributors setup. Then change
sources.list and

apt-get update
apt-get dist-upgrade 

Upgrading suceeded (besides some manual action needed because of tzdata, I had
to enable Force-LoopBreak for apt. Nobody else found this?)

I am not at that box now, and will not be at a real box (something not too
slow) at least for a couple of days. Will try again when possible, but I
would really like to know what causes this annoyant behavior.

> vim /etc/apt/sources.list (etch -> lenny)
> apt-get update
> 
> Remove the `|| true' statements in /var/lib/dpkg/info/docbook-xml.prerm
> and add an `set -ex' at the top and you will get the error doing:
> 
> apt-get dist-upgrade
> 
> Unfortunately I removed the log. But I will produce a new one and send
> relevant parts in a second mail. I hope, I understood the log correctly.
> 
> ATM I think of using a
> 
> Pre-Depends: perl, perl-modules
> 
> for xml-core and I hope, it works. But I'm not sure. What is your
> opinion?

Looking at /usr/sbin/update-xmlcatalog, seems that only
File::Spec::Functions function used is 'catfile' whose calls should be
pretty simple to replace,

From File::Spec::Unix (where File::Spec::Functions points to)

catfile Concatenate one or more directory names and a filename to form
        a complete path ending with a filename

I am attaching a fully untested quick and dirty patch, intending to get rid
of File::Spec::Functions by replacing 'catfile' calls. 

Hope this helps,

-- 
Agustin
[update-xmlcatalog.deprecate_functions.diff (text/x-diff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Wed, 08 Oct 2008 04:12:02 GMT) Full text and rfc822 format available.

Message #245 received at 482140@bugs.debian.org (full text, mbox):

From: Damyan Ivanov <dam@modsoftsys.com>
To: Agustin Martin <agustin.martin@hispalinux.es>
Cc: 482140@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Wed, 8 Oct 2008 07:10:29 +0300
[Message part 1 (text/plain, inline)]
-=| Agustin Martin, Wed, Oct 08, 2008 at 12:45:30AM +0200 |=-
> Looking at /usr/sbin/update-xmlcatalog, seems that only
> File::Spec::Functions function used is 'catfile' whose calls should be
> pretty simple to replace,
> 
> >From File::Spec::Unix (where File::Spec::Functions points to)
> 
> catfile Concatenate one or more directory names and a filename to form
>         a complete path ending with a filename
> 
> I am attaching a fully untested quick and dirty patch, intending to get rid
> of File::Spec::Functions by replacing 'catfile' calls. 

File::Spec provides a portable way of creating filesystem paths. Your 
patch would break portability.


-- 
dam            JabberID: dam@jabber.minus273.org
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Wed, 08 Oct 2008 07:18:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Wed, 08 Oct 2008 07:18:05 GMT) Full text and rfc822 format available.

Message #250 received at 482140@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: Daniel Leidert <daniel.leidert.spam@gmx.net>
Cc: debian-perl@lists.debian.org, 482140@bugs.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Wed, 8 Oct 2008 10:17:39 +0300
On Tue, Oct 07, 2008 at 05:51:20PM +0200, Daniel Leidert wrote:
 
> Examining bug #482140 I found, that update-xmlcatalog fails during
> dist-upgrade from Etch to Lenny with an Error, that Functions.pm cannot
> be found in @INC (the same goes for defoma-app, IIRC there Copy.pm was
> not found). The paths in @INC were only the generic paths and the 5.8
> paths, but the 5.10 paths were missing.

First, please see #495359 for a discussion about the defoma-app case.
It's possible that it needs more attention.

There are no guarantees that package dependencies are in a configured
state at the 'prerm upgrade' phase. Only Essential:yes packages must
be working correctly at that point.

In this case, perl and perl-modules have already been upgraded to 5.10
but they have not been configured yet, and their dependencies (perl-base
5.10, that is) are not satisfied when the docbook-xml 'old-prerm upgrade'
gets run.

It's unfortunate that the breakage is caused by something as trivial as
File::Spec::Functions, which (AFAICS) update-xmlcatalog only uses for
exporting catfile() from File::Spec, which *is* in perl-base. There's
nothing to be done about the Etch part of this anymore, of course, but
I think this should definitely be fixed in the Lenny update-xmlcatalog.

As for fixing the upgrade issue, the options I can think of are:

- fix update-xmlcatalog in a newer xml-core version as above, then make 
  the Lenny packages using the script Pre-Depend on the fixed xml-core.
  * Somewhat ugly. 
  * All the packages using update-xmlcatalog have to be modified.

- move/add upgrade functionality from 'prerm upgrade' into 
  'postinst configure <old-version>'.
  * If I understand this correctly, new versions of each package would have
    to know the catalog information from previous versions so they know what
    to remove
  * The maintainer scripts are actually generated by dh_installxmlcatalogs
    from xml-core; this probably doesn't fit its interface
  * Again, all the packages using update-xmlcatalog have to be modified.

The first option looks by far the simpler one.

Making the Lenny xml-core pre-depend on a newer perl doesn't help,
because the upgrade is (or at least can be) done when the old xml-core
is still installed.

I can find 11 source packages in Etch/main using dh_installxmlcatalogs:
13 packages build-depend on xml-core, but two of them (ddccontrol and
pilot-qof) are false positives. The remaining ones are

docbook-ebnf
docbook-simple
docbook-slides
docbook-website
docbook-xml
docbook-xsl
openoffice.org
qa-assistant
scrollkeeper
sgml-data
w3c-dtd-xhtml

-- 
Niko Tyni   ntyni@debian.org




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Wed, 08 Oct 2008 07:54:05 GMT) Full text and rfc822 format available.

Acknowledgement sent to Raphael Hertzog <hertzog@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Wed, 08 Oct 2008 07:54:06 GMT) Full text and rfc822 format available.

Message #255 received at 482140@bugs.debian.org (full text, mbox):

From: Raphael Hertzog <hertzog@debian.org>
To: Daniel Leidert <daniel.leidert.spam@gmx.net>, Damyan Ivanov <dam@modsoftsys.com>, Agustin Martin <agustin.martin@hispalinux.es>, 482140@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Wed, 8 Oct 2008 09:50:02 +0200
On Tue, 07 Oct 2008, Daniel Leidert wrote:
> Remove the `|| true' statements in /var/lib/dpkg/info/docbook-xml.prerm
> and add an `set -ex' at the top and you will get the error doing:

A prerm cannot rely on packages being configured unless you predepend on
them. But predependencies are to be avoided. Ideally you only use stuff
from Essential in such scripts or you have sane fallback in case you
encounter problems.

> Pre-Depends: perl, perl-modules
> 
> for xml-core and I hope, it works. But I'm not sure. What is your
> opinion?

It should work but I wouldn't go for this solution. See below.

On Wed, 08 Oct 2008, Damyan Ivanov wrote:
> -=| Agustin Martin, Wed, Oct 08, 2008 at 12:45:30AM +0200 |=-
> > Looking at /usr/sbin/update-xmlcatalog, seems that only
> > File::Spec::Functions function used is 'catfile' whose calls should be
> > pretty simple to replace,
> > 
> > >From File::Spec::Unix (where File::Spec::Functions points to)
> > 
> > catfile Concatenate one or more directory names and a filename to form
> >         a complete path ending with a filename
> > 
> > I am attaching a fully untested quick and dirty patch, intending to get rid
> > of File::Spec::Functions by replacing 'catfile' calls. 
> 
> File::Spec provides a portable way of creating filesystem paths. Your 
> patch would break portability.

Not a big deal I would say. But if it's important then you can always use
this non-portable function as a fallback only:

BEGIN {
    eval 'use File::Spec';
    if ($@) {
	eval q{
	    sub catfile { return join("/", @_); }
	};
    }
}

Cheers,
-- 
Raphaël Hertzog

Le best-seller français mis à jour pour Debian Etch :
http://www.ouaza.com/livre/admin-debian/




Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Wed, 08 Oct 2008 18:30:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Agustin Martin <agustin.martin@hispalinux.es>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Wed, 08 Oct 2008 18:30:02 GMT) Full text and rfc822 format available.

Message #260 received at 482140@bugs.debian.org (full text, mbox):

From: Agustin Martin <agustin.martin@hispalinux.es>
To: 482140@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Wed, 8 Oct 2008 20:29:02 +0200
[Message part 1 (text/plain, inline)]
On Wed, Oct 08, 2008 at 09:50:02AM +0200, Raphael Hertzog wrote:
> On Wed, 08 Oct 2008, Damyan Ivanov wrote:
> > -=| Agustin Martin, Wed, Oct 08, 2008 at 12:45:30AM +0200 |=-
> > > I am attaching a fully untested quick and dirty patch, intending to get rid
> > > of File::Spec::Functions by replacing 'catfile' calls. 
> > 
> > File::Spec provides a portable way of creating filesystem paths. Your 
> > patch would break portability.
> 
> Not a big deal I would say. But if it's important then you can always use
> this non-portable function as a fallback only:
> 
> BEGIN {
>     eval 'use File::Spec';
>     if ($@) {
> 	eval q{
> 	    sub catfile { return join("/", @_); }
> 	};
>     }
> }

I like this one, although I guess you mean 'File::Spec::Functions'
instead of 'File::Spec'. 

This script is Debian-only, so full portability is not that important.
But if people strongly thinks otherwise, and 'File::Spec', from perl-base,
is properly available during all the upgrade, using it and
'File::Spec->catfile', like in attached patch, is another approach. 

This, regarding modifications to update-xmlcatalog in the short term. After
lenny this probably needs to be rewritten to work from postinst as Niko
suggests.

However, that is only one part of the problem. The other part is what
happens if docbook-xml is unpacked before new xml-core is unpacked and
before perl-modules is configured. Seems that unpacking is done in
alphabetical order (and seems that people finds this problem in
docbook-xml because it goes early in the alphabetical list), and thus,
docbook-xml goes before xml-core (at least in normal apt-get runs, did
not try with dist-upgrade), and so prerm is run with old xml-core script,
failing. I wonder why this sometimes does not fail.

I am afraid the only way to make sure is following Niko proposal about
pre-dependencies on a newer and fixed xml-core.

-- 
Agustin
[update-xmlcatalog.spec-catfile-method.diff (text/x-diff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Thu, 09 Oct 2008 21:51:07 GMT) Full text and rfc822 format available.

Acknowledgement sent to Luca Capello <luca@pca.it>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Thu, 09 Oct 2008 21:52:06 GMT) Full text and rfc822 format available.

Message #265 received at 482140@bugs.debian.org (full text, mbox):

From: Luca Capello <luca@pca.it>
To: Daniel Leidert <daniel.leidert@wgdd.de>
Cc: 482140@bugs.debian.org
Subject: Re: Reproducible and playing machine available
Date: Thu, 09 Oct 2008 23:44:48 +0200
[Message part 1 (text/plain, inline)]
Hi Daniel!

I'm sorry for being late: I was hit by two bugs during the etch
installation on QEMU [1][2] and free time is missing here.

On Tue, 07 Oct 2008 15:17:24 +0200, Daniel Leidert wrote:
> Am Dienstag, den 07.10.2008, 09:53 +0200 schrieb Luca Capello:
>> 1) IMHO this bug is Severity: important, it leaves GNOME in an not
                                 ^^^^^^^^^
Sorry, my fault, this should have been "critical".

>>    usable state (see attached log)
>
> It breaks the upgrade, not GNOME. It needs manual intervention. IMHO
> seeverity > important is correct.

It breaks GNOME, try it: I've only create one non-root user (the one d-i
asks for) and after login I get a GNOME error and cannot continue:

  The configuration could not be loaded

  You are not allowed to access the system configuration.

This means "makes unrelated software on the system (or the whole system)
break, or causes serious data loss, or introduces a security hole on
systems where you install the package" [3].

>> I reproduced the error on three different installations: two plain etch
>> on powerpc (where "plain" means "Dekstop + Standard tasks, no more") and
>> another etch on i386 which I installed on May and then left there,
>> without never upgrading.
>
> All installations from an Etch installation media (CD/DVD)?

Netinst for i386 and powerpc, businesscard for QEMU.  All etch 4.0r4

>> One of the two powerpc installation is still in the error state,
>> i.e. `apt-get dist-upgrade` produces an error.  I can put it online and
>> accessible via SSH only if you need it, it's a playing machine (the same
>> used for bug #501367 [1]), thus you can do whatever you want.
>
> I would indeed like to take a look at it.

Since it seems that you have found a way to reproduce it [4], I don't
think you still want to take a look at my powerpc machine.  In case of,
I won't touch this machine for one week.

About [4], I would have expected to be at least cc:ed: I clearly stated
in my first mail to this bug [5] that before reporting my experience I
tried different times to reproduce the bug, which means I spent my
(already small) free time on it instead of other Debian-related stuff I
like more.  Please no insult here, just a consideration.

>> IIRC [2]
>> I still have the whole etch /etc folder, in case you want to analyze it.
>
> Not sure, if it is necessary. Maybe it will help.

As above, it'll be available for one week more.

>> I'm now installing etch on a QEMU image to check *again* if I can
>> reproduce this bug: the advantage of QEMU is that you've the -snapshot
>> option, thus you can test it whatever times you need.  I'll report back
>> as soon as the installation has finished.
>
> Thanks. Please tell, if you can reproduce it with QEMU.

Because of the bugs I found [1][2] and the fact that you can now
reproduce it, I stopped working on it.  FWIW, I still have the QEMU etch
image, which I'll discard in one week from now.

Thx, bye,
Gismo / Luca

Footnotes: 
[1] http://bugs.debian.org/501723
[2] http://bugs.debian.org/501731
[3] http://www.debian.org/Bugs/Developer#severities
[4] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=482140#232
[5] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=482140#222
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Fri, 10 Oct 2008 14:18:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Agustin Martin <agmartin@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Fri, 10 Oct 2008 14:18:02 GMT) Full text and rfc822 format available.

Message #270 received at 482140@bugs.debian.org (full text, mbox):

From: Agustin Martin <agmartin@debian.org>
To: 482140@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Fri, 10 Oct 2008 16:14:27 +0200
[Message part 1 (text/plain, inline)]
On Wed, Oct 08, 2008 at 08:29:02PM +0200, Agustin Martin wrote:

> I am afraid the only way to make sure is following Niko proposal about
> pre-dependencies on a newer and fixed xml-core.

Me may be lucky and do not need any of this. See below for a possible fix.

On Tue, Oct 07, 2008 at 05:51:20PM +0200, Daniel Leidert wrote:
> Hi all,
> 
> Examining bug #482140 I found, that update-xmlcatalog fails during
> dist-upgrade from Etch to Lenny with an Error, that Functions.pm cannot
> be found in @INC (the same goes for defoma-app, IIRC there Copy.pm was
> not found). The paths in @INC were only the generic paths and the 5.8
> paths, but the 5.10 paths were missing.
> 
> I wonder, how to solve the problem. The problem is reprosucible in my
> pbuilder (Etch-)CHROOT doing:
> 
> apt-get install docbook-xml vim
> apt-get install gnome

Finally reproduced. Do not know what gnome triggers here, probably changes
package installation ordering, causing the error condition. Trying without
gnome installed I could not reproduce the error.

The *good news* are that seems I have a patch to xml-core that makes this
bug not being triggered, at least with gnome. An xml-core package with
the changes is available through

deb http://people.debian.org/~agmartin/debian-store/experimental ./

For inclusion with 'apt-key add', repository is signed with my Debian key,
available from the Debian keyring. It contains a number of changes that
should IMHO, go into xml-core,

* tools/update-xmlcatalog:
  - Use perl-base File::Spec rather than perl-modules File::Spec::Functions.
  - Call catfile as a File::Spec method instead of as a function.
* debian/rules:
  - Pass -d option to dh_perl, we no longer use anything outside perl-base.

This is important, because, unless I am wrong it was the only call to something
outside perl-base. Seems that after the change all perl modules used in
xml-core update-xmlcatalogs

File::Spec
Getopt::Long
vars

are now in perl-base (or in debhelper for Debian::Debhelper::Dh_Lib use in
dh_installxmlcatalogs), so we can drop the dependency on full perl (better
pass -d option to dh_perl, so looks for versioned dependency in perl-base
if any)

*This really needs to be double-checked*, but seems I did not miss any non
perl-base module.

* debian/rules:
  - Make sure auto-generated man pages are removed on clean target.
* tools/update-xmlcatalog:
  - Be more verbose if error is signalled on already registered entity.

As you see above, I added a couple of things in the patch. Make failure a bit
more verbose and remove auto-generated man pages from clean target.

Note that I finally used the File::Spec->catfile way, so full portability is
preserved. 

I am not a perl wizard, so I keep debian-perl cc'ed in case people there
see problems I am missing.

Not sure that this will fix all uses, but seems that at least works well
with the interaction with gnome.

For further checking, and may be (I hope not) to identify other scenarios
for this bug, I am Bcc'ing the people that reported reproducing the bug, in
case they want to try with my package. Sorry if I missed someone.

As told above, my repo is signed with my gpg key, available at the Debian
keyring.

Patch is attached.

-- 
Agustin
[xml-core_0.11_fix-update-xmlcatalogs.diff (text/x-diff, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Sat, 11 Oct 2008 09:39:09 GMT) Full text and rfc822 format available.

Acknowledgement sent to Niko Tyni <ntyni@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Sat, 11 Oct 2008 09:39:09 GMT) Full text and rfc822 format available.

Message #275 received at 482140@bugs.debian.org (full text, mbox):

From: Niko Tyni <ntyni@debian.org>
To: Agustin Martin <agmartin@debian.org>
Cc: 482140@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Sat, 11 Oct 2008 12:27:39 +0300
tag 482140 - unreproducible
thanks

On Fri, Oct 10, 2008 at 04:14:27PM +0200, Agustin Martin wrote:

> On Tue, Oct 07, 2008 at 05:51:20PM +0200, Daniel Leidert wrote:

> > Examining bug #482140 I found, that update-xmlcatalog fails during
> > dist-upgrade from Etch to Lenny with an Error, that Functions.pm cannot
> > be found in @INC (the same goes for defoma-app, IIRC there Copy.pm was
> > not found). The paths in @INC were only the generic paths and the 5.8
> > paths, but the 5.10 paths were missing.

> Finally reproduced. Do not know what gnome triggers here, probably changes
> package installation ordering, causing the error condition. Trying without
> gnome installed I could not reproduce the error.

Here's a simple recipe, starting with a clean Etch chroot:

# apt-get install docbook-xml
# sed -i s/etch/lenny/ /etc/apt/sources.list
# apt-get update
# apt-get -d install perl-modules docbook-xml
# cd /var/cache/apt/archives
# dpkg --unpack perl-modules_5.10.0-*.deb docbook-xml_4.5-5*.deb
[...]
Can't locate File/Spec/Functions.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl .) at /usr/sbin/update-xmlcatalog line 124.
BEGIN failed--compilation aborted at /usr/sbin/update-xmlcatalog line 124.
Removing obsolete conffile /etc/sgml/docbook-xml/3.1.7/dbgenent.ent ...
Unpacking replacement docbook-xml ...
# apt-get -f dist-upgrade
[...]
Setting up docbook-xml (4.5-5) ...
update-xmlcatalog: error: entity already registered
dpkg: error processing docbook-xml (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 docbook-xml

I still think the only options to fix this for sure are to change
the docbook-xml postinst or to make the package pre-depend on a fixed
xml-core.

Fortunately docbook-xml does seem to be the only package affected after all.

I've gone through my earlier list of packages using dh_installxmlcatalogs,
and there are only six packages with a newer version in Lenny than in
Etch. Out of these, all the other five can be upgraded succesfully with
the above recipe.

I think (but haven't systematically verified) that the other five
succeed because they re-register the same catalog information in the
postinst, so it doesn't matter that 'prerm upgrade' failed to remove
the old information.

(The update-xmlcatalog script only bails out with an error if asked to
 add catalog information with an existing key but different contents. If
 the key and the contents match existing data, it will just exit
 succesfully.)

For reference, the packages I've gone through are

docbook-xsl
docbook-ebnf
docbook-simple
scrollkeeper
openoffice.org-dtd-officedocument1.0
-- 
Niko Tyni   ntyni@debian.org




Tags removed: unreproducible Request was from Niko Tyni <ntyni@debian.org> to control@bugs.debian.org. (Sat, 11 Oct 2008 09:39:12 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Sat, 11 Oct 2008 13:09:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert.spam@gmx.net>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Sat, 11 Oct 2008 13:09:04 GMT) Full text and rfc822 format available.

Message #282 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert.spam@gmx.net>
To: Niko Tyni <ntyni@debian.org>
Cc: Agustin Martin <agmartin@debian.org>, 482140@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Sat, 11 Oct 2008 15:06:34 +0200
Am Samstag, den 11.10.2008, 12:27 +0300 schrieb Niko Tyni:
> On Fri, Oct 10, 2008 at 04:14:27PM +0200, Agustin Martin wrote:
> > On Tue, Oct 07, 2008 at 05:51:20PM +0200, Daniel Leidert wrote:

[..]
> Here's a simple recipe, starting with a clean Etch chroot:

Thanks.

[..]
> I still think the only options to fix this for sure are to change
> the docbook-xml postinst or to make the package pre-depend on a fixed
> xml-core.

I will go for an "and" not an "or". I will remove the 2 offending
entities in the postinst again and I will "fix" update-xmlcatalog and
make docbook-xml pre-depend on it. I hope, this will make sure, that
everything works. I will also check the Sarge package.

> Fortunately docbook-xml does seem to be the only package affected after all.

Yes, there I changed 2 entities. The other should ship only new
entities, not changed ones (at least those I maintain). But I will check
myself too (you did not test all :)).

Many thanks (to you, Agustin and the others) for your help.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 14 Oct 2008 08:36:13 GMT) Full text and rfc822 format available.

Acknowledgement sent to Mauro Lizaur <lavaramano@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 14 Oct 2008 08:36:13 GMT) Full text and rfc822 format available.

Message #287 received at 482140@bugs.debian.org (full text, mbox):

From: Mauro Lizaur <lavaramano@gmail.com>
To: 482140@bugs.debian.org
Subject: Updating from etch to lenny on 2008.10.13
Date: Tue, 14 Oct 2008 05:34:47 -0300
[Message part 1 (text/plain, inline)]
Happened the same thing as many people on this bug report:

1. Installed etch from DVD.

2. Updated the package list for Etch
   # apt-get update

3. Installed the newest versions for everything installed on Etch.
   # apt-get dist-upgrade

4. Change sources.list to get packages from Lenny
   # sed -i -e 's/etch/lenny/g' /etc/apt/sources.list

5. Update the package list for Lenny
   # apt-get update

6. Dist-Upgrade to Lenny.
   # apt-get dist-upgrade

7. Finishes to download packages and start to install them, everything
   works fine until dockbook-xml package is being installed:

    Configurando docbook-xml (4.5-5) ...
    update-xmlcatalog: error: entity already registered
    dpkg: error al procesar docbook-xml (--configure):
     el subproceso post-installation script devolvió el código de salida de error 1
    dpkg: problemas de dependencias impiden la configuración de scrollkeeper:
     scrollkeeper depende de docbook-xml (>= 4.2-11); sin embargo:
     El paquete `docbook-xml' no está configurado todavía.
    dpkg: error al procesar scrollkeeper (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-panel-data:
     gnome-panel-data depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-panel-data (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando libgnome-window-settings1 (1:2.22.2.1-2) ...
    Configurando libgnomekbd2 (2.22.0-1) ...
    Configurando libgnomekbdui2 (2.22.0-1) ...
    Configurando libnautilus-extension1 (2.20.0-7) ...
    Configurando libslab0 (0.9.8.svn.20070430-1.1) ...
    dpkg: problemas de dependencias impiden la configuración de capplets-data:
     capplets-data depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar capplets-data (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando gnome-settings-daemon (2.22.2.1-1) ...
    dpkg: problemas de dependencias impiden la configuración de gnome-control-center:
     gnome-control-center depende de capplets-data (>= 1:2.22); sin embargo:
     El paquete `capplets-data' no está configurado todavía.
     gnome-control-center depende de capplets-data (<< 1:2.23); sin embargo:
     El paquete `capplets-data' no está configurado todavía.
    dpkg: error al procesar gnome-control-center (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando gnome-about (2.22.3-2) ...
    dpkg: problemas de dependencias impiden la configuración de gnome-panel:
     gnome-panel depende de gnome-panel-data (>= 2.20); sin embargo:
     El paquete `gnome-panel-data' no está configurado todavía.
     gnome-panel depende de gnome-panel-data (<< 2.21); sin embargo:
     El paquete `gnome-panel-data' no está configurado todavía.
     gnome-panel depende de gnome-control-center (>= 1:2.8.2-3); sin embargo:
     El paquete `gnome-control-center' no está configurado todavía.
    dpkg: error al procesar gnome-panel (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de bug-buddy:
     bug-buddy depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar bug-buddy (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-session:
     gnome-session depende de gnome-control-center (>= 1:2.22); sin embargo:
     El paquete `gnome-control-center' no está configurado todavía.
    dpkg: error al procesar gnome-session (--configure):
     problemas de dependencias - se deja sin configurar


    scrollkeeper-update: deferring update until scrollkeeper is configured
    dpkg: problemas de dependencias impiden la configuración de fast-user-switch-applet:
     fast-user-switch-applet depende de gnome-panel; sin embargo:
     El paquete `gnome-panel' no está configurado todavía.
    dpkg: error al procesar fast-user-switch-applet (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando file-roller (2.22.4-2) ...
    scrollkeeper-update: deferring update until scrollkeeper is configured
    Configurando foomatic-db-gutenprint (5.0.2-4) ...
    Configurando foomatic-db-hpijs (20080211-1) ...
    Configurando python-foomatic (0.7.9.1) ...
    Configurando foomatic-gui (0.7.9.1) ...
    Configurando gcalctool (5.22.3-2) ...
    scrollkeeper-update: deferring update until scrollkeeper is configured
    Configurando gconf-editor (2.22.0-1) ...
    scrollkeeper-update: deferring update until scrollkeeper is configured
    Configurando gdebi (0.3.11debian1) ...
    Configurando libgtksourceview2.0-0 (2.2.2-1) ...
    Configurando python-gtksourceview2 (2.2.0-1+b1) ...
    dpkg: problemas de dependencias impiden la configuración de gedit:
     gedit depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gedit (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando libgucharmap6 (1:2.22.3-2) ...
    Configurando libgweather1 (2.22.3-1) ...
    dpkg: problemas de dependencias impiden la configuración de gnome-applets-data:
     gnome-applets-data depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-applets-data (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-applets:
     gnome-applets depende de gnome-applets-data (>= 2.22); sin embargo:
     El paquete `gnome-applets-data' no está configurado todavía.
     gnome-applets depende de gnome-applets-data (<< 2.23); sin embargo:
     El paquete `gnome-applets-data' no está configurado todavía.
     gnome-applets depende de gnome-panel (>= 2.13.4); sin embargo:
     El paquete `gnome-panel' no está configurado todavía.
    dpkg: error al procesar gnome-applets (--configure):
     problemas de dependencias - se deja sin configurar

    Configurando libeel2-2.20 (2.20.0-7) ...
    dpkg: problemas de dependencias impiden la configuración de nautilus-data:
     nautilus-data depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar nautilus-data (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de nautilus:
     nautilus depende de nautilus-data (>= 2.20); sin embargo:
     El paquete `nautilus-data' no está configurado todavía.
     nautilus depende de nautilus-data (<< 2.21); sin embargo:
     El paquete `nautilus-data' no está configurado todavía.
     nautilus depende de gnome-control-center (>= 2.6); sin embargo:
     El paquete `gnome-control-center' no está configurado todavía.
    dpkg: error al procesar nautilus (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de yelp:
     yelp depende de docbook-xml (>= 4.1.2); sin embargo:
     El paquete `docbook-xml' no está configurado todavía.
    dpkg: error al procesar yelp (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-core:
     gnome-core depende de gnome-control-center (>= 1:2.22.2.1); sin embargo:
     El paquete `gnome-control-center' no está configurado todavía.
     gnome-core depende de gedit (>= 2.22.3); sin embargo:
     El paquete `gedit' no está configurado todavía.
     gnome-core depende de gnome-applets (>= 2.22.2); sin embargo:
     El paquete `gnome-applets' no está configurado todavía.
     gnome-core depende de gnome-panel (>= 2.20.3); sin embargo:
     El paquete `gnome-panel' no está configurado todavía.
     gnome-core depende de gnome-session (>= 2.22.2); sin embargo:
     El paquete `gnome-session' no está configurado todavía.
     gnome-core depende de gnome-terminal (>= 2.22.2); sin embargo:
     El paquete `gnome-terminal' no está configurado todavía.
     gnome-core depende de nautilus (>= 2.20.0); sin embargo:
     El paquete `nautilus' no está configurado todavía.
     gnome-core depende de rarian-compat | scrollkeeper; sin embargo:
      El paquete `rarian-compat' no está instalado.
     El paquete `scrollkeeper' no está configurado todavía.
     gnome-core depende de yelp (>= 2.22.1); sin embargo:
     El paquete `yelp' no está configurado todavía.
    dpkg: error al procesar gnome-core (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando gnome-keyring-manager (2.20.0-1) ...


    dpkg: problemas de dependencias impiden la configuración de gnome-system-monitor:
     gnome-system-monitor depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-system-monitor (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando gnome-themes (2.22.2-1) ...
    gtk-update-icon-cache: Cache file created successfully.
    gtk-update-icon-cache: Cache file created successfully.
    dpkg: problemas de dependencias impiden la configuración de gnome-user-guide:
     gnome-user-guide depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
     gnome-user-guide depende de yelp; sin embargo:
     El paquete `yelp' no está configurado todavía.
    dpkg: error al procesar gnome-user-guide (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-utils:
     gnome-utils depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-utils (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando gnome-volume-manager (2.22.1-1) ...
    Configurando gnomebaker (0.6.4-1) ...
    scrollkeeper-update: deferring update until scrollkeeper is configured
    dpkg: problemas de dependencias impiden la configuración de grdesktop:
     grdesktop depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar grdesktop (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando libgtkhtml3.8-15 (3.12.3-3) ...


     nautilus-cd-burner depende de nautilus; sin embargo:
     El paquete `nautilus' no está configurado todavía.
    dpkg: error al procesar nautilus-cd-burner (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando openoffice.org-help-en-us (1:2.4.1-9) ...
    Configurando openoffice.org-thesaurus-en-us (1:2.4.0-2) ...
    Updating OpenOffice.org's dictionary list... done.
    Configurando printconf (0.7.9.1) ...
    Configurando seahorse (2.22.3-2) ...
    scrollkeeper-update: deferring update until scrollkeeper is configured
    Configurando sound-juicer (2.22.0-2) ...
    scrollkeeper-update: deferring update until scrollkeeper is configured
    Configurando libswfdec-0.6-90 (0.6.8-1) ...
    Configurando swfdec-gnome (2.22.2-2) ...
    Configurando type-handling (0.2.23) ...
    Configurando vinagre (0.5.1-1) ...
    scrollkeeper-update: deferring update until scrollkeeper is configured
    Configurando vino (2.22.2-1) ...
    dpkg: problemas de dependencias impiden la configuración de xorg:
     xorg depende de xterm | x-terminal-emulator; sin embargo:
      El paquete `xterm' no está instalado.
      El paquete `x-terminal-emulator' no está instalado.
      El paquete `gnome-terminal' que provee `x-terminal-emulator' aún no está configurado.
    dpkg: error al procesar xorg (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando xsane (0.995-6) ...
    Configurando xulrunner-gnome-support (1.8.0.14~pre071019b-0lenny1) ...
    Configurando xutils (1:7.3+17) ...
    rmdir: failed to remove «/etc/X11/rstart/commands/x11r6/»: No existe el fichero o el directorio
    rmdir: failed to remove «/etc/X11/rstart/commands/»: No existe el fichero o el directorio
    rmdir: failed to remove «/etc/X11/rstart/contexts/»: No existe el fichero o el directorio
    rmdir: failed to remove «/etc/X11/rstart/»: No existe el fichero o el directorio
    dpkg: problemas de dependencias impiden la configuración de zenity:
     zenity depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar zenity (--configure):
     problemas de dependencias - se deja sin configurar
    Configurando foomatic-filters-ppds (20080528-1+nmu1) ...
    invoke-rc.d: unknown initscript, /etc/init.d/cupsys not found.




    Se encontraron errores al procesar:
     docbook-xml
     scrollkeeper
     gnome-panel-data
     capplets-data
     gnome-control-center
     gnome-panel
     bug-buddy
     gnome-session
     synaptic
     gnome-terminal
     software-properties-gtk
     update-manager
     update-notifier
     fast-user-switch-applet
     gedit
     gnome-applets-data
     gnome-applets
     nautilus-data
     nautilus
     yelp
     gnome-core
     gnome-system-monitor
     gnome-user-guide
     gnome-utils
     grdesktop
     nautilus-cd-burner
     xorg
     zenity
    E: Sub-process /usr/bin/dpkg returned an error code (1)


8. So I tried to install it alone via apt-get,
   which didn't worked:


    oasis:~# apt-get install docbook-xml
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    xorg ya está en su versión más reciente.
    0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
    23 no instalados del todo o eliminados.
    After this operation, 0B of additional disk space will be used.
    Configurando docbook-xml (4.5-5) ...
    update-xmlcatalog: error: entity already registered
    dpkg: error al procesar docbook-xml (--configure):
     el subproceso post-installation script devolvió el código de salida de error 1
    dpkg: problemas de dependencias impiden la configuración de scrollkeeper:
     scrollkeeper depende de docbook-xml (>= 4.2-11); sin embargo:
     El paquete `docbook-xml' no está configurado todavía.
    dpkg: error al procesar scrollkeeper (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de capplets-data:
     capplets-data depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar capplets-data (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-applets-data:
     gnome-applets-data depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-applets-data (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-panel-data:
     gnome-panel-data depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-panel-data (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-control-center:
     gnome-control-center depende de capplets-data (>= 1:2.22); sin embargo:
     El paquete `capplets-data' no está configurado todavía.
     gnome-control-center depende de capplets-data (<< 1:2.23); sin embargo:
     El paquete `capplets-data' no está configurado todavía.
    dpkg: error al procesar gnome-control-center (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-panel:
     gnome-panel depende de gnome-panel-data (>= 2.20); sin embargo:
     El paquete `gnome-panel-data' no está configurado todavía.
     gnome-panel depende de gnome-panel-data (<< 2.21); sin embargo:
     El paquete `gnome-panel-data' no está configurado todavía.
     gnome-panel depende de gnome-control-center (>= 1:2.8.2-3); sin embargo:
     El paquete `gnome-control-center' no está configurado todavía.
    dpkg: error al procesar gnome-panel (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-applets:
     gnome-applets depende de gnome-applets-data (>= 2.22); sin embargo:
     El paquete `gnome-applets-data' no está configurado todavía.
     gnome-applets depende de gnome-applets-data (<< 2.23); sin embargo:
     El paquete `gnome-applets-data' no está configurado todavía.
     gnome-applets depende de gnome-panel (>= 2.13.4); sin embargo:
     El paquete `gnome-panel' no está configurado todavía.
    dpkg: error al procesar gnome-applets (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-session:
     gnome-session depende de gnome-control-center (>= 1:2.22); sin embargo:
     El paquete `gnome-control-center' no está configurado todavía.
    dpkg: error al procesar gnome-session (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-system-monitor:
     gnome-system-monitor depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-system-monitor (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-terminal:
     gnome-terminal depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-terminal (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de yelp:
     yelp depende de docbook-xml (>= 4.1.2); sin embargo:
     El paquete `docbook-xml' no está configurado todavía.
    dpkg: error al procesar yelp (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-user-guide:
     gnome-user-guide depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
     gnome-user-guide depende de yelp; sin embargo:
     El paquete `yelp' no está configurado todavía.
    dpkg: error al procesar gnome-user-guide (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de gnome-utils:
     gnome-utils depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar gnome-utils (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de grdesktop:
     grdesktop depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar grdesktop (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de nautilus-data:
     nautilus-data depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar nautilus-data (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de nautilus:
     nautilus depende de nautilus-data (>= 2.20); sin embargo:
     El paquete `nautilus-data' no está configurado todavía.
     nautilus depende de nautilus-data (<< 2.21); sin embargo:
     El paquete `nautilus-data' no está configurado todavía.
     nautilus depende de gnome-control-center (>= 2.6); sin embargo:
     El paquete `gnome-control-center' no está configurado todavía.
    dpkg: error al procesar nautilus (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de nautilus-cd-burner:
     nautilus-cd-burner depende de nautilus; sin embargo:
     El paquete `nautilus' no está configurado todavía.
    dpkg: error al procesar nautilus-cd-burner (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de synaptic:
     synaptic depende de scrollkeeper; sin embargo:
     El paquete `scrollkeeper' no está configurado todavía.
    dpkg: error al procesar synaptic (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de software-properties-gtk:
     software-properties-gtk depende de synaptic (>= 0.57.8); sin embargo:
     El paquete `synaptic' no está configurado todavía.
    dpkg: error al procesar software-properties-gtk (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de update-manager:
     update-manager depende de synaptic; sin embargo:
     El paquete `synaptic' no está configurado todavía.
     update-manager depende de software-properties-gtk; sin embargo:
     El paquete `software-properties-gtk' no está configurado todavía.
    dpkg: error al procesar update-manager (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de update-notifier:
     update-notifier depende de update-manager; sin embargo:
     El paquete `update-manager' no está configurado todavía.
    dpkg: error al procesar update-notifier (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de xorg:
     xorg depende de xterm | x-terminal-emulator; sin embargo:
      El paquete `xterm' no está instalado.
      El paquete `x-terminal-emulator' no está instalado.
      El paquete `gnome-terminal' que provee `x-terminal-emulator' aún no está configurado.
    dpkg: error al procesar xorg (--configure):
     problemas de dependencias - se deja sin configurar
    Se encontraron errores al procesar:
     docbook-xml
     scrollkeeper
     capplets-data
     gnome-applets-data
     gnome-panel-data
     gnome-control-center
     gnome-panel
     gnome-applets
     gnome-session
     gnome-system-monitor
     gnome-terminal
     yelp
     gnome-user-guide
     gnome-utils
     grdesktop
     nautilus-data
     nautilus
     nautilus-cd-burner
     synaptic
     software-properties-gtk
     update-manager
     update-notifier
     xorg
    E: Sub-process /usr/bin/dpkg returned an error code (1)


9. So finally I ended re-installing it using dpkg, which worked.

    oasis:~# aptitude why docbook-xml
    u   synaptic     Depende scrollkeeper
    u A scrollkeeper Depende docbook-xml (>= 4.2-11)
    oasis:~# dpkg -l | grep docbook-xml
    iF  docbook-xml                          4.5-5                       standard XML documentation system, for softw
    oasis:/var/cache/apt/archives# dpkg -i docbook-xml_4.5-5_all.deb
    (Leyendo la base de datos ...
    81768 ficheros y directorios instalados actualmente.)
    Preparando para reemplazar docbook-xml 4.5-5 (usando docbook-xml_4.5-5_all.deb) ...
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    update-xmlcatalog: error: entity not registered
    Desempaquetando el reemplazo de docbook-xml ...
    Configurando docbook-xml (4.5-5) ...
    oasis:/var/cache/apt/archives# aptitude dist-upgrade
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    Leyendo la información de estado extendido
    Inicializando el estado de los paquetes... Hecho
    Leyendo las descripciones de las tareas... Hecho
    Se configurarán los siguientes paquetes que están ahora parcialmente instalados:
      capplets-data gnome-applets gnome-applets-data gnome-control-center gnome-panel gnome-panel-data gnome-session gnome-system-monitor gnome-terminal gnome-user-guide gnome-utils
      grdesktop nautilus nautilus-cd-burner nautilus-data scrollkeeper software-properties-gtk synaptic update-manager update-notifier xorg yelp
    0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
    Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
    Configurando scrollkeeper (0.3.14-16) ...
    Instalando una nueva versión del fichero de configuración /etc/cron.monthly/scrollkeeper ...
    Rebuilding the database. This may take some time.
    Configurando capplets-data (1:2.22.2.1-2) ...
    Configurando gnome-applets-data (2.22.3-3) ...
    Instalando una nueva versión del fichero de configuración /etc/sound/events/battstat_applet.soundlist ...
    Configurando gnome-panel-data (2.20.3-5) ...
    Configurando gnome-control-center (1:2.22.2.1-2) ...
    Configurando gnome-panel (2.20.3-5) ...
    Configurando gnome-applets (2.22.3-3) ...
    Configurando gnome-session (2.22.3-1) ...
    Configurando gnome-system-monitor (2.22.3-1) ...
    Configurando gnome-terminal (2.22.3-3) ...
    Configurando yelp (2.22.1-8) ...
    Configurando gnome-user-guide (2.22.1-1) ...
    Configurando gnome-utils (2.20.0.1-2) ...
    Configurando grdesktop (0.23+d040330-1) ...
    Configurando nautilus-data (2.20.0-7) ...
    Configurando nautilus (2.20.0-7) ...
    Configurando nautilus-cd-burner (2.20.0-1) ...
    Configurando synaptic (0.62.1) ...
    Configurando software-properties-gtk (0.60.debian-1.1) ...
    Configurando update-manager (0.68.debian-6) ...
    Configurando update-notifier (0.70.7.debian-4) ...
    Configurando xorg (1:7.3+17) ...
    Processing triggers for python-support ...
    Processing triggers for menu ...
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias
    Leyendo la información de estado... Hecho
    Leyendo la información de estado extendido
    Inicializando el estado de los paquetes... Hecho
    Leyendo las descripciones de las tareas... Hecho

    oasis:/var/cache/apt/archives#



Hope it's useful to the XML/SGML group :)

Regards,
Mauro

--
JID: lavaramano@jabber.org | http://lusers.com.ar/
2B82 A38D 1BA5 847A A74D 6C34 6AB7 9ED6 C8FD F9C1
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 14 Oct 2008 12:12:04 GMT) Full text and rfc822 format available.

Acknowledgement sent to Daniel Leidert <daniel.leidert@wgdd.de>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 14 Oct 2008 12:12:04 GMT) Full text and rfc822 format available.

Message #292 received at 482140@bugs.debian.org (full text, mbox):

From: Daniel Leidert <daniel.leidert@wgdd.de>
To: 482140@bugs.debian.org
Cc: Mauro Lizaur <lavaramano@gmail.com>
Subject: Re: Bug#482140: Updating from etch to lenny on 2008.10.13
Date: Tue, 14 Oct 2008 14:09:16 +0200
Am Dienstag, den 14.10.2008, 05:34 -0300 schrieb Mauro Lizaur:
> Happened the same thing as many people on this bug report:
[..]
> Hope it's useful to the XML/SGML group :)

We already found the reason for the issue and are working on a fix.

Please send reports, if some *other* package than docbook-xml reports an
error because of an already registered entity.

Regards, Daniel





Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Tue, 14 Oct 2008 13:45:03 GMT) Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin.pitt@ubuntu.com>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Tue, 14 Oct 2008 13:45:03 GMT) Full text and rfc822 format available.

Message #297 received at 482140@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin.pitt@ubuntu.com>
To: Agustin Martin <agustin.martin@hispalinux.es>
Cc: 482140@bugs.debian.org, debian-perl@lists.debian.org
Subject: Re: etch -> lenny upgrade fails, because @INC does not contain 5.10 paths
Date: Tue, 14 Oct 2008 15:37:30 +0200
Hi all,

just for the record, I tested Agustin's patch, and it works very well.
We have a similar problem in Ubuntu with the same root cause [1], just a
slightly different apperance (we move from scrollkeeper to
rarian-compat during the upgrade, and the latter makes things blow
up).

In Debian we not affected by this case, since we don't automatically
change scrollkeeper to rarian-compat in Lenny; and after Lenny is
released, an auto-upgrade from scrollkeeper to rarian-compat in
Lenny+1 will have a fixed update-xmlcatalog in all cases. So I won't
forward any Pre-Depends: or similar change Ubuntu does to
rarian-compat to Debian.

Many thanks,

Martin

[1] https://bugs.launchpad.net/bugs/256131

-- 
Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)




Forcibly Merged 482140 502781. Request was from "Daniel Leidert" <Daniel.Leidert.Spam@gmx.net> to control@bugs.debian.org. (Sun, 19 Oct 2008 20:51:11 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>:
Bug#482140; Package docbook-xml. (Mon, 27 Oct 2008 22:30:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to Steve <nix4ever@earthlink.net>:
Extra info received and forwarded to list. Copy sent to Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>. (Mon, 27 Oct 2008 22:30:02 GMT) Full text and rfc822 format available.

Message #304 received at 482140@bugs.debian.org (full text, mbox):

From: Steve <nix4ever@earthlink.net>
To: 482140@bugs.debian.org
Subject: Same problem Etch -> Lenny upgrade
Date: Mon, 27 Oct 2008 15:28:50 -0700
$ apt-get install --reinstall docbook-xml
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission
denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you
root?
loki@link:~$ sudo apt-get install --reinstall docbook-xml
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not
upgraded.
27 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up docbook-xml (4.5-5) ...
update-xmlcatalog: error: entity already registered
dpkg: error processing docbook-xml (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of scrollkeeper:
 scrollkeeper depends on docbook-xml (>= 4.2-11); however:
  Package docbook-xml is not configured yet.
dpkg: error processing scrollkeeper (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bug-buddy:
 bug-buddy depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing bug-buddy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of capplets-data:
 capplets-data depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing capplets-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel-data:
 gnome-panel-data depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-panel-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-control-center:
 gnome-control-center depends on capplets-data (>= 1:2.22); however:
  Package capplets-data is not configured yet.
 gnome-control-center depends on capplets-data (<< 1:2.23); however:
  Package capplets-data is not configured yet.
dpkg: error processing gnome-control-center (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
 gnome-panel depends on gnome-panel-data (>= 2.20); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-panel-data (<< 2.21); however:
  Package gnome-panel-data is not configured yet.
 gnome-panel depends on gnome-control-center (>= 1:2.8.2-3); however:
  Package gnome-control-center is not configured yet.
dpkg: error processing gnome-panel (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
fast-user-switch-applet:
 fast-user-switch-applet depends on gnome-panel; however:
  Package gnome-panel is not configured yet.
dpkg: error processing fast-user-switch-applet (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gedit:
 gedit depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gedit (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-applets-data:
 gnome-applets-data depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-applets-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-applets:
 gnome-applets depends on gnome-applets-data (>= 2.22); however:
  Package gnome-applets-data is not configured yet.
 gnome-applets depends on gnome-applets-data (<< 2.23); however:
  Package gnome-applets-data is not configured yet.
 gnome-applets depends on gnome-panel (>= 2.13.4); however:
  Package gnome-panel is not configured yet.
dpkg: error processing gnome-applets (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-session:
 gnome-session depends on gnome-control-center (>= 1:2.22); however:
  Package gnome-control-center is not configured yet.
dpkg: error processing gnome-session (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-terminal:
 gnome-terminal depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-terminal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus-data:
 nautilus-data depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing nautilus-data (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus:
 nautilus depends on nautilus-data (>= 2.20); however:
  Package nautilus-data is not configured yet.
 nautilus depends on nautilus-data (<< 2.21); however:
  Package nautilus-data is not configured yet.
 nautilus depends on gnome-control-center (>= 2.6); however:
  Package gnome-control-center is not configured yet.
dpkg: error processing nautilus (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of yelp:
 yelp depends on docbook-xml (>= 4.1.2); however:
  Package docbook-xml is not configured yet.
dpkg: error processing yelp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-core:
 gnome-core depends on gnome-control-center (>= 1:2.22.2.1); however:
  Package gnome-control-center is not configured yet.
 gnome-core depends on gedit (>= 2.22.3); however:
  Package gedit is not configured yet.
 gnome-core depends on gnome-applets (>= 2.22.2); however:
  Package gnome-applets is not configured yet.
 gnome-core depends on gnome-panel (>= 2.20.3); however:
  Package gnome-panel is not configured yet.
 gnome-core depends on gnome-session (>= 2.22.2); however:
  Package gnome-session is not configured yet.
 gnome-core depends on gnome-terminal (>= 2.22.2); however:
  Package gnome-terminal is not configured yet.
 gnome-core depends on nautilus (>= 2.20.0); however:
  Package nautilus is not configured yet.
 gnome-core depends on rarian-compat | scrollkeeper; however:
  Package rarian-compat is not installed.
  Package scrollkeeper is not configured yet.
 gnome-core depends on yelp (>= 2.22.1); however:
  Package yelp is not configured yet.
dpkg: error processing gnome-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-system-monitor:
 gnome-system-monitor depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-system-monitor (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-user-guide:
 gnome-user-guide depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
 gnome-user-guide depends on yelp; however:
  Package yelp is not configured yet.
dpkg: error processing gnome-user-guide (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-utils:
 gnome-utils depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing gnome-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus-cd-burner:
 nautilus-cd-burner depends on nautilus; however:
  Package nautilus is not configured yet.
dpkg: error processing nautilus-cd-burner (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of zenity:
 zenity depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing zenity (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
gnome-desktop-environment:
 gnome-desktop-environment depends on gnome-core (= 1:2.22.2~5);
however:
  Package gnome-core is not configured yet.
 gnome-desktop-environment depends on fast-user-switch-applet (>=
2.22.0); however:
  Package fast-user-switch-applet is not configured yet.
 gnome-desktop-environment depends on gnome-system-monitor (>= 2.22.2);
however:
  Package gnome-system-monitor is not configured yet.
 gnome-desktop-environment depends on gnome-user-guide (>= 2.22.1);
however:
  Package gnome-user-guide is not configured yet.
 gnome-desktop-environment depends on gnome-utils (>= 2.20.0.1);
however:
  Package gnome-utils is not configured yet.
 gnome-desktop-environment depends on nautilus-cd-burner (>= 2.20.0);
however:
  Package nautilus-cd-burner is not configured yet.
 gnome-desktop-environment depends on zenity (>= 2.22.1); however:
  Package zenity is not configured yet.
dpkg: error processing gnome-desktop-environment (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of synaptic:
 synaptic depends on scrollkeeper; however:
  Package scrollkeeper is not configured yet.
dpkg: error processing synaptic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of
software-properties-gtk:
 software-properties-gtk depends on synaptic (>= 0.57.8); however:
  Package synaptic is not configured yet.
dpkg: error processing software-properties-gtk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of update-manager:
 update-manager depends on synaptic; however:
  Package synaptic is not configured yet.
 update-manager depends on software-properties-gtk; however:
  Package software-properties-gtk is not configured yet.
dpkg: error processing update-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on update-manager; however:
  Package update-manager is not configured yet.
dpkg: error processing update-notifier (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 docbook-xml
 scrollkeeper
 bug-buddy
 capplets-data
 gnome-panel-data
 gnome-control-center
 gnome-panel
 fast-user-switch-applet
 gedit
 gnome-applets-data
 gnome-applets
 gnome-session
 gnome-terminal
 nautilus-data
 nautilus
 yelp
 gnome-core
 gnome-system-monitor
 gnome-user-guide
 gnome-utils
 nautilus-cd-burner
 zenity
 gnome-desktop-environment
 synaptic
 software-properties-gtk
 update-manager
 update-notifier
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thats basically the same error you get dumped every time when trying to
install anything.

marvil07's post also worked for me! (HIS POST FOLLOWS):

Message #149 received at 482140@bugs.debian.org (full text, mbox):

From: marvil07 <marvil07@gmail.com>
To: 482140@bugs.debian.org
Subject: Re: [xml/sgml-pkgs] Bug#482140: docbook-xml: Package does not install: update-xmlcatalog: error: entity, already registered
Date: Thu, 3 Jul 2008 23:49:03 -0500
I'm also on a freshly-installed etch upgrading to lenny on i686 and
running the both commands:

update-xmlcatalog --del --type public --id '-//OASIS//DTD DocBook XML
V4.1//EN' --package docbook-xml
update-xmlcatalog --del --type public --id '-//OASIS//DTD XML Exchange
Table Model 19990315//EN' --package docbook-xml

solve the problem.
___________________________

Marco Antonio Villegas Vega
http://blog.pucp.edu.pe/marvil07

PS. sorry if this isnt in the right format or politically correct
hopefully his post wont go unnoticed with this repeat.





Reply sent to Daniel Leidert (dale) <daniel.leidert@wgdd.de>:
You have taken responsibility. (Tue, 28 Oct 2008 11:24:03 GMT) Full text and rfc822 format available.

Notification sent to Sami Liedes <sliedes@cc.hut.fi>:
Bug acknowledged by developer. (Tue, 28 Oct 2008 11:24:03 GMT) Full text and rfc822 format available.

Message #309 received at 482140-close@bugs.debian.org (full text, mbox):

From: Daniel Leidert (dale) <daniel.leidert@wgdd.de>
To: 482140-close@bugs.debian.org
Subject: Bug#482140: fixed in docbook-xml 4.5-6
Date: Tue, 28 Oct 2008 10:27:36 +0000
Source: docbook-xml
Source-Version: 4.5-6

We believe that the bug you reported is fixed in the latest version of
docbook-xml, which is due to be installed in the Debian FTP archive:

docbook-xml_4.5-6.diff.gz
  to pool/main/d/docbook-xml/docbook-xml_4.5-6.diff.gz
docbook-xml_4.5-6.dsc
  to pool/main/d/docbook-xml/docbook-xml_4.5-6.dsc
docbook-xml_4.5-6_all.deb
  to pool/main/d/docbook-xml/docbook-xml_4.5-6_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 482140@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Leidert (dale) <daniel.leidert@wgdd.de> (supplier of updated docbook-xml package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sun, 26 Oct 2008 15:13:10 +0100
Source: docbook-xml
Binary: docbook-xml
Architecture: source all
Version: 4.5-6
Distribution: unstable
Urgency: low
Maintainer: Debian XML/SGML Group <debian-xml-sgml-pkgs@lists.alioth.debian.org>
Changed-By: Daniel Leidert (dale) <daniel.leidert@wgdd.de>
Description: 
 docbook-xml - standard XML documentation system, for software and systems
Closes: 482140
Changes: 
 docbook-xml (4.5-6) unstable; urgency=low
 .
   * debian/compat: Raised to v5.
   * debian/control: Vcs fields transition. Added DM-Upload-Allowed.
     (Vcs-Svn): Fixed location.
     (Build-Depends): Raised debhelper to v5.
     (Depends): Moved xml-core to Pre-Depends and increased the version to 0.12
     (closes: #482140).
     (Standards-Version): Raised to 3.7.3.
   * debian/rules (debian/docbook-xml.install): Fixed to not put non-existent
     files into the .install file.
     (debian/docbook-xml.xmlcatalogs): Use `sed -i' and do not create a
     temporary file.
   * debian/source.lintian-overrides: Added to override
     patch-system-but-direct-changes-in-diff warning, because file creation is
     intended.
Checksums-Sha1: 
 68b92c15f02f4f8dacc9422d377ed612b5e26c99 1360 docbook-xml_4.5-6.dsc
 e9b51f69a434a01e4958f66c9f02eb2babc280b4 22059 docbook-xml_4.5-6.diff.gz
 8bb8f3d77c37feec07d8741e3475a5668f752384 344524 docbook-xml_4.5-6_all.deb
Checksums-Sha256: 
 38154040e8edd4dae1d7adc25b414e4d52842a3c823efaf77a68e1737a6a9755 1360 docbook-xml_4.5-6.dsc
 dc7e54c743140feccdd0a9ce69ad1c0860c5959ce97f4d25de20e6e58dc14de5 22059 docbook-xml_4.5-6.diff.gz
 056aff9e8ed20753035cd42f44ad26f6f8ab0cb2ab9da9c686744979b9c1a138 344524 docbook-xml_4.5-6_all.deb
Files: 
 7b31a7d0ca136613b423e1afe00f19cc 1360 text optional docbook-xml_4.5-6.dsc
 308664c0b3dca46430e0f47731323f0a 22059 text optional docbook-xml_4.5-6.diff.gz
 a61a49447bb3888c04a9ef07af0d6487 344524 text optional docbook-xml_4.5-6_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQFJBlwFmHaJYZ7RAb8RAu00AJ9+PMZEH+1iPMqwzxeiIL6NsKPdhQCfYYEG
wTwR59M8Ut/2Wf3zZZx7nSQ=
=aSQW
-----END PGP SIGNATURE-----





Reply sent to Daniel Leidert (dale) <daniel.leidert@wgdd.de>:
You have taken responsibility. (Tue, 28 Oct 2008 11:24:04 GMT) Full text and rfc822 format available.

Notification sent to sylvain cherrier <sylvain.cherrier@free.fr>:
Bug acknowledged by developer. (Tue, 28 Oct 2008 11:24:04 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 07 Dec 2008 07:27:59 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 16:51:24 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.