Debian Bug report logs - #460915
perl-modules: Please Provides/Replaces/Conflicts libversion-perl

version graph

Package: perl-modules; Maintainer for perl-modules is Niko Tyni <ntyni@debian.org>; Source for perl-modules is src:perl.

Reported by: gregor herrmann <gregor+debian@comodo.priv.at>

Date: Tue, 15 Jan 2008 16:09:05 UTC

Severity: important

Found in version perl/5.10.0-2

Fixed in version perl/5.10.0-3

Done: Brendan O'Dea <bod@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Brendan O'Dea <bod@debian.org>:
Bug#460915; Package perl-modules. Full text and rfc822 format available.

Acknowledgement sent to gregor herrmann <gregor+debian@comodo.priv.at>:
New Bug report received and forwarded. Copy sent to Brendan O'Dea <bod@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: gregor herrmann <gregor+debian@comodo.priv.at>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: perl-modules: Please Provides/Replaces/Conflicts libversion-perl
Date: Tue, 15 Jan 2008 17:08:30 +0100
Package: perl-modules
Version: 5.10.0-2
Severity: important

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


When trying to rebuild some lib*-perl packages against perl 5.10 from
experimental I noticed that a couple of modules directly or
indirectly build depend on libversion-perl; libversion-perl has a
"Depends: perl (<< 5.9)" (with a notice that it will be in perl 5.10)
- -- which make the rebuilding efforts a little difficult :)

AFAICS version.pm is in perl-modules 5.10 (perl-modules:
/usr/share/perl/5.10.0/version.pm); please add a
Provides/Replaces/Conflicts like it's there for some other modules.

(Setting severity to important because of the effects on other
packages, feel free to adjust.)

Thanks in advance,
gregor

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHjNp9OzKYnQDzz+QRAmEaAJ49EIvFQeI/V6h2eGr6K6QVCELMSACg0zC5
TaU3r10wwVd24+KHSbPa53Y=
=dN58
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#460915; Package perl-modules. Full text and rfc822 format available.

Acknowledgement sent to Brendan O'Dea <bod@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #10 received at 460915@bugs.debian.org (full text, mbox):

From: Brendan O'Dea <bod@debian.org>
To: gregor herrmann <gregor+debian@comodo.priv.at>, 460915@bugs.debian.org
Subject: Re: Bug#460915: perl-modules: Please Provides/Replaces/Conflicts libversion-perl
Date: Sun, 27 Jan 2008 12:38:14 +1100
On Tue, Jan 15, 2008 at 05:08:30PM +0100, gregor herrmann wrote:
>AFAICS version.pm is in perl-modules 5.10 (perl-modules:
>/usr/share/perl/5.10.0/version.pm); please add a
>Provides/Replaces/Conflicts like it's there for some other modules.

Thanks, done.

--bod




Reply sent to Brendan O'Dea <bod@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to gregor herrmann <gregor+debian@comodo.priv.at>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #15 received at 460915-close@bugs.debian.org (full text, mbox):

From: Brendan O'Dea <bod@debian.org>
To: 460915-close@bugs.debian.org
Subject: Bug#460915: fixed in perl 5.10.0-3
Date: Mon, 28 Jan 2008 01:47:06 +0000
Source: perl
Source-Version: 5.10.0-3

We believe that the bug you reported is fixed in the latest version of
perl, which is due to be installed in the Debian FTP archive:

libcgi-fast-perl_5.10.0-3_all.deb
  to pool/main/p/perl/libcgi-fast-perl_5.10.0-3_all.deb
libperl-dev_5.10.0-3_amd64.deb
  to pool/main/p/perl/libperl-dev_5.10.0-3_amd64.deb
libperl5.10_5.10.0-3_amd64.deb
  to pool/main/p/perl/libperl5.10_5.10.0-3_amd64.deb
perl-base_5.10.0-3_amd64.deb
  to pool/main/p/perl/perl-base_5.10.0-3_amd64.deb
perl-debug_5.10.0-3_amd64.deb
  to pool/main/p/perl/perl-debug_5.10.0-3_amd64.deb
perl-doc_5.10.0-3_all.deb
  to pool/main/p/perl/perl-doc_5.10.0-3_all.deb
perl-modules_5.10.0-3_all.deb
  to pool/main/p/perl/perl-modules_5.10.0-3_all.deb
perl-suid_5.10.0-3_amd64.deb
  to pool/main/p/perl/perl-suid_5.10.0-3_amd64.deb
perl_5.10.0-3.diff.gz
  to pool/main/p/perl/perl_5.10.0-3.diff.gz
perl_5.10.0-3.dsc
  to pool/main/p/perl/perl_5.10.0-3.dsc
perl_5.10.0-3_amd64.deb
  to pool/main/p/perl/perl_5.10.0-3_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 460915@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Brendan O'Dea <bod@debian.org> (supplier of updated perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 28 Jan 2008 11:58:25 +1100
Source: perl
Binary: perl-base libperl5.10 libcgi-fast-perl libperl-dev perl-debug perl-modules perl perl-suid perl-doc
Architecture: source all amd64
Version: 5.10.0-3
Distribution: experimental
Urgency: low
Maintainer: Brendan O'Dea <bod@debian.org>
Changed-By: Brendan O'Dea <bod@debian.org>
Description: 
 libcgi-fast-perl - CGI::Fast Perl module
 libperl-dev - Perl library: development files
 libperl5.10 - Shared Perl library
 perl       - Larry Wall's Practical Extraction and Report Language
 perl-base  - The Pathologically Eclectic Rubbish Lister
 perl-debug - Debug-enabled Perl interpreter
 perl-doc   - Perl documentation
 perl-modules - Core Perl modules
 perl-suid  - Runs setuid Perl scripts
Closes: 49669 459841 460915
Changes: 
 perl (5.10.0-3) experimental; urgency=low
 .
   * New version fixes retains pos after localizing target (closes: #49669).
   * Add conflicts/replaces/provides for libperl-version (closes: #460915).
   * Correct typo in CGI.pm documentaion (closes: #459841).
   * Modify MakeMaker install target dependencies to facilitate parallel makes.
Files: 
 887a1eb2764ee2cf639b670eee42bb57 775 perl standard perl_5.10.0-3.dsc
 16062b41dd2652747765465ffb97ab14 76451 perl standard perl_5.10.0-3.diff.gz
 80384289ef30f1a15cea14cc162ad2da 41558 perl optional libcgi-fast-perl_5.10.0-3_all.deb
 110741c32552dd79072dba1551700a53 8202492 doc optional perl-doc_5.10.0-3_all.deb
 8b50b724fefcff53e16cc4be2843836f 3272554 perl standard perl-modules_5.10.0-3_all.deb
 0ee79c47f86b873f700afa218d523a31 919396 perl required perl-base_5.10.0-3_amd64.deb
 630cdd1d111dc0ce4af59fb003cdf3b3 3610422 perl optional perl-debug_5.10.0-3_amd64.deb
 c809ba542e41025cb27ec4e94da265b1 31444 perl optional perl-suid_5.10.0-3_amd64.deb
 586561817864fc567857376f02c49add 1004 libs optional libperl5.10_5.10.0-3_amd64.deb
 fb3245218883feacbb99a24f079e8645 728190 libdevel optional libperl-dev_5.10.0-3_amd64.deb
 104ab5880f53e97e5f7bf50e8680b8ff 5226814 perl standard perl_5.10.0-3_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (Darwin)

iD8DBQFHnTE58NyOALKMWZURAiJhAKDVGwttEKp///LfxgE7V7POFgQqrACg0wca
pNV1Sl1k6/YuWgYE7uzidUc=
=AfJx
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 25 Feb 2008 07:28:19 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 08:39:12 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.