Debian Bug report logs - #455283
konqueror-nsplugins: nspluginviewer does not yet support newest Adobe Flash Player

version graph

Package: konqueror-nsplugins; Maintainer for konqueror-nsplugins is Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>; Source for konqueror-nsplugins is src:kde-baseapps.

Reported by: David Baron <d_baron@012.net.il>

Date: Sun, 9 Dec 2007 17:18:02 UTC

Severity: important

Fixed in version 4:3.5.5a.dfsg.1-6etch2

Done: Philippe Cloutier <chealer@gmail.com>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#455283; Package flashplugin-nonfree. Full text and rfc822 format available.

Acknowledgement sent to David Baron <d_baron@012.net.il>:
New Bug report received and forwarded. Copy sent to Bart Martens <bartm@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: David Baron <d_baron@012.net.il>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: flashplugin: Crashes Konqueror nspluginviewer
Date: Sun, 09 Dec 2007 19:15:21 +0200
Package: flashplugin-nonfree
Version: 9.0.115.0.1
Severity: grave
File: flashplugin
Justification: renders package unusable

Get multiple crashes (KDE) viewing pages in Konqueror.

Here is the backtrace (not very illuminating since this is release):
Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".[Thread
debugging using libthread_db enabled][New Thread 0xb60ab6e0 (LWP 23414)][New
Thread 0xb32e3b90 (LWP 23419)][New Thread 0xb3baab90 (LWP 23418)][KCrash
handler]#6  0xb6bf2af7 in XtRemoveTimeOut () from /usr/lib/libXt.so.6#7
0xb542edb1 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so#8
0xb5424338 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so#9
0xb541d181 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so#10
0xb5421937 in ?? () from /usr/lib/mozilla/plugins/libflashplayer.so#11
0x080ebbe8 in ?? ()#12 0xbfebd2fc in ?? ()#13 0x080ec0b0 in ?? ()#14
0x080ec0b0 in ?? ()#15 0xbfebd2e8 in ?? ()#16 0x080ec0b0 in ?? ()#17
0xbfebd318 in ?? ()#18 0x08062911 in NSPluginInstance::destroy 

PCVersions of packages flashplugin-nonfree depends on:
ii  debconf [debconf-2.0]   1.5.17           Debian configuration management 
sy
ii  fontconfig              2.5.0-2          generic font configuration 
library
ii  libatk1.0-0             1.20.0-1         The ATK accessibility toolkit
ii  libc6                   2.7-4            GNU C Library: Shared libraries
ii  libcairo2               1.4.10-1.2       The Cairo 2D vector graphics 
libra
ii  libexpat1               1.95.8-4         XML parsing C library - runtime 
li
ii  libfontconfig1          2.5.0-2          generic font configuration 
library
ii  libfreetype6            2.3.5-1+b1       FreeType 2 font engine, shared 
lib
ii  libglib2.0-0            2.14.4-2         The GLib library of C routines
ii  libgtk2.0-0             2.12.3-1         The GTK+ graphical user interface 
ii  libice6                 2:1.0.4-1        X11 Inter-Client Exchange library
ii  libpango1.0-0           1.18.3-1         Layout and rendering of 
internatio
ii  libpng12-0              1.2.15~beta5-3   PNG library - runtime
ii  libsm6                  2:1.0.3-1+b1     X11 Session Management library
ii  libx11-6                2:1.0.3-7        X11 client-side library
ii  libxau6                 1:1.0.3-2        X11 authorisation library
ii  libxcursor1             1:1.1.9-1        X cursor management library
ii  libxdmcp6               1:1.0.2-2        X11 Display Manager Control 
Protoc
ii  libxext6                1:1.0.3-2        X11 miscellaneous extension 
librar
ii  libxfixes3              1:4.0.3-2        X11 miscellaneous 'fixes' 
extensio
ii  libxi6                  2:1.1.3-1        X11 Input extension library
ii  libxinerama1            1:1.0.2-1        X11 Xinerama extension library
ii  libxrandr2              2:1.2.2-1        X11 RandR extension library
ii  libxrender1             1:0.9.4-1        X Rendering Extension client 
libra
ii  libxt6                  1:1.0.5-3        X11 toolkit intrinsics library
ii  wget                    1.10.2-3         retrieves files from the web
ii  zlib1g                  1:1.2.3.3.dfsg-7 compression library - runtime

flashplugin-nonfree recommends no packages.

-- debconf information:
  flashplugin-nonfree/httpget: false
* flashplugin-nonfree/not_exist:
  flashplugin-nonfree/local:





Severity set to `important' from `grave' Request was from Bart Martens <bartm@knars.be> to control@bugs.debian.org. (Tue, 11 Dec 2007 16:45:02 GMT) Full text and rfc822 format available.

Reply sent to Bart Martens <bartm@knars.be>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to David Baron <d_baron@012.net.il>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #12 received at 455283-done@bugs.debian.org (full text, mbox):

From: Bart Martens <bartm@knars.be>
To: 455283-done@bugs.debian.org
Subject: flashplugin-nonfree: md5sum mismatch
Date: Tue, 11 Dec 2007 17:45:04 +0100
[Message part 1 (text/plain, inline)]
Now documented on http://wiki.debian.org/FlashPlayer :

Supported versions
      * flashplugin-nonfree version 9.0.115.0.1~bpo40+1 : Should work on
        Debian Etch (stable). 
      * flashplugin-nonfree version 9.0.115.0.1 : Should work on Debian
        Lenny (testing) and should work on Debian Sid (unstable). 

If you use any other version, then you are strongly advised to remove
all instances of libflashplayer.so on your system at once for security
reasons.

[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#455283; Package flashplugin-nonfree. Full text and rfc822 format available.

Acknowledgement sent to Craig Howard <craig@choward.ca>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. Full text and rfc822 format available.

Message #17 received at 455283@bugs.debian.org (full text, mbox):

From: Craig Howard <craig@choward.ca>
To: 455283@bugs.debian.org
Subject: flashplugin: Crashes Konqueror nspluginviewer
Date: Tue, 11 Dec 2007 23:42:32 -0800
I'm seeing this too.  I've got the latest of everything in unstable as of Dec 
11.  The closing email doesn't seem to match this bug, was it closed in 
error?
-- 

Craig Howard
craig@choward.ca
Software Engineer - Amazon.com
BMath CompSci - University of Waterloo




Bug reopened, originator not changed. Request was from Bart Martens <bartm@knars.be> to control@bugs.debian.org. (Wed, 12 Dec 2007 08:42:02 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#455283; Package flashplugin-nonfree. Full text and rfc822 format available.

Acknowledgement sent to Paolo Saggese <NO.SPAM@lngs.infn.it>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. Full text and rfc822 format available.

Message #24 received at 455283@bugs.debian.org (full text, mbox):

From: Paolo Saggese <NO.SPAM@lngs.infn.it>
To: Debian Bug Tracking System <455283@bugs.debian.org>
Subject: flashplugin-nonfree: same problem here
Date: Mon, 17 Dec 2007 18:03:29 +0100
Package: flashplugin-nonfree
Version: 9.0.115.0.1~bpo40+1
Followup-For: Bug #455283


not much more to say... after the last flashplugin-nonfree 
update, the plugin no longer works in Konqueror. 

The page loads displaying only grey backround(s) in place of 
any flash content. When leaving the page, a KDE crash report 
message appears.

The same happens on all my Etch boxes with flashplugin-nonfree 
from backpors.org.


-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (900, 'stable'), (90, 'unstable'), (7, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-5-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages flashplugin-nonfree depends on:
ii  debconf [debconf-2.0]  1.5.11            Debian configuration management sy
ii  fontconfig             2.4.2-1.2         generic font configuration library
ii  libatk1.0-0            1.12.4-3          The ATK accessibility toolkit
ii  libc6                  2.3.6.ds1-13etch2 GNU C Library: Shared libraries
ii  libcairo2              1.2.4-4           The Cairo 2D vector graphics libra
ii  libexpat1              1.95.8-3.4        XML parsing C library - runtime li
ii  libfontconfig1         2.4.2-1.2         generic font configuration library
ii  libfreetype6           2.2.1-5+etch1     FreeType 2 font engine, shared lib
ii  libglib2.0-0           2.12.4-2          The GLib library of C routines
ii  libgtk2.0-0            2.8.20-7          The GTK+ graphical user interface 
ii  libice6                1:1.0.1-2         X11 Inter-Client Exchange library
ii  libpango1.0-0          1.14.8-5          Layout and rendering of internatio
ii  libpng12-0             1.2.15~beta5-1    PNG library - runtime
ii  libsm6                 1:1.0.1-3         X11 Session Management library
ii  libx11-6               2:1.0.3-7         X11 client-side library
ii  libxau6                1:1.0.1-2         X11 authorisation library
ii  libxcursor1            1.1.7-4           X cursor management library
ii  libxdmcp6              1:1.0.1-2         X11 Display Manager Control Protoc
ii  libxext6               1:1.0.1-2         X11 miscellaneous extension librar
ii  libxfixes3             1:4.0.1-5         X11 miscellaneous 'fixes' extensio
ii  libxi6                 1:1.0.1-4         X11 Input extension library
ii  libxinerama1           1:1.0.1-4.1       X11 Xinerama extension library
ii  libxrandr2             2:1.1.0.2-5       X11 RandR extension library
ii  libxrender1            1:0.9.1-3         X Rendering Extension client libra
ii  libxt6                 1:1.0.2-2         X11 toolkit intrinsics library
ii  wget                   1.10.2-2          retrieves files from the web
ii  zlib1g                 1:1.2.3-13        compression library - runtime

flashplugin-nonfree recommends no packages.

-- debconf information:
  flashplugin-nonfree/httpget: false
  flashplugin-nonfree/not_exist:
  flashplugin-nonfree/local:




Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#455283; Package flashplugin-nonfree. Full text and rfc822 format available.

Acknowledgement sent to Nils <linuxuser@knabber.homelinux.net>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. Full text and rfc822 format available.

Message #29 received at 455283@bugs.debian.org (full text, mbox):

From: Nils <linuxuser@knabber.homelinux.net>
To: 455283@bugs.debian.org
Subject: flashplugin: Crashes Konqueror nspluginviewer
Date: Wed, 19 Dec 2007 08:03:42 +0100
Package: flashplugin-nonfree
Version: 9.0.115.0.1
Followup-For: Bug #455283
Debian Release: lenny/sid
Architecture: i386 (i686)
Kernel: Linux-2.6.23.9

I have the problem after upgrading the flashplugin-nonfree, too. I find in 
the .xsession-errors the same Gtk-Error which is described in the bug report 
#456538 for the opera browser:

(process:20276): Gtk-CRITICAL **: gtk_clipboard_get_for_display: assertion 
`display != NULL' failed
Adobe Flash Player: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying 
to call gtk_init(0,0);

After this the nspluginviewer crashs:

KCrash: Application 'nspluginviewer' crashing...
DCOP aborting call from 'konqueror-18377' to 'nspluginviewer-18377'
ASSERT: "!icon.isEmpty()" 
in /tmp/buildd/kdebase-3.5.8.dfsg.1/./libkonq/konq_pixmapprovider.cc (81)






Information forwarded to debian-bugs-dist@lists.debian.org, Bart Martens <bartm@debian.org>:
Bug#455283; Package flashplugin-nonfree. Full text and rfc822 format available.

Acknowledgement sent to Philippe Cloutier <chealer@gmail.com>:
Extra info received and forwarded to list. Copy sent to Bart Martens <bartm@debian.org>. Full text and rfc822 format available.

Message #34 received at 455283@bugs.debian.org (full text, mbox):

From: Philippe Cloutier <chealer@gmail.com>
To: debian-release@lists.debian.org, 455283@bugs.debian.org
Subject: Re: flashplugin-nonfree in etch
Date: Thu, 27 Dec 2007 16:45:01 -0500
Le December 19, 2007 04:28:38 pm Scott Kitterman, vous avez écrit :
> On Wednesday 19 December 2007 12:06, Holger Levsen wrote:
> > Hi,
> >
> > I would like to know what the stable release managers plan to do
> > regarding flashplugin-nonfree in etch.
> >
> > As I see it, there are three options:
> >
> > 1. do nothing, keep a broken package in etch
> >
> > 2. remove the broken package from etch
> >
> > 3. request another upload, as the version currently in stable-proposed
> > updates has broken since it was uploaded (which was before r1)
> >
> >
> > Additionally I would like to ("officially") ask the volatile team about
> > their opinion of including flashplugin-nonfree in volatile/contrib. As I
> > read the requierements for volatile, the package fully fulfills them.
> > (The package is rock stable and just an installer for (the latest)
> > nonfree flash (from adobe) - so it does exactly what the users expect.)
>
> The new Flash is *known* to break konqueror but works as intended on
> FireFox, the reason for this is konqueror does not support XEmbed.  For a
> stable distribution, I'm not sure what the best solution would be.

This problem was reported against flashplugin-nonfree at 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=455283

What happened with this? Was it introduced in 4.0r2, the same way as in 
testing? I have no etch install, but I checked the changelog and the package 
a bit and I saw nothing mitigating this bug. There were more than 10 
duplicates of the bug report requesting XEmbed support in upstream konqueror 
nsplugins opened in the last 2 weeks.




Bug reassigned from package `flashplugin-nonfree' to `konqueror-nsplugins'. Request was from Bart Martens <bartm@knars.be> to control@bugs.debian.org. (Fri, 28 Dec 2007 17:42:02 GMT) Full text and rfc822 format available.

Changed Bug title to `konqueror-nsplugins: nspluginviewer does not yet support newest Adobe Flash Player' from `flashplugin: Crashes Konqueror nspluginviewer'. Request was from Bart Martens <bartm@knars.be> to control@bugs.debian.org. (Fri, 28 Dec 2007 17:42:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>:
Bug#455283; Package konqueror-nsplugins. Full text and rfc822 format available.

Acknowledgement sent to Raúl Sánchez Siles <rasasi78@gmail.com>:
Extra info received and forwarded to list. Copy sent to Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>. Full text and rfc822 format available.

Message #43 received at 455283@bugs.debian.org (full text, mbox):

From: Raúl Sánchez Siles <rasasi78@gmail.com>
To: 455283@bugs.debian.org
Subject: It works for me.
Date: Sat, 9 Feb 2008 01:35:09 +0100
[Message part 1 (text/plain, inline)]
  Hello:

  I don't know about you for me flash is working correctly on amd64 and almost 
correctly on i386.

  I have kdelibs and kdebase 4:3.5.8.dfsg.1-7 on unstable with 
flashplugin-nonfree 1.1.3.

  I would like to hear any feedback to check if this is finally solved.

  BTW, I've known that upstream included a yet newer patch solving some minor 
issues, maybe we could see it on 3.5.8..dfsg.1-8

  Thanks.

-- 
     Raúl Sánchez Siles
----->Proud Debian user<-----
Linux registered user #416098
[signature.asc (application/pgp-signature, inline)]

Reply sent to Philippe Cloutier <chealer@gmail.com>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to David Baron <d_baron@012.net.il>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #48 received at 455283-close@bugs.debian.org (full text, mbox):

From: Philippe Cloutier <chealer@gmail.com>
To: 455283-close@bugs.debian.org
Subject: Fixed
Date: Wed, 27 Feb 2008 17:48:11 -0500
Version: 4:3.5.5a.dfsg.1-6etch2

Well, it does look like this affected 4.0r2 - but it was fixed in 4.0r3. Note 
that flashplugin-nonfree was removed from etch in 4.0r3, though.
Thanks Fathi.




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 27 Mar 2008 07:38:25 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 19:30:58 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.