Debian Bug report logs - #447492
wordpress: should depend on php4-gd | php5-gd

version graph

Package: wordpress; Maintainer for wordpress is Craig Small <csmall@debian.org>; Source for wordpress is src:wordpress.

Reported by: Russell Coker <russell@coker.com.au>

Date: Sun, 21 Oct 2007 15:39:01 UTC

Severity: normal

Found in version wordpress/2.3-1

Fixed in version wordpress/2.3.1-1

Done: Kai Hendry <hendry@iki.fi>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Kai Hendry <hendry@iki.fi>:
Bug#447492; Package wordpress. Full text and rfc822 format available.

Acknowledgement sent to Russell Coker <russell@coker.com.au>:
New Bug report received and forwarded. Copy sent to Kai Hendry <hendry@iki.fi>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Russell Coker <russell@coker.com.au>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: wordpress: should depend on php4-gd | php5-gd
Date: Mon, 22 Oct 2007 01:36:09 +1000
Package: wordpress
Version: 2.3-1
Severity: normal

Image uploads is a commonly used blog feature.  Thumbnails of images is a
standard feature.  If php4-gd | php5-gd is not installed then the Thumbnails
silently don't work and there is no explanation why.  The case where this
functionality is not needed is rare, the benefit of not having the library
installed is small.  The pain involved in tracking this down when Wordpress
just refuses to create thumbnails is immense.

Therefore I believe that php4-gd | php5-gd should be a dependency.

Having virtual-mysql-server be a suggestion however is fine as Wordpress
will notify you if it can't contact a database.




Information forwarded to debian-bugs-dist@lists.debian.org, Kai Hendry <hendry@iki.fi>:
Bug#447492; Package wordpress. Full text and rfc822 format available.

Acknowledgement sent to "Kai Hendry" <hendry@iki.fi>:
Extra info received and forwarded to list. Copy sent to Kai Hendry <hendry@iki.fi>. Full text and rfc822 format available.

Message #10 received at 447492@bugs.debian.org (full text, mbox):

From: "Kai Hendry" <hendry@iki.fi>
To: "Russell Coker" <russell@coker.com.au>, 447492@bugs.debian.org
Subject: Re: Bug#447492: wordpress: should depend on php4-gd | php5-gd
Date: Thu, 25 Oct 2007 17:44:31 +0100
Thanks for the bug report Russell. I will fix it when 2.3.1 comes out. Cheers,




Reply sent to Kai Hendry <hendry@iki.fi>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Russell Coker <russell@coker.com.au>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #15 received at 447492-close@bugs.debian.org (full text, mbox):

From: Kai Hendry <hendry@iki.fi>
To: 447492-close@bugs.debian.org
Subject: Bug#447492: fixed in wordpress 2.3.1-1
Date: Tue, 30 Oct 2007 18:02:10 +0000
Source: wordpress
Source-Version: 2.3.1-1

We believe that the bug you reported is fixed in the latest version of
wordpress, which is due to be installed in the Debian FTP archive:

wordpress_2.3.1-1.diff.gz
  to pool/main/w/wordpress/wordpress_2.3.1-1.diff.gz
wordpress_2.3.1-1.dsc
  to pool/main/w/wordpress/wordpress_2.3.1-1.dsc
wordpress_2.3.1-1_all.deb
  to pool/main/w/wordpress/wordpress_2.3.1-1_all.deb
wordpress_2.3.1.orig.tar.gz
  to pool/main/w/wordpress/wordpress_2.3.1.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 447492@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Kai Hendry <hendry@iki.fi> (supplier of updated wordpress package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 28 Oct 2007 17:20:12 +0000
Source: wordpress
Binary: wordpress
Architecture: source all
Version: 2.3.1-1
Distribution: unstable
Urgency: high
Maintainer: Kai Hendry <hendry@iki.fi>
Changed-By: Kai Hendry <hendry@iki.fi>
Description: 
 wordpress  - an award winning weblog manager
Closes: 447492
Changes: 
 wordpress (2.3.1-1) unstable; urgency=high
 .
   * New upstream security release
   * http://wordpress.org/development/2007/10/wordpress-231/
   * should depend on php4-gd | php5-gd (Closes: #447492)
     php4-gd | php5-gd moves from suggests to depends
   * Bugs closed in this release:
     http://trac.wordpress.org/query?status=closed&milestone=2.3.1
Files: 
 629f9aac54b549169047a1c85123bcca 558 web optional wordpress_2.3.1-1.dsc
 bd53264cbe80e470c5a9bc2cf7aa85e4 883535 web optional wordpress_2.3.1.orig.tar.gz
 83777c5c7e65b389e2c3aa30e4883166 9788 web optional wordpress_2.3.1-1.diff.gz
 d9c7581fb5b8b18aa099d3bd091a7d3a 870566 web optional wordpress_2.3.1-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHJ3C9K/juK3+WFWQRAkbxAJ4/6GLRBgzPKMvxbzDj6YXTQUw5iQCglw21
GbKmk3/LR72d67XfthZalRo=
=lelB
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 01 Dec 2007 07:37:17 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 01:50:56 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.