Debian Bug report logs - #445464
psycopg dependency conflicts tinyerp-server with python-sqlalchemy

version graph

Package: tinyerp-server; Maintainer for tinyerp-server is (unknown);

Reported by: alex bodnaru <alexbodn@012.net.il>

Date: Sat, 6 Oct 2007 01:33:01 UTC

Severity: important

Found in version tinyerp-server/4.0.3-2

Fixed in version tinyerp-server/4.2.1-1

Done: Daniel Baumann <daniel@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Daniel Baumann <daniel@debian.org>:
Bug#445464; Package tinyerp-server. Full text and rfc822 format available.

Acknowledgement sent to alex bodnaru <alexbodn@012.net.il>:
New Bug report received and forwarded. Copy sent to Daniel Baumann <daniel@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: alex bodnaru <alexbodn@012.net.il>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: psycopg dependency conflicts tinyerp-server with python-sqlalchemy
Date: Sat, 06 Oct 2007 03:29:50 +0200
Package: tinyerp-server
Version: 4.0.3-2
Severity: important

hi,

thank you for providing tinyerp.

upstream sqlalchemy does support either psycopg or psycopg2, 
but would use the second if both installed. since the support 
of psycopg1 to some sa actions is limited, sa maintainer has 
decided to conflict sa with psycopg1, thus with tinyerp-server too.

sa is a very important package, and turbogears (which provides 
tinyerp web access) depends on it.

i'm sure you know about this conflict, but here is a solution:
if package psycopg1 would depend on psycopg2, each program will 
have the choice of which psycopg to import, so sa (and mezogis, 
which i'm maintaining) would use psycopg2, and will allow other 
programs to use psycopg1.


-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.21-2-686 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages tinyerp-server depends on:
ii  adduser                    3.105         add and remove users and groups
ii  python                     2.4.4-6       An interactive high-level object-o
ii  python-libxml2             2.6.30.dfsg-2 Python bindings for the GNOME XML 
ii  python-libxslt1            1.1.22-1      Python bindings for libxslt1
ii  python-psycopg2            2.0.6-1       Python module for PostgreSQL
ii  python-reportlab           2.0dfsg-1     ReportLab library to create PDF do
ii  python-support             0.7.3         automated rebuilding support for p
ii  python-xml                 0.8.4-8       XML tools for Python

Versions of packages tinyerp-server recommends:
pn  graphviz                      <none>     (no description available)
ii  postgresql-8.1                8.1.10-1   object-relational SQL database, ve
pn  postgresql-client             <none>     (no description available)
ii  python-imaging                1.1.6-1    Python Imaging Library
pn  python-pyparsing              <none>     (no description available)

-- no debconf information




Reply sent to Daniel Baumann <daniel@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to alex bodnaru <alexbodn@012.net.il>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #10 received at 445464-close@bugs.debian.org (full text, mbox):

From: Daniel Baumann <daniel@debian.org>
To: 445464-close@bugs.debian.org
Subject: Bug#445464: fixed in tinyerp-server 4.2.1-1
Date: Sat, 12 Jan 2008 15:17:06 +0000
Source: tinyerp-server
Source-Version: 4.2.1-1

We believe that the bug you reported is fixed in the latest version of
tinyerp-server, which is due to be installed in the Debian FTP archive:

tinyerp-server_4.2.1-1.diff.gz
  to pool/main/t/tinyerp-server/tinyerp-server_4.2.1-1.diff.gz
tinyerp-server_4.2.1-1.dsc
  to pool/main/t/tinyerp-server/tinyerp-server_4.2.1-1.dsc
tinyerp-server_4.2.1-1_all.deb
  to pool/main/t/tinyerp-server/tinyerp-server_4.2.1-1_all.deb
tinyerp-server_4.2.1.orig.tar.gz
  to pool/main/t/tinyerp-server/tinyerp-server_4.2.1.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 445464@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Daniel Baumann <daniel@debian.org> (supplier of updated tinyerp-server package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 12 Jan 2008 15:20:00 +0100
Source: tinyerp-server
Binary: tinyerp-server
Architecture: source all
Version: 4.2.1-1
Distribution: unstable
Urgency: low
Maintainer: Daniel Baumann <daniel@debian.org>
Changed-By: Daniel Baumann <daniel@debian.org>
Description: 
 tinyerp-server - Enterprise Resource Management software (server)
Closes: 445464 445464
Changes: 
 tinyerp-server (4.2.1-1) unstable; urgency=low
 .
   * Maintainer upload from the Zuerich BSP.
   * New upstream release.
   * Bumping to new policy.
   * Using new homepage field in control.
   * Including documentation for migration and testing (Closes: #445464).
   * Adjusting 04-bind-exit.dpatch to new upstream release.
   * Added lintian overrides.
   * Depending now on python-psycopg2, not python-psycopg anymore
     (Closes: #445464).
Files: 
 444fa5087b1994246687d875b40d5be1 727 net optional tinyerp-server_4.2.1-1.dsc
 7edc9714527705c34bce2d79af2ea24d 2322222 net optional tinyerp-server_4.2.1.orig.tar.gz
 ef02c1a4f6cce7e848099e95f421a3ba 6918 net optional tinyerp-server_4.2.1-1.diff.gz
 807520298e89fd9a227d3ae2c12b2943 2353614 net optional tinyerp-server_4.2.1-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHiNg/+C5cwEsrK54RAsikAKDUXRgKHCjFy3tzbFc88CYpGKQ8uQCg4vQH
SY6SD2P7H4mJ3z15+THHEzM=
=/z/m
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 21 Feb 2008 07:30:55 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 24 21:37:29 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.