Debian Bug report logs - #437664
rdesktop: segfaults when logging successfully first time

version graph

Package: rdesktop; Maintainer for rdesktop is Laszlo Boszormenyi (GCS) <gcs@debian.hu>; Source for rdesktop is src:rdesktop.

Reported by: Bambr <wooshie@gmail.com>

Date: Mon, 13 Aug 2007 14:09:01 UTC

Severity: normal

Found in version rdesktop/1.5.0-1

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Laszlo Boszormenyi (GCS) <gcs@debian.hu>:
Bug#437664; Package rdesktop. Full text and rfc822 format available.

Acknowledgement sent to Bambr <wooshie@gmail.com>:
New Bug report received and forwarded. Copy sent to Laszlo Boszormenyi (GCS) <gcs@debian.hu>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Bambr <wooshie@gmail.com>
To: submit@bugs.debian.org
Subject: rdesktop: segfaults when logging successfully first time
Date: Mon, 13 Aug 2007 17:08:22 +0300
[Message part 1 (text/plain, inline)]
Package: rdesktop
Version: 1.5.0-1
Severity: normal

When I'm connecting to Windows Server 2003 R2 (2005) with Terminal
Server and entering login/password successfully from the first time - ti
segfaults. If I intentionally fail first login - it goes well after it.

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-4-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages rdesktop depends on:
ii  libc6                       2.3.6.ds1-13 GNU C Library: Shared libraries
ii  libssl0.9.8                 0.9.8c-4     SSL shared libraries
ii  libx11-6                    2:1.0.3-7    X11 client-side library

rdesktop recommends no packages.

-- no debconf information

-- 
Bambr in da house
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Laszlo Boszormenyi (GCS) <gcs@debian.hu>:
Bug#437664; Package rdesktop. Full text and rfc822 format available.

Acknowledgement sent to Bambr <wooshie@gmail.com>:
Extra info received and forwarded to list. Copy sent to Laszlo Boszormenyi (GCS) <gcs@debian.hu>. Full text and rfc822 format available.

Message #10 received at 437664@bugs.debian.org (full text, mbox):

From: Bambr <wooshie@gmail.com>
To: 437664@bugs.debian.org
Subject: addition
Date: Mon, 13 Aug 2007 17:21:53 +0300
[Message part 1 (text/plain, inline)]
also, even if i'm logged in, i can't use Ctrl+S combination in EditPlus2,
rdesktop crashes with segfault.

-- 
Bambr in da house
[Message part 2 (text/html, inline)]

Message sent on to Bambr <wooshie@gmail.com>:
Bug#437664. (Wed, 21 Apr 2010 12:15:08 GMT) Full text and rfc822 format available.

Message #13 received at 437664-submitter@bugs.debian.org (full text, mbox):

From: Maximilian Gass <maximilian.gass@credativ.de>
To: 437664-submitter@bugs.debian.org
Subject: Reproducible on QEMU/KVM
Date: Wed, 21 Apr 2010 12:57:51 +0200
I have encountered this problem with a Debian Live system (squeeze) running in
QEMU/KVM.  It does not happen on my squeeze host system though.

Running the same live image on real hardware does not show the problem
either, so I guess it's related to QEMU.

Also, the bug occurs on both i386 and amd64.




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 01:01:12 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.