Debian Bug report logs - #432145
libsmokeqt4-dev: does not ship smoke.h

version graph

Package: libsmokeqt4-dev; Maintainer for libsmokeqt4-dev is Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>; Source for libsmokeqt4-dev is src:smokeqt.

Reported by: Felipe Sateler <fsateler@gmail.com>

Date: Sat, 7 Jul 2007 21:48:06 UTC

Severity: grave

Found in version libqt4-ruby/1.4.9-1

Fixed in version libqt4-ruby/1.4.9-2

Done: Vincent Fourmond <fourmond@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Vincent Fourmond <fourmond@debian.org>:
Bug#432145; Package libsmokeqt4-dev. Full text and rfc822 format available.

Acknowledgement sent to Felipe Sateler <fsateler@gmail.com>:
New Bug report received and forwarded. Copy sent to Vincent Fourmond <fourmond@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Felipe Sateler <fsateler@gmail.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libsmokeqt4-dev: does not ship smoke.h
Date: Sat, 07 Jul 2007 17:47:26 -0400
Package: libsmokeqt4-dev
Version: 1.4.9-1
Severity: grave
Justification: renders package unusable

libsmokeqt4-dev doesn't include the smoke.h header file, which makes
this package rather unusable. The problem is that the header is
installed in the install-indep target, but the install-arch target
dh_clean, which erases it. This happens because libsmokeqt4-dev is not
arch: all, but arch: any. Thus, moving the installation to install-arch,
where it belongs, fixes the issue.

As an aside, why copy the header manually instead of making debhelper do
the work (via libsmokeqt4-dev.install)?

As a second aside, at install-indep time there is no debian/tmp folder,
so the dh_install call is superfluous.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.21-felipe (PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libsmokeqt4-dev depends on:
ii  libsmokeqt4-1                 1.4.9-1    Smoke library for Qt4

libsmokeqt4-dev recommends no packages.

-- no debconf information



Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#432145; Package libsmokeqt4-dev. Full text and rfc822 format available.

Acknowledgement sent to Vincent Fourmond <fourmond@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #10 received at 432145@bugs.debian.org (full text, mbox):

From: Vincent Fourmond <fourmond@debian.org>
To: Felipe Sateler <fsateler@gmail.com>, 432145@bugs.debian.org
Subject: Re: Bug#432145: libsmokeqt4-dev: does not ship smoke.h
Date: Sun, 08 Jul 2007 00:02:32 +0200
Felipe Sateler wrote:
> libsmokeqt4-dev doesn't include the smoke.h header file, which makes
> this package rather unusable. 

  Ooops... Sorry.

> The problem is that the header is
> installed in the install-indep target, but the install-arch target
> dh_clean, which erases it. This happens because libsmokeqt4-dev is not
> arch: all, but arch: any. Thus, moving the installation to install-arch,
> where it belongs, fixes the issue.

  Thanks !

> As an aside, why copy the header manually instead of making debhelper do
> the work (via libsmokeqt4-dev.install)?

  Because I use dh_install in a dh_movefile fashion, which means that
all files that I want to install must reside in the debian/tmp dir. But
smoke.h isn't installed by upstream's build system.

> As a second aside, at install-indep time there is no debian/tmp folder,
> so the dh_install call is superfluous.

  Thanks, I'll clean that as well.

  Cheers,

	Vincent


-- 
Vincent Fourmond, Debian Developer
http://vincent.fourmond.neuf.fr/
-- pretty boring signature, isn't it ?



Reply sent to Vincent Fourmond <fourmond@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Felipe Sateler <fsateler@gmail.com>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #15 received at 432145-close@bugs.debian.org (full text, mbox):

From: Vincent Fourmond <fourmond@debian.org>
To: 432145-close@bugs.debian.org
Subject: Bug#432145: fixed in libqt4-ruby 1.4.9-2
Date: Sat, 07 Jul 2007 22:47:05 +0000
Source: libqt4-ruby
Source-Version: 1.4.9-2

We believe that the bug you reported is fixed in the latest version of
libqt4-ruby, which is due to be installed in the Debian FTP archive:

libqt4-ruby1.8_1.4.9-2_amd64.deb
  to pool/main/libq/libqt4-ruby/libqt4-ruby1.8_1.4.9-2_amd64.deb
libqt4-ruby_1.4.9-2.diff.gz
  to pool/main/libq/libqt4-ruby/libqt4-ruby_1.4.9-2.diff.gz
libqt4-ruby_1.4.9-2.dsc
  to pool/main/libq/libqt4-ruby/libqt4-ruby_1.4.9-2.dsc
libqt4-ruby_1.4.9-2_all.deb
  to pool/main/libq/libqt4-ruby/libqt4-ruby_1.4.9-2_all.deb
libsmokeqt4-1_1.4.9-2_amd64.deb
  to pool/main/libq/libqt4-ruby/libsmokeqt4-1_1.4.9-2_amd64.deb
libsmokeqt4-dev_1.4.9-2_amd64.deb
  to pool/main/libq/libqt4-ruby/libsmokeqt4-dev_1.4.9-2_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 432145@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Vincent Fourmond <fourmond@debian.org> (supplier of updated libqt4-ruby package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 08 Jul 2007 00:04:27 +0200
Source: libqt4-ruby
Binary: libsmokeqt4-1 libqt4-ruby libqt4-ruby1.8 libsmokeqt4-dev
Architecture: source amd64 all
Version: 1.4.9-2
Distribution: unstable
Urgency: low
Maintainer: Vincent Fourmond <fourmond@debian.org>
Changed-By: Vincent Fourmond <fourmond@debian.org>
Description: 
 libqt4-ruby - ruby bindings for the Qt4 GUI library
 libqt4-ruby1.8 - ruby bindings for the Qt4 GUI library
 libsmokeqt4-1 - Smoke library for Qt4
 libsmokeqt4-dev - Smoke library for Qt4
Closes: 432145
Changes: 
 libqt4-ruby (1.4.9-2) unstable; urgency=low
 .
   * The 'Ooops I should have looked debc output better' release
   * Finally include usr/include/smoke.h (Closes: #432145)
   * Some small debian/rules cleanups, courtesy of
     Felipe Sateler <fsateler@gmail.com>
Files: 
 5af947ee362e89c2f21715a72f6da1bc 813 interpreters optional libqt4-ruby_1.4.9-2.dsc
 9d858dc65f168f901c0e7f1799203459 34091 interpreters optional libqt4-ruby_1.4.9-2.diff.gz
 6a9dd658dde4ebb9d76ae0b7551c20c8 459800 interpreters optional libqt4-ruby1.8_1.4.9-2_amd64.deb
 fbbf3acaf4749981c40e00bc46f12614 2891848 libs optional libsmokeqt4-1_1.4.9-2_amd64.deb
 2ed88e61756f4b660fc9adf156559e44 8550 libdevel optional libsmokeqt4-dev_1.4.9-2_amd64.deb
 6b95c76e04121a814524d7ddef7e3d76 5900 interpreters optional libqt4-ruby_1.4.9-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGkBRXx/UhwSKygsoRAswBAKCre/n5Xse6dpvLqK86eGE0b+WmQwCeJ2b+
fF+HyGYhOBMR4oNdgaLnYPM=
=2fCo
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 16 Aug 2007 07:29:02 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 10:57:49 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.