Debian Bug report logs - #414185
libapache2-mod-fastcgi: auth does not work with apache 2.2

version graph

Package: libapache2-mod-fastcgi; Maintainer for libapache2-mod-fastcgi is Tatsuki Sugiura <sugi@nemui.org>; Source for libapache2-mod-fastcgi is src:libapache-mod-fastcgi.

Reported by: Martin Furter <mf@rola.ch>

Date: Fri, 9 Mar 2007 19:21:06 UTC

Severity: important

Tags: patch

Found in version libapache-mod-fastcgi/2.4.2-8

Fixed in version 2.4.2-10

Done: Tatsuki Sugiura <sugi@nemui.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Tatsuki Sugiura <sugi@nemui.org>:
Bug#414185; Package libapache2-mod-fastcgi. Full text and rfc822 format available.

Acknowledgement sent to Martin Furter <mf@rola.ch>:
New Bug report received and forwarded. Copy sent to Tatsuki Sugiura <sugi@nemui.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Martin Furter <mf@rola.ch>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libapache2-mod-fastcgi: auth does not work with apache 2.2
Date: Fri, 09 Mar 2007 20:18:53 +0100
Package: libapache2-mod-fastcgi
Version: 2.4.2-8
Severity: important
Tags: patch

The authentication and authorization API's have been completely changed
in apache httpd 2.2 which causes auth requests using mod_fastcgi to
fail.

Also the compatibility defines which have been marked as deprecated in
apache 2.0 have been dropped in apache 2.2 what causes lots of compiler
warnings.

Two patches can be found here:
http://repos.borg.ch/misc/mod_f22cgi/trunk/patches/

URLs.txt contains URL's to the mailing list where I found the patches.

apache-2.2-api.patch fixes the compiler warnings. It won't compile
anymore with apache 1.3, not sure about 2.0.

apache-mod_fastcgi-apache22.patch-1.3 registers mod_fastcgi as an AUTHN
provider. This is an apache 2.2 feature, so it won't work with apache
2.0 anymore. The author of the patch also mentioned that it is
incomplete, though it solved my problems.

With this patch "AuthBasicProvider fastcgi" has to be added to the
apache config next to "FastCgiAuthenticator ..." to select fastcgi as
authentication provider.

-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (990, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16.31-mf1
Locale: LANG=en_US.ISO-8859-1, LC_CTYPE=en_US.ISO-8859-1 (charmap=ISO-8859-1)

Versions of packages libapache2-mod-fastcgi depends on:
ii  apache2.2-common              2.2.3-3.3  Next generation, scalable, extenda

libapache2-mod-fastcgi recommends no packages.

-- no debconf information



Reply sent to Tatsuki Sugiura <sugi@nemui.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Martin Furter <mf@rola.ch>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #10 received at 414185-done@bugs.debian.org (full text, mbox):

From: Tatsuki Sugiura <sugi@nemui.org>
To: 414185-done@bugs.debian.org, 415913-done@bugs.debian.org
Date: Mon, 28 Jan 2008 17:04:17 +0900
Version: 2.4.2-10

I forgot to upload previous version (2.4.2-9).
This bug fixed on that.

Now I'm closeing the bug, and I'm sorry for your
inconvenience long time.

-- 
Tatsuki Sugiura   mailto:sugi@nemui.org




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Fri, 14 Mar 2008 07:37:52 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 23:24:13 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.