Debian Bug report logs - #413271
lastfm-player -- an audio player for last.fm personalized radio

version graph

Package: lastfm; Maintainer for lastfm is John Stamp <jstamp@users.sourceforge.net>; Source for lastfm is src:lastfm.

Reported by: "Artur R. Czechowski" <arturcz@hell.pl>

Date: Sat, 3 Mar 2007 20:54:01 UTC

Severity: wishlist

Fixed in version lastfm/1:1.1.3.0-1

Done: John Stamp <jstamp@users.sourceforge.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, fpletz@franz-pletz.org, <wnpp@debian.org>:
Bug#413271; Package wnpp. Full text and rfc822 format available.

Acknowledgement sent to "Artur R. Czechowski" <arturcz@hell.pl>:
New Bug report received and forwarded. Copy sent to fpletz@franz-pletz.org, <wnpp@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "Artur R. Czechowski" <arturcz@hell.pl>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: RFP: lastfm-player -- an audio player for last.fm personalized radio
Date: Sat, 3 Mar 2007 21:52:17 +0100
Package: wnpp
Severity: wishlist

* Package name    : lastfm-client
  Version         : 1.1.3
  Upstream Author : last.fm team
* URL             : http://static.last.fm/client/Linux/last.fm-1.1.3.src.tar.bz2
* License         : GPL
  Programming Lang: C++
  Description     : an audio player for last.fm personalized radio

(copied from lastfm package)

Last.fm is the flagship product from the team that designed the Audioscrobbler
system, a music engine based on a massive collection of Music Profiles.
Each music profile belongs to one person, and describes their taste in music.
Last.fm uses these music profiles to make personalized recommendations, match
you up with people who like similar music, and generate custom radio
stations for each person.

This package will allow you to play your personalized radio station streams
from the last.fm website.  You will need a (free) account there to make use
of this package.

This package is replacement for previous lastfm package.


Please note, that lastfm-client is different software than current lastfm
package. The difference is explained here:
http://www.last.fm/group/Debian+Linux/forum/8592/_/200414/_/2483152


It needs to be considered whether it is better to create a new package
or to replace the current lastfm.

Note to maintainer of lastfm package: Franz, if you think that replacement
is an option, feel free to reassign this bug accordingly.

Regards
	Artur

-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-4-amd64
Locale: LANG=C, LC_CTYPE=pl_PL (charmap=ISO-8859-2)

-- 
Documentation is like sex: When it is good, it is very, very, good.
And when it is bad, it is better than nothing.
                                                  /Dick Brandon/



Changed Bug title to lastfm-player -- an audio player for last.fm personalized radio from RFP: lastfm-player -- an audio player for last.fm personalized radio. Request was from John Stamp <jstamp@users.sourceforge.net> to control@bugs.debian.org. (Sun, 22 Apr 2007 16:30:01 GMT) Full text and rfc822 format available.

Bug reassigned from package `wnpp' to `lastfm'. Request was from John Stamp <jstamp@users.sourceforge.net> to control@bugs.debian.org. (Sun, 22 Apr 2007 16:30:03 GMT) Full text and rfc822 format available.

Reply sent to John Stamp <jstamp@users.sourceforge.net>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to "Artur R. Czechowski" <arturcz@hell.pl>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #14 received at 413271-close@bugs.debian.org (full text, mbox):

From: John Stamp <jstamp@users.sourceforge.net>
To: 413271-close@bugs.debian.org
Subject: Bug#413271: fixed in lastfm 1:1.1.3.0-1
Date: Wed, 02 May 2007 11:02:02 +0000
Source: lastfm
Source-Version: 1:1.1.3.0-1

We believe that the bug you reported is fixed in the latest version of
lastfm, which is due to be installed in the Debian FTP archive:

lastfm_1.1.3.0-1.diff.gz
  to pool/main/l/lastfm/lastfm_1.1.3.0-1.diff.gz
lastfm_1.1.3.0-1.dsc
  to pool/main/l/lastfm/lastfm_1.1.3.0-1.dsc
lastfm_1.1.3.0-1_i386.deb
  to pool/main/l/lastfm/lastfm_1.1.3.0-1_i386.deb
lastfm_1.1.3.0.orig.tar.gz
  to pool/main/l/lastfm/lastfm_1.1.3.0.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 413271@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
John Stamp <jstamp@users.sourceforge.net> (supplier of updated lastfm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 01 May 2007 15:05:28 -0700
Source: lastfm
Binary: lastfm
Architecture: source i386
Version: 1:1.1.3.0-1
Distribution: unstable
Urgency: low
Maintainer: John Stamp <jstamp@users.sourceforge.net>
Changed-By: John Stamp <jstamp@users.sourceforge.net>
Description: 
 lastfm     - an audio player for last.fm personalized radio
Closes: 354405 355194 366977 373239 388064 395078 399423 412130 413271
Changes: 
 lastfm (1:1.1.3.0-1) unstable; urgency=low
 .
    * Take over package with the maintainer's permission.
    * Upload to unstable. (Closes: #412130, #413271)
    * Close bugs fixed by patches:
      - dmix support (Closes: #354405)
      - don't segfault on wrong/busy audio devices (Closes: #355194, #395078)
      - don't limit output to first soundcard (Closes: #366977)
      - fix distorted output (Closes: #373239, #388064)
      - fix memory leaks (Closes: #399423)
    * Update description to include a note about the msk patchset.
    * Do not generate/remove lastfm.js and lastfm.protocol in
      postinst/postrm. Install them as files.
 .
 lastfm (1:1.1.3.0~msk8) unstable; urgency=low
 .
   * Changed patches:
     - 13_alsa: fix a potential overflow in the device description.
     - 20_noupdates: remove unused reference to actionCheckForUpdates in
       container.ui. This was only partially removed before.
   * Update man page.
 .
 lastfm (1:1.1.3.0~msk7) unstable; urgency=low
 .
   * Changed patches:
     - 22_loqqer: delete instances of gLogger in the class destructors
   * remove Loqqer.o when cleaning a previous build.
 .
 lastfm (1:1.1.3.0~msk6) unstable; urgency=low
 .
   * Added patches:
     - 22_loqqer: Change implementation of Loqqer to prevent text relocations.
       Needed for amd64, ia64, SELinux, etc.
   * Changed patches:
     - 03_translations: Add Turkish translation from Pardus:
       http://paketler.pardus.org.tr/devel/source/lastfm-player.html
     - 13_alsa: use a more generalized linux test in LastFM.pro.
   * Update 16_select-browser so it applies cleanly.
 .
 lastfm (1:1.1.3.0~msk5) unstable; urgency=low
 .
   * Added patches:
     - 00_qt41: permit building on Qt 4.1 so dapper can enjoy new versions too
   * Changed patches:
   * - 10_tray: make sure show/hide behavior works for both Qt 4.1 and 4.2
     - 11_history:
       . add "Remove this station" to the context menu for recent stations
       . increase history size to 100
       . fix RecentStations counting error when playing an older station
       . delete station names that are no longer in the history
     - 12_loveban: fix track banning.  Thanks Fluxid!
   * Update the rest of the patches so they apply cleanly
   * Fix rules, postinst, postrm to properly use ldconfig
   * Lower Qt build dependency to 4.1.0
 .
 lastfm (1:1.1.3.0~msk4) unstable; urgency=low
 .
   * Change 10_tray to add discovery mode option to tray popup.
   * Add 21_tray-icon-size and trayicons22.tar.gz so we can have 22x22 tray
     icons instead of those tiny 16x16 ones.
   * Lintian override added: package-name-doesnt-match-sonames libLastFMTools1
 .
 lastfm (1:1.1.3.0~msk3) unstable; urgency=low
 .
   * Add support for iceweasel in postinst and postrm.
 .
 lastfm (1:1.1.3.0~msk2) unstable; urgency=low
 .
   * Update 13_alsa so it can choose from multiple default devices
     in a multi-card environment.
 .
 lastfm (1:1.1.3.0~msk1) unstable; urgency=low
 .
   * New upstream.
   * Removed patches:
     - 00_build: Doesn't seem to be needed anymore.
     - 17_draglabel: Applied upstream.
   * Added patches:
     - 03_translations: Patch the .pro files to install translations.
   * Update the rest of the patches so they apply cleanly.
   * Fix rules to properly clean things before a rebuild.
 .
 lastfm (1:1.0.9.6~msk3) unstable; urgency=low
 .
   * Changed patches:
     - 10_tray: slightly modify behavior to make it more intuitive (for me).
     - 13_alsa: Get rid of some unused variables.
     - 14_timebar: Trim to include only the necessary bits.
   * Removed patches:
     - 16_sensiblebrowser: Not needed for Linux client.  1.0.9.6 lets Qt figure
       it out for itself, but see below.
   * New patches:
     - 16_select-browser: Some people want to select which browser they use,
       and apparently Qt's default isn't acceptable.  Add an option in
       Tools->Options->Connection to manually configure the browser that the
       client uses.  It will default to "sensible-browser."
     - 19_delete-http: The webservice plugin doesn't delete http requests,
       which causes lastfm to use up more and more memory at each song change.
       (This seems to average about 200-300k per song, according to top.)  One
       delete was commented out (why?) and another was missing.  Add/enable
       them.
     - 20_noupdates: Downloading binary updates and plugins is a bad idea in a
       packaged situation.  This aggressively removes any code that checks for
       new versions, that downloads updates and plugins, or that configures
       media devices or players.  None of it relates to the linux client, and
       removing it shrinks the app by about 150K.
 .
 lastfm (1:1.0.9.6~msk2) unstable; urgency=low
 .
   * Change 13_alsa: now it's a whole new ALSA plugin that
     builds libplayback_alsa.so instead of libplayback_rtaudio.so.
     Advantages:
     - Adds default device support for those who need dmix.
     - Full device names appear in the soundcard combobox
     - No need to restart app after changing devices: just stop and
       play again.
     - Easier to debug. :)
   * Add 18_valgrind: fix a few memory leaks that valgrind reported.
 .
 lastfm (1:1.0.9.6~msk1) unstable; urgency=low
 .
   * New upstream.
   * New patches:
     - 02_noitunes: Linux doesn't have iTunes, so don't build things that we
       will never use.
   * Update older patches to account for source changes:
     - 00_build: no need to patch definitions.pro.inc, but we do need to fix
       some misbehaving makefiles (see #345388).
     - 11_history: remove friendly history names; implemented upstream.
     - 17_draglabel: no more CPU load problem, so remove.  But do show all
       words in multi-word labels.
     - Other minor tweaks to patches so they apply cleanly.
 .
 lastfm (1:1.0.7-0.04) unstable; urgency=low
 .
   * Use cdbs.  Makes patch admin easier.
   * Update and reorder patches:
     - patches < 10 are needed for a working package
     - patches >= 10 are bugfixes / features
   * Remove 04_oss in favor of 13_alsa ALSA "default" device patch.
   * Link to libasound2 again and remove dependency on alsa-oss
   * Update app icons to match those for Windows / Mac.
 .
 lastfm (1:1.0.7-0.03) unstable; urgency=low
 .
   * I'm using the OSS patch.  So don't link to libasound2 and add alsa-oss to
     package dependencies.
   * Add sharutils to build dependencies
   * Use absolute path for ldconfig
 .
 lastfm (1:1.0.7-0.02) unstable; urgency=low
 .
   * Compile with Debian testing version of Qt
   * Add 10_draglabel to prevent massive cpu usage when using Qt >= 4.2.
   * Make 04_oss a little more aggressive so we don't compile code we'll
     never use.
   * Bring packaging a little closer to official packaging for 1.1.90
 .
 lastfm (1:1.0.7-0.01) unstable; urgency=low
 .
   * New upstream
   * Use version epoch since 1.0.7 < 1.1.90.
   * Update patches from 1.1.90.
   * Add mine:
     - 01_tray: Single click in tray show/hides main window
     - 02_history:
       . Max history items changed from 9 to 50
       . Give history items friendly descriptions
     - 03_loveban: Add love/ban items to Recently Played context menu
     - 04_oss: Use OSS instead of ALSA and add aoss to .desktop command
     - 05_timebar: Show a timebar even when not scrobbling
     - 06_icons: Adjust icon and library paths
     - 07_scrobble: Possibly fix a minor scrobbling issue
     - 08_sensiblebrowser: use "sensible-browser" instead of "firefox" for now
     - 09_showradio: undefine HIDE_RADIO so we have an interface.
Files: 
 47497cde0da5c804d8f893ab4756983f 721 sound optional lastfm_1.1.3.0-1.dsc
 c76a86e64479636ee898bfc73cc9539c 1050944 sound optional lastfm_1.1.3.0.orig.tar.gz
 7517eaecaf5faaf9ca070b133e509861 102106 sound optional lastfm_1.1.3.0-1.diff.gz
 bc4eb421e4cb3283c82a0346f2ea2409 1256366 sound optional lastfm_1.1.3.0-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Signed by Adeodato Simó <dato@net.com.org.es>

iEYEARECAAYFAkY4bHkACgkQgyNlRdHEGIKPRQCggDMkxOXs7ywKfTdSQtUcnbLO
jOwAoJomGYJIqVcSRulV0XrNbhhlgbF0
=B11o
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 05 Jul 2007 07:56:21 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 19:27:51 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.