Debian Bug report logs - #404125
libpoe-component-jabber-perl: new upstream version available: 1.21

version graph

Package: libpoe-component-jabber-perl; Maintainer for libpoe-component-jabber-perl is Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>; Source for libpoe-component-jabber-perl is src:libpoe-component-jabber-perl.

Reported by: Kees Cook <kees@outflux.net>

Date: Thu, 21 Dec 2006 21:18:01 UTC

Severity: grave

Found in version libpoe-component-jabber-perl/1.1-1

Fixed in version libpoe-component-jabber-perl/2.02-1

Done: Kees Cook <kees@outflux.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Florian Ragwitz <rafl@debianforum.de>:
Bug#404125; Package libpoe-component-jabber-perl. Full text and rfc822 format available.

Acknowledgement sent to Kees Cook <kees@outflux.net>:
New Bug report received and forwarded. Copy sent to Florian Ragwitz <rafl@debianforum.de>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Kees Cook <kees@outflux.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libpoe-component-jabber-perl: new upstream version available: 1.21
Date: Thu, 21 Dec 2006 12:53:45 -0800
Package: libpoe-component-jabber-perl
Version: 1.1-1
Severity: normal

Hello!  A new upstream version exists.  (Which fixes the change of 
POE::Preprocessor to Filter::Template, the bug I recently ran into.)

Thanks,

-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-686
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages libpoe-component-jabber-perl depends on:
ii  libauthen-sasl-perl           2.10-1     Authen::SASL - SASL Authentication
ii  libdigest-sha1-perl           2.11-2     NIST SHA-1 message digest algorith
ii  libnet-ssleay-perl            1.30-1     Perl module for Secure Sockets Lay
ii  libpoe-filter-xml-perl        0.31-0.2   A POE Filter for parsing XML
ii  libpoe-perl                   2:0.3502-1 An event driven component architec
ii  perl                          5.8.8-7    Larry Wall's Practical Extraction 

libpoe-component-jabber-perl recommends no packages.

-- no debconf information



Information forwarded to debian-bugs-dist@lists.debian.org, pkg-perl-maintainers@lists.alioth.debian.org, kees@outflux.net, Florian Ragwitz <rafl@debianforum.de>:
Bug#404125; Package libpoe-component-jabber-perl. Full text and rfc822 format available.

Acknowledgement sent to Nicolas Aupetit <nicolas.aupetit+reportbug@ebzao.info>:
Extra info received and forwarded to list. Copy sent to pkg-perl-maintainers@lists.alioth.debian.org, kees@outflux.net, Florian Ragwitz <rafl@debianforum.de>. Full text and rfc822 format available.

Message #10 received at 404125@bugs.debian.org (full text, mbox):

From: Nicolas Aupetit <nicolas.aupetit+reportbug@ebzao.info>
To: Debian Bug Tracking System <404125@bugs.debian.org>
Subject: libpoe-component-jabber-perl: jirc doesn't start
Date: Tue, 08 May 2007 15:04:48 +0200
Package: libpoe-component-jabber-perl
Version: 1.1-1
Followup-For: Bug #404125

Hello!

I was trying to play with jirc, which depends on
libpoe-component-jabber-perl, and this tool doesn't start
with :

Can't locate POE/Preprocessor.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl .) at
/usr/share/perl5/POE/Component/Jabber/Client/Legacy.pm 

If I modify /usr/share/perl5/POE/Component/Jabber/Client/Legacy.pm
with only :

 package POE::Component::Jabber::Client::Legacy;
-use POE::Preprocessor;
+use Filter::Template;
 const XNode POE::Filter::XML::Node

it could start and work perfectly!

So I could hope that with the new upstream version described
in this bug #404125, it will work directly.

Thank you very much for updating this package.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.20-1-k7 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libpoe-component-jabber-perl depends on:
ii  libauthen-sasl-perl           2.10-1     Authen::SASL - SASL Authentication
ii  libdigest-sha1-perl           2.11-2     NIST SHA-1 message digest algorith
ii  libnet-ssleay-perl            1.30-1     Perl module for Secure Sockets Lay
ii  libpoe-filter-xml-perl        0.31-0.2   A POE Filter for parsing XML
ii  libpoe-perl                   2:0.9989-1 An event driven component architec
ii  perl                          5.8.8-7    Larry Wall's Practical Extraction 

libpoe-component-jabber-perl recommends no packages.

-- no debconf information



Severity set to `grave' from `normal' Request was from Kees Cook <kees@outflux.net> to control@bugs.debian.org. (Mon, 23 Jul 2007 23:54:03 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Florian Ragwitz <rafl@debianforum.de>:
Bug#404125; Package libpoe-component-jabber-perl. Full text and rfc822 format available.

Acknowledgement sent to Kees Cook <kees@outflux.net>:
Extra info received and forwarded to list. Copy sent to Florian Ragwitz <rafl@debianforum.de>. Full text and rfc822 format available.

Message #17 received at 404125@bugs.debian.org (full text, mbox):

From: Kees Cook <kees@outflux.net>
To: 404125@bugs.debian.org
Subject: NMU?
Date: Mon, 27 Aug 2007 16:30:26 -0700
[Message part 1 (text/plain, inline)]
Hi,

I've packaged the missing dep[1] for the new version (2.02) of
libpoe-component-jabber-perl, so once that's been sponsored and made
its way past NEW, the attached diff should work for the 2.02 version of
libpoe-component-jabber-perl.  I've also attached an interdiff between
the diff.gz's and the .dsc.  The orig is here[2].

Thanks,

-Kees

[1] http://mentors.debian.net/debian/pool/main/l/libpoe-component-sslify-perl/libpoe-component-sslify-perl_0.08-1.dsc
[2] http://search.cpan.org/CPAN/authors/id/N/NP/NPEREZ/POE-Component-Jabber-2.02.tar.gz

-- 
Kees Cook                                            @outflux.net
[debian.diff (text/x-diff, attachment)]
[libpoe-component-jabber-perl_2.02-0.1.dsc (text/plain, attachment)]
[libpoe-component-jabber-perl_2.02-0.1.diff.gz (application/octet-stream, attachment)]

Reply sent to Kees Cook <kees@outflux.net>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Kees Cook <kees@outflux.net>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #22 received at 404125-close@bugs.debian.org (full text, mbox):

From: Kees Cook <kees@outflux.net>
To: 404125-close@bugs.debian.org
Subject: Bug#404125: fixed in libpoe-component-jabber-perl 2.02-1
Date: Wed, 05 Dec 2007 22:02:03 +0000
Source: libpoe-component-jabber-perl
Source-Version: 2.02-1

We believe that the bug you reported is fixed in the latest version of
libpoe-component-jabber-perl, which is due to be installed in the Debian FTP archive:

libpoe-component-jabber-perl_2.02-1.diff.gz
  to pool/main/libp/libpoe-component-jabber-perl/libpoe-component-jabber-perl_2.02-1.diff.gz
libpoe-component-jabber-perl_2.02-1.dsc
  to pool/main/libp/libpoe-component-jabber-perl/libpoe-component-jabber-perl_2.02-1.dsc
libpoe-component-jabber-perl_2.02-1_all.deb
  to pool/main/libp/libpoe-component-jabber-perl/libpoe-component-jabber-perl_2.02-1_all.deb
libpoe-component-jabber-perl_2.02.orig.tar.gz
  to pool/main/libp/libpoe-component-jabber-perl/libpoe-component-jabber-perl_2.02.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 404125@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Kees Cook <kees@outflux.net> (supplier of updated libpoe-component-jabber-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 27 Aug 2007 14:16:01 -0700
Source: libpoe-component-jabber-perl
Binary: libpoe-component-jabber-perl
Architecture: source all
Version: 2.02-1
Distribution: unstable
Urgency: low
Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Changed-By: Kees Cook <kees@outflux.net>
Description: 
 libpoe-component-jabber-perl - A POE Component for communicating over Jabber
Closes: 404125 434444
Changes: 
 libpoe-component-jabber-perl (2.02-1) unstable; urgency=low
 .
   [ Kees Cook ]
   * New upstream release (Closes: #404125, #434444).
   * debian/control:
     - add new Build-Deps libmodule-build-perl and libpoe-component-sslify-perl.
     - maintainer changed to Debian Perl Group, with permission from Florian
       Ragwitz.
     - bumped standards version
   * debian/rules: converted to using Module::Build.
   * debian/watch: added
   * debian/copyright: download URL added
   * debian/compat: updated to 5
 .
   [ Damyan Ivanov ]
   * Fix debian/rules' target inter-dependencies to allow for a parallel build
Files: 
 eda22c286b2d70aa804e93f954d64109 1168 perl optional libpoe-component-jabber-perl_2.02-1.dsc
 fc66b0afdcb6f11b4ce61d016d299a04 31275 perl optional libpoe-component-jabber-perl_2.02.orig.tar.gz
 6e6e585a9a21fefbdd2bbc4308c9b4d1 2373 perl optional libpoe-component-jabber-perl_2.02-1.diff.gz
 1122cd4d5761875133a1c2c6d3f18783 57818 perl optional libpoe-component-jabber-perl_2.02-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHVxtNH/9LqRcGPm0RAjSiAJ9Xl9xs32mTSmtZqQB8v/8MERrknwCfU5Mh
q1faRvCkDgYM0sz2IIxQp/k=
=SPOO
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Mon, 14 Jan 2008 07:27:37 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 16:31:06 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.