Debian Bug report logs - #388756
zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1

version graph

Package: zaptel-source; Maintainer for zaptel-source is (unknown);

Reported by: Alessandro Polverini <alex@nibbles.it>

Date: Fri, 22 Sep 2006 11:33:58 UTC

Severity: grave

Found in version zaptel/1:1.2.8.dfsg-1

Fixed in version zaptel/1:1.2.9.1.dfsg-2

Done: Mark Purcell <msp@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Alessandro Polverini <alex@nibbles.it>:
New Bug report received and forwarded. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Alessandro Polverini <alex@nibbles.it>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Fri, 22 Sep 2006 13:29:28 +0200
Package: zaptel-source
Version: 1:1.2.8.dfsg-1
Severity: grave
Justification: renders package unusable

I just rebuilt modules for the latest kernel (2.6.17-2) and some modules are missing,
wct4xxp.ko is one of those.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing'), (50, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-2-486
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages zaptel-source depends on:
ii  bzip2                         1.0.3-6    high-quality block-sorting file co
ii  debhelper                     5.0.37.3   helper programs for debian/rules
ii  module-assistant              0.10.6     tool to make module package creati

Versions of packages zaptel-source recommends:
ii  zaptel                    1:1.2.8.dfsg-1 zapata telephony utilities

-- no debconf information



Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Tzafrir Cohen <tzafrir.cohen@xorcom.com>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #10 received at 388756@bugs.debian.org (full text, mbox):

From: Tzafrir Cohen <tzafrir.cohen@xorcom.com>
To: Alessandro Polverini <alex@nibbles.it>, 388756@bugs.debian.org
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Fri, 22 Sep 2006 14:48:40 +0300
On Fri, Sep 22, 2006 at 01:29:28PM +0200, Alessandro Polverini wrote:
> Package: zaptel-source
> Version: 1:1.2.8.dfsg-1
> Severity: grave
> Justification: renders package unusable
> 
> I just rebuilt modules for the latest kernel (2.6.17-2) and some modules are missing,
> wct4xxp.ko is one of those.

iIt is installed into a subdirectory and only the 2.6 build was adapted
for that.

http://bugs.digium.com/view.php?id=7964 (patch should be there, haven't
looked).

Sadly, I will probably not have much "computer time" this weekend to
start packaging the beta...

-- 
Tzafrir Cohen         sip:tzafrir@local.xorcom.com
icq#16849755          iax:tzafrir@local.xorcom.com
+972-50-7952406          jabber:tzafrir@jabber.org
tzafrir.cohen@xorcom.com     http://www.xorcom.com



Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Alessandro Polverini <alex@nibbles.it>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #15 received at 388756@bugs.debian.org (full text, mbox):

From: Alessandro Polverini <alex@nibbles.it>
To: 388756@bugs.debian.org
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Fri, 22 Sep 2006 14:02:46 +0200
On Fri, 2006-09-22 at 14:48 +0300, Tzafrir Cohen wrote:
> [...] 
> > I just rebuilt modules for the latest kernel (2.6.17-2) and some modules are missing,
> > wct4xxp.ko is one of those.
> 
> iIt is installed into a subdirectory and only the 2.6 build was adapted
> for that.

Hello Tzafrir, and thanks for you reply.
I'm using the 2.6 kernel, but there are no subdirectories. Here is the
complete list of modules of the package:
/lib/modules/2.6.17-2-k7/misc/cwain.ko
/lib/modules/2.6.17-2-k7/misc/opvxa1200.ko
/lib/modules/2.6.17-2-k7/misc/pciradio.ko
/lib/modules/2.6.17-2-k7/misc/qozap.ko
/lib/modules/2.6.17-2-k7/misc/tor2.ko
/lib/modules/2.6.17-2-k7/misc/torisa.ko
/lib/modules/2.6.17-2-k7/misc/vzaphfc
/lib/modules/2.6.17-2-k7/misc/vzaphfc/vzaphfc.ko
/lib/modules/2.6.17-2-k7/misc/wcfxo.ko
/lib/modules/2.6.17-2-k7/misc/wct1xxp.ko
/lib/modules/2.6.17-2-k7/misc/wctdm.ko
/lib/modules/2.6.17-2-k7/misc/wctdm24xxp.ko
/lib/modules/2.6.17-2-k7/misc/wcte11xp.ko
/lib/modules/2.6.17-2-k7/misc/wcusb.ko
/lib/modules/2.6.17-2-k7/misc/xpp
/lib/modules/2.6.17-2-k7/misc/xpp/xpd_fxo.ko
/lib/modules/2.6.17-2-k7/misc/xpp/xpd_fxs.ko
/lib/modules/2.6.17-2-k7/misc/xpp/xpp.ko
/lib/modules/2.6.17-2-k7/misc/xpp/xpp_usb.ko
/lib/modules/2.6.17-2-k7/misc/zaphfc.ko
/lib/modules/2.6.17-2-k7/misc/zaptel.ko
/lib/modules/2.6.17-2-k7/misc/ztd-eth.ko
/lib/modules/2.6.17-2-k7/misc/ztd-loc.ko
/lib/modules/2.6.17-2-k7/misc/ztdummy.ko
/lib/modules/2.6.17-2-k7/misc/ztdynamic.ko
/lib/modules/2.6.17-2-k7/misc/ztgsm.ko

Thanks,
Alex




Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Santiago Ruano Rincón <santiago@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #20 received at 388756@bugs.debian.org (full text, mbox):

From: Santiago Ruano Rincón <santiago@debian.org>
To: Alessandro Polverini <alex@nibbles.it>, 388756@bugs.debian.org
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Wed, 27 Sep 2006 18:28:08 -0500
[Message part 1 (text/plain, inline)]
Hi,

The wct4xxp module was dropped from zaptel-source since 1.2.7-2, becuse
it uses sourceless firmware. I don't know if it the module is still
usefull without the .ima file. 

I'll try to digger about that, but I don't have any TEXXP card
available.

Regards,

Santiago
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Alessandro Polverini <alex@nibbles.it>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #25 received at 388756@bugs.debian.org (full text, mbox):

From: Alessandro Polverini <alex@nibbles.it>
To: Santiago Ruano Rincón <santiago@debian.org>
Cc: 388756@bugs.debian.org
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Thu, 28 Sep 2006 13:07:27 +0200
On Wed, 2006-09-27 at 18:28 -0500, Santiago Ruano Rincón wrote:
> Hi,
> 
> The wct4xxp module was dropped from zaptel-source since 1.2.7-2, becuse
> it uses sourceless firmware.

:-O

This debian policy of the firmware is really annoying: zaptel without
that module is pretty useless (for me, of course).

Any way to overcome that problem?

Thanks,
Alex




Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Stephan Seitz <nur-ab-sal@gmx.de>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #30 received at 388756@bugs.debian.org (full text, mbox):

From: Stephan Seitz <nur-ab-sal@gmx.de>
To: pkg-voip-maintainers@lists.alioth.debian.org
Cc: 388756@bugs.debian.org
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Thu, 28 Sep 2006 14:32:20 +0200
[Message part 1 (text/plain, inline)]
On Thu, Sep 28, 2006 at 01:07:27PM +0200, Alessandro Polverini wrote:
>> The wct4xxp module was dropped from zaptel-source since 1.2.7-2, 
>> becuse it uses sourceless firmware.
>Any way to overcome that problem?

a) Get the sources of the firmware;
b) Get a permission to distribute the firmware (it can’t be part of a 
file under an open licence like GPL) in a separate file and package it 
for non-free;

Shade and sweet water!

	Stephan

-- 
| Stephan Seitz                    E-Mail: Nur-Ab-Sal@gmx.de |
| PGP Public Keys: http://fsing.rootsland.net/~stse/pgp.html |
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Alessandro Polverini <alex@nibbles.it>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #35 received at 388756@bugs.debian.org (full text, mbox):

From: Alessandro Polverini <alex@nibbles.it>
To: Stephan Seitz <nur-ab-sal@gmx.de>
Cc: pkg-voip-maintainers@lists.alioth.debian.org, 388756@bugs.debian.org
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Mon, 02 Oct 2006 15:31:58 +0200
On Thu, 2006-09-28 at 14:32 +0200, Stephan Seitz wrote:
> On Thu, Sep 28, 2006 at 01:07:27PM +0200, Alessandro Polverini wrote:
> >> The wct4xxp module was dropped from zaptel-source since 1.2.7-2, 
> >> becuse it uses sourceless firmware.
> >Any way to overcome that problem?
> 
> a) Get the sources of the firmware;
> b) Get a permission to distribute the firmware (it can’t be part of a 
> file under an open licence like GPL) in a separate file and package it 
> for non-free;

Hello Stephan,
I'll reply with the words of Marco d'Itri[1] on the subject, whom I
completely agree with:

---
Firmwares are an essential part of any modern computer, and it is an
annoying but currently hard to change fact of life that we lack the
source for almost all of them.

I reject the notion that we can ignore some fundamental parts of the
computers which we use only because we do not distribute them: this
would be hypocritical.

Even if Debian stopped distributing sourceless firmwares users would
continue to use them, either on a flash chip or by downloading and
installing them on their file systems.

Such a change on our part would not drive users to buy hardware whose
firmwares are accompanied by their source, because with a very small
number of exceptions there are no such devices. The claim that vendors
would start to distribute the firmware sources is unproven, and indeed I
cannot see how it could happen when only a small part of the community
would care enough to deliberately make life harder for their customers.

Instead this would push the less technically competent users toward
other distributions, whose commitment to free software is usually less
strong than our own.

In this scenario I do not see an advancement for the cause of free
software.
---

Bye,
Alex

[1] http://blog.bofh.it/id_114





Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Stephan Seitz <nur-ab-sal@gmx.de>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #40 received at 388756@bugs.debian.org (full text, mbox):

From: Stephan Seitz <nur-ab-sal@gmx.de>
To: Alessandro Polverini <alex@nibbles.it>
Cc: pkg-voip-maintainers@lists.alioth.debian.org, 388756@bugs.debian.org
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Mon, 2 Oct 2006 15:58:21 +0200
[Message part 1 (text/plain, inline)]
On Mon, Oct 02, 2006 at 03:31:58PM +0200, Alessandro Polverini wrote:
>On Thu, 2006-09-28 at 14:32 +0200, Stephan Seitz wrote:
>> a) Get the sources of the firmware;
>> b) Get a permission to distribute the firmware (it can’t be part of a 
>> file under an open licence like GPL) in a separate file and package it 
>> for non-free;
>I'll reply with the words of Marco d'Itri[1] on the subject, whom I
>completely agree with:
>---
>Firmwares are an essential part of any modern computer, and it is an
>annoying but currently hard to change fact of life that we lack the
>source for almost all of them.

Then you can’t distribute these firmwares within the GPL driver sources.  
You can only get the permission to distribute the firmware outside the 
driver. In Debian this means, you can put it in non-free.

The closed-source nvidia drivers are in non-free, no firmware is 
available for the Intel wireless cards like 2915abg within Debian. I 
don’t know if nobody cares about it or if there is no permission to 
distribute it.

>Even if Debian stopped distributing sourceless firmwares users would
>continue to use them, either on a flash chip or by downloading and
>installing them on their file systems.

Nobody wants to stop Debian to distribute such firmware in non-free, but 
Debian needs the permission to distribute it. If the firmware is part of 
a GPL driver, then this is a licence violation. If the firmware has no 
separate licence, no copyright and the vendor won’t give you the 
permission to distribute it, then simply you can’t.

>Instead this would push the less technically competent users toward
>other distributions, whose commitment to free software is usually less
>strong than our own.

Debian will not show much commitment to free software if it distributes 
firmware without source (or without permission) in main. Debian is about 
free software, not about making your life easier in every situation.

Shade and sweet water!

	Stephan

-- 
| Stephan Seitz                    E-Mail: Nur-Ab-Sal@gmx.de |
| PGP Public Keys: http://fsing.rootsland.net/~stse/pgp.html |
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Alessandro Polverini <alex@nibbles.it>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #45 received at 388756@bugs.debian.org (full text, mbox):

From: Alessandro Polverini <alex@nibbles.it>
To: Stephan Seitz <nur-ab-sal@gmx.de>
Cc: pkg-voip-maintainers@lists.alioth.debian.org, 388756@bugs.debian.org
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Mon, 02 Oct 2006 16:16:45 +0200
On Mon, 2006-10-02 at 15:58 +0200, Stephan Seitz wrote:
[...]
> >---
> >Firmwares are an essential part of any modern computer, and it is an
> >annoying but currently hard to change fact of life that we lack the
> >source for almost all of them.
> 
> Then you can’t distribute these firmwares within the GPL driver sources.  
> You can only get the permission to distribute the firmware outside the 
> driver. In Debian this means, you can put it in non-free.
> [...]

>From what I see, would it be possible to have a useful (i.e.: complete)
package of zaptel-source in the non-free archive?

That would be enough for me.

> Debian will not show much commitment to free software if it
> distributes firmware without source (or without permission) in main.

The firmware is inside a tarball with a GPL license from Digium, is this
sufficient to freely distribute the firmware?
I would say yes, but IANAL so I'll try to ask Digium about that.

Some comments from the package mantainers?

Thanks!
Alex





Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to "Kevin P. Fleming" <kpfleming@digium.com>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #50 received at 388756@bugs.debian.org (full text, mbox):

From: "Kevin P. Fleming" <kpfleming@digium.com>
To: 388756@bugs.debian.org
Subject: Comments from Digium
Date: Mon, 2 Oct 2006 13:32:24 -0500 (CDT)
This issue was just brought to my attention, so I'll try to clear up any confusion involved here regarding the wct4xxp driver.

First, even though the .ima file is included in a tarball that contains a GPL license, it is not covered by that license. It is also not directly part of the program in that form. The build process does convert the firmware into a header file and include it into the module, though, which is (to some degree) a violation of the GPL on the kernel. Given that kernel maintainers' stance on this in the past, we are not terribly concerned about it. It also violates the GPL on Zaptel itself, but since we are the GPL licensors of Zaptel and also the distributors of the infringing code, we are not concerned about that either.

Second, the driver already contains support for userspace loading of the firmware, and it's trivial to modify the Makefile/driver to _NOT_ build the firmware into the kernel module at all. This was done specifically so that people could avoid this GPL issue.

The module is completely usable without the firmware, as long as the user does not have the optional Octasic module on their TE4XXP card (and most users do not have those modules).

My recommendation would be for Debian to build/ship wct4xxp.ko with only userspace firmware loading enabled (not the build-time linking of the firmware into the module), and then package the firmware itself in a non-free package that just puts the firmware into the proper place for the userspace firmware loader to find it.

-- 
Kevin P. Fleming
Senior Software Engineer
Digium, Inc.




Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Mark Purcell <msp@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #55 received at 388756@bugs.debian.org (full text, mbox):

From: Mark Purcell <msp@debian.org>
To: 388756@bugs.debian.org
Cc: Alessandro Polverini <alex@nibbles.it>, Stephan Seitz <nur-ab-sal@gmx.de>
Subject: Re: Bug#388756: zaptel-source: wct4xxp and other modules are not built anymore on zaptel-1.2.8.dfsg-1
Date: Mon, 9 Oct 2006 13:10:37 +1000
On Tuesday 03 October 2006 00:16, Alessandro Polverini wrote:
> >From what I see, would it be possible to have a useful (i.e.: complete)
> > package of zaptel-source in the non-free archive?
>
> That would be enough for me.

Alessandro,

I would be happy to move zaptel to non-free.

However it appears that the firmware doesn't do a whole lot, except for a very 
limited set of users:

 "The module is completely usable without the firmware, as long as the user 
does not have the optional Octasic module on their TE4XXP card (and most 
users do not have those modules)."

I should thus be able to remove the firmware and get the wct4xxp module built 
within the package.. So everyone should be happy..

The reason why the wct4xxp module was removed, was I didn't realise it could 
be built without the firmware and didn't require it for operation.

I'll see what I can do and get something uploaded soon..

Mark



Tags added: pending Request was from Mark Purcell <msp@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Reply sent to Mark Purcell <msp@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Alessandro Polverini <alex@nibbles.it>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #62 received at 388756-close@bugs.debian.org (full text, mbox):

From: Mark Purcell <msp@debian.org>
To: 388756-close@bugs.debian.org
Subject: Bug#388756: fixed in zaptel 1:1.2.9.1.dfsg-2
Date: Tue, 10 Oct 2006 02:21:19 -0700
Source: zaptel
Source-Version: 1:1.2.9.1.dfsg-2

We believe that the bug you reported is fixed in the latest version of
zaptel, which is due to be installed in the Debian FTP archive:

libtonezone-dev_1.2.9.1.dfsg-2_i386.deb
  to pool/main/z/zaptel/libtonezone-dev_1.2.9.1.dfsg-2_i386.deb
libtonezone1_1.2.9.1.dfsg-2_i386.deb
  to pool/main/z/zaptel/libtonezone1_1.2.9.1.dfsg-2_i386.deb
zaptel-source_1.2.9.1.dfsg-2_all.deb
  to pool/main/z/zaptel/zaptel-source_1.2.9.1.dfsg-2_all.deb
zaptel_1.2.9.1.dfsg-2.diff.gz
  to pool/main/z/zaptel/zaptel_1.2.9.1.dfsg-2.diff.gz
zaptel_1.2.9.1.dfsg-2.dsc
  to pool/main/z/zaptel/zaptel_1.2.9.1.dfsg-2.dsc
zaptel_1.2.9.1.dfsg-2_i386.deb
  to pool/main/z/zaptel/zaptel_1.2.9.1.dfsg-2_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 388756@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mark Purcell <msp@debian.org> (supplier of updated zaptel package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 10 Oct 2006 09:36:58 +1000
Source: zaptel
Binary: libtonezone1 zaptel-source zaptel libtonezone-dev
Architecture: source all i386
Version: 1:1.2.9.1.dfsg-2
Distribution: unstable
Urgency: low
Maintainer: Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>
Changed-By: Mark Purcell <msp@debian.org>
Description: 
 libtonezone-dev - tonezone library (development)
 libtonezone1 - tonezone library (runtime)
 zaptel     - zapata telephony utilities
 zaptel-source - Zapata telephony interface (source code for kernel driver)
Closes: 388756 390903 391840
Changes: 
 zaptel (1:1.2.9.1.dfsg-2) unstable; urgency=low
 .
   [ Tzafrir Cohen ]
   * zaptel 1.4 compatibility changes:
   - place zaptel.h and tonezone.h in /usr/include/zaptel (through symlinks)
   - zaptelh_14.dpatch: declare some zaptel 1.4 interfaces (not implemented
     anywhere, though).
 .
   [ Mark Purcell ]
   * debian/rules patch from Robert Millan
     - the package doesn't compile  (Closes: #390903)
   * add debian/patches/dbug391840.dpatch
     - ztcfg segfaults because of -O4 (Closes: #391840)
   * add debian/patches/wct4xxp-dfsg.dpatch
     - wct4xxp and other modules are not built anymore on zaptel-
     1.2.8.dfsg-1 (Closes: #388756)
Files: 
 d9c1f0fc733324ef164d552a82a351a1 964 comm optional zaptel_1.2.9.1.dfsg-2.dsc
 915c3c9e6bbc1484ab4e5519e77dce50 141363 comm optional zaptel_1.2.9.1.dfsg-2.diff.gz
 d0ead5dcdc67a1e4388fc98f3f771513 737680 devel optional zaptel-source_1.2.9.1.dfsg-2_all.deb
 833e661287ea4723211f155dc060c0be 106022 comm optional zaptel_1.2.9.1.dfsg-2_i386.deb
 ce68c91d1c0d000e240848a312c6992b 24962 libs optional libtonezone1_1.2.9.1.dfsg-2_i386.deb
 5f10ab48bb3bf4bfca59a41b0b8e06cc 26046 libdevel optional libtonezone-dev_1.2.9.1.dfsg-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFKt2RoCzanz0IthIRAkaYAJ4u8lF1AbqLNvl3irBhN5WbzZTdBwCfU//5
1Xth/U6573J0YBUnD6n1skk=
=eVQy
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to "Marc Fargas" <telenieko@telenieko.com>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #67 received at 388756@bugs.debian.org (full text, mbox):

From: "Marc Fargas" <telenieko@telenieko.com>
To: 388756@bugs.debian.org
Subject: Then, wct4xxp is or isn't build with latest release?
Date: Tue, 10 Oct 2006 15:01:28 +0200
[Message part 1 (text/plain, inline)]
Just to know, as the bug log says that Mark can move zaptel to non-free, but
another entry says it's not required and that the firmware could be moved
alone to a new package...

If I get the latest zaptel will I have wct4xpp?

Thanks,
Marc.

-- 
The probability of failure of a (computer) system is exponentially
proportional to the physical distance between it and the one who could fix
it. -- Martin F. Krafft
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to "Mark Purcell" <msp@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #72 received at 388756@bugs.debian.org (full text, mbox):

From: "Mark Purcell" <msp@debian.org>
To: "Marc Fargas" <telenieko@telenieko.com>, 388756@bugs.debian.org
Subject: Re: Bug#388756: Then, wct4xxp is or isn't build with latest release?
Date: Wed, 11 Oct 2006 08:28:30 +0100 (BST)
> Just to know, as the bug log says that Mark can move zaptel to non-free,
> but
> another entry says it's not required and that the firmware could be moved
> alone to a new package...
>
> If I get the latest zaptel will I have wct4xpp?

Latest zaptel does have the wct4xpp module and doesn't have the firmware.

The firmware isn't needed for the majority of users so it shouldn't be an
issue.

Mark




Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to "Marc Fargas" <telenieko@telenieko.com>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #77 received at 388756@bugs.debian.org (full text, mbox):

From: "Marc Fargas" <telenieko@telenieko.com>
To: 388756@bugs.debian.org
Subject: Re: Bug#388756: Then, wct4xxp is or isn't build with latest release?
Date: Wed, 11 Oct 2006 10:24:32 +0200
[Message part 1 (text/plain, inline)]
Thanks for the information, now I can upgrade without fears :)

Cheers,
Marc

On 10/11/06, Mark Purcell <msp@debian.org> wrote:
>
> > Just to know, as the bug log says that Mark can move zaptel to non-free,
> > but
> > another entry says it's not required and that the firmware could be
> moved
> > alone to a new package...
> >
> > If I get the latest zaptel will I have wct4xpp?
>
> Latest zaptel does have the wct4xpp module and doesn't have the firmware.
>
> The firmware isn't needed for the majority of users so it shouldn't be an
> issue.
>
> Mark
>
>
>
> _______________________________________________
> Pkg-voip-maintainers mailing list
> Pkg-voip-maintainers@lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/pkg-voip-maintainers
>



-- 
The probability of failure of a (computer) system is exponentially
proportional to the physical distance between it and the one who could fix
it. -- Martin F. Krafft
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Mark Purcell <msp@debian.org>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #82 received at 388756@bugs.debian.org (full text, mbox):

From: Mark Purcell <msp@debian.org>
To: Max Bowsher <maxb@mxtelecom.com>, 395499-done@bugs.debian.org, 388756@bugs.debian.org
Subject: Re: Bug#395499: Support for wct4xxp module dropped
Date: Fri, 27 Oct 2006 18:58:05 +0100
On Friday 27 October 2006 13:03, Max Bowsher wrote:
> Dropping support for wct4xxp represents a critical regression to people
> using that hardware.

Max,

I would suggest you have a read of:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=388756

wct4xxp was removed from unstable, but was restored with zaptel 
(1:1.2.9.1.dfsg-2) which is currently sitting in both testing and unstable.

Mark



Information forwarded to debian-bugs-dist@lists.debian.org, Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>:
Bug#388756; Package zaptel-source. Full text and rfc822 format available.

Acknowledgement sent to Max Bowsher <maxb@mxtelecom.com>:
Extra info received and forwarded to list. Copy sent to Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>. Full text and rfc822 format available.

Message #87 received at 388756@bugs.debian.org (full text, mbox):

From: Max Bowsher <maxb@mxtelecom.com>
To: Mark Purcell <msp@debian.org>, 395499@bugs.debian.org
Cc: 388756@bugs.debian.org
Subject: Re: Bug#395499: Support for wct4xxp module dropped
Date: Mon, 30 Oct 2006 10:24:37 +0000
Mark Purcell wrote:
> On Friday 27 October 2006 13:03, Max Bowsher wrote:
>> Dropping support for wct4xxp represents a critical regression to people
>> using that hardware.
> 
> Max,
> 
> I would suggest you have a read of:
> 
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=388756
> 
> wct4xxp was removed from unstable, but was restored with zaptel 
> (1:1.2.9.1.dfsg-2) which is currently sitting in both testing and unstable.

Oops, my apologies. I checked versions in Ubuntu, then went back to
Debian to report the bug since it wasn't Ubuntu-specific, but forgot to
check for newer versions in Debian. That was rather stupid of me.

Sorry about that, and thanks for the response,

Max.



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 26 Jun 2007 00:02:46 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 00:20:36 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.