Debian Bug report logs - #386867
atokx2 needs Depends: libstdc++5

version graph

Package: atokx2; Maintainer for atokx2 is (unknown);

Reported by: Masahito Omote <omote@debian.org>

Date: Sun, 10 Sep 2006 18:48:55 UTC

Severity: serious

Found in version atokx2/17.0-2.0-4

Fixed in version 17.0-2.0-4.1

Done: Steve Langasek <vorlon@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Taku YASUI <tach@debian.or.jp>:
Bug#386867; Package atokx2. Full text and rfc822 format available.

Acknowledgement sent to Masahito Omote <omote@debian.org>:
New Bug report received and forwarded. Copy sent to Taku YASUI <tach@debian.or.jp>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Masahito Omote <omote@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: atokx2 needs Depends: libstdc++5
Date: Mon, 11 Sep 2006 03:43:18 +0900
Package: atokx2
Version: 17.0-2.0-4
Severity: serious

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

/usr/sbin/atokx2mngdaemon, /usr/lib/atokx2/usr/lib/im/leif/atokx2.so,
/usr/lib/atokx2/usr/lib/im/locale/ja/atokx2/atokx2aux.so and so on
are depending on libstdc++.so.5.

Therefore atokx2 does not work at all if libstdc++5 is not installed.
Please add libstdc++5 to Depends field.

ldd results are as follows,
% ldd /usr/sbin/atokx2mngdaemon
	linux-gate.so.1 =>  (0xffffe000)
	libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb7e88000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7e7d000)
	libc.so.6 => /lib/tls/libc.so.6 (0xb7d4a000)
	libm.so.6 => /lib/tls/libm.so.6 (0xb7d25000)
	/lib/ld-linux.so.2 (0xb7f56000)
% ldd /usr/lib/atokx2/usr/lib/im/leif/atokx2.so
	linux-gate.so.1 =>  (0xffffe000)
	libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb7e97000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7e8c000)
	libdl.so.2 => /lib/tls/libdl.so.2 (0xb7e88000)
	libpthread.so.0 => /lib/tls/libpthread.so.0 (0xb7e76000)
	libc.so.6 => /lib/tls/libc.so.6 (0xb7d44000)
	libm.so.6 => /lib/tls/libm.so.6 (0xb7d1f000)
	/lib/ld-linux.so.2 (0x80000000)
% ldd /usr/lib/atokx2/usr/lib/im/locale/ja/atokx2/atokx2aux.so
	linux-gate.so.1 => (0xffffe000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0xb7e40000)
	libiiimcf.so.2 => /usr/lib/libiiimcf.so.2 (0xb7e16000)
	libiiimp.so.0 => /usr/lib/libiiimp.so.0 (0xb7deb000)
	libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0xb7d31000)
	libm.so.6 => /lib/tls/libm.so.6 (0xb7d0c000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7d01000)
	libc.so.6 => /lib/tls/libc.so.6 (0xb7bce000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0xb7bcb000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7bc6000)
	libdl.so.2 => /lib/tls/libdl.so.2 (0xb7bc2000)
	/lib/ld-linux.so.2 (0x80000000)

- -- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17.2-3
Locale: LANG=ja_JP.eucJP, LC_CTYPE=ja_JP.eucJP (charmap=EUC-JP)

Versions of packages atokx2 depends on:
ii  debconf [debconf-2.0]      1.5.4         Debian configuration management sy
ii  iiimf-htt-server           11.4.1870-7.3 Htt input method server
ii  iiimf-htt-xbe              11.4.1870-7.3 IIIMF Htt XIM BackEnd module
ii  im-switch                  1.11          Input method switch framework
ii  libc6                      2.3.6.ds1-4   GNU C Library: Shared libraries
ii  libgtk2.0-0                2.8.20-1      The GTK+ graphical user interface 

atokx2 recommends no packages.

- -- debconf information:
* atokx2/archive_dir: /cdrom/bin/ATOK

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFBFzF4QYOB7JaXPERAuBAAJ9FSIM5F5gmAmNktVBfPgX1yHEDCgCfd2dw
+UxhqzUajZe07djqv/5ylEU=
=EqYr
-----END PGP SIGNATURE-----



Tags added: fixed Request was from Michael Meskes <meskes@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Taku YASUI <tach@debian.or.jp>:
Bug#386867; Package atokx2. Full text and rfc822 format available.

Acknowledgement sent to Kurt Roeckx <kurt@roeckx.be>:
Extra info received and forwarded to list. Copy sent to Taku YASUI <tach@debian.or.jp>. Full text and rfc822 format available.

Message #12 received at 386867@bugs.debian.org (full text, mbox):

From: Kurt Roeckx <kurt@roeckx.be>
To: 386867@bugs.debian.org, control@bugs.debian.org
Cc: Masahito Omote <omote@debian.org>, Michael Meskes <meskes@debian.org>
Subject: Re: atokx2 needs Depends: libstdc++5
Date: Sat, 16 Sep 2006 17:21:00 +0200
reopen 386867
thanks

Hi,

I don't see such a binary in the package in the first place.  If it
exists, the source also seems to be missing.

Also, manually adding a Depends on libstdc++5 is plain wrong, the call
to dh_shlibdeps should have added that.

If this really contained such binaries, and there was a source for
it, rebuilding it should get you a dependency on libstdc++6, not on
libstdc++5.

I think this NMU was just plain wrong.


Kurt




Tags removed: fixed Request was from Kurt Roeckx <kurt@roeckx.be> to control@bugs.debian.org. Full text and rfc822 format available.

Reply sent to Michael Meskes <meskes@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Masahito Omote <omote@debian.org>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #19 received at 386867-done@bugs.debian.org (full text, mbox):

From: Michael Meskes <meskes@debian.org>
To: Kurt Roeckx <kurt@roeckx.be>
Cc: 386867-done@bugs.debian.org, Masahito Omote <omote@debian.org>
Subject: Re: atokx2 needs Depends: libstdc++5
Date: Sat, 16 Sep 2006 19:24:06 +0200
On Sat, Sep 16, 2006 at 05:21:00PM +0200, Kurt Roeckx wrote:
> I don't see such a binary in the package in the first place.  If it
> exists, the source also seems to be missing.
> 
> Also, manually adding a Depends on libstdc++5 is plain wrong, the call
> to dh_shlibdeps should have added that.
> 
> If this really contained such binaries, and there was a source for
> it, rebuilding it should get you a dependency on libstdc++6, not on
> libstdc++5.
> 
> I think this NMU was just plain wrong.

Please get the facts right first. This is an INSTALLER package. It
installs software that is not part of Debian. And this software depends
on libstdc++5. So feel free to suggest a better solution. :-)

Michael

-- 
Michael Meskes
Email: Michael at Fam-Meskes dot De, Michael at Meskes dot (De|Com|Net|Org)
ICQ: 179140304, AIM/Yahoo: michaelmeskes, Jabber: meskes@jabber.org
Go SF 49ers! Go Rhein Fire! Use Debian GNU/Linux! Use PostgreSQL!



Bug reopened, originator not changed. Request was from Steve Langasek <vorlon@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Bug marked as fixed in version 17.0-2.0-4.1, send any further explanations to Masahito Omote <omote@debian.org> Request was from Steve Langasek <vorlon@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 15 Jul 2007 07:30:16 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 13:39:25 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.