Debian Bug report logs - #355140
FTBFS: Oberon-2 compiler was not installed with X11 support.

version graph

Package: libooc-vo; Maintainer for libooc-vo is (unknown);

Reported by: Martin Michlmayr <tbm@cyrius.com>

Date: Fri, 3 Mar 2006 15:03:12 UTC

Severity: serious

Found in version libooc-vo/20020310-3

Fixed in version 20020310-3+rm

Done: Lucas Nussbaum <lucas@lucas-nussbaum.net>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, 347139@bugs.debian.org, fmw@debian.org (Florian M. Weps):
Bug#355140; Package libooc-vo. Full text and rfc822 format available.

Acknowledgement sent to Martin Michlmayr <tbm@cyrius.com>:
New Bug report received and forwarded. Copy sent to 347139@bugs.debian.org, fmw@debian.org (Florian M. Weps). Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: FTBFS: Oberon-2 compiler was not installed with X11 support.
Date: Fri, 3 Mar 2006 14:37:38 +0000
Package: libooc-vo
Version: 20020310-3
Severity: serious

Your packages doesn't build in unstable; it fails with "Oberon-2
compiler was not installed with X11 support".  This may arguably be a
bug in libooc-x11, but looking at the libooc-x11 bug package suggests
that it may not.  Please investigate if this package, libooc-x11 or
both are at fault.  Looking at #347139 may be helpful.


> Automatic build of libooc-vo_20020310-3 on bigsur by sbuild/mips 1.75
...
> Get:1 ftp://ftp-uxsup.csx.cam.ac.uk unstable/main libooc-x11 20020123-2.2 [7120B]
> Get:2 ftp://ftp-uxsup.csx.cam.ac.uk unstable/main libooc-x11-dev 20020123-2.2 [99.0kB]
> Get:3 ftp://ftp-uxsup.csx.cam.ac.uk unstable/main libooc-xml 3.2.0-1 [172kB]
> Get:4 ftp://ftp-uxsup.csx.cam.ac.uk unstable/main libooc-xml-dev 3.2.0-1 [414kB]
...
> checking for oo2c... oo2c
> checking initialization file... /usr/lib/oo2c/oo2crc
> checking installation directory... /usr/lib/oo2c
> checking for ooconfig... /usr/lib/oo2c/ooconfig
> checking for library support... yes
> checking for oocn... oocn
> checking for a BSD-compatible install... /usr/bin/install -c
> checking for module X11.Mod... no
> configure: error: The Oberon-2 compiler was not installed with X11 support.
> make: *** [configure-stamp] Error 1
> ******************************************************************************
> Build finished at 20060303-1045
> FAILED [dpkg-buildpackage died]

-- 
Martin Michlmayr
http://www.cyrius.com/



Information forwarded to debian-bugs-dist@lists.debian.org, fmw@debian.org (Florian M. Weps):
Bug#355140; Package libooc-vo. Full text and rfc822 format available.

Acknowledgement sent to Martin Michlmayr <tbm@cyrius.com>:
Extra info received and forwarded to list. Copy sent to fmw@debian.org (Florian M. Weps). Full text and rfc822 format available.

Message #10 received at submit@bugs.debian.org (full text, mbox):

From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: Re: Bug#355140: FTBFS: Oberon-2 compiler was not installed with X11 support.
Date: Fri, 3 Mar 2006 15:21:40 +0000
* Martin Michlmayr <tbm@cyrius.com> [2006-03-03 14:37]:
> compiler was not installed with X11 support".  This may arguably be a
> bug in libooc-x11, but looking at the libooc-x11 bug package suggests
> that it may not.  Please investigate if this package, libooc-x11 or
> both are at fault.  Looking at #347139 may be helpful.

I also found #133970 but it seems that's not the problem.

Here's my config.log btw:


This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure --prefix=/usr

## --------- ##
## Platform. ##
## --------- ##

hostname = bigsur
uname -m = mips64
uname -r = 2.6.16-rc5
uname -s = Linux
uname -v = #8 SMP Thu Mar 2 15:19:49 GMT 2006

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = mips64
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/X11R6/bin
PATH: /usr/games


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1231: checking for oo2c
configure:1247: found /usr/bin/oo2c
configure:1257: result: oo2c
configure:1344: checking initialization file
configure:1353: result: /usr/lib/oo2c/oo2crc
configure:1359: checking installation directory
configure:1372: result: /usr/lib/oo2c
configure:1386: checking for ooconfig
configure:1400: result: /usr/lib/oo2c/ooconfig
configure:1408: checking for library support
configure:1426: result: yes
configure:1434: checking for oocn
configure:1450: found /usr/bin/oocn
configure:1460: result: oocn
configure:1505: checking for a BSD-compatible install
configure:1560: result: /usr/bin/install -c
configure:1573: checking for module X11.Mod
configure:1600: oo2c -Mv -O --libs  conftest.Mod 1>&5
- ./conftest.Mod
   new symbol file
gcc -pipe -D_REENTRANT   -I/usr/include/gc -O2 -I. -I/usr/lib/oo2c/obj -I/usr/lib/oo2c/lib -I/usr/lib/oo2c/X11/obj -I/usr/lib/oo2c/XML/obj -I- -c ./conftest.c -o ./conftest.o
cc1: note: obsolete option -I- used, please use -iquote instead
gcc -pipe -D_REENTRANT   -I/usr/include/gc -O2 -I. -I/usr/lib/oo2c/obj -I/usr/lib/oo2c/lib -I/usr/lib/oo2c/X11/obj -I/usr/lib/oo2c/XML/obj -I- -c ./_conftest.c -o ./_conftest.o
cc1: note: obsolete option -I- used, please use -iquote instead
gcc -o conftest -L/usr/lib /usr/lib/oo2c/obj/__oo2c.o ./conftest.o ./_conftest.o -loo2c_x11  -L/usr/X11R6/lib -lX11 -loo2c -lgc
/usr/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
Error: Linker reported error, aborting
configure:1603: $? = 1
configure: failed program was:
#line 1587 "configure"
char XOpenDisplay();
int test_fct() {
XOpenDisplay(); return 0; }

MODULE conftest [INTERFACE "C"; LINK FILE "conftest.c" END];
IMPORT dummy:=Strings, Strings, X11;
END conftest.
configure:1617: result: no
configure:1623: error: The Oberon-2 compiler was not installed with X11 support.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/usr/bin/install -c'
ac_cv_prog_OOC=oo2c
ac_cv_prog_OOCN=oocn
ooc_cv_ooc_have_libs=yes
ooc_cv_ooc_have_x11=no
ooc_cv_path_ooc_init=/usr/lib/oo2c/oo2crc
ooc_cv_path_ooc_libdir=/usr/lib/oo2c
ooc_cv_prog_ooconfig=/usr/lib/oo2c/ooconfig

## ----------------- ##
## Output variables. ##
## ----------------- ##

DEFS=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
LIBOBJS=''
LIBS=''
LTLIBOBJS=''
OFLAGS='-O'
OOC='oo2c'
OOCN='oocn'
OOCONFIG='/usr/lib/oo2c/ooconfig'
OOC_INIT='/usr/lib/oo2c/oo2crc'
OOC_LIBDIR='/usr/lib/oo2c'
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
SET_MAKE=''
SHELL='/bin/sh'
bindir='${exec_prefix}/bin'
build_alias=''
datadir='${prefix}/share'
exec_prefix='NONE'
have_libImlib=''
have_libXext=''
have_libXpm=''
have_libgif=''
have_libjpeg=''
have_libm=''
have_libpng=''
have_libtiff=''
have_libz=''
have_x11='no'
host_alias=''
includedir='${prefix}/include'
infodir='${prefix}/info'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
mandir='${prefix}/man'
oldincludedir='/usr/include'
ooc_Imlib_prefix=''
ooc_Xext_prefix=''
ooc_Xpm_prefix=''
ooc_gif_prefix=''
ooc_have_libs='yes'
ooc_jpeg_prefix=''
ooc_m_prefix=''
ooc_png_prefix=''
ooc_tiff_prefix=''
ooc_z_prefix=''
prefix='/usr'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""

configure: exit 1

-- 
Martin Michlmayr
http://www.cyrius.com/



Bug marked as fixed in version 20020310-3+rm, send any further explanations to Martin Michlmayr <tbm@cyrius.com> Request was from Lucas Nussbaum <lucas@lucas-nussbaum.net> to control@bugs.debian.org. (Wed, 09 Apr 2008 16:36:07 GMT) Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sun, 10 Aug 2008 14:07:07 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 06:18:15 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.