Debian Bug report logs - #349142
xterm: Warning "mesg: error: tty device is not owned by group `tty'"

version graph

Package: xterm; Maintainer for xterm is Debian X Strike Force <debian-x@lists.debian.org>; Source for xterm is src:xterm.

Reported by: Roman Bertle <bertle@kph.tuwien.ac.at>

Date: Sat, 21 Jan 2006 10:33:02 UTC

Severity: minor

Merged with 349924

Found in version xterm/208-3.1

Fixed in version xterm/226-1

Done: Julien Cristau <jcristau@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#349142; Package xterm. Full text and rfc822 format available.

Acknowledgement sent to Roman Bertle <bertle@kph.tuwien.ac.at>:
New Bug report received and forwarded. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Roman Bertle <bertle@kph.tuwien.ac.at>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: xterm: Warning "mesg: error: tty device is not owned by group `tty'"
Date: Sat, 21 Jan 2006 11:27:53 +0100
Package: xterm
Version: 208-3.1
Severity: minor

Hello,

since my last system upgrade, if I open a xterm a warning message is written:

mesg: error: tty device is not owned by group `tty'

Regards, Roman

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-686
Locale: LANG=de_AT.UTF-8, LC_CTYPE=de_AT.UTF-8 (charmap=UTF-8)

Versions of packages xterm depends on:
ii  libc6                     2.3.5-12       GNU C Library: Shared libraries an
ii  libfontconfig1            2.3.2-1.1      generic font configuration library
ii  libfreetype6              2.1.10-1       FreeType 2 font engine, shared lib
ii  libice6                   6.9.0.dfsg.1-4 Inter-Client Exchange library
ii  libncurses5               5.5-1          Shared libraries for terminal hand
ii  libsm6                    6.9.0.dfsg.1-4 X Window System Session Management
ii  libx11-6                  6.9.0.dfsg.1-4 X Window System protocol client li
ii  libxaw8                   6.9.0.dfsg.1-4 X Athena widget set library
ii  libxext6                  6.9.0.dfsg.1-4 X Window System miscellaneous exte
ii  libxft2                   2.1.7-1        FreeType-based font drawing librar
ii  libxmu6                   6.9.0.dfsg.1-4 X Window System miscellaneous util
ii  libxrender1               1:0.9.0.2-1    X Rendering Extension client libra
ii  libxt6                    6.9.0.dfsg.1-4 X Toolkit Intrinsics
ii  xlibs-data                6.9.0.dfsg.1-4 X Window System client data
ii  zlib1g                    1:1.2.3-9      compression library - runtime

Versions of packages xterm recommends:
ii  xutils                    6.9.0.dfsg.1-4 X Window System utility programs

-- debconf information:
  xterm/clobber_xresource_file: true
  xterm/xterm_needs_devpts:



Information forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#349142; Package xterm. Full text and rfc822 format available.

Acknowledgement sent to Thomas Dickey <dickey@radix.net>:
Extra info received and forwarded to list. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. Full text and rfc822 format available.

Message #10 received at 349142@bugs.debian.org (full text, mbox):

From: Thomas Dickey <dickey@radix.net>
To: Roman Bertle <bertle@kph.tuwien.ac.at>, 349142@bugs.debian.org
Subject: Re: Bug#349142: xterm: Warning "mesg: error: tty device is not owned by group `tty'"
Date: Sat, 21 Jan 2006 11:18:20 -0500
[Message part 1 (text/plain, inline)]
On Sat, Jan 21, 2006 at 11:40:09AM +0100, Roman Bertle wrote:
> Package: xterm
> Version: 208-3.1
> Severity: minor
> 
> Hello,
> 
> since my last system upgrade, if I open a xterm a warning message is written:

That more than likely indicates a problem with your configuration than
xterm (of course it could be the package).
 
> mesg: error: tty device is not owned by group `tty'

On my system for instance, xterm is setgid to utmp.  Perhaps these (xterm)
changelog entries are related to your problem:

                   Patch #206 - 2005/11/3 - XFree86 4.5.99.15

     * modify  Imakefile  to  use  setgid  mode for installing with Linux,
       OpenBSD and FreeBSD.
     * add  configure  --with-setuid and --with-reference options to allow
       packagers more flexibility in customizing install permissions.
     * generalize  and  make  optional  (configure --with-utmp-setgid) the
       change made for XFree86 Bugzilla #878 in [219]patch #205 (FreeBSD
       bug report #ports/86663).

 
> Regards, Roman
> 
> -- System Information:
> Debian Release: testing/unstable
>   APT prefers unstable
>   APT policy: (500, 'unstable')
> Architecture: i386 (i686)
> Shell:  /bin/sh linked to /bin/bash
> Kernel: Linux 2.6.15-1-686
> Locale: LANG=de_AT.UTF-8, LC_CTYPE=de_AT.UTF-8 (charmap=UTF-8)
> 
> Versions of packages xterm depends on:
> ii  libc6                     2.3.5-12       GNU C Library: Shared libraries an
> ii  libfontconfig1            2.3.2-1.1      generic font configuration library
> ii  libfreetype6              2.1.10-1       FreeType 2 font engine, shared lib
> ii  libice6                   6.9.0.dfsg.1-4 Inter-Client Exchange library
> ii  libncurses5               5.5-1          Shared libraries for terminal hand
> ii  libsm6                    6.9.0.dfsg.1-4 X Window System Session Management
> ii  libx11-6                  6.9.0.dfsg.1-4 X Window System protocol client li
> ii  libxaw8                   6.9.0.dfsg.1-4 X Athena widget set library
> ii  libxext6                  6.9.0.dfsg.1-4 X Window System miscellaneous exte
> ii  libxft2                   2.1.7-1        FreeType-based font drawing librar
> ii  libxmu6                   6.9.0.dfsg.1-4 X Window System miscellaneous util
> ii  libxrender1               1:0.9.0.2-1    X Rendering Extension client libra
> ii  libxt6                    6.9.0.dfsg.1-4 X Toolkit Intrinsics
> ii  xlibs-data                6.9.0.dfsg.1-4 X Window System client data
> ii  zlib1g                    1:1.2.3-9      compression library - runtime
> 
> Versions of packages xterm recommends:
> ii  xutils                    6.9.0.dfsg.1-4 X Window System utility programs
> 
> -- debconf information:
>   xterm/clobber_xresource_file: true
>   xterm/xterm_needs_devpts:
> 
> 
> -- 
> To UNSUBSCRIBE, email to debian-bugs-dist-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
-- 
Thomas E. Dickey
http://invisible-island.net
ftp://invisible-island.net
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Debian X Strike Force <debian-x@lists.debian.org>:
Bug#349142; Package xterm. Full text and rfc822 format available.

Acknowledgement sent to David Nusinow <david_nusinow@verizon.net>:
Extra info received and forwarded to list. Copy sent to Debian X Strike Force <debian-x@lists.debian.org>. Full text and rfc822 format available.

Message #15 received at 349142@bugs.debian.org (full text, mbox):

From: David Nusinow <david_nusinow@verizon.net>
To: 349142@bugs.debian.org
Subject: Re: Bug#349142: xterm: Warning "mesg: error: tty device is not owned by group `tty'"
Date: Mon, 13 Mar 2006 21:49:41 -0500
On Sat, Jan 21, 2006 at 11:18:20AM -0500, Thomas Dickey wrote:
> On Sat, Jan 21, 2006 at 11:40:09AM +0100, Roman Bertle wrote:
> > Package: xterm
> > Version: 208-3.1
> > Severity: minor
> > 
> > Hello,
> > 
> > since my last system upgrade, if I open a xterm a warning message is written:
> 
> That more than likely indicates a problem with your configuration than
> xterm (of course it could be the package).
>  
> > mesg: error: tty device is not owned by group `tty'
> 
> On my system for instance, xterm is setgid to utmp.  Perhaps these (xterm)
> changelog entries are related to your problem:
> 
>                    Patch #206 - 2005/11/3 - XFree86 4.5.99.15
> 
>      * modify  Imakefile  to  use  setgid  mode for installing with Linux,
>        OpenBSD and FreeBSD.
>      * add  configure  --with-setuid and --with-reference options to allow
>        packagers more flexibility in customizing install permissions.
>      * generalize  and  make  optional  (configure --with-utmp-setgid) the
>        change made for XFree86 Bugzilla #878 in [219]patch #205 (FreeBSD
>        bug report #ports/86663).

Hrm, regarding your fix in xterm 210, I'm not sure if this will work
entirely. On my system, I have some tty's owned by group root and others by
group tty. Won't setting the tty group with the --with-tty-group only work
for one set of these tty's, but not the other?

 - David Nusinow, who hasn't yet reproduced this on his system



Merged 349142 349924. Request was from Julien Cristau <julien.cristau@ens-lyon.org> to control@bugs.debian.org. Full text and rfc822 format available.

Reply sent to Julien Cristau <jcristau@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Roman Bertle <bertle@kph.tuwien.ac.at>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #22 received at 349142-close@bugs.debian.org (full text, mbox):

From: Julien Cristau <jcristau@debian.org>
To: 349142-close@bugs.debian.org
Subject: Bug#349142: fixed in xterm 226-1
Date: Mon, 18 Jun 2007 13:47:09 +0000
Source: xterm
Source-Version: 226-1

We believe that the bug you reported is fixed in the latest version of
xterm, which is due to be installed in the Debian FTP archive:

xterm_226-1.diff.gz
  to pool/main/x/xterm/xterm_226-1.diff.gz
xterm_226-1.dsc
  to pool/main/x/xterm/xterm_226-1.dsc
xterm_226-1_i386.deb
  to pool/main/x/xterm/xterm_226-1_i386.deb
xterm_226.orig.tar.gz
  to pool/main/x/xterm/xterm_226.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 349142@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Julien Cristau <jcristau@debian.org> (supplier of updated xterm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Mon, 18 Jun 2007 14:02:22 +0100
Source: xterm
Binary: xterm
Architecture: source i386
Version: 226-1
Distribution: unstable
Urgency: low
Maintainer: Debian X Strike Force <debian-x@lists.debian.org>
Changed-By: Julien Cristau <jcristau@debian.org>
Description: 
 xterm      - X terminal emulator
Closes: 12261 349142 418324 420974 421523 422521 426364 426863
Changes: 
 xterm (226-1) unstable; urgency=low
 .
   [ Branden Robinson ]
   * Remove debian/NEWS; the events it attested to (like the "upcoming 7.0
     modularization" are no longer news, and are in the past.
 .
   [ Julien Cristau ]
   * Configure with --with-tty-group=tty, to prevent security problems in case
     of buggy build environment (closes: #349142).
   * New upstream release.
     + fix  an  infinite  loop  when  showing  a  2-column character in a
       1-column screen (closes: #426863).
     + add  XF86Paste  and  SunPaste  to the default translations
       (closes: #422521, patch by Bernhard R Link).
     + improve  permissions  logic  when  closing pseudo-terminal
       (closes: #12261, patch by Nathanael Nerode, analysis by Richard
       Braakman).
     + add  a check in case someone tries to call the popup-menu() action
       on a menu which is not initialized (closes: #426364).
     + fix error-checking on internal font switching for "Selection" menu
       entry (closes: #421523).
     + amend select/paste change from patch #225 by limiting it to
       non-UTF-8/non-KOI8-R encoding (closes: #420974).
     + add  workaround  for  groff  ".URL" codes which are not present in
       some commonly-used bitmap fonts (closes: #418324).
   * Update reference to xlibs-data in xterm's description, refer to xbitmaps
     instead.
   * Build-depend on desktop-file-utils to install the new desktop files for
     xterm and uxterm, and change debian/rules and debian/xterm.install to
     install these files and the icons.
Files: 
 104129b8aabcf3498c64be24716de973 825 x11 optional xterm_226-1.dsc
 93d1f43ac3c13af86c598493f14a36f6 835862 x11 optional xterm_226.orig.tar.gz
 57ae2778e0a806deb01a41cc6fee0292 61616 x11 optional xterm_226-1.diff.gz
 94f81ecbb70c7cf120552b2a5a4bdeb2 452080 x11 optional xterm_226-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGdovGmEvTgKxfcAwRAhbbAKCEL0Aq2kLgqYfTaeThWox3p9KYNwCePjvT
hGOcCnN7IKcs8dgUyCxOLVc=
=U44l
-----END PGP SIGNATURE-----




Reply sent to Julien Cristau <jcristau@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Klaus Ethgen <Klaus@Ethgen.de>:
Bug acknowledged by developer. Full text and rfc822 format available.

Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Sat, 28 Jul 2007 07:26:58 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Mon Apr 21 16:55:11 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.