Debian Bug report logs - #345478
opensp: onsgmls fails to validate xhtml document after upgrade to 1.5.2-1

version graph

Package: opensp; Maintainer for opensp is Neil Roeth <neil@debian.org>; Source for opensp is src:opensp.

Reported by: Allen Chan <allen@developers.alyz.com>

Date: Sat, 31 Dec 2005 21:33:01 UTC

Severity: normal

Found in version opensp/1.5.2-1

Fixed in version opensp/1.5.2-4

Done: Neil Roeth <neil@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Neil Roeth <neil@debian.org>:
Bug#345478; Package opensp. Full text and rfc822 format available.

Acknowledgement sent to Allen Chan <allen@developers.alyz.com>:
New Bug report received and forwarded. Copy sent to Neil Roeth <neil@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Allen Chan <allen@developers.alyz.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: opensp: onsgmls fails to validate xhtml document after upgrade to 1.5.2-1
Date: Sat, 31 Dec 2005 16:19:18 -0500
[Message part 1 (text/plain, inline)]
Package: opensp
Version: 1.5.2-1
Severity: normal

After upgrading from 1.5.1.0-4 to 1.5.2-1, the command:
    onsgmls -s test.xhtml
generates a lengthy error message that begins with:

onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:237:27:E:
omitted tag minimization parameter can be omitted only if OMITTAG NO is
specified
onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:239:8:E:
character ":" invalid: only "CDATA", "ENTITIES", "ENTITY", "ID",
"IDREF", "IDREFS", "NAME", "NAMES", "NMTOKEN", "NMTOKENS", "NOTATION",
"NUMBER", "NUMBERS", "NUTOKEN", "NUTOKENS" and parameter separators
allowed
onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:253:49:E:
omitted tag minimization parameter can be omitted only if OMITTAG NO is
specified
onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:256:8:E:
character ":" invalid: only "CDATA", "ENTITIES", "ENTITY", "ID",
"IDREF", "IDREFS", "NAME", "NAMES", "NMTOKEN", "NMTOKENS", "NOTATION",
"NUMBER", "NUMBERS", "NUTOKEN", "NUTOKENS" and parameter separators
allowed
onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:265:25:E:
omitted tag minimization parameter can be omitted only if OMITTAG NO is
specified
...

Downgrading opensp to 1.5.1.0-4 avoids the problem.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (990, 'unstable'), (650, 'testing'), (600, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-1-alyz-k7
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages opensp depends on:
ii  libc6                         2.3.5-9    GNU C Library: Shared libraries an
ii  libgcc1                       1:4.0.2-5  GCC support library
ii  libosp5                       1.5.2-1    Runtime library for OpenJade group
ii  libstdc++6                    4.0.2-5    The GNU Standard C++ Library v3
ii  sgml-base                     1.26       SGML infrastructure and SGML catal

opensp recommends no packages.

-- no debconf information
[test.xhtml (application/xhtml+xml, attachment)]

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#345478; Package opensp. Full text and rfc822 format available.

Acknowledgement sent to Neil Roeth <neil@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #10 received at 345478@bugs.debian.org (full text, mbox):

From: Neil Roeth <neil@debian.org>
To: Allen Chan <allen@developers.alyz.com>, 345478@bugs.debian.org
Subject: Bug#345478: opensp: onsgmls fails to validate xhtml document after upgrade to 1.5.2-1
Date: Sat, 31 Dec 2005 23:19:00 -0500
On Dec 31, Allen Chan (allen@developers.alyz.com) wrote:
 > Package: opensp
 > Version: 1.5.2-1
 > Severity: normal
 > 
 > After upgrading from 1.5.1.0-4 to 1.5.2-1, the command:
 >     onsgmls -s test.xhtml
 > generates a lengthy error message that begins with:
 > 
 > onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:237:27:E:
 > omitted tag minimization parameter can be omitted only if OMITTAG NO is
 > specified
 > onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:239:8:E:
 > character ":" invalid: only "CDATA", "ENTITIES", "ENTITY", "ID",
 > "IDREF", "IDREFS", "NAME", "NAMES", "NMTOKEN", "NMTOKENS", "NOTATION",
 > "NUMBER", "NUMBERS", "NUTOKEN", "NUTOKENS" and parameter separators
 > allowed
 > onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:253:49:E:
 > omitted tag minimization parameter can be omitted only if OMITTAG NO is
 > specified
 > onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:256:8:E:
 > character ":" invalid: only "CDATA", "ENTITIES", "ENTITY", "ID",
 > "IDREF", "IDREFS", "NAME", "NAMES", "NMTOKEN", "NMTOKENS", "NOTATION",
 > "NUMBER", "NUMBERS", "NUTOKEN", "NUTOKENS" and parameter separators
 > allowed
 > onsgmls:/usr/share/xml/xhtml/schema/dtd/1.0/xhtml1-strict.dtd:265:25:E:
 > omitted tag minimization parameter can be omitted only if OMITTAG NO is
 > specified
 > ...
 > 
 > Downgrading opensp to 1.5.1.0-4 avoids the problem.

I get the same errors with that command line with both 1.5.1.0 and 1.5.2.  If
I add the XML declaration to the command line, I get no errors with both:

onsgmls -s declaration/xml.dcl test.xhtml

Can you confirm that you get different results with 1.5.1.0 and 1.5.2?


-- 
Neil Roeth



Information forwarded to debian-bugs-dist@lists.debian.org, Neil Roeth <neil@debian.org>:
Bug#345478; Package opensp. Full text and rfc822 format available.

Acknowledgement sent to Allen Chan <allen@developers.alyz.com>:
Extra info received and forwarded to list. Copy sent to Neil Roeth <neil@debian.org>. Full text and rfc822 format available.

Message #15 received at 345478@bugs.debian.org (full text, mbox):

From: Allen Chan <allen@developers.alyz.com>
To: Neil Roeth <neil@debian.org>
Cc: 345478@bugs.debian.org
Subject: Re: Bug#345478: opensp: onsgmls fails to validate xhtml document after upgrade to 1.5.2-1
Date: Sun, 1 Jan 2006 06:54:02 -0500
[Message part 1 (text/plain, inline)]
On Saturday 31 December 2005 11:19 pm, Neil Roeth wrote:
> Can you confirm that you get different results with 1.5.1.0 and
> 1.5.2?

After receiving your message, I downgraded to 1.5.1.0-2 on my desktop, 
and it worked fine (i.e., no output).  Then I upgraded to 1.5.1.0-4 
and it worked fine as well.  Then I upgraded to 1.5.2-1 and it 
produced all the error messages.

I repeated this procedure on my laptop, but the results were not 
consistent with the desktop.  This time, I get the error messages for 
all three versions of the opensp package.

I tried different permutations of installed packages on the desktop 
and laptop, but have not yet discovered the reason for the 
inconsistent results on the two machines.

However, adding "declaration/xml.dcl" on the command line did solve 
the problem in all cases.  For now, I'm satisfied that this is the 
real source of the problem, that I need to add "declaration/xml.dcl" 
whenever I use onsgml to validate xml files.

-- 
Allen Chan
allen@developers.alyz.com
http://www.alyz.com
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#345478; Package opensp. Full text and rfc822 format available.

Acknowledgement sent to Neil Roeth <neil@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #20 received at 345478@bugs.debian.org (full text, mbox):

From: Neil Roeth <neil@debian.org>
To: Allen Chan <allen@developers.alyz.com>, 345478@bugs.debian.org
Subject: Bug#345478: opensp: onsgmls fails to validate xhtml document after upgrade to 1.5.2-1
Date: Sun, 1 Jan 2006 09:14:34 -0500
On Jan  1, Allen Chan (allen@developers.alyz.com) wrote:
 > On Saturday 31 December 2005 11:19 pm, Neil Roeth wrote:
 > > Can you confirm that you get different results with 1.5.1.0 and
 > > 1.5.2?
 > 
 > After receiving your message, I downgraded to 1.5.1.0-2 on my desktop, 
 > and it worked fine (i.e., no output).  Then I upgraded to 1.5.1.0-4 
 > and it worked fine as well.  Then I upgraded to 1.5.2-1 and it 
 > produced all the error messages.
 > 
 > I repeated this procedure on my laptop, but the results were not 
 > consistent with the desktop.  This time, I get the error messages for 
 > all three versions of the opensp package.
 > 
 > I tried different permutations of installed packages on the desktop 
 > and laptop, but have not yet discovered the reason for the 
 > inconsistent results on the two machines.
 > 
 > However, adding "declaration/xml.dcl" on the command line did solve 
 > the problem in all cases.  For now, I'm satisfied that this is the 
 > real source of the problem, that I need to add "declaration/xml.dcl" 
 > whenever I use onsgml to validate xml files.

I was able to reproduce the bug by installing the w3c-dtd-xhtml package on my
machine.  Before that, it was using the URL to go to the www.w3.org for the
DTD, after that, it retrieved it locally.  I suspect that is the difference
between your laptop and desktop.  Can you check?  Thanks.

-- 
Neil Roeth



Information forwarded to debian-bugs-dist@lists.debian.org, Neil Roeth <neil@debian.org>:
Bug#345478; Package opensp. Full text and rfc822 format available.

Acknowledgement sent to Allen Chan <allen@developers.alyz.com>:
Extra info received and forwarded to list. Copy sent to Neil Roeth <neil@debian.org>. Full text and rfc822 format available.

Message #25 received at 345478@bugs.debian.org (full text, mbox):

From: Allen Chan <allen@developers.alyz.com>
To: Neil Roeth <neil@debian.org>
Cc: 345478@bugs.debian.org
Subject: Re: Bug#345478: opensp: onsgmls fails to validate xhtml document after upgrade to 1.5.2-1
Date: Sun, 1 Jan 2006 10:53:13 -0500
[Message part 1 (text/plain, inline)]
On Sunday 01 January 2006 09:14 am, Neil Roeth wrote:
> I was able to reproduce the bug by installing the w3c-dtd-xhtml
> package on my machine.  Before that, it was using the URL to go to
> the www.w3.org for the DTD, after that, it retrieved it locally.  I
> suspect that is the difference between your laptop and desktop. 
> Can you check?  Thanks.

Yes.  That was the difference.  The desktop had w3c-dtd-xhtml 
installed while the laptop did not.  After installing w3c-dtd-xhtml 
on the laptop, it replicated the original reported bahavior where 
versions 1.5.1.* of opensp validated the test.xhtml document without 
the need to explicitly specify "declaration/xml.dcl" on the command 
line, but version 1.5.2-1 did not.

-- 
Allen Chan
allen@developers.alyz.com
http://www.alyz.com
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#345478; Package opensp. Full text and rfc822 format available.

Acknowledgement sent to Neil Roeth <neil@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #30 received at 345478@bugs.debian.org (full text, mbox):

From: Neil Roeth <neil@debian.org>
To: Allen Chan <allen@developers.alyz.com>, 345478@bugs.debian.org
Subject: Bug#345478: opensp: onsgmls fails to validate xhtml document after upgrade to 1.5.2-1
Date: Sun, 1 Jan 2006 11:49:27 -0500
On Jan  1, Allen Chan (allen@developers.alyz.com) wrote:
 > On Sunday 01 January 2006 09:14 am, Neil Roeth wrote:
 > > I was able to reproduce the bug by installing the w3c-dtd-xhtml
 > > package on my machine.  Before that, it was using the URL to go to
 > > the www.w3.org for the DTD, after that, it retrieved it locally.  I
 > > suspect that is the difference between your laptop and desktop. 
 > > Can you check?  Thanks.
 > 
 > Yes.  That was the difference.  The desktop had w3c-dtd-xhtml 
 > installed while the laptop did not.  After installing w3c-dtd-xhtml 
 > on the laptop, it replicated the original reported bahavior where 
 > versions 1.5.1.* of opensp validated the test.xhtml document without 
 > the need to explicitly specify "declaration/xml.dcl" on the command 
 > line, but version 1.5.2-1 did not.

Thanks.  This is due to the disabling of DTDDECL handling, which was done to
improve the performance (it's 15-20 times slower with this enabled).  I didn't
realize that this bug would be a result of turning DTDDECL handling off; I
always explicitly specify the XML declaration anyway.

I'm not sure what I am going to do about this yet, but it's a fairly high
priority.  Thanks for filing the bug and working with me to confirm the cause.

-- 
Neil Roeth



Blocking bugs of 354760 added: 345478 Request was from Sven Arvidsson <sa@whiz.se> to control@bugs.debian.org. (Sat, 17 Mar 2007 23:03:04 GMT) Full text and rfc822 format available.

Reply sent to Neil Roeth <neil@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Allen Chan <allen@developers.alyz.com>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #37 received at 345478-close@bugs.debian.org (full text, mbox):

From: Neil Roeth <neil@debian.org>
To: 345478-close@bugs.debian.org
Subject: Bug#345478: fixed in opensp 1.5.2-4
Date: Thu, 17 Apr 2008 11:02:05 +0000
Source: opensp
Source-Version: 1.5.2-4

We believe that the bug you reported is fixed in the latest version of
opensp, which is due to be installed in the Debian FTP archive:

libosp-dev_1.5.2-4_i386.deb
  to pool/main/o/opensp/libosp-dev_1.5.2-4_i386.deb
libosp5_1.5.2-4_i386.deb
  to pool/main/o/opensp/libosp5_1.5.2-4_i386.deb
opensp_1.5.2-4.diff.gz
  to pool/main/o/opensp/opensp_1.5.2-4.diff.gz
opensp_1.5.2-4.dsc
  to pool/main/o/opensp/opensp_1.5.2-4.dsc
opensp_1.5.2-4_i386.deb
  to pool/main/o/opensp/opensp_1.5.2-4_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 345478@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Neil Roeth <neil@debian.org> (supplier of updated opensp package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 15 Apr 2008 21:55:06 -0400
Source: opensp
Binary: opensp libosp5 libosp-dev
Architecture: source i386
Version: 1.5.2-4
Distribution: unstable
Urgency: low
Maintainer: Neil Roeth <neil@debian.org>
Changed-By: Neil Roeth <neil@debian.org>
Description: 
 libosp-dev - OpenJade group's SP suite, developer support
 libosp5    - Runtime library for OpenJade group's SP suite
 opensp     - OpenJade group's SGML parsing tools
Closes: 345478 350797
Changes: 
 opensp (1.5.2-4) unstable; urgency=low
 .
   * Verified OpenSP builds with gcc 4.3.
   * Added comment to README.Debian about needing to explicitly specify
     declaration in some cases due to dropping DTDDECL support.  (Closes:
     #345478, #350797).
Checksums-Sha1: 
 6283a629f84b236f90cfe1d6208922425ead3c08 1033 opensp_1.5.2-4.dsc
 340e05c979d758722b5f6d772b9655a1eb64393a 16469 opensp_1.5.2-4.diff.gz
 736bbc32d7039fe7bbe1e81c02149c3a6a6e62ea 522406 opensp_1.5.2-4_i386.deb
 6be98cf3cf6c8aa332edaf016da873346fc44aec 1237922 libosp5_1.5.2-4_i386.deb
 ac2c8665f9fcf7ebd27d21f682f7bf9c69c935ab 1511764 libosp-dev_1.5.2-4_i386.deb
Checksums-Sha256: 
 2ae76f63d42726473575fed7669fbe77e7cb3a53e374ce314aaa9b1a3d55ff4f 1033 opensp_1.5.2-4.dsc
 e058f532b34a09a7283e2c48b62bb77622c8897e81d8931e222d026faea95c1b 16469 opensp_1.5.2-4.diff.gz
 294aaa22546b480fac80d43c5113b16623819164bb0eaf6b85763a8cd199a1ab 522406 opensp_1.5.2-4_i386.deb
 79ec28c38aeef628313d625b444d574ea7f705d3c712ac0c4ffbf57f86faea4c 1237922 libosp5_1.5.2-4_i386.deb
 1808a497af82bd22fe07b623a4ff28de6ae36d23075e3ce594a414ca618e87e6 1511764 libosp-dev_1.5.2-4_i386.deb
Files: 
 25df3e272219865fdb0188761fbd894b 1033 text optional opensp_1.5.2-4.dsc
 1a76bbf4efcd73567ed3f19888e52f13 16469 text optional opensp_1.5.2-4.diff.gz
 6ecad3297d1015d51f978601acd0c464 522406 text optional opensp_1.5.2-4_i386.deb
 1d4e9c0c910f28fc21c4a3abc8dd8824 1237922 libs optional libosp5_1.5.2-4_i386.deb
 898b72d7bfe949d02a176b62127ecb82 1511764 libdevel optional libosp-dev_1.5.2-4_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIByt96j+skPrutKkRAjLVAKC+kD1kKIB78mjiegpbjivChW9nhgCeNwyS
XTy61c/ltDFe9YVNxX3KftY=
=qxGk
-----END PGP SIGNATURE-----





Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Wed, 27 Jul 2011 07:40:18 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 10:45:43 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.