Debian Bug report logs - #344487
ftp.debian.org: Please remove mips/mipsel PostgreSQL debs from sid/testing

Package: ftp.debian.org; Maintainer for ftp.debian.org is Debian FTP Master <ftpmaster@ftp-master.debian.org>;

Reported by: Martin Pitt <martin@piware.de>

Date: Fri, 23 Dec 2005 00:33:04 UTC

Severity: important

Tags: moreinfo

Done: Debian Archive Maintenance <ftpmaster@ftp-master.debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, James Troup and others <ftpmaster@ftp-master.debian.org>:
Bug#344487; Package ftp.debian.org. Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <martin@piware.de>:
New Bug report received and forwarded. Copy sent to James Troup and others <ftpmaster@ftp-master.debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Martin Pitt <martin@piware.de>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: ftp.debian.org: Please remove mips/mipsel PostgreSQL debs from sid/testing
Date: Fri, 23 Dec 2005 01:08:42 +0100
[Message part 1 (text/plain, inline)]
Package: ftp.debian.org
Severity: important
Justification: fails to build from source

Hi ftp masters!

As reported in #330296 and #329197 and reported upstream, all
postgresql version die with a SIGBUS on mips and mipsel for a long
time now. I failed to debug this; no combination of versions, compiler
versions, compiler switches, or configure options makes it work, the
bug is almost impossible to debug, and upstream does not know what to
do about it ATM.

Therefore Steve Langasek and I agreed to remove the mips and mipsel
binaries from testing and unstable until this is solved. Recent 7.4,
8.0, and 8.1 packages do not build mips packages any more (see below),
so I closed above two RC bugs to allow testing migration for the other
architectures again.

7.4 and 8.0 succeed/FTBFS based on the test suite outcome, so mips and
mipsel packages will be built again as soon as this is fixed. 8.1
cannot FTBFS completely since client programs, and even more
important, the client libraries are required on mips and mipsel, too.
Therefore the postgresql-8.1 now lists all but mips[el] in the
Architecture: field and a failed test suite does not cause an FTBFS.

In particular, please remove the following debs from sid and testing
for mips and mipsel:

 * all debs generated by postgresql-7.4
 * all debs generated by postgresql-8.0
 * postgresql-8.1
 * postgresql-contrib-8.1
 * postgresql-plperl-8.1
 * postgresql-plpython-8.1
 * postgresql-pltcl-8.1

Thank you!

Martin

-- System Information:
Debian Release: 3.1
Architecture: i386 (i686)
Kernel: Linux 2.6.14.3
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)

-- 
Martin Pitt              http://www.piware.de
Ubuntu Developer   http://www.ubuntulinux.org
Debian Developer        http://www.debian.org
[signature.asc (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, James Troup and others <ftpmaster@ftp-master.debian.org>:
Bug#344487; Package ftp.debian.org. Full text and rfc822 format available.

Acknowledgement sent to Jeroen van Wolffelaar <jeroen@wolffelaar.nl>:
Extra info received and forwarded to list. Copy sent to James Troup and others <ftpmaster@ftp-master.debian.org>. Full text and rfc822 format available.

Message #10 received at 344487@bugs.debian.org (full text, mbox):

From: Jeroen van Wolffelaar <jeroen@wolffelaar.nl>
To: Martin Pitt <martin@piware.de>, 344487@bugs.debian.org
Cc: Debian Bugs Control Bot <control@bugs.debian.org>
Subject: Re: ftp.debian.org: Please remove mips/mipsel PostgreSQL debs from sid/testing
Date: Thu, 6 Apr 2006 00:55:16 +0200
tags 344487 moreinfo
thanks

On Fri, Dec 23, 2005 at 01:08:42AM +0100, Martin Pitt wrote:
> Hi ftp masters!

Hi Martin,

> As reported in #330296 and #329197 and reported upstream, all
> postgresql version die with a SIGBUS on mips and mipsel for a long
> time now. I failed to debug this; no combination of versions, compiler
> versions, compiler switches, or configure options makes it work, the
> bug is almost impossible to debug, and upstream does not know what to
> do about it ATM.
> 
> Therefore Steve Langasek and I agreed to remove the mips and mipsel
> binaries from testing and unstable until this is solved. Recent 7.4,
> 8.0, and 8.1 packages do not build mips packages any more (see below),
> so I closed above two RC bugs to allow testing migration for the other
> architectures again.
> 
> 7.4 and 8.0 succeed/FTBFS based on the test suite outcome, so mips and
> mipsel packages will be built again as soon as this is fixed. 8.1
> cannot FTBFS completely since client programs, and even more
> important, the client libraries are required on mips and mipsel, too.
> Therefore the postgresql-8.1 now lists all but mips[el] in the
> Architecture: field and a failed test suite does not cause an FTBFS.
> 
> In particular, please remove the following debs from sid and testing
> for mips and mipsel:
> 
>  * all debs generated by postgresql-7.4
>  * all debs generated by postgresql-8.0

This will break a number of further rdepends, like libpam-pqsl,
facturalux, libdbd-pqsl, and more. Should mipsen binaries there also be
removed, or...?

>  * postgresql-8.1
>  * postgresql-contrib-8.1
>  * postgresql-plperl-8.1
>  * postgresql-plpython-8.1
>  * postgresql-pltcl-8.1

Those don't seem to be failing to build, or lagging at all. Please make
sure that happens, otherwise a same version build might succeseed,
resulting in again the exact same version numbers to appear, but
actually being different builds. There are a few ways to achieve this.
One way that you should always use if it is possible, is to have a small
testsuite during build time, that will test the functionality, and fails
to build if it doesn't work. This is a good idea anyway, it can prevent
some broken uploads.

If you really opted for the solution you noted above, something is
failing here or you didn't upload yet? For example:

postgresql-8.1 |    8.1.3-3 |      unstable | source, alpha, amd64, arm, hppa, hurd-i386, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

--Jeroen

-- 
Jeroen van Wolffelaar
jeroen@wolffelaar.nl
http://jeroen.A-Eskwadraat.nl



Tags added: moreinfo Request was from Jeroen van Wolffelaar <jeroen@wolffelaar.nl> to control@bugs.debian.org. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, James Troup and others <ftpmaster@ftp-master.debian.org>:
Bug#344487; Package ftp.debian.org. Full text and rfc822 format available.

Acknowledgement sent to Martin Pitt <mpitt@debian.org>:
Extra info received and forwarded to list. Copy sent to James Troup and others <ftpmaster@ftp-master.debian.org>. Full text and rfc822 format available.

Message #17 received at 344487@bugs.debian.org (full text, mbox):

From: Martin Pitt <mpitt@debian.org>
To: Jeroen van Wolffelaar <jeroen@wolffelaar.nl>, 344487@bugs.debian.org
Subject: Re: ftp.debian.org: Please remove mips/mipsel PostgreSQL debs from sid/testing
Date: Thu, 6 Apr 2006 08:48:30 +0200
[Message part 1 (text/plain, inline)]
Hi Jeroen,

Jeroen van Wolffelaar [2006-04-06  0:55 +0200]:
> >  * all debs generated by postgresql-7.4
> >  * all debs generated by postgresql-8.0
> 
> This will break a number of further rdepends, like libpam-pqsl,
> facturalux, libdbd-pqsl, and more. Should mipsen binaries there also be
> removed, or...?

No, these are just client applications. They should be rebuilt against
the current libpq-dev, libpq3 is deprecated anyway.

> >  * postgresql-8.1
> >  * postgresql-contrib-8.1
> >  * postgresql-plperl-8.1
> >  * postgresql-plpython-8.1
> >  * postgresql-pltcl-8.1
> 
> Those don't seem to be failing to build, or lagging at all. Please make
> sure that happens, otherwise a same version build might succeseed,
> resulting in again the exact same version numbers to appear

Hm, just bad timing. The server debs were indeed not built until
8.1.3-2, but since testing was not updated for 6 months(!) I finally
decided to let the new version slip in and did:

postgresql-8.1 (8.1.3-3) unstable; urgency=low
[...]
  * debian/control: Build server packages on mips and mipsel again, even if
    they do not work. No need to block testing migration forever (the
    ftp-masters seem reluctant to remove the mips binaries, see #344487), and
    the bug is in binutils, not PostgreSQL itself (see #357603).

I reverted this in the development version for -4, so that mips[el]
won't build them again. Sorry for hitting the race condition!

> but actually being different builds. There are a few ways to achieve this.
> One way that you should always use if it is possible, is to have a small
> testsuite during build time, that will test the functionality, and fails
> to build if it doesn't work. This is a good idea anyway, it can prevent
> some broken uploads.

The packages indeed have test suites, and their failure causes an
FTBFS for 7.4 and 8.0. However, this approach is not possible for 8.1,
since it is crucial to have the client side library being built
(hundreds of packages depend on them, and they should work fine). So
for 8.1, I need to tweak the Architecture: field for the server
packages.

> If you really opted for the solution you noted above, something is
> failing here or you didn't upload yet? For example:
> 
> postgresql-8.1 |    8.1.3-3 |      unstable | source, alpha, amd64, arm, hppa, hurd-i386, i386, ia64, m68k, mips, mipsel, powerpc, s390, sparc

Thanks,

Martin

-- 
Martin Pitt        http://www.piware.de
Ubuntu Developer   http://www.ubuntu.com
Debian Developer   http://www.debian.org

In a world without walls and fences, who needs Windows and Gates?
[signature.asc (application/pgp-signature, inline)]

Reply sent to Debian Archive Maintenance <ftpmaster@ftp-master.debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Martin Pitt <martin@piware.de>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #22 received at 344487-close@bugs.debian.org (full text, mbox):

From: Debian Archive Maintenance <ftpmaster@ftp-master.debian.org>
To: 344487-close@bugs.debian.org
Cc: libpq3@packages.debian.org, libpq3@packages.qa.debian.org, postgresql-7.4@packages.debian.org, postgresql-7.4@packages.qa.debian.org, postgresql-client-7.4@packages.debian.org, postgresql-client-7.4@packages.qa.debian.org, postgresql-contrib-7.4@packages.debian.org, postgresql-contrib-7.4@packages.qa.debian.org, postgresql-plperl-7.4@packages.debian.org, postgresql-plperl-7.4@packages.qa.debian.org, postgresql-plpython-7.4@packages.debian.org, postgresql-plpython-7.4@packages.qa.debian.org, postgresql-pltcl-7.4@packages.debian.org, postgresql-pltcl-7.4@packages.qa.debian.org
Subject: Bug#344487: fixed
Date: Mon, 01 May 2006 11:44:21 -0700
We believe that the bug you reported is now fixed; the following
package(s) have been removed from unstable:

    libpq3 | 1:7.4.10-1 | mips, mipsel
postgresql-7.4 | 1:7.4.10-1 | mips, mipsel
postgresql-client-7.4 | 1:7.4.10-1 | mips, mipsel
postgresql-contrib-7.4 | 1:7.4.10-1 | mips, mipsel
postgresql-plperl-7.4 | 1:7.4.10-1 | mips, mipsel
postgresql-plpython-7.4 | 1:7.4.10-1 | mips, mipsel
postgresql-pltcl-7.4 | 1:7.4.10-1 | mips, mipsel

Note that the package(s) have simply been removed from the tag
database and may (or may not) still be in the pool; this is not a bug.
The package(s) will be physically removed automatically when no suite
references them (and in the case of source, when no binary references
it).  Please also remember that the changes have been done on the
master archive (ftp-master.debian.org) and will not propagate to any
mirrors (ftp.debian.org included) until the next cron.daily run at the
earliest.

Packages are never removed from testing by hand.  Testing tracks
unstable and will automatically remove packages which were removed
from unstable when removing them from testing causes no dependency
problems.

Bugs which have been reported against this package are not automatically
removed from the Bug Tracking System.  Please check all open bugs and
close them or re-assign them to another package if the removed package
was superseded by another one.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 344487@bugs.debian.org.

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing
ftpmaster@debian.org.

Debian distribution maintenance software
pp.
Jeroen van Wolffelaar (the ftpmaster behind the curtain)



Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 19 Jun 2007 01:42:42 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 04:30:48 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.