Debian Bug report logs - #321578
/usr/sbin/mysqld: old_passwords variable seems to be incompatible with new versions of mysql

version graph

Package: mysql-server; Maintainer for mysql-server is Debian MySQL Maintainers <pkg-mysql-maint@lists.alioth.debian.org>; Source for mysql-server is src:mysql-5.5.

Reported by: Damien CASSOU <damien.cassou@laposte.net>

Date: Sat, 6 Aug 2005 10:48:04 UTC

Severity: grave

Tags: patch

Found in version mysql-server/4.0.24-10

Fixed in version mysql-dfsg-4.1/4.1.14-2

Done: Christian Hammers <ch@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Christian Hammers <ch@debian.org>:
Bug#321578; Package mysql-server. Full text and rfc822 format available.

Acknowledgement sent to Damien CASSOU <damien.cassou@laposte.net>:
New Bug report received and forwarded. Copy sent to Christian Hammers <ch@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Damien CASSOU <damien.cassou@laposte.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: /usr/sbin/mysqld: old_passwords variable seems to be incompatible with new versions of mysql
Date: Sat, 06 Aug 2005 12:42:46 +0200
Package: mysql-server
Version: 4.0.24-10
Severity: grave
File: /usr/sbin/mysqld
Tags: patch
Justification: renders package unusable


Hi,

it seems that the variable  old_passwords is not available in the last
mysql version which prevents mysqld  to be launched. So I commented it
: 

# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
# old_passwords	= 1
#

Now, everything seems to work.


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11.7
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)

Versions of packages mysql-server depends on:
ii  adduser          3.66                    Add and remove users and groups
ii  debconf          1.4.56                  Debian configuration management sy
ii  libc6            2.3.5-3                 GNU C Library: Shared libraries an
ii  libdbi-perl      1.48-1                  Perl5 database interface by Tim Bu
ii  libgcc1          1:4.0.1-3               GCC support library
ii  libmysqlclient12 4.0.24-10               mysql database client library
ii  libstdc++5       1:3.3.6-7               The GNU Standard C++ Library v3
ii  libwrap0         7.6.dbs-8               Wietse Venema's TCP wrappers libra
ii  mailx            1:8.1.2-0.20050715cvs-1 A simple mail user agent
ii  mysql-client     4.0.24-10               mysql database client binaries
ii  mysql-common     5.0.7beta-1             mysql database common files (e.g. 
ii  passwd           1:4.0.3-39              change and administer password and
ii  perl             5.8.7-4                 Larry Wall's Practical Extraction 
ii  psmisc           21.6-1                  Utilities that use the proc filesy
ii  zlib1g           1:1.2.3-3               compression library - runtime

mysql-server recommends no packages.

-- debconf information:
  mysql-server/skip_networking: false
  mysql-server/really_downgrade_from_41: false
  mysql-server/want_chroot: false
* mysql-server/start_on_boot: true
  mysql-server/postrm_remove_databases: false
* mysql-server/mysql_install_db_notes:
  mysql-server/nis_warning:
  mysql-server/mysql_update_hints1:
* mysql-server/postrm_remove_database: false
  mysql-server/fix_privileges_warning:



Reply sent to Christian Hammers <ch@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Damien CASSOU <damien.cassou@laposte.net>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #10 received at 321578-done@bugs.debian.org (full text, mbox):

From: Christian Hammers <ch@debian.org>
To: Damien CASSOU <damien.cassou@laposte.net>, 321578-done@bugs.debian.org
Subject: Re: Bug#321578: /usr/sbin/mysqld: old_passwords variable seems to be incompatible with new versions of mysql
Date: Sun, 14 Aug 2005 18:14:46 +0200
Hello Damien

On 2005-08-06 Damien CASSOU wrote:
> it seems that the variable  old_passwords is not available in the last
> mysql version which prevents mysqld  to be launched. So I commented it
> : 
> 
> # For compatibility to other Debian packages that still use
> # libmysqlclient10 and libmysqlclient12.
> # old_passwords	= 1
> #
> 
> Now, everything seems to work.

This was a temporary problem. Now the mysql-server (4.0) package is no longer
availble and replaced by mysql-server-4.1.

bye,

-christian-



Information forwarded to debian-bugs-dist@lists.debian.org, Christian Hammers <ch@debian.org>:
Bug#321578; Package mysql-server. Full text and rfc822 format available.

Acknowledgement sent to Michael Wardle <michael@endbracket.net>:
Extra info received and forwarded to list. Copy sent to Christian Hammers <ch@debian.org>. Full text and rfc822 format available.

Message #15 received at 321578@bugs.debian.org (full text, mbox):

From: Michael Wardle <michael@endbracket.net>
To: 321578@bugs.debian.org
Date: Mon, 29 Aug 2005 21:46:24 +1000
I was just hit by this in Etch after an update, upgrade.

mysql-server 4.0.24-10 seems to be the current version and
mysql-server-4.1 does not yet replace mysql-server 4.0.

Is this something that was not caught when this issue was resolved, or
is there something still coming down the line for Etch?

% apt-cache policy mysql-server mysql-common
mysql-server:
  Installed: 4.0.24-10
  Candidate: 4.0.24-10
  Version Table:
 *** 4.0.24-10 0
        500 ftp://ftp.iinet.net.au etch/main Packages
        500 http://mirror.pacific.net.au etch/main Packages
        100 /var/lib/dpkg/status
mysql-common:
  Installed: 5.0.7beta-1
  Candidate: 5.0.7beta-1
  Version Table:
 *** 5.0.7beta-1 0
        500 ftp://ftp.iinet.net.au etch/main Packages
        500 http://mirror.pacific.net.au etch/main Packages
        100 /var/lib/dpkg/status




Reply sent to Christian Hammers <ch@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Damien CASSOU <damien.cassou@laposte.net>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #20 received at 321578-close@bugs.debian.org (full text, mbox):

From: Christian Hammers <ch@debian.org>
To: 321578-close@bugs.debian.org
Subject: Bug#321578: fixed in mysql-dfsg-4.1 4.1.14-2
Date: Thu, 15 Sep 2005 13:47:51 -0700
Source: mysql-dfsg-4.1
Source-Version: 4.1.14-2

We believe that the bug you reported is fixed in the latest version of
mysql-dfsg-4.1, which is due to be installed in the Debian FTP archive:

libmysqlclient14-dev_4.1.14-2_i386.deb
  to pool/main/m/mysql-dfsg-4.1/libmysqlclient14-dev_4.1.14-2_i386.deb
libmysqlclient14_4.1.14-2_i386.deb
  to pool/main/m/mysql-dfsg-4.1/libmysqlclient14_4.1.14-2_i386.deb
mysql-client-4.1_4.1.14-2_i386.deb
  to pool/main/m/mysql-dfsg-4.1/mysql-client-4.1_4.1.14-2_i386.deb
mysql-client_4.1.14-2_i386.deb
  to pool/main/m/mysql-dfsg-4.1/mysql-client_4.1.14-2_i386.deb
mysql-dfsg-4.1_4.1.14-2.diff.gz
  to pool/main/m/mysql-dfsg-4.1/mysql-dfsg-4.1_4.1.14-2.diff.gz
mysql-dfsg-4.1_4.1.14-2.dsc
  to pool/main/m/mysql-dfsg-4.1/mysql-dfsg-4.1_4.1.14-2.dsc
mysql-server-4.1_4.1.14-2_i386.deb
  to pool/main/m/mysql-dfsg-4.1/mysql-server-4.1_4.1.14-2_i386.deb
mysql-server_4.1.14-2_i386.deb
  to pool/main/m/mysql-dfsg-4.1/mysql-server_4.1.14-2_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 321578@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Christian Hammers <ch@debian.org> (supplier of updated mysql-dfsg-4.1 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Thu, 15 Sep 2005 20:50:42 +0200
Source: mysql-dfsg-4.1
Binary: libmysqlclient14-dev mysql-client libmysqlclient14 mysql-server mysql-server-4.1 mysql-client-4.1
Architecture: source i386
Version: 4.1.14-2
Distribution: unstable
Urgency: high
Maintainer: Christian Hammers <ch@debian.org>
Changed-By: Christian Hammers <ch@debian.org>
Description: 
 libmysqlclient14 - mysql database client library
 libmysqlclient14-dev - mysql database development files
 mysql-client - mysql database client (transitional dummy package)
 mysql-client-4.1 - mysql database client binaries
 mysql-server - mysql database server (transitional dummy package)
 mysql-server-4.1 - mysql database server binaries
Closes: 320869 321578 324035 324044 325521 326411 328413
Changes: 
 mysql-dfsg-4.1 (4.1.14-2) unstable; urgency=high
 .
   * Changed the conflicts of mysql-server-4.1 with mysql-client to only
     versions << ${Source-Version} so that the package does *not* conflict
     with its own transitional package (to force the upgrade from mysql-server)
     any more! Did the same for mysql-client-4.1. Thanks to Steve Langasek!
     This also closes those "mysql fails to start due to my.cnf option" bugs.
     Closes: #328413, #324035, #324044, #320869, #326411, #321578
   * Added transitional package for mysql-client (similar to the existing
     one for mysql-server for those users who have only the client installed.
   * The new upstream version also fixed some nasty MySQL bugs (thanks to
     Ruben Puettmann). Closes: #325521
Files: 
 e12c8aecf770844ad66dbd37207a8130 1042 misc optional mysql-dfsg-4.1_4.1.14-2.dsc
 6359b9eb5a56756d0664f33293726a8c 163959 misc optional mysql-dfsg-4.1_4.1.14-2.diff.gz
 e64b11bfb07485908d816a732279c2df 845264 misc optional mysql-client-4.1_4.1.14-2_i386.deb
 54c5d2a0792480de13fd13a412efdb48 14690126 misc optional mysql-server-4.1_4.1.14-2_i386.deb
 1f3d3e191211c402f2b159e9f8bf07ad 1465566 libs optional libmysqlclient14_4.1.14-2_i386.deb
 e76bb82fc962ba4e6f2cd35db78020cb 5267202 libdevel optional libmysqlclient14-dev_4.1.14-2_i386.deb
 ae93b29d35444256eb616e82f65aa65d 34684 misc optional mysql-server_4.1.14-2_i386.deb
 e8c5decc4a2e3e27c4c640e74701b57c 34686 misc optional mysql-client_4.1.14-2_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iEYEARECAAYFAkMp1QAACgkQkR9K5oahGOZtUACfSnfkvgevOnbU0lDB2jiL1E+q
mK0AnR2AHeCCfFQ0tqABssNU8V/+sEvC
=JYWR
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 26 Jun 2007 16:17:27 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 11:27:59 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.