Debian Bug report logs - #306807
libapache-mod-encoding(GNU/k*BSD): FTBFS: out of date libtool scripts

version graph

Package: libapache-mod-encoding; Maintainer for libapache-mod-encoding is Tatsuki Sugiura <sugi@nemui.org>;

Reported by: Aurelien Jarno <aurel32@debian.org>

Date: Thu, 28 Apr 2005 16:48:02 UTC

Severity: important

Tags: patch

Found in versions 0.0.20021209-8, 0.0.20021209-9

Fixed in versions 0.0.20021209-9, libapache-mod-encoding/0.0.20021209-10

Done: Tatsuki Sugiura <sugi@nemui.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Tatsuki Sugiura <sugi@nemui.org>:
Bug#306807; Package libapache-mod-encoding. Full text and rfc822 format available.

Acknowledgement sent to Aurelien Jarno <aurel32@debian.org>:
New Bug report received and forwarded. Copy sent to Tatsuki Sugiura <sugi@nemui.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Aurelien Jarno <aurel32@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libapache-mod-encoding(GNU/k*BSD): FTBFS: out of date libtool scripts
Date: Thu, 28 Apr 2005 18:39:17 +0200
Package: libapache-mod-encoding
Version: N/A
Severity: wishlist


Hello,


The current version of libapache-mod-encoding fails to build on
GNU/kFreeBSD, because of outdated libtool.

The version of libtool in libapache-mod-encoding is too old to correctly 
support Debian GNU/k*BSD.  libtool 1.5.2-1 or later is need.

Here is how to update the libtool in your package (Make sure you
are using libtool 1.5.2-1 or later:
  libtoolize -c -f
  aclocal (-Im4 might be needed if there's an "m4" template dir)
  autoconf

It would also be nice if you can ask upstream to update libtool 
in their next release.


Thanks for your cooperation.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: kfreebsd-i386 (i686)
Kernel: GNU/kFreeBSD 5.3-9
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)



Severity set to `important'. Request was from Aurelien Jarno <aurelien@aurel32.net> to control@bugs.debian.org. Full text and rfc822 format available.

Tags added: fixed Request was from Tatsuki Sugiura <sugi@nemui.org> to control@bugs.debian.org. Full text and rfc822 format available.

Reply sent to sugi@nemui.org:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Aurelien Jarno <aurel32@debian.org>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #14 received at 306807-done@bugs.debian.org (full text, mbox):

From: sugi@nemui.org
To: 359436-done@bugs.debian.org, 306807-done@bugs.debian.org, 361579-done@bugs.debian.org, 345752-done@bugs.debian.org, 361975-done@bugs.debian.org, 352498-done@bugs.debian.org
Subject: fixed bugs
Date: Fri, 07 Jul 2006 12:34:22 +0900
I'm closing bugs fixed by NMU.
Thanks for Taku.

-- 
Tatsuki Sugiura   mailto:sugi@nemui.org



Information forwarded to debian-bugs-dist@lists.debian.org, Tatsuki Sugiura <sugi@nemui.org>:
Bug#306807; Package libapache-mod-encoding. Full text and rfc822 format available.

Acknowledgement sent to Petr Salinger <Petr.Salinger@seznam.cz>:
Extra info received and forwarded to list. Copy sent to Tatsuki Sugiura <sugi@nemui.org>. Full text and rfc822 format available.

Message #19 received at 306807@bugs.debian.org (full text, mbox):

From: Petr Salinger <Petr.Salinger@seznam.cz>
To: 306807@bugs.debian.org
Cc: control@bugs.debian.org
Subject: libapache-mod-encoding(GNU/k*BSD): FTBFS: out of date libtool scripts
Date: Fri, 17 Nov 2006 23:00:51 +0100 (CET)
found 306807 0.0.20021209-8
reopen 306807
severity 306807 important
thanks

Hi,

the current version of still fails to build on GNU/kFreeBSD,
because of outdated libtool.

Your configure is located in subdir lib, so the right recipe is:
  cd lib
  libtoolize -c -f
  aclocal-1.4
  autoconf

Thanks in advance

			Petr




Bug marked as found in version 0.0.20021209-8. Request was from Petr Salinger <Petr.Salinger@seznam.cz> to control@bugs.debian.org. Full text and rfc822 format available.

Bug reopened, originator not changed. Request was from Petr Salinger <Petr.Salinger@seznam.cz> to control@bugs.debian.org. Full text and rfc822 format available.

Severity set to `important' from `important' Request was from Petr Salinger <Petr.Salinger@seznam.cz> to control@bugs.debian.org. Full text and rfc822 format available.

Tags removed: fixed Request was from Petr Salinger <Petr.Salinger@seznam.cz> to control@bugs.debian.org. Full text and rfc822 format available.

Tags removed: fixed Request was from Petr Salinger <Petr.Salinger@seznam.cz> to control@bugs.debian.org. Full text and rfc822 format available.

Tags added: patch Request was from Cyril Brulebois <cyril.brulebois@enst-bretagne.fr> to control@bugs.debian.org. (Thu, 15 Mar 2007 22:36:03 GMT) Full text and rfc822 format available.

Reply sent to Tatsuki Sugiura <sugi@nemui.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Aurelien Jarno <aurel32@debian.org>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #36 received at 306807-close@bugs.debian.org (full text, mbox):

From: Tatsuki Sugiura <sugi@nemui.org>
To: 306807-close@bugs.debian.org
Subject: Bug#306807: fixed in libapache-mod-encoding 0.0.20021209-9
Date: Tue, 24 Jul 2007 09:17:02 +0000
Source: libapache-mod-encoding
Source-Version: 0.0.20021209-9

We believe that the bug you reported is fixed in the latest version of
libapache-mod-encoding, which is due to be installed in the Debian FTP archive:

libapache-mod-encoding_0.0.20021209-9.diff.gz
  to pool/main/liba/libapache-mod-encoding/libapache-mod-encoding_0.0.20021209-9.diff.gz
libapache-mod-encoding_0.0.20021209-9.dsc
  to pool/main/liba/libapache-mod-encoding/libapache-mod-encoding_0.0.20021209-9.dsc
libiconv-hook-dev_0.0.20021209-9_amd64.deb
  to pool/main/liba/libapache-mod-encoding/libiconv-hook-dev_0.0.20021209-9_amd64.deb
libiconv-hook1_0.0.20021209-9_amd64.deb
  to pool/main/liba/libapache-mod-encoding/libiconv-hook1_0.0.20021209-9_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 306807@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Tatsuki Sugiura <sugi@nemui.org> (supplier of updated libapache-mod-encoding package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 22 Jan 2006 15:32:52 +0900
Source: libapache-mod-encoding
Binary: libiconv-hook1 libiconv-hook-dev
Architecture: source amd64
Version: 0.0.20021209-9
Distribution: unstable
Urgency: low
Maintainer: Taku YASUI <tach@debian.or.jp>
Changed-By: Tatsuki Sugiura <sugi@nemui.org>
Description: 
 libiconv-hook-dev - header files of libiconv-hook
 libiconv-hook1 - extension of iconv for libapache-mod-encoding
Closes: 306807 429121 429539
Changes: 
 libapache-mod-encoding (0.0.20021209-9) unstable; urgency=low
 .
   * The module for apache1 has been removed.  (Closes: #429121, #429539)
   * Libtool script updated (Closes: #306807)
   * Section was changed to net.
Files: 
 147af037341931a903a41646417b237f 698 net optional libapache-mod-encoding_0.0.20021209-9.dsc
 69a87bdeb0a15f3fd0c91380a6254711 149449 net optional libapache-mod-encoding_0.0.20021209-9.diff.gz
 864f464304b5d650be403328c5f52451 114558 libs optional libiconv-hook1_0.0.20021209-9_amd64.deb
 c930067f5732ea3b79c7c71da032dc7d 5348 libdevel optional libiconv-hook-dev_0.0.20021209-9_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGpcJ9FwU5DuZsm7ARAvXmAJ41JCBHBkceMzyDKxTnBPqLdnYoFQCgnGuX
yX5nCob3MOtusnSdoGUgi7Y=
=3IHw
-----END PGP SIGNATURE-----




Information forwarded to debian-bugs-dist@lists.debian.org, Tatsuki Sugiura <sugi@nemui.org>:
Bug#306807; Package libapache-mod-encoding. Full text and rfc822 format available.

Acknowledgement sent to Petr Salinger <Petr.Salinger@seznam.cz>:
Extra info received and forwarded to list. Copy sent to Tatsuki Sugiura <sugi@nemui.org>. Full text and rfc822 format available.

Message #41 received at 306807@bugs.debian.org (full text, mbox):

From: Petr Salinger <Petr.Salinger@seznam.cz>
To: 306807@bugs.debian.org
Subject: libapache-mod-encoding(GNU/k*BSD): still outdated libtool
Date: Tue, 24 Jul 2007 12:22:19 +0200 (CEST)
found 306807 0.0.20021209-9
reopen 306807
thanks

Hi,

the current version of still fails to build on GNU/kFreeBSD,
because of outdated libtool. Please, see my mail from "Fri, 17 Nov 2006",
update of libtool have to be performed in "lib" subdirectory.

Your configure is located in subdir lib, so the right recipe is:
  cd lib
  libtoolize -c -f
  aclocal-1.4
  autoconf

Thanks in advance

                        Petr



Bug marked as found in version 0.0.20021209-9 and reopened. Request was from Petr Salinger <Petr.Salinger@seznam.cz> to control@bugs.debian.org. (Tue, 24 Jul 2007 10:30:04 GMT) Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#306807; Package libapache-mod-encoding. Full text and rfc822 format available.

Acknowledgement sent to Tatsuki Sugiura <sugi@nemui.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #48 received at 306807@bugs.debian.org (full text, mbox):

From: Tatsuki Sugiura <sugi@nemui.org>
To: Petr Salinger <Petr.Salinger@seznam.cz>, 306807@bugs.debian.org
Subject: Re: Bug#306807: libapache-mod-encoding(GNU/k*BSD): still outdated libtool
Date: Tue, 24 Jul 2007 19:31:59 +0900
Hello,

>>> In Message "Bug#306807: libapache-mod-encoding(GNU/k*BSD): still outdated libtool"
>>>            <Pine.LNX.4.62.0707241219040.6184@sci.felk.cvut.cz>,
>>> Petr Salinger <Petr.Salinger@seznam.cz>  said;
> found 306807 0.0.20021209-9
> reopen 306807
> thanks

> Hi,

> the current version of still fails to build on GNU/kFreeBSD,
> because of outdated libtool. Please, see my mail from "Fri, 17 Nov 2006",
> update of libtool have to be performed in "lib" subdirectory.

Oh, I'm sorry about misunderstood your report.
I'll fix it next...

-- 
Tatsuki Sugiura   mailto:sugi@nemui.org



Reply sent to Tatsuki Sugiura <sugi@nemui.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Aurelien Jarno <aurel32@debian.org>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #53 received at 306807-close@bugs.debian.org (full text, mbox):

From: Tatsuki Sugiura <sugi@nemui.org>
To: 306807-close@bugs.debian.org
Subject: Bug#306807: fixed in libapache-mod-encoding 0.0.20021209-10
Date: Sun, 02 Sep 2007 04:47:02 +0000
Source: libapache-mod-encoding
Source-Version: 0.0.20021209-10

We believe that the bug you reported is fixed in the latest version of
libapache-mod-encoding, which is due to be installed in the Debian FTP archive:

libapache-mod-encoding_0.0.20021209-10.diff.gz
  to pool/main/liba/libapache-mod-encoding/libapache-mod-encoding_0.0.20021209-10.diff.gz
libapache-mod-encoding_0.0.20021209-10.dsc
  to pool/main/liba/libapache-mod-encoding/libapache-mod-encoding_0.0.20021209-10.dsc
libiconv-hook-dev_0.0.20021209-10_amd64.deb
  to pool/main/liba/libapache-mod-encoding/libiconv-hook-dev_0.0.20021209-10_amd64.deb
libiconv-hook1_0.0.20021209-10_amd64.deb
  to pool/main/liba/libapache-mod-encoding/libiconv-hook1_0.0.20021209-10_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 306807@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Tatsuki Sugiura <sugi@nemui.org> (supplier of updated libapache-mod-encoding package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 25 Aug 2007 11:20:09 +0900
Source: libapache-mod-encoding
Binary: libiconv-hook1 libiconv-hook-dev
Architecture: source amd64
Version: 0.0.20021209-10
Distribution: unstable
Urgency: low
Maintainer: Taku YASUI <tach@debian.or.jp>
Changed-By: Tatsuki Sugiura <sugi@nemui.org>
Description: 
 libiconv-hook-dev - header files of libiconv-hook
 libiconv-hook1 - extension of iconv for libapache-mod-encoding
Closes: 306807
Changes: 
 libapache-mod-encoding (0.0.20021209-10) unstable; urgency=low
 .
   * Libtool script updated for libiconv-hook (Closes: #306807)
Files: 
 b1ad849465055c50f47d39daa31433c7 700 net optional libapache-mod-encoding_0.0.20021209-10.dsc
 07cb25d43eabc6792c02e6bc52d46808 462143 net optional libapache-mod-encoding_0.0.20021209-10.diff.gz
 2d64dfa9d1771153c2dfcf36fb8f7962 114814 libs optional libiconv-hook1_0.0.20021209-10_amd64.deb
 9baeed9df94cce8f2bd78e9866baa4d3 5376 libdevel optional libiconv-hook-dev_0.0.20021209-10_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFG2j1TFwU5DuZsm7ARAjliAKDhPjwhhhGb/umM8pXhGhKQ8u8JmQCgkcpe
bw6DPMQm5UMrewKG6UySE1s=
=1LMn
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 11 Oct 2007 07:25:29 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 01:24:47 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.