Debian Bug report logs - #289433
ITA: libcgi-untaint-perl -- Process CGI input parameters

version graph

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: Jeroen van Wolffelaar <jeroen@wolffelaar.nl>

Date: Sun, 9 Jan 2005 02:03:01 UTC

Severity: normal

Fixed in version libcgi-untaint-perl/1.25-1

Done: Stephen Quinney <stephen@jadevine.org.uk>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Dagfinn Ilmari Mannsaker <ilmari@ilmari.org>, <wnpp@debian.org>:
Bug#289433; Package wnpp. Full text and rfc822 format available.

Acknowledgement sent to Jeroen van Wolffelaar <jeroen@wolffelaar.nl>:
New Bug report received and forwarded. Copy sent to Dagfinn Ilmari Mannsaker <ilmari@ilmari.org>, <wnpp@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Jeroen van Wolffelaar <jeroen@wolffelaar.nl>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: O: libcgi-untaint-perl -- Process CGI input parameters
Date: Sun, 09 Jan 2005 02:46:05 +0100
Package: wnpp
Severity: normal

The current maintainer of libcgi-untaint-perl, Dagfinn Ilmari Mannsaker <ilmari@ilmari.org>,
has orphaned this package.  If you want to be the new maintainer, please
take it -- see http://www.debian.org/devel/wnpp/index.html#howto-o for
detailed instructions how to adopt a package properly.

Some information about this package:

Package: libcgi-untaint-perl
Binary: libcgi-untaint-perl
Version: 1.00-1
Priority: optional
Section: perl
Maintainer: Dagfinn Ilmari Mannsaker <ilmari@ilmari.org>
Build-Depends-Indep: debhelper (>= 4.1.0), cdbs, perl (>= 5.8.0), libuniversal-require-perl
Architecture: all
Standards-Version: 3.6.1
Format: 1.0
Directory: pool/main/libc/libcgi-untaint-perl
Files: c0f6a123ffa62e7f3f679a2cd3618707 671 libcgi-untaint-perl_1.00-1.dsc
 02b38ef8bcdf1731ef7836503ea6f1da 7268 libcgi-untaint-perl_1.00.orig.tar.gz
 bbff654510e6054a56c2bf5b02fdd6f1 1960 libcgi-untaint-perl_1.00-1.diff.gz

Package: libcgi-untaint-perl
Priority: optional
Section: perl
Installed-Size: 116
Maintainer: Dagfinn Ilmari Mannsaker <ilmari@ilmari.org>
Architecture: all
Version: 1.00-1
Depends: perl (>= 5.6.0-16), libuniversal-require-perl
Filename: pool/main/libc/libcgi-untaint-perl/libcgi-untaint-perl_1.00-1_all.deb
Size: 21706
MD5sum: ff7f8ee9a0683b417f93e98017ed780e
Description: Process CGI input parameters
 Dealing with large web based applications with multiple forms is a
 minefield. It's often hard enough to ensure you validate all your
 input at all, without having to worry about doing it in a consistent
 manner. If any of the validation rules change, you often have to alter
 them in many different places. And, if you want to operate taint-safe,
 then you're just adding even more headaches.
 .
 This module provides a simple, convenient, abstracted and extensible
 manner for validating and untainting the input from web forms.
 .
 You simply create a handler with a hash of your parameters (usually
 $q->Vars), and then iterate over the fields you wish to extract,
 performing whatever validations you choose. The resulting variable is
 guaranteed not only to be valid, but also untainted.



Changed Bug title. Request was from Stephen Quinney <stephen@jadevine.org.uk> to control@bugs.debian.org. Full text and rfc822 format available.

Reply sent to Stephen Quinney <stephen@jadevine.org.uk>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Jeroen van Wolffelaar <jeroen@wolffelaar.nl>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #12 received at 289433-close@bugs.debian.org (full text, mbox):

From: Stephen Quinney <stephen@jadevine.org.uk>
To: 289433-close@bugs.debian.org
Subject: Bug#289433: fixed in libcgi-untaint-perl 1.25-1
Date: Wed, 12 Jan 2005 15:47:31 -0500
Source: libcgi-untaint-perl
Source-Version: 1.25-1

We believe that the bug you reported is fixed in the latest version of
libcgi-untaint-perl, which is due to be installed in the Debian FTP archive:

libcgi-untaint-perl_1.25-1.diff.gz
  to pool/main/libc/libcgi-untaint-perl/libcgi-untaint-perl_1.25-1.diff.gz
libcgi-untaint-perl_1.25-1.dsc
  to pool/main/libc/libcgi-untaint-perl/libcgi-untaint-perl_1.25-1.dsc
libcgi-untaint-perl_1.25-1_all.deb
  to pool/main/libc/libcgi-untaint-perl/libcgi-untaint-perl_1.25-1_all.deb
libcgi-untaint-perl_1.25.orig.tar.gz
  to pool/main/libc/libcgi-untaint-perl/libcgi-untaint-perl_1.25.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 289433@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Stephen Quinney <stephen@jadevine.org.uk> (supplier of updated libcgi-untaint-perl package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Wed, 12 Jan 2005 20:32:54 +0000
Source: libcgi-untaint-perl
Binary: libcgi-untaint-perl
Architecture: source all
Version: 1.25-1
Distribution: unstable
Urgency: low
Maintainer: Stephen Quinney <stephen@jadevine.org.uk>
Changed-By: Stephen Quinney <stephen@jadevine.org.uk>
Description: 
 libcgi-untaint-perl - Process CGI input parameters
Closes: 289433
Changes: 
 libcgi-untaint-perl (1.25-1) unstable; urgency=low
 .
   * New upstream release
   * New maintainer, closes: #289433.
   * debian/rules - replaced with my standard system. This removes the
     build-dependency on cdbs.
Files: 
 2eb2cc61c6e340370749df84f15316b3 660 perl optional libcgi-untaint-perl_1.25-1.dsc
 f75b2641202e441a16db5040c37170c0 7679 perl optional libcgi-untaint-perl_1.25.orig.tar.gz
 a8053d1d4f6837b65360abfb3cf51380 2694 perl optional libcgi-untaint-perl_1.25-1.diff.gz
 37bf143dc5e73c4a0aa72965230d5619 22146 perl optional libcgi-untaint-perl_1.25-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFB5YyDITGblEwaW+URAvFLAKC/5c1MOwxtIHfLDo/qz6bkaJOAPACdF5L6
wFnLY1zoZkYSIH8Q8YlS7ns=
=C4IL
-----END PGP SIGNATURE-----




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sat Apr 19 03:07:51 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.