Debian Bug report logs - #236288
libmysqlclient12: libmysqlclient* should use versioned symbols

version graph

Package: libmysqlclient12; Maintainer for libmysqlclient12 is (unknown);

Reported by: Andreas Metzler <ametzler@debian.org>

Date: Fri, 5 Mar 2004 12:48:01 UTC

Severity: normal

Tags: patch, upstream

Found in version 4.0.18-2

Fixed in versions mysql-dfsg-4.1/4.1.14-3, mysql-dfsg-5.0/5.0.12beta-3

Done: Christian Hammers <ch@debian.org>

Bug is archived. No further changes may be made.

Forwarded to http://bugs.mysql.com/3074

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Christian Hammers <ch@debian.org>:
Bug#236288; Package libmysqlclient12. Full text and rfc822 format available.

Acknowledgement sent to Andreas Metzler <ametzler@debian.org>:
New Bug report received and forwarded. Copy sent to Christian Hammers <ch@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Andreas Metzler <ametzler@debian.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: libmysqlclient12: libmysqlclient* should use versioned symbols
Date: Fri, 5 Mar 2004 13:31:14 +0100
Package: libmysqlclient12
Version: 4.0.18-2
Severity: normal

libmysqlclient10 and libmysqlclient12 do not use versioned symbols.
If a program links at runtime against both versions of the library
the resulting symbol clashes cause segmentation faults.

If you wonder how this can happen, I'll point to #235938: exim4 links
against -12 and libpam. A user is using libpam-mysql for authentication
with exim and at runtime both versions are linked to the binary,
libmysqlclient12 and libmysqlclient10 is dlpened by PAM.

Another example is apache with its multitude of modules.

As you know for license reasons it is not possble to get rid of the
"old" libmysqlclient10 so the nly solution is to introduce versioned
symbols in both libraries.
                   thanks, cu andreas



Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#236288; Package libmysqlclient12. Full text and rfc822 format available.

Acknowledgement sent to Christian Hammers <ch@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #10 received at 236288@bugs.debian.org (full text, mbox):

From: Christian Hammers <ch@debian.org>
To: Andreas Metzler <ametzler@debian.org>, 236288@bugs.debian.org, control@bugs.debian.org
Subject: Re: Bug#236288: libmysqlclient12: libmysqlclient* should use versioned symbols
Date: Fri, 5 Mar 2004 14:22:35 +0100
tags 236288 + upstream
forwarded 236288 http://bugs.mysql.com/ as #3074
thanks

Hello

> libmysqlclient10 and libmysqlclient12 do not use versioned symbols.
> If a program links at runtime against both versions of the library
> the resulting symbol clashes cause segmentation faults.
...

I checked the upstream binaries and they, too, are unversioned. So it's
no bug in the way I compile. 
I filed a bug report at bugs.mysql.com and asked for a comment.

bye,

-christian-




Tags added: upstream Request was from Christian Hammers <ch@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Noted your statement that Bug has been forwarded to http://bugs.mysql.com/ as #3074. Request was from Christian Hammers <ch@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#236288; Package libmysqlclient12. Full text and rfc822 format available.

Acknowledgement sent to Christian Hammers <ch@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #19 received at 236288@bugs.debian.org (full text, mbox):

From: Christian Hammers <ch@debian.org>
To: 236288@bugs.debian.org, 236288-submitter@bugs.debian.org
Cc: control@bugs.debian.org
Subject: Re: Bug #3074 [Opn->!Bg]: Unversioned symbols in shared library
Date: Sat, 6 Mar 2004 16:43:47 +0100
tags 236288 + wontfix
thanks

Hello

Here's MySQLs response.

bye,

-christian-

On Sat, Mar 06, 2004 at 02:30:17PM -0000, Bug Database wrote:
>  ID:               3074
>  Updated by:       Sinisa Milivojevic
>  Reported by:      Christian Hammers
>  User Type:        User
> -Originating List: 
> +Originating List: General
> -Status:           Open
> +Status:           Not a Bug
>  Severity:         Non-critical
>  Priority:         Low
>  Category:         libmysql
>  Operating System: Debian GNU/Linux
>  Version:          4.0.18
>  New Comment:
> 
> Of course.
> 
> We do not plan to version symbols.
> 
> As our manual strongly recommends, you should have one set of includes
> and one set of libraries for C API, never more then one.




Tags added: wontfix Request was from Christian Hammers <ch@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Message sent on to Andreas Metzler <ametzler@debian.org>:
Bug#236288. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, Christian Hammers <ch@debian.org>:
Bug#236288; Package libmysqlclient12. Full text and rfc822 format available.

Acknowledgement sent to Andreas Metzler <ametzler@downhill.at.eu.org>:
Extra info received and forwarded to list. Copy sent to Christian Hammers <ch@debian.org>. Full text and rfc822 format available.

Message #29 received at 236288@bugs.debian.org (full text, mbox):

From: Andreas Metzler <ametzler@downhill.at.eu.org>
To: 236288@bugs.debian.org
Subject: Re: Bug#236288: Bug #3074 [Opn->!Bg]: Unversioned symbols in shared library
Date: Sat, 6 Mar 2004 17:03:11 +0100
On 2004-03-06 Christian Hammers <ch@debian.org> wrote:
> Here's MySQLs response.

> On Sat, Mar 06, 2004 at 02:30:17PM -0000, Bug Database wrote:
> >  ID:               3074
> >  Updated by:       Sinisa Milivojevic
[...] 
> > Of course.
 
> > We do not plan to version symbols.
 
> > As our manual strongly recommends, you should have one set of includes
> > and one set of libraries for C API, never more then one.

Darn. Thanks for trying.

I hope the license-mess will be resolved and libmysqlclient10 be
removed, but my hopes are not too high.
               cu andras
-- 
"See, I told you they'd listen to Reason," [SPOILER] Svfurlr fnlf,
fuhggvat qbja gur juveyvat tha.
Neal Stephenson in "Snow Crash"



Forwarded-to-address changed from http://bugs.mysql.com/ as #3074 to http://bugs.mysql.com/3074. Request was from Adam Majer <adamm@galacticasoftware.com> to control@bugs.debian.org. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#236288; Package libmysqlclient12. Full text and rfc822 format available.

Acknowledgement sent to Christian Hammers <ch@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #36 received at 236288@bugs.debian.org (full text, mbox):

From: Christian Hammers <ch@debian.org>
To: 236288@bugs.debian.org, vorlon@debian.org, dc <control@bugs.debian.org>
Subject: Re: Versioned symbols in MySQL? Need help :)
Date: Mon, 19 Sep 2005 21:21:00 +0200
[Message part 1 (text/plain, inline)]
tags 236288 - wontfix
tags 236288 + patch
thanks

Hello

After 1.5 years this bug report finally get touched again :) Thanks to a patch
Steve submitted, I will be able to add versioned symbols to libmysqlclient.

The patch has also been submitted to the corresponding upstream bugreport.

bye,

-christian-
[Message part 2 (message/rfc822, inline)]
66.93.39.86]=20
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1EGaVW-0006hs-00; Sat, 17 Sep 2005 06:05:23 -0500
Received: by tennyson.dodds.net (Postfix, from userid 1000)
	id E7D677038; Sat, 17 Sep 2005 04:05:21 -0700 (PDT)
Date: Sat, 17 Sep 2005 04:05:21 -0700
From: Steve Langasek <vorlon@debian.org>
To: Christian Hammers <ch@debian.org>
Subject: Re: Versioned symbols in MySQL? Need help :)
Message-ID: <20050917110521.GA1754@tennyson.dodds.net>
References: <20050916132956.6f3d2e98@xeniac.intern>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=3Dpgp-sha1;
	protocol=3D"application/pgp-signature"; boundary=3D"uZ3hkaAS1mZxFaxD"
Content-Disposition: inline
In-Reply-To: <20050916132956.6f3d2e98@xeniac.intern>
User-Agent: Mutt/1.5.9i
X-Spam-Status: No, hits=3D0.1 tagged_above=3D-999.0 required=3D5.0 tests=3D=
AWL,
	FORGED_RCVD_HELO
X-Spam-Level:=20


--uZ3hkaAS1mZxFaxD
Content-Type: multipart/mixed; boundary=3D"45Z9DzgjV8m4Oswq"
Content-Disposition: inline


--45Z9DzgjV8m4Oswq
Content-Type: text/plain; charset=3Dus-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hi Christian,

On Fri, Sep 16, 2005 at 01:29:56PM +0200, Christian Hammers wrote:
> Adam Conrad asked me to contact you regarding versioned symbols in MySQL:
> "Talk to vorlon (Steve Langasek)... He'll JUMP at the chance to walk you
> through it and/or provide a patch, if upstream may accept it."

Absolutely!

> Currently we have:
> libmysqlclient12 (MySQL 4.0.x/Sarge)
> libmysqlclient14 (MySQL 4.1.x/Etch,Sid)
> libmysqlclient15 (MySQL 5.0.x/Etch+1,Sid)

> The libmysqlclient12 should be dropped as soon as possible (debian-release
> asked me to wait a bit) and libmysqlclient14 should be used in Etch.
> libmysqlclient15 is no big difference but from the 5.0.xbeta versions and
> thus not suitable.

> If we had versioned symbols it probably would be no problem if one package
> links against v12 and loads an add-on module which links against v14, or?
> This would give us some time because as Adam noted some maintainers
> already started to build against v14 (as these possible linking problems
> are not obvious to all maintainers, of course)

> Can you give me a hint how to "enable" them? Surely only a compile time
> option... (if you have no time that's ok, too, then I google on my own
> but that would take longer :))

Please find attached a patch which enables symbol versioning for
libmysqlclient14.  The same patch will probably apply pretty cleanly to
libmysqlclient12 as well, but I wanted to give you the libmysqlclient14
version first so that you could begin discussing it with upstream as
necessary.  Since most new software being compiled on Debian will be linked
against libmysqlclient14, it's important to get symbol versions officially
added as soon as possible so that people rebuilding packages will get the
benefit of them.

This is just like adding any new symbol to a library -- you can run old
software against a library that has added a new symbol, but if you have
software that uses the new symbol, it won't work against the old version of
the library.  For that reason, the patch enables symbol versioning
*unconditionally* on platforms that are known to support it, to ensure
compatibility across all distributions that are using this version of the
library.  The patch also probably warrants bumping SHARED_LIB_VERSION from
14:0:0 to 15:0:1 for the same reason (which is supposed to still give an
soname of libmysqlclient.so.14, AIUI).

I think that getting versioned symbols added to 14 and 15 should be the
first priority:  12 will mostly be an issue for transitions from sarge,
since most packages that get rebuilt will rebuild against 14; and we can't
add symbol versioning to the sarge package now, so adding them at all will
only help in the rare case that packages are re-uploaded and still building
against 12.  Just having 14 versioned will help take care of some segfaults,
though (statistically, half of them).

The symbol version that I chose, MYSQL_4.1, is arbitrary; if upstream would
prefer to use MYSQL_14, that's also a good choice.  Like package names, they
don't *have* to match the soname, but it's important that there be a 1:1
mapping with sonames; so basing the symbol version name on the SONAME is a
good way to ensure this.  Just make sure upstream uses a different one for
libmysqlclient15. :)

Any questions, just ask!

Cheers,
--=3D20
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

--45Z9DzgjV8m4Oswq
Content-Type: text/plain; charset=3Dus-ascii
Content-Disposition: attachment; filename=3D"mysql-dfsg-4.1-symbolversions.=
diff"
Content-Transfer-Encoding: quoted-printable

diff -u mysql-dfsg-4.1-4.1.14/debian/changelog mysql-dfsg-4.1-4.1.14/debian=
=3D
/changelog
--- mysql-dfsg-4.1-4.1.14/debian/changelog
+++ mysql-dfsg-4.1-4.1.14/debian/changelog
@@ -1,3 +1,10 @@
+mysql-dfsg-4.1 (4.1.14-2.1) unstable; urgency=3D3Dlow
+
+  * Non-maintainer upload.
+  * Symbol versioning support!  wooooohoooooo!
+
+ -- Steve Langasek <vorlon@debian.org>  Sat, 17 Sep 2005 02:01:48 -0700
+
 mysql-dfsg-4.1 (4.1.14-2) unstable; urgency=3D3Dhigh
=3D20
   * Changed the conflicts of mysql-server-4.1 with mysql-client to only
only in patch2:
unchanged:
--- mysql-dfsg-4.1-4.1.14.orig/configure.in
+++ mysql-dfsg-4.1-4.1.14/configure.in
@@ -1281,6 +1281,17 @@
     ;;
 esac
=3D20
+# use symbol versioning on Linux, to avoid problems when
+# mixing-and-matching multiple lib versions; may be useful on other
+# platforms that support symbol versioning (BSDs?)
+case $SYSTEM_TYPE in
+  *linux*)
+	LINKER_SCRIPT=3D3D"-Wl,--version-script=3D3D\$(srcdir)/libmysql.ver"
+	;;
+  *) ;;
+esac
+AC_SUBST(LINKER_SCRIPT)
+
=3D20
 #---START: Used in for client configure
 # Check if we threads are in libc or if we should use
only in patch2:
unchanged:
--- mysql-dfsg-4.1-4.1.14.orig/mysys/libmysql.ver
+++ mysql-dfsg-4.1-4.1.14/mysys/libmysql.ver
@@ -0,0 +1,11 @@
+HIDDEN {
+	local:
+		__*;
+		_rest*;
+		_save*;
+};
+
+MYSQL_4.1 {
+	global:
+		*;
+};
only in patch2:
unchanged:
--- mysql-dfsg-4.1-4.1.14.orig/libmysql_r/Makefile.am
+++ mysql-dfsg-4.1-4.1.14/libmysql_r/Makefile.am
@@ -44,3 +44,4 @@
 	  rm -f $(srcdir)/$$f; \
 	  @LN_CP_F@ $(libmysql_dir)/$$f $(srcdir)/$$f; \
 	done
+	@LN_CP_F@ $(srcdir)/../mysys/libmysql.ver $(srcdir)/$$f
only in patch2:
unchanged:
--- mysql-dfsg-4.1-4.1.14.orig/libmysql/Makefile.shared
+++ mysql-dfsg-4.1-4.1.14/libmysql/Makefile.shared
@@ -75,7 +75,7 @@
 mysysobjects =3D3D		$(mysysobjects1) $(mysysobjects2)
 target_libadd =3D3D		$(mysysobjects) $(mystringsobjects) $(dbugobjects) \
  $(sql_cmn_objects) $(vio_objects) $(sqlobjects)
-target_ldflags =3D3D -version-info @SHARED_LIB_VERSION@
+target_ldflags =3D3D -version-info @SHARED_LIB_VERSION@ @LINKER_SCRIPT@
 vio_objects=3D3D vio.lo viosocket.lo viossl.lo viosslfactories.lo
 CLEANFILES =3D3D		$(target_libadd) $(SHLIBOBJS) \
 			$(target)
only in patch2:
unchanged:
--- mysql-dfsg-4.1-4.1.14.orig/libmysql/Makefile.am
+++ mysql-dfsg-4.1-4.1.14/libmysql/Makefile.am
@@ -70,6 +70,7 @@
 	  @LN_CP_F@ $(srcdir)/../sql/net_serv.cc $(srcdir)/net.c ; \
 	  rm -f $(srcdir)/password.c; \
 	  @LN_CP_F@ $(srcdir)/../sql/password.c $(srcdir)/password.c
+	  @LN_CP_F@ $(srcdir)/../mysys/libmysql.ver $(srcdir)/$$f
=3D20
 # This part requires GNUmake
 #

--45Z9DzgjV8m4Oswq--

--uZ3hkaAS1mZxFaxD
Content-Type: application/pgp-signature; name=3D"signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDK/hxKN6ufymYLloRAhcLAKDJugc/h0z3A2wjq9I6zmLM4zoziACgqHPK
aftVpxqLYMvhqyrJ/UjKbaY=3D
=3Dsjy0
-----END PGP SIGNATURE-----

--uZ3hkaAS1mZxFaxD--

Tags removed: wontfix Request was from Christian Hammers <ch@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Tags added: patch Request was from Christian Hammers <ch@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#236288; Package libmysqlclient12. Full text and rfc822 format available.

Acknowledgement sent to Christian Hammers <ch@debian.org>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #45 received at 236288@bugs.debian.org (full text, mbox):

From: Christian Hammers <ch@debian.org>
To: 236288@bugs.debian.org, vorlon@bugs.debian.org
Subject: Re: Versioned symbols in MySQL? Need help :)
Date: Tue, 20 Sep 2005 09:14:01 +0200
Hello Steve

One question regarding the versioned symbols: How do I check if your patch
worked?

$ nm libmysql/.libs/libmysqlclient.so.15.0.0 | grep mysql_query
0000e310 T mysql_query

I had expected this to be "T mysql_query__MYSQL_4.1" or similar like I saw in
some other libraries. Your symbol is present though, is this enough?

$ nm libmysql/.libs/libmysqlclient.so.15.0.0 | grep MYSQL_
00000000 A MYSQL_4.1

(I just applied the patch to the 5.0 source tree, of course I have to change
the version number yet *g*)

bye,

-christian-



Reply sent to Christian Hammers <ch@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Andreas Metzler <ametzler@debian.org>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #50 received at 236288-close@bugs.debian.org (full text, mbox):

From: Christian Hammers <ch@debian.org>
To: 236288-close@bugs.debian.org
Subject: Bug#236288: fixed in mysql-dfsg-4.1 4.1.14-3
Date: Wed, 21 Sep 2005 08:02:14 -0700
Source: mysql-dfsg-4.1
Source-Version: 4.1.14-3

We believe that the bug you reported is fixed in the latest version of
mysql-dfsg-4.1, which is due to be installed in the Debian FTP archive:

libmysqlclient14-dev_4.1.14-3_i386.deb
  to pool/main/m/mysql-dfsg-4.1/libmysqlclient14-dev_4.1.14-3_i386.deb
libmysqlclient14_4.1.14-3_i386.deb
  to pool/main/m/mysql-dfsg-4.1/libmysqlclient14_4.1.14-3_i386.deb
mysql-client-4.1_4.1.14-3_i386.deb
  to pool/main/m/mysql-dfsg-4.1/mysql-client-4.1_4.1.14-3_i386.deb
mysql-client_4.1.14-3_i386.deb
  to pool/main/m/mysql-dfsg-4.1/mysql-client_4.1.14-3_i386.deb
mysql-dfsg-4.1_4.1.14-3.diff.gz
  to pool/main/m/mysql-dfsg-4.1/mysql-dfsg-4.1_4.1.14-3.diff.gz
mysql-dfsg-4.1_4.1.14-3.dsc
  to pool/main/m/mysql-dfsg-4.1/mysql-dfsg-4.1_4.1.14-3.dsc
mysql-server-4.1_4.1.14-3_i386.deb
  to pool/main/m/mysql-dfsg-4.1/mysql-server-4.1_4.1.14-3_i386.deb
mysql-server_4.1.14-3_i386.deb
  to pool/main/m/mysql-dfsg-4.1/mysql-server_4.1.14-3_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 236288@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Christian Hammers <ch@debian.org> (supplier of updated mysql-dfsg-4.1 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Thu, 15 Sep 2005 22:26:03 +0200
Source: mysql-dfsg-4.1
Binary: libmysqlclient14-dev mysql-client libmysqlclient14 mysql-server mysql-server-4.1 mysql-client-4.1
Architecture: source i386
Version: 4.1.14-3
Distribution: unstable
Urgency: medium
Maintainer: Christian Hammers <ch@debian.org>
Changed-By: Christian Hammers <ch@debian.org>
Description: 
 libmysqlclient14 - mysql database client library
 libmysqlclient14-dev - mysql database development files
 mysql-client - mysql database client (transitional dummy package)
 mysql-client-4.1 - mysql database client binaries
 mysql-server - mysql database server (transitional dummy package)
 mysql-server-4.1 - mysql database server binaries
Closes: 236288 329166
Changes: 
 mysql-dfsg-4.1 (4.1.14-3) unstable; urgency=medium
 .
   * Symbol versioning support!  wooooohoooooo!
     (thanks to Steve Langasek) Closes: #236288
   * Moved libndbcclient.so.0 to the -dev package as it is provided by
     libmysqlclient14 and -15 which must be installable simultaneously.
     (it is version 0.0.0 and really not intended to be used in production)
   * Removed recommends to libmysqlclient14-dev from libmysqlclient14
     (thanks to Adam Majer). Closes: #329166
Files: 
 b33d527a7eba5d16a2e1011a0b37cb5a 1042 misc optional mysql-dfsg-4.1_4.1.14-3.dsc
 fe433946f38620e3839042e77f6e48f9 166143 misc optional mysql-dfsg-4.1_4.1.14-3.diff.gz
 f9e5e51747a90987b89f0baef8c80609 845560 misc optional mysql-client-4.1_4.1.14-3_i386.deb
 d62d8a8bfd26d40c255f8a332d0f3678 14690448 misc optional mysql-server-4.1_4.1.14-3_i386.deb
 16a1d8238a81dec1687a13b00e1e05c8 1208912 libs optional libmysqlclient14_4.1.14-3_i386.deb
 a4836003fdc6a7e25867363532add3c3 5523914 libdevel optional libmysqlclient14-dev_4.1.14-3_i386.deb
 ae4293723d994e2afc9c5596a06ca668 34840 misc optional mysql-server_4.1.14-3_i386.deb
 68ef5740796bcc8673bc812b81a3b5b4 34840 misc optional mysql-client_4.1.14-3_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iEYEARECAAYFAkMxcOoACgkQkR9K5oahGObt7QCffL0aCczE/AGWWm+MXeQqB/Yd
tEwAoO/i3GHXrWGlq7WtwuRwnpxOTq3q
=SCzU
-----END PGP SIGNATURE-----




Reply sent to Christian Hammers <ch@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Andreas Metzler <ametzler@debian.org>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #55 received at 236288-close@bugs.debian.org (full text, mbox):

From: Christian Hammers <ch@debian.org>
To: 236288-close@bugs.debian.org
Subject: Bug#236288: fixed in mysql-dfsg-5.0 5.0.12beta-3
Date: Thu, 22 Sep 2005 17:17:08 -0700
Source: mysql-dfsg-5.0
Source-Version: 5.0.12beta-3

We believe that the bug you reported is fixed in the latest version of
mysql-dfsg-5.0, which is due to be installed in the Debian FTP archive:

libmysqlclient15-dev_5.0.12beta-3_i386.deb
  to pool/main/m/mysql-dfsg-5.0/libmysqlclient15-dev_5.0.12beta-3_i386.deb
libmysqlclient15_5.0.12beta-3_i386.deb
  to pool/main/m/mysql-dfsg-5.0/libmysqlclient15_5.0.12beta-3_i386.deb
mysql-client-5.0_5.0.12beta-3_i386.deb
  to pool/main/m/mysql-dfsg-5.0/mysql-client-5.0_5.0.12beta-3_i386.deb
mysql-common_5.0.12beta-3_all.deb
  to pool/main/m/mysql-dfsg-5.0/mysql-common_5.0.12beta-3_all.deb
mysql-dfsg-5.0_5.0.12beta-3.diff.gz
  to pool/main/m/mysql-dfsg-5.0/mysql-dfsg-5.0_5.0.12beta-3.diff.gz
mysql-dfsg-5.0_5.0.12beta-3.dsc
  to pool/main/m/mysql-dfsg-5.0/mysql-dfsg-5.0_5.0.12beta-3.dsc
mysql-server-5.0_5.0.12beta-3_i386.deb
  to pool/main/m/mysql-dfsg-5.0/mysql-server-5.0_5.0.12beta-3_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 236288@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Christian Hammers <ch@debian.org> (supplier of updated mysql-dfsg-5.0 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 20 Sep 2005 00:07:03 +0200
Source: mysql-dfsg-5.0
Binary: libmysqlclient15-dev libmysqlclient15 mysql-client-5.0 mysql-server-5.0 mysql-common
Architecture: source i386 all
Version: 5.0.12beta-3
Distribution: unstable
Urgency: medium
Maintainer: Christian Hammers <ch@debian.org>
Changed-By: Christian Hammers <ch@debian.org>
Description: 
 libmysqlclient15 - mysql database client library
 libmysqlclient15-dev - mysql database development files
 mysql-client-5.0 - mysql database client binaries
 mysql-common - mysql database common files (e.g. /etc/mysql/my.cnf)
 mysql-server-5.0 - mysql database server binaries
Closes: 236288
Changes: 
 mysql-dfsg-5.0 (5.0.12beta-3) unstable; urgency=medium
 .
   * Symbol versioning support!  wooooohoooooo!
     (thanks to Steve Langasek) Closes: #236288
   * Moved libndbcclient.so.0 to the -dev package as it is provided by
     libmysqlclient14 and -15 which must be installable simultaneously.
   * Removed mysql-*-doc suggestions.
Files: 
 59624c2eb6af27dd5767780738793861 1040 misc optional mysql-dfsg-5.0_5.0.12beta-3.dsc
 83b7e6d0523e2ddbec38c7c9c7a95301 110594 misc optional mysql-dfsg-5.0_5.0.12beta-3.diff.gz
 413f4ad93dcf30b97a9effec82beac33 36996 misc optional mysql-common_5.0.12beta-3_all.deb
 0ac80153ea93a04c4c97daa65a6a1637 1344504 libs optional libmysqlclient15_5.0.12beta-3_i386.deb
 2878b0b84c2b13778bebd0da96fd56df 6020448 libdevel optional libmysqlclient15-dev_5.0.12beta-3_i386.deb
 2c62d3204da666da28361b391e2db937 6175726 misc optional mysql-client-5.0_5.0.12beta-3_i386.deb
 5a98471527befe2d3369eecba2749fbc 14465778 misc optional mysql-server-5.0_5.0.12beta-3_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iEYEARECAAYFAkMzR3UACgkQkR9K5oahGOakPgCgmmq/KdsfNo1/yOwVDb96AHm1
gpEAoNbB4I2GJO7bf3AK0aOU7PnAdmdp
=ulRO
-----END PGP SIGNATURE-----




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Tue, 19 Jun 2007 01:33:54 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 21:31:45 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.