Debian Bug report logs - #215065
[CODE REWRITE][Build-Dependency solver] Build-Depends on guile, libguile-dev (>= 1:1.4-10) breaks pbuilder

version graph

Package: pbuilder; Maintainer for pbuilder is Debian pbuilder maintenance team <pbuilder-maint@lists.alioth.debian.org>; Source for pbuilder is src:pbuilder.

Reported by: Daniel Schepler <dschepler@gmail.com>

Date: Fri, 10 Oct 2003 02:33:04 UTC

Severity: normal

Found in version 0.88

Fixed in version 0.172

Done: Loïc Minier <lool@dooz.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Junichi Uekawa <dancer@debian.org>:
Bug#215065; Package pbuilder. Full text and rfc822 format available.

Acknowledgement sent to Daniel Schepler <schepler@math.berkeley.edu>:
New Bug report received and forwarded. Copy sent to Junichi Uekawa <dancer@debian.org>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Daniel Schepler <schepler@math.berkeley.edu>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: pbuilder: Build-Depends on guile, libguile-dev (>= 1:1.4-10) breaks pbuilder
Date: Thu, 09 Oct 2003 19:21:26 -0700
Package: pbuilder
Version: 0.88
Severity: normal

When I run "pbuilder gconf_1.0.9-5.dsc", part of the output reads:

 -> Considering  guile
   -> Trying guile
       -> Cannot install guile; apt errors follow:
Reading Package Lists...
Building Dependency Tree...
Package guile is a virtual package provided by:
  guile1.4 1:1.4-24
  guile-1.6 1.6.4-4
You should explicitly select one to install.
E: Package guile has no installation candidate
     -> Considering guile-1.6 to satisfy the dependency 
 -> Considering  libguile-dev (>= 1:1.4-10)
   -> Trying libguile-dev
       -> Cannot install libguile-dev; apt errors follow:
Reading Package Lists...
Building Dependency Tree...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  guile-1.6: Conflicts: libguile-dev (<= 1:1.4-24)
E: Broken packages
     -> Considering guile-1.6-dev to satisfy the dependency 

Then later, dpkg-checkbuilddeps fails.  I've already reported a bug
against gconf regarding the fact that "guile" isn't specific enough.
However, I was wondering why pbuilder-satisfydepends tried installing
guile-1.6-dev for libguile-dev despite the versioned Build-Depends.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux frobnitz 2.6.0-test4 #1 Thu Aug 28 00:56:57 PDT 2003 i686
Locale: LANG=C, LC_CTYPE=C

Versions of packages pbuilder depends on:
ii  debianutils                   2.5.5      Miscellaneous utilities specific t
ii  debootstrap                   0.2.10     Bootstrap a basic Debian system
ii  gcc                           4:3.3.1-2  The GNU C compiler.
ii  wget                          1.8.2-11   retrieves files from the web

-- no debconf information


-- 
Daniel Schepler              "Please don't disillusion me.  I
schepler@math.berkeley.edu    haven't had breakfast yet."
                                 -- Orson Scott Card



Information forwarded to debian-bugs-dist@lists.debian.org, Junichi Uekawa <dancer@debian.org>:
Bug#215065; Package pbuilder. Full text and rfc822 format available.

Acknowledgement sent to Junichi Uekawa <dancer@netfort.gr.jp>:
Extra info received and forwarded to list. Copy sent to Junichi Uekawa <dancer@debian.org>. Full text and rfc822 format available.

Message #10 received at 215065@bugs.debian.org (full text, mbox):

From: Junichi Uekawa <dancer@netfort.gr.jp>
To: Daniel Schepler <schepler@math.berkeley.edu>, 215065@bugs.debian.org
Subject: Re: Bug#215065: pbuilder: Build-Depends on guile, libguile-dev (>= 1:1.4-10) breaks pbuilder
Date: Tue, 14 Oct 2003 22:45:36 +0900
> The following packages have unmet dependencies:
>   guile-1.6: Conflicts: libguile-dev (<= 1:1.4-24)
> E: Broken packages
>      -> Considering guile-1.6-dev to satisfy the dependency 
> 
> Then later, dpkg-checkbuilddeps fails.  I've already reported a bug
> against gconf regarding the fact that "guile" isn't specific enough.
> However, I was wondering why pbuilder-satisfydepends tried installing
> guile-1.6-dev for libguile-dev despite the versioned Build-Depends.


unlike apt and others, pbuilder does not solve all dependencies at once, 
but only progressively. Therefore, it needs to be able to determine what
to install from left-to-right parsing.

In this case, 'guile' cannot be determined until you see the next 
statement and backtrack.


regards,
	junichi





Information forwarded to debian-bugs-dist@lists.debian.org, Junichi Uekawa <dancer@debian.org>:
Bug#215065; Package pbuilder. Full text and rfc822 format available.

Acknowledgement sent to Daniel Schepler <schepler@math.berkeley.edu>:
Extra info received and forwarded to list. Copy sent to Junichi Uekawa <dancer@debian.org>. Full text and rfc822 format available.

Message #15 received at 215065@bugs.debian.org (full text, mbox):

From: Daniel Schepler <schepler@math.berkeley.edu>
To: Junichi Uekawa <dancer@netfort.gr.jp>
Cc: 215065@bugs.debian.org
Subject: Re: Bug#215065: pbuilder: Build-Depends on guile, libguile-dev (>= 1:1.4-10) breaks pbuilder
Date: Thu, 23 Oct 2003 16:52:31 -0700
Junichi Uekawa <dancer@netfort.gr.jp> writes:

>> The following packages have unmet dependencies:
>>   guile-1.6: Conflicts: libguile-dev (<= 1:1.4-24)
>> E: Broken packages
>>      -> Considering guile-1.6-dev to satisfy the dependency 
>> 
>> Then later, dpkg-checkbuilddeps fails.  I've already reported a bug
>> against gconf regarding the fact that "guile" isn't specific enough.
>> However, I was wondering why pbuilder-satisfydepends tried installing
>> guile-1.6-dev for libguile-dev despite the versioned Build-Depends.
>
>
> unlike apt and others, pbuilder does not solve all dependencies at once, 
> but only progressively. Therefore, it needs to be able to determine what
> to install from left-to-right parsing.
>
> In this case, 'guile' cannot be determined until you see the next 
> statement and backtrack.

I'm aware of that.  What seemed to be happening here, though, was that
the specific package satisfied the version, but wasn't installable for
other reasons.  But then pbuilder-satisfydepends went on to try to
satisfy the dependency using a providing package for some reason,
despite the fact that the build dependency was versioned.
-- 
Daniel Schepler              "Please don't disillusion me.  I
schepler@math.berkeley.edu    haven't had breakfast yet."
                                 -- Orson Scott Card



Changed Bug title. Request was from Junichi Uekawa <dancer@netfort.gr.jp> to control@bugs.debian.org. Full text and rfc822 format available.

Changed Bug title. Request was from Junichi Uekawa <dancer@netfort.gr.jp> to control@bugs.debian.org. Full text and rfc822 format available.

Changed Bug submitter from Daniel Schepler <schepler@math.berkeley.edu> to Daniel Schepler <dschepler@gmail.com>. Request was from Daniel Schepler <dschepler@gmail.com> to control@bugs.debian.org. (Thu, 09 Apr 2009 23:58:29 GMT) Full text and rfc822 format available.

Reply sent to Loïc Minier <lool@dooz.org>:
You have taken responsibility. (Wed, 30 Dec 2009 10:33:12 GMT) Full text and rfc822 format available.

Notification sent to Daniel Schepler <dschepler@gmail.com>:
Bug acknowledged by developer. (Wed, 30 Dec 2009 10:33:12 GMT) Full text and rfc822 format available.

Message #26 received at 215065-done@bugs.debian.org (full text, mbox):

From: Loïc Minier <lool@dooz.org>
To: Daniel Schepler <dschepler@gmail.com>, 215065-done@bugs.debian.org
Subject: Re: Bug#215065: pbuilder: Build-Depends on guile, libguile-dev (>= 1:1.4-10) breaks pbuilder
Date: Wed, 30 Dec 2009 11:24:59 +0100
Version: 0.172

        Hi

On Thu, Oct 09, 2003, Daniel Schepler wrote:
> When I run "pbuilder gconf_1.0.9-5.dsc", part of the output reads:
>  -> Considering  guile
>    -> Trying guile
>        -> Cannot install guile; apt errors follow:

 The two shell dependency resolvers have limitations in what they will
 accept / try; I think the "experimental" resolver worked slightly
 better in your case, but in any case the "aptitude" based resolver
 which is the current default should just work.  I'm closing this bug
 with the version in which it was made the default; please reopen the
 bug if it's still not working with the aptiture resolver.

   Thanks
-- 
Loïc Minier




Bug archived. Request was from Debbugs Internal Request <owner@bugs.debian.org> to internal_control@bugs.debian.org. (Thu, 28 Jan 2010 07:34:46 GMT) Full text and rfc822 format available.

Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Sun Apr 20 06:23:15 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.