Debian Bug report logs - #204424
the patch does not apply cleanly to kernel-source-2.4.18-12

version graph

Package: kernel-patch-2.4-grsecurity; Maintainer for kernel-patch-2.4-grsecurity is (unknown);

Reported by: "ODi" <odi@imn.pl>

Date: Thu, 7 Aug 2003 08:03:02 UTC

Severity: important

Tags: help, moreinfo

Merged with 203759

Found in versions 1.9.4-3, 1.9.4-1

Fixed in version kernel-patch-2.4-grsecurity/1.9.12-2

Done: madduck@debian.org (martin f. krafft)

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Jonathan McDowell <noodles@earth.li>:
Bug#204424; Package kernel-patch-2.4-grsecurity. Full text and rfc822 format available.

Acknowledgement sent to "ODi" <odi@imn.pl>:
New Bug report received and forwarded. Copy sent to Jonathan McDowell <noodles@earth.li>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: "ODi" <odi@imn.pl>
To: <submit@bugs.debian.org>
Cc: <debian-user-polish@lists.debian.org>, <debian-user@lists.debian.org>
Subject: the patch does not apply cleanly to kernel-source-2.4.18-12
Date: Thu, 7 Aug 2003 09:49:05 +0200
[Message part 1 (text/plain, inline)]
Package: kernel-patch-2.4-grsecurity
Version: 1.9.4-3

the patch gives a conflict when trying to apply to nesest kernel-source
(2.4.18-12). The patch probably solves a bug that was solved in last update
of kernel-source.

root@odi:/usr/src/kernel-source-2.4.18# ./grsecurity_2_4
Testing whether Greater Security for Linux 2.4.x patch for 2.4.18 applies (dry run):
1 out of 1 hunk FAILED -- saving rejects to file fs/proc/proc_tty.c.rej
1 out of 11 hunks FAILED -- saving rejects to file include/linux/sched.h.rej
Greater Security for Linux 2.4.x patch for 2.4.18 does not apply cleanly

Debiana GNU/Linux 3.0, kernel 2.4.18, glibc-2.2.5-11.5, patch 2.5.4
[Message part 2 (text/html, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, Jonathan McDowell <noodles@earth.li>:
Bug#204424; Package kernel-patch-2.4-grsecurity. Full text and rfc822 format available.

Acknowledgement sent to martin f krafft <madduck@debian.org>:
Extra info received and forwarded to list. Copy sent to Jonathan McDowell <noodles@earth.li>. Full text and rfc822 format available.

Message #10 received at 204424@bugs.debian.org (full text, mbox):

From: martin f krafft <madduck@debian.org>
To: 206458@bugs.debian.org, 199510@bugs.debian.org, 194225@bugs.debian.org, 203759@bugs.debian.org, 204424@bugs.debian.org
Cc: control@bugs.debian.org
Subject: more info needed
Date: Tue, 2 Sep 2003 22:50:53 +0200
[Message part 1 (text/plain, inline)]
severity 194225 important
severity 203759 important
severity 204424 important
severity 206458 important
tags 194225 +moreinfo +help
tags 199510 +moreinfo +help
tags 203759 +moreinfo +help
tags 204424 +moreinfo +help
tags 206458 +moreinfo +help
merge 194225 206458
merge 204424 203759
thanks

Hey thee, submitters of bugs...

If you expect me to fix the bug in the grsecurity kernel patch not
applying cleanly to your version of the kernel (whichever that was),
then please provide more information. Building a kernel with patches
takes more time than I have. Please give me the output of `make-kpkg
configure`, but try to trim it down to the stuff related to
grsecurity.

Also, a tarball of *just* the .rej files would be incredibly
helpful. Try to put that somewhere for download, upload it to
ftp://ftp.madduck.net/incoming, just please don't send it via email.

I will tag these bugs as wontfix if I don't receive help on them.
The reason is that 2.4.22 is out, and thus these problems are
theoretically problems of the past.

Thanks,

-- 
Please do not CC me when replying to lists; I read them!
 
 .''`.     martin f. krafft <madduck@debian.org>
: :'  :    proud Debian developer, admin, and user
`. `'`
  `-  Debian - when you have better things to do than fixing a system
 
Invalid/expired PGP subkeys? Use subkeys.pgp.net as keyserver!
[Message part 2 (application/pgp-signature, inline)]

Severity set to `important'. Request was from martin f krafft <madduck@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Tags added: moreinfo Request was from martin f krafft <madduck@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Merged 203759 204424. Request was from martin f krafft <madduck@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Tags added: help Request was from madduck@piper.madduck.net (Martin F. Krafft) to control@bugs.debian.org. Full text and rfc822 format available.

Tags added: help Request was from madduck@piper.madduck.net (Martin F. Krafft) to control@bugs.debian.org. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, madduck@debian.org (martin f. krafft):
Bug#204424; Package kernel-patch-2.4-grsecurity. Full text and rfc822 format available.

Acknowledgement sent to root <root@janc.int.pl>:
Extra info received and forwarded to list. Copy sent to madduck@debian.org (martin f. krafft). Full text and rfc822 format available.

Message #25 received at 204424@bugs.debian.org (full text, mbox):

From: root <root@janc.int.pl>
To: Debian Bug Tracking System <204424@bugs.debian.org>
Subject: kernel-patch-2.4-grsecurity: grsec with 2.4.18-13 - more info
Date: Fri, 12 Sep 2003 23:21:54 +0200
Package: kernel-patch-2.4-grsecurity
Version: 1.9.4-1
Followup-For: Bug #204424

Here are .rej file that you were asking for:
http://szymon.janc.int.pl/grsec/

Kernel is in version 2.4.18-13

Hope it will help.

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux serwer 2.4.21-grsec #3 pon wrz 8 02:24:36 CEST 2003 i586
Locale: LANG=pl_PL, LC_CTYPE=pl_PL

Versions of packages kernel-patch-2.4-grsecurity depends on:
ii  patch                         2.5.4-11   Apply a diff file to an original




Information forwarded to debian-bugs-dist@lists.debian.org, madduck@debian.org (martin f. krafft):
Bug#204424; Package kernel-patch-2.4-grsecurity. Full text and rfc822 format available.

Acknowledgement sent to martin f krafft <madduck@debian.org>:
Extra info received and forwarded to list. Copy sent to madduck@debian.org (martin f. krafft). Full text and rfc822 format available.

Message #30 received at 204424@bugs.debian.org (full text, mbox):

From: martin f krafft <madduck@debian.org>
To: root <root@janc.int.pl>, 204424@bugs.debian.org
Subject: Re: Bug#204424: kernel-patch-2.4-grsecurity: grsec with 2.4.18-13 - more info
Date: Sat, 13 Sep 2003 02:10:28 +0200
[Message part 1 (text/plain, inline)]
also sprach root <root@janc.int.pl> [2003.09.12.2321 +0200]:
> Package: kernel-patch-2.4-grsecurity
> Version: 1.9.4-1
> Followup-For: Bug #204424

Two things:

(1) Don't send mail as root!
(2) We are at version 1.9.11-1. Please try if that package fixes the
problem. 1.9.4-1 is not supported anymore.

-- 
Please do not CC me when replying to lists; I read them!
 
 .''`.     martin f. krafft <madduck@debian.org>
: :'  :    proud Debian developer, admin, and user
`. `'`
  `-  Debian - when you have better things to do than fixing a system
 
Invalid/expired PGP subkeys? Use subkeys.pgp.net as keyserver!
[Message part 2 (application/pgp-signature, inline)]

Information forwarded to debian-bugs-dist@lists.debian.org, madduck@debian.org (martin f. krafft):
Bug#204424; Package kernel-patch-2.4-grsecurity. Full text and rfc822 format available.

Acknowledgement sent to Szymon Janc <szymon@janc.int.pl>:
Extra info received and forwarded to list. Copy sent to madduck@debian.org (martin f. krafft). Full text and rfc822 format available.

Message #35 received at 204424@bugs.debian.org (full text, mbox):

From: Szymon Janc <szymon@janc.int.pl>
To: martin f krafft <madduck@debian.org>, 204424@bugs.debian.org
Subject: Re: Bug#204424: kernel-patch-2.4-grsecurity: grsec with 2.4.18-13 - more info
Date: Sat, 13 Sep 2003 14:45:17 +0200
> Two things:
>
> (1) Don't send mail as root!

Yeap :) It was sended by mistake from wrong account :>

> (2) We are at version 1.9.11-1. Please try if that package fixes the
> problem. 1.9.4-1 is not supported anymore.

But this problem is woody related so how 1.9.4-1 can be unsupported ?
Grsecurity deb is unusable on woody and I think that this should be fixed.

1.9.11-1 don't apply to 2.4.18-13 too... this is becouse it detects 2.4.18 
kernel and apply 1.9.4 patch which doesn't apply to 2.4.18-13...

-- 
Szymon Janc
szymon#janc.int.pl // GG: 1383435
Jabber: szymon@jabber.atman.pl




Information forwarded to debian-bugs-dist@lists.debian.org, madduck@debian.org (martin f. krafft):
Bug#204424; Package kernel-patch-2.4-grsecurity. Full text and rfc822 format available.

Acknowledgement sent to martin f krafft <madduck@debian.org>:
Extra info received and forwarded to list. Copy sent to madduck@debian.org (martin f. krafft). Full text and rfc822 format available.

Message #40 received at 204424@bugs.debian.org (full text, mbox):

From: martin f krafft <madduck@debian.org>
To: Szymon Janc <szymon@janc.int.pl>
Cc: 204424@bugs.debian.org
Subject: Re: Bug#204424: kernel-patch-2.4-grsecurity: grsec with 2.4.18-13 - more info
Date: Sat, 13 Sep 2003 20:48:34 +0200
[Message part 1 (text/plain, inline)]
also sprach Szymon Janc <szymon@janc.int.pl> [2003.09.13.1445 +0200]:
> But this problem is woody related so how 1.9.4-1 can be
> unsupported ? Grsecurity deb is unusable on woody and I think that
> this should be fixed.

Okay. I will see what I can do.

-- 
Please do not CC me when replying to lists; I read them!
 
 .''`.     martin f. krafft <madduck@debian.org>
: :'  :    proud Debian developer, admin, and user
`. `'`
  `-  Debian - when you have better things to do than fixing a system
 
Invalid/expired PGP subkeys? Use subkeys.pgp.net as keyserver!
[Message part 2 (application/pgp-signature, inline)]

Tags added: pending Request was from madduck@piper.madduck.net (Martin F. Krafft) to control@bugs.debian.org. Full text and rfc822 format available.

Tags added: pending Request was from madduck@piper.madduck.net (Martin F. Krafft) to control@bugs.debian.org. Full text and rfc822 format available.

Information forwarded to debian-bugs-dist@lists.debian.org, madduck@debian.org (martin f. krafft):
Bug#204424; Package kernel-patch-2.4-grsecurity. Full text and rfc822 format available.

Acknowledgement sent to martin f krafft <madduck@debian.org>:
Extra info received and forwarded to list. Copy sent to madduck@debian.org (martin f. krafft). Full text and rfc822 format available.

Message #49 received at 204424@bugs.debian.org (full text, mbox):

From: martin f krafft <madduck@debian.org>
To: undisclosed-recipients: ;
Subject: grsecurity bugs
Date: Sun, 21 Sep 2003 14:01:29 +0200
[Message part 1 (text/plain, inline)]
I have uploaded a new version of grsecurity. However, it won't
support Debian kernels 2.4.20 and up. README.2.4.2x in the package
will tell you why. In addition:

  http://lists.debian.org/debian-devel/2003/debian-devel-200309/msg01133.html

I am sorry if this inconveniences you. I don't have a choice, not
only because I can't afford to put more time into this, but also
because I am not going to remove functionality from grsecurity,
which would be required to cater for the Debian kernels.

Please complain to the kernel maintainer(s) if you don't like this.
Or just use a vanilla kernel source tree.

-- 
Please do not CC me when replying to lists; I read them!
 
 .''`.     martin f. krafft <madduck@debian.org>
: :'  :    proud Debian developer, admin, and user
`. `'`
  `-  Debian - when you have better things to do than fixing a system
 
Invalid/expired PGP subkeys? Use subkeys.pgp.net as keyserver!
[Message part 2 (application/pgp-signature, inline)]

Reply sent to madduck@debian.org (martin f. krafft):
You have taken responsibility. Full text and rfc822 format available.

Notification sent to "ODi" <odi@imn.pl>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #54 received at 203759-close@bugs.debian.org (full text, mbox):

From: madduck@debian.org (martin f. krafft)
To: 203759-close@bugs.debian.org
Subject: Bug#203759: fixed in kernel-patch-2.4-grsecurity 1.9.12-2
Date: Sun, 21 Sep 2003 08:02:11 -0400
Source: kernel-patch-2.4-grsecurity
Source-Version: 1.9.12-2

We believe that the bug you reported is fixed in the latest version of
kernel-patch-2.4-grsecurity, which is due to be installed in the Debian FTP archive:

kernel-patch-2.4-grsecurity_1.9.12-2.dsc
  to pool/main/k/kernel-patch-2.4-grsecurity/kernel-patch-2.4-grsecurity_1.9.12-2.dsc
kernel-patch-2.4-grsecurity_1.9.12-2.tar.gz
  to pool/main/k/kernel-patch-2.4-grsecurity/kernel-patch-2.4-grsecurity_1.9.12-2.tar.gz
kernel-patch-2.4-grsecurity_1.9.12-2_all.deb
  to pool/main/k/kernel-patch-2.4-grsecurity/kernel-patch-2.4-grsecurity_1.9.12-2_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 203759@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
martin f. krafft <madduck@debian.org> (supplier of updated kernel-patch-2.4-grsecurity package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 21 Sep 2003 13:44:43 +0200
Source: kernel-patch-2.4-grsecurity
Binary: kernel-patch-2.4-grsecurity
Architecture: source all
Version: 1.9.12-2
Distribution: unstable
Urgency: low
Maintainer: martin f. krafft <madduck@debian.org>
Changed-By: martin f. krafft <madduck@debian.org>
Description: 
 kernel-patch-2.4-grsecurity - grsecurity kernel patch - 2.4.x security patch
Closes: 203759 204424
Changes: 
 kernel-patch-2.4-grsecurity (1.9.12-2) unstable; urgency=low
 .
   * Fixed the patch to apply to Debian kernel version 2.4.17
   * Fixed the patch to apply to Debian kernel version 2.4.18
       closes: Bug#203759, Bug#204424
   * Fixed the patch to apply to Debian kernel version 2.4.19
   * Decided to *not* support Debian kernel versions 2.4.20 and up. This
     decision is documented in
     /usr/share/doc/kernel-patch-2.4-grsecurity/README.2.4.2x.
   * Added note pertaining to the latter to debian/control.
   * Added debconf notice pertaining to the latter.
   * Changed debhelper scripts to use -i.
Files: 
 fe9650e46901a9fb5a77b433cbf8657d 580 devel extra kernel-patch-2.4-grsecurity_1.9.12-2.dsc
 6d9ec48ec9b71578a02d9a7073d1d9c0 835108 devel extra kernel-patch-2.4-grsecurity_1.9.12-2.tar.gz
 a2144cb0ba761a0c38fba78954da5602 844328 devel extra kernel-patch-2.4-grsecurity_1.9.12-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQE/bZAHIgvIgzMMSnURAoCJAKDgM4J0cd66L2LKazjm7O8Dh+kp9ACeNbjy
WzwZfrgTtz8s0olGjZI65Iw=
=wYdQ
-----END PGP SIGNATURE-----




Message #55 received at 204424-close@bugs.debian.org (full text, mbox):

From: madduck@debian.org (martin f. krafft)
To: 204424-close@bugs.debian.org
Subject: Bug#204424: fixed in kernel-patch-2.4-grsecurity 1.9.12-2
Date: Sun, 21 Sep 2003 08:02:11 -0400
Source: kernel-patch-2.4-grsecurity
Source-Version: 1.9.12-2

We believe that the bug you reported is fixed in the latest version of
kernel-patch-2.4-grsecurity, which is due to be installed in the Debian FTP archive:

kernel-patch-2.4-grsecurity_1.9.12-2.dsc
  to pool/main/k/kernel-patch-2.4-grsecurity/kernel-patch-2.4-grsecurity_1.9.12-2.dsc
kernel-patch-2.4-grsecurity_1.9.12-2.tar.gz
  to pool/main/k/kernel-patch-2.4-grsecurity/kernel-patch-2.4-grsecurity_1.9.12-2.tar.gz
kernel-patch-2.4-grsecurity_1.9.12-2_all.deb
  to pool/main/k/kernel-patch-2.4-grsecurity/kernel-patch-2.4-grsecurity_1.9.12-2_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 204424@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
martin f. krafft <madduck@debian.org> (supplier of updated kernel-patch-2.4-grsecurity package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 21 Sep 2003 13:44:43 +0200
Source: kernel-patch-2.4-grsecurity
Binary: kernel-patch-2.4-grsecurity
Architecture: source all
Version: 1.9.12-2
Distribution: unstable
Urgency: low
Maintainer: martin f. krafft <madduck@debian.org>
Changed-By: martin f. krafft <madduck@debian.org>
Description: 
 kernel-patch-2.4-grsecurity - grsecurity kernel patch - 2.4.x security patch
Closes: 203759 204424
Changes: 
 kernel-patch-2.4-grsecurity (1.9.12-2) unstable; urgency=low
 .
   * Fixed the patch to apply to Debian kernel version 2.4.17
   * Fixed the patch to apply to Debian kernel version 2.4.18
       closes: Bug#203759, Bug#204424
   * Fixed the patch to apply to Debian kernel version 2.4.19
   * Decided to *not* support Debian kernel versions 2.4.20 and up. This
     decision is documented in
     /usr/share/doc/kernel-patch-2.4-grsecurity/README.2.4.2x.
   * Added note pertaining to the latter to debian/control.
   * Added debconf notice pertaining to the latter.
   * Changed debhelper scripts to use -i.
Files: 
 fe9650e46901a9fb5a77b433cbf8657d 580 devel extra kernel-patch-2.4-grsecurity_1.9.12-2.dsc
 6d9ec48ec9b71578a02d9a7073d1d9c0 835108 devel extra kernel-patch-2.4-grsecurity_1.9.12-2.tar.gz
 a2144cb0ba761a0c38fba78954da5602 844328 devel extra kernel-patch-2.4-grsecurity_1.9.12-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQE/bZAHIgvIgzMMSnURAoCJAKDgM4J0cd66L2LKazjm7O8Dh+kp9ACeNbjy
WzwZfrgTtz8s0olGjZI65Iw=
=wYdQ
-----END PGP SIGNATURE-----




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Wed Apr 16 08:10:14 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.