Debian Bug report logs - #202172
ITA: allows ordinary users to run their own CGI scripts

version graph

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: Martin Michlmayr <tbm@cyrius.com>

Date: Sun, 20 Jul 2003 12:48:03 UTC

Severity: normal

Fixed in version cgiwrap/3.8-1

Done: Pierre Machard <pmachard@debian.org>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#202172; Package wnpp. Full text and rfc822 format available.

Acknowledgement sent to Martin Michlmayr <tbm@cyrius.com>:
New Bug report received and forwarded. Copy sent to wnpp@debian.org. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Martin Michlmayr <tbm@cyrius.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Cc: Jim Lynch <jwl@debian.org>
Subject: O: cgiwrap -- allows ordinary users to run their own CGI scripts
Date: Sun, 20 Jul 2003 14:30:38 +0200
Package: wnpp
Severity: normal

The current maintainer of cgiwrap, Jim Lynch <jwl@debian.org>,
is apparently not active anymore.  Therefore, I orphan this package
now.  If you want to be the new maintainer, please take it -- see
http://www.debian.org/devel/wnpp/index.html#howto-o for detailed
instructions how to adopt a package properly.

Some information about this package:

Package: cgiwrap
Binary: cgiwrap
Version: 3.7.1-0.2
Priority: optional
Section: web
Maintainer: Jim Lynch <jwl@debian.org>
Build-Depends: debhelper (>= 2.0.40)
Architecture: any
Standards-Version: 3.1.1
Format: 1.0
Directory: pool/main/c/cgiwrap
Files: 137ee13f5b544b63ab9c75a2065af365 603 cgiwrap_3.7.1-0.2.dsc
 9d496242d52bdb407ee045d72500c270 117771 cgiwrap_3.7.1.orig.tar.gz
 7e1b9fa19b284b9f1e515ed42cdd2e73 37234 cgiwrap_3.7.1-0.2.diff.gz

Package: cgiwrap
Priority: optional
Section: web
Installed-Size: 244
Maintainer: Jim Lynch <jwl@debian.org>
Architecture: i386
Version: 3.7.1-0.2
Depends: libc6 (>= 2.2.4-4)
Conflicts: suidmanager (<< 0.50)
Filename: pool/main/c/cgiwrap/cgiwrap_3.7.1-0.2_i386.deb
Size: 53282
MD5sum: d9bf69a9f53c73978b2539ea94c22280
Description: allows ordinary users to run their own CGI scripts
 a gateway that allows more secure user access to CGI programs on
 an HTTPd server than is provided  by the http server itself. The
 primary function  of  CGIwrap is to make  certain   that any CGI
 script runs  with the permissions of  the user who installed it,
 and not those of the server.

Justification: All packages were NMUed several times, outstanding RC
bugs; was contacted several times, promised ed to fix but never did.

-- 
Martin Michlmayr
tbm@cyrius.com



Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org:
Bug#202172; Package wnpp. Full text and rfc822 format available.

Acknowledgement sent to Martin Michlmayr <tbm@cyrius.com>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org. Full text and rfc822 format available.

Message #10 received at 202172@bugs.debian.org (full text, mbox):

From: Martin Michlmayr <tbm@cyrius.com>
To: Jim Lynch <jwl@debian.org>
Cc: 202172@bugs.debian.org
Subject: Re: O: cgiwrap -- allows ordinary users to run their own CGI scripts
Date: Tue, 22 Jul 2003 00:24:54 +0100
* Jim Lynch <jwl@debian.org> [2003-07-20 13:23]:
> NO. I MAINTAIN THIS PACKAGE. LAY OFF.

We obviously have different concepts of the word "maintain".


cgiwrap (3.7.1-0.2) unstable; urgency=low

  * Non-maintainer upload.
  * Update config.guess and config.sub (closes: #119065).

 -- Colin Watson <cjwatson@debian.org>  Thu, 15 Nov 2001 21:34:45 +0000

cgiwrap (3.7.1-0.1) unstable; urgency=low

  * Non-maintainer upload to fix security hole.
  * New upstream release.
    - HTML-encodes error messages appropriately, fixing cross-site scripting
      vulnerability (closes: #106299).
  * debian/control: Add build-dependencies (closes: #70266).
  * Remove call to obsolete dh_suidregister from debian/rules, and conflict
    with suidmanager (<< 0.50) instead for statoverrides (closes: #83834).
  * Don't install old /usr/man/man1 directory.
  * Policy version 3.1.1.

 -- Colin Watson <cjwatson@debian.org>  Sat, 10 Nov 2001 01:58:50 +0000

cgiwrap (3.6.4-2) unstable; urgency=low

  * jwl@debian.org is adopting package from Karl Hegbloom

 -- Jim Lynch <jwl@debian.org>  Sun,  9 Jan 2000 20:13:35 -0800

-- 
Martin Michlmayr
tbm@cyrius.com



Changed Bug title. Request was from Pierre Machard <pmachard@debian.org> to control@bugs.debian.org. Full text and rfc822 format available.

Reply sent to Pierre Machard <pmachard@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Martin Michlmayr <tbm@cyrius.com>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #17 received at 202172-close@bugs.debian.org (full text, mbox):

From: Pierre Machard <pmachard@debian.org>
To: 202172-close@bugs.debian.org
Subject: Bug#202172: fixed in cgiwrap 3.8-1
Date: Sat, 16 Aug 2003 05:03:13 -0400
We believe that the bug you reported is fixed in the latest version of
cgiwrap, which is due to be installed in the Debian FTP archive:

cgiwrap_3.8-1.dsc
  to pool/main/c/cgiwrap/cgiwrap_3.8-1.dsc
cgiwrap_3.8-1.tar.gz
  to pool/main/c/cgiwrap/cgiwrap_3.8-1.tar.gz
cgiwrap_3.8-1_i386.deb
  to pool/main/c/cgiwrap/cgiwrap_3.8-1_i386.deb
php-cgiwrap_3.8-1_i386.deb
  to pool/main/c/cgiwrap/php-cgiwrap_3.8-1_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 202172@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Pierre Machard <pmachard@debian.org> (supplier of updated cgiwrap package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Thu, 14 Aug 2003 02:33:24 +0200
Source: cgiwrap
Binary: php-cgiwrap cgiwrap
Architecture: source i386
Version: 3.8-1
Distribution: unstable
Urgency: low
Maintainer: Pierre Machard <pmachard@debian.org>
Changed-By: Pierre Machard <pmachard@debian.org>
Description: 
 cgiwrap    - allows ordinary users to run their own CGI scripts
 php-cgiwrap - allows ordinary users to run their own CGI scripts
Closes: 58327 68660 70266 83834 106299 109366 119065 202172
Changes: 
 cgiwrap (3.8-1) unstable; urgency=low
 .
   * Adopt the package (closes: #202172)
   * New upsteam release
   * Use dpkg-statoverride
   * Register documentation with doc-base
   * Remove empty directory examples (closes: #68660)
   * Split the package in two binary packages now you can use
     PHP (closes: #109366)
   * Use symlinks instead of hard links for aliases of cgiwrap
   * Set the user cgi-bin to $HOME/cgi-bin so that user's cgis are not
     directly accessible from the web (closes: #58327)
   * Policy version 3.6.0
   * Accept NMUs. (closes: #119065, #106299, #70266, #83834)
Files: 
 3866e27903d8013d7dff9a7dcfd3e5fc 507 web optional cgiwrap_3.8-1.dsc
 634063f7f9081b93f1319d35b6bf175c 150264 web optional cgiwrap_3.8-1.tar.gz
 432437d279cd20634626c21712631bb2 44904 web optional cgiwrap_3.8-1_i386.deb
 3beca76e95cd3567b493257dc57e05f2 41310 web optional php-cgiwrap_3.8-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (GNU/Linux)

iD8DBQE/Ot+ss6AtZiNwb4cRAh60AJ9TNdOqgCRxB3WpXifTwBmrHEAf7wCeMxoB
QN3d2lsB2wuik88dtq6d+oI=
=tkh6
-----END PGP SIGNATURE-----




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 19:27:01 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.