Debian Bug report logs - #192681
ITA: libparagui1.0 -- standard themes for the widget set library

version graph

Package: wnpp; Maintainer for wnpp is wnpp@debian.org;

Reported by: Martin Michlmayr <tbm@cyrius.com>

Date: Fri, 9 May 2003 16:19:26 UTC

Owned by: fenio@o2.pl

Severity: normal

Fixed in versions libparagui1.0/1.0.2-3, libparagui1.0/1.0.4-1

Done: Bartosz Fenski <fenio@o2.pl>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, wnpp@packages.qa.debian.org:
Bug#192681; Package wnpp. Full text and rfc822 format available.

Acknowledgement sent to Martin Michlmayr <tbm@cyrius.com>:
New Bug report received and forwarded. Copy sent to wnpp@debian.org, wnpp@packages.qa.debian.org. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: Martin Michlmayr <tbm@cyrius.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Cc: Michael Moerz <mikem@debian.org>
Subject: O: libparagui1.0 -- Standard themes for the widget set library
Date: Sat, 10 May 2003 02:17:06 +1000
Package: wnpp
Severity: normal

The current maintainer of libparagui1.0, Michael Moerz <mikem@debian.org>,
is apparently not active anymore.  Therefore, I orphan this package
now.  If you want to be the new maintainer, please take it -- see
http://www.debian.org/devel/wnpp/index.html#howto-o for detailed
instructions how to adopt a package properly.

Some information about this package:

Package: libparagui1.0
Binary: libparagui1.0-dev, paragui-themes, libparagui1.0
Version: 0.1.0-1
Priority: optional
Section: libs
Maintainer: Michael Moerz <mikem@debian.org>
Build-Depends: debhelper (>> 3.0.0), zip (>= 2.30-1), libexpat1-dev, libfreetype6-dev, libstdc++2.10-dev | libstdc++3-dev, libsdl1.2-dev (>= 1.2.3+cvs20020303-1), zlib1g-dev
Architecture: any
Standards-Version: 3.5.2
Format: 1.0
Directory: pool/main/libp/libparagui1.0
Files: 4375f477735d4aa940e93bec16b0dc4c 728 libparagui1.0_0.1.0-1.dsc
 9340d4fcaf2d473aff228e48f1f95e3c 760300 libparagui1.0_0.1.0-1.tar.gz

Package: libparagui1.0
Priority: optional
Section: libs
Installed-Size: 552
Maintainer: Michael Moerz <mikem@debian.org>
Architecture: i386
Version: 0.1.0-1
Depends: libc6 (>= 2.2.4-4), libexpat1 (>= 1.95.2-6), libjpeg62, libpng2(>=1.0.12), libsdl-image1.2 (>= 1.2.1), libsdl1.2debian (>> 1.2.3), libstdc++2.10-glibc2.2 (>= 1:2.95.4-0.010810), libtiff3g, zlib1g (>= 1:1.1.4), paragui-themes
Filename: pool/main/libp/libparagui1.0/libparagui1.0_0.1.0-1_i386.deb
Size: 189690
MD5sum: 2a033598134f5a29525925ea4c06767e
Description: a real crossplatform widget set based on SDL
 ParaGUI is a cross-platform high-level application framework and GUI
 (graphical user interface) library.
 .
 ParaGUI's is completely based on the Simple DirectMedia Layer.

Package: libparagui1.0-dev
Priority: optional
Section: devel
Installed-Size: 1640
Maintainer: Michael Moerz <mikem@debian.org>
Architecture: i386
Source: libparagui1.0
Version: 0.1.0-1
Depends: libparagui1.0 (= 0.1.0-1), libc6-dev
Filename: pool/main/libp/libparagui1.0/libparagui1.0-dev_0.1.0-1_i386.deb
Size: 354218
MD5sum: 409763ce2160b5555ad9d4eeed154027
Description: Development files for the widget set library
 ParaGUI is a cross-platform high-level application framework and GUI
 (graphical user interface) library.
 .
 ParaGUI's is completely based on the Simple DirectMedia Layer.
 .
 This package contains files needed if you wish to use the paragui library
 in your own programs.

Package: paragui-themes
Priority: optional
Section: misc
Installed-Size: 240
Maintainer: Michael Moerz <mikem@debian.org>
Architecture: i386
Source: libparagui1.0
Version: 0.1.0-1
Filename: pool/main/libp/libparagui1.0/paragui-themes_0.1.0-1_i386.deb
Size: 217230
MD5sum: 82c95ba8af4c021cecd96ca10da32730
Description: Standard themes for the widget set library
 ParaGUI is a cross-platform high-level application framework and GUI
 (graphical user interface) library.
 .
 ParaGUI's is completely based on the Simple DirectMedia Layer.
 .
 This package contains standard themes files for the paragui library.

Justification: RC bugs, NMUs, did not respond to ITH or pings

-- 
Martin Michlmayr
tbm@cyrius.com



Information forwarded to debian-bugs-dist@lists.debian.org, wnpp@debian.org, wnpp@packages.qa.debian.org:
Bug#192681; Package wnpp. Full text and rfc822 format available.

Acknowledgement sent to Aurelien Jarno <aurel32@debian.org>:
Extra info received and forwarded to list. Copy sent to wnpp@debian.org, wnpp@packages.qa.debian.org. Full text and rfc822 format available.

Message #10 received at 192681@bugs.debian.org (full text, mbox):

From: Aurelien Jarno <aurel32@debian.org>
To: 192681@bugs.debian.org
Subject: Re: Bug#192681: O: libparagui1.0 -- Standard themes for the widget set library
Date: Sun, 11 May 2003 23:52:33 +0200
[Message part 1 (text/plain, inline)]
Information for a possible new maintainer:
------------------------------------------

I have uploaded a new version of this package, which fixes all the bugs,
but one:
#148582: libparagui1.0: name of the source package should be the same as the upstream one

I didn't fixed it, as I don't want to have to deal with overrides when
uploading the package. 

You should also consider to merge paragui-themes with libparagui1.0 as 
libparagui1.0 depends on the former package, which is very small. There 
is also the Standards-Version to check and bump to the latest version 
of the policy. Finally, the section of the packages should be changed as
I get this warning after uploading the package:

libparagui1.0_1.0.2-1_i386.deb: package says section is devel, override says libs.
libparagui1.0-dev_1.0.2-1_i386.deb: package says section is devel, override says libdevel.
paragui-themes_1.0.2-1_i386.deb: package says section is devel, override says misc.


Except these minor things, the package should be in good shape. In any
case, please wait the package gets into testing before uploading a new 
one: it is holding a lot of packages using SDL out of testing.
[Message part 2 (application/pgp-signature, inline)]

Reply sent to Aurelien Jarno <aurel32@debian.org>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Martin Michlmayr <tbm@cyrius.com>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #15 received at 192681-close@bugs.debian.org (full text, mbox):

From: Aurelien Jarno <aurel32@debian.org>
To: 192681-close@bugs.debian.org
Subject: Bug#192681: fixed in libparagui1.0 1.0.2-3
Date: Tue, 13 May 2003 00:17:28 -0400
We believe that the bug you reported is fixed in the latest version of
libparagui1.0, which is due to be installed in the Debian FTP archive:

libparagui1.0-dev_1.0.2-3_i386.deb
  to pool/main/libp/libparagui1.0/libparagui1.0-dev_1.0.2-3_i386.deb
libparagui1.0_1.0.2-3.diff.gz
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.2-3.diff.gz
libparagui1.0_1.0.2-3.dsc
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.2-3.dsc
libparagui1.0_1.0.2-3_i386.deb
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.2-3_i386.deb
paragui-themes_1.0.2-3_i386.deb
  to pool/main/libp/libparagui1.0/paragui-themes_1.0.2-3_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 192681@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aurelien Jarno <aurel32@debian.org> (supplier of updated libparagui1.0 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 13 May 2003 05:58:35 +0200
Source: libparagui1.0
Binary: libparagui1.0 paragui-themes libparagui1.0-dev
Architecture: source i386
Version: 1.0.2-3
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Aurelien Jarno <aurel32@debian.org>
Description: 
 libparagui1.0 - a real crossplatform widget set based on SDL
 libparagui1.0-dev - Development files for the widget set library
 paragui-themes - Standard themes for the widget set library
Closes: 192681
Changes: 
 libparagui1.0 (1.0.2-3) unstable; urgency=low
 .
   * Added build-dependency on automake1.4 and autoconf2.13 (closes:
     bug#192681).
   * Changed sections: libparagui1.0 from devel to libs, libparagui1.0-dev
     from devel to libdevel and paragui-themes from devel to misc.
Files: 
 8010781fa7c9630420ea4a6fcf1aae2a 758 libs optional libparagui1.0_1.0.2-3.dsc
 fda506eb381106ec73675310a6e56cb3 40801 libs optional libparagui1.0_1.0.2-3.diff.gz
 7ce6e252abbf215eeb03156a95598e0a 199860 libdevel optional libparagui1.0_1.0.2-3_i386.deb
 270eb6208317c0e358db0d443f17921d 348680 misc optional libparagui1.0-dev_1.0.2-3_i386.deb
 e2bf6b8f2d7432672ce0e6531457e350 211256 libs optional paragui-themes_1.0.2-3_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQE+wHDew3ao2vG823MRAjZ3AJ98lG1zY2mI5eCFMdQWCl8wOTX/8QCdH9Sj
INx2QCK+wIGACfBQo+2PX5w=
=C3Rd
-----END PGP SIGNATURE-----




Bug reopened, originator not changed. Request was from Aurelien Jarno <aurelien@aurel32.net> to control@bugs.debian.org. Full text and rfc822 format available.

Changed Bug title. Request was from Bartosz Fenski aka fEnIo <fenio@o2.pl> to control@bugs.debian.org. Full text and rfc822 format available.

Owner recorded as fenio@o2.pl. Request was from Bartosz Fenski aka fEnIo <fenio@o2.pl> to control@bugs.debian.org. Full text and rfc822 format available.

Reply sent to Bartosz Fenski <fenio@o2.pl>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to Martin Michlmayr <tbm@cyrius.com>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #26 received at 192681-close@bugs.debian.org (full text, mbox):

From: Bartosz Fenski <fenio@o2.pl>
To: 192681-close@bugs.debian.org
Subject: Bug#192681: fixed in libparagui1.0 1.0.4-1
Date: Sun, 09 May 2004 13:17:13 -0400
Source: libparagui1.0
Source-Version: 1.0.4-1

We believe that the bug you reported is fixed in the latest version of
libparagui1.0, which is due to be installed in the Debian FTP archive:

libparagui1.0-dev_1.0.4-1_i386.deb
  to pool/main/libp/libparagui1.0/libparagui1.0-dev_1.0.4-1_i386.deb
libparagui1.0_1.0.4-1.diff.gz
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.4-1.diff.gz
libparagui1.0_1.0.4-1.dsc
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.4-1.dsc
libparagui1.0_1.0.4-1_i386.deb
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.4-1_i386.deb
libparagui1.0_1.0.4.orig.tar.gz
  to pool/main/libp/libparagui1.0/libparagui1.0_1.0.4.orig.tar.gz



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 192681@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Bartosz Fenski <fenio@o2.pl> (supplier of updated libparagui1.0 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue,  4 May 2004 19:41:28 +0200
Source: libparagui1.0
Binary: libparagui1.0 libparagui1.0-dev
Architecture: source i386
Version: 1.0.4-1
Distribution: unstable
Urgency: low
Maintainer: Bartosz Fenski <fenio@o2.pl>
Changed-By: Bartosz Fenski <fenio@o2.pl>
Description: 
 libparagui1.0 - a real crossplatform widget set based on SDL
 libparagui1.0-dev - Development files for the widget set library
Closes: 192681 223307 243539 246469 246470
Changes: 
 libparagui1.0 (1.0.4-1) unstable; urgency=low
 .
   * New maintainer (Closes: #192681)
   * New upstream release.
   * Merged paragui-themes with libparagui1.0
   * debian/control:
     - bumped Standards-Version
     - added Conflicts: paragui-themes (it's now merged with libparagui1.0)
     - added libsdl1.2-dev to libparagui1.0-dev dependencies (Closes: #246470)
     - removed part describing paragui-themes
   * debian/libparagui1.0.install:
     - adjusted to install also symlink (Closes: #243539, #223307, #246469)
     - rewritten to avoid changing it with every release
   * debian/rules:
     - cleaned up (many unnecesarry comments)
   * debian/copyright:
     - some parts rewritten to avoid changing it with every release
     - mentioned previous maintainer
   * debian:
     - removed unneeded file libparagui1.0.links
     - removed unneeded file paragui-themes.install
Files: 
 328ea6cc5ae6a7396e7cced82c1cb548 747 libs optional libparagui1.0_1.0.4-1.dsc
 08e000e136898731734fc69eeded1516 1089912 libs optional libparagui1.0_1.0.4.orig.tar.gz
 cb3eac63439057416b8ea1414286a302 4862 libs optional libparagui1.0_1.0.4-1.diff.gz
 73903a822afd9a7d159519829b241b0b 382756 libs optional libparagui1.0_1.0.4-1_i386.deb
 682b9f4d95bd318e3c035599bcd38e7c 348850 libdevel optional libparagui1.0-dev_1.0.4-1_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAnmNKw3ao2vG823MRAuoyAJsG68UVdKBIiwUC2UyJIuygCKp5ngCfRm6D
oweOvE2fXBXZX/kL30D4/SQ=
=BBvr
-----END PGP SIGNATURE-----




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Fri Apr 18 03:57:53 2014; Machine Name: beach.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.