Debian Bug report logs - #123725
zsnes_1.337-3(unstable/i386): missing build-depends

version graph

Package: zsnes; Maintainer for zsnes is Debian Games Team <pkg-games-devel@lists.alioth.debian.org>; Source for zsnes is src:zsnes.

Reported by: James Troup <james@nocrew.org>

Date: Wed, 12 Dec 2001 23:18:03 UTC

Severity: serious

Found in version 1.337-3

Fixed in version zsnes/1.337-4

Done: Aaron Lehmann <aaronl@vitelus.com>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to debian-bugs-dist@lists.debian.org, Aaron Lehmann <aaronl@vitelus.com>:
Bug#123725; Package zsnes. Full text and rfc822 format available.

Acknowledgement sent to James Troup <james@nocrew.org>:
New Bug report received and forwarded. Copy sent to Aaron Lehmann <aaronl@vitelus.com>. Full text and rfc822 format available.

Message #5 received at submit@bugs.debian.org (full text, mbox):

From: James Troup <james@nocrew.org>
To: submit@bugs.debian.org
Subject: zsnes_1.337-3(unstable/i386): missing build-depends
Date: 12 Dec 2001 23:16:37 +0000
Package: zsnes
Version: 1.337-3
Severity: serious

You appear to be missing build-depends on at least xutils and
libpng2-dev.  Also you presumably really meant zlib1g-dev not zlib1g.

| Automatic build of zsnes_1.337-3 on augustus by sbuild/i386 1.159
| Build started at 20011212-0902
| ******************************************************************************

[...]

| ** Using build dependencies supplied by package:
| Build-Depends: debhelper (>> 3.0.0), nasm, libsdl1.2-dev (>= 1.2.2-3.1), zlib1g, sharutils
| **** Warning:
| **** The following central src deps are (probably) missing:
|   libpng2-dev (>= 1.0.12)

[...]

| checking for X... libraries /usr/X11R6/lib, headers 

(Notice how it can't find the header files?  That means it needs
 xutils... try it in a clean chroot if you don't believe me)

| -- Where is libSDL and zlib, and do we want/have libPNG and OpenGL support?
| checking for sdl-config... /usr/bin/sdl-config
| checking for SDL - version >= 1.2.0... no
| *** Could not run SDL test program, checking why...
| *** The test program failed to compile or link. See the file config.log for the
| *** exact error that occured. This usually means SDL was incorrectly installed
| *** or that you have moved SDL since it was installed. In the latter case, you
| *** may want to edit the sdl-config script: /usr/bin/sdl-config
| configure: error: SDL >= 1.2.0 is required

A complete build log is available on demand.

-- 
James



Information forwarded to debian-bugs-dist@lists.debian.org:
Bug#123725; Package zsnes. Full text and rfc822 format available.

Acknowledgement sent to Aaron Lehmann <aaronl@vitelus.com>:
Extra info received and forwarded to list. Full text and rfc822 format available.

Message #10 received at 123725@bugs.debian.org (full text, mbox):

From: Aaron Lehmann <aaronl@vitelus.com>
To: James Troup <james@nocrew.org>, 123725@bugs.debian.org
Subject: Re: Bug#123725: zsnes_1.337-3(unstable/i386): missing build-depends
Date: Wed, 12 Dec 2001 18:43:36 -0800
On Wed, Dec 12, 2001 at 11:16:37PM +0000, James Troup wrote:
> | checking for sdl-config... /usr/bin/sdl-config
> | checking for SDL - version >= 1.2.0... no
> | *** Could not run SDL test program, checking why...
> | *** The test program failed to compile or link. See the file config.log for the
> | *** exact error that occured. This usually means SDL was incorrectly installed
> | *** or that you have moved SDL since it was installed. In the latter case, you
> | *** may want to edit the sdl-config script: /usr/bin/sdl-config
> | configure: error: SDL >= 1.2.0 is required

Why is this happening? There is a build dependency on
libsdl1.2-dev (>= 1.2.2-3.1).



Information forwarded to debian-bugs-dist@lists.debian.org, Aaron Lehmann <aaronl@vitelus.com>:
Bug#123725; Package zsnes. Full text and rfc822 format available.

Acknowledgement sent to James Troup <james@nocrew.org>:
Extra info received and forwarded to list. Copy sent to Aaron Lehmann <aaronl@vitelus.com>. Full text and rfc822 format available.

Message #15 received at 123725@bugs.debian.org (full text, mbox):

From: James Troup <james@nocrew.org>
To: Aaron Lehmann <aaronl@vitelus.com>
Cc: 123725@bugs.debian.org
Subject: Re: Bug#123725: zsnes_1.337-3(unstable/i386): missing build-depends
Date: 13 Dec 2001 19:05:43 +0000
Aaron Lehmann <aaronl@vitelus.com> writes:

> On Wed, Dec 12, 2001 at 11:16:37PM +0000, James Troup wrote:
> > | checking for sdl-config... /usr/bin/sdl-config
> > | checking for SDL - version >= 1.2.0... no
> > | *** Could not run SDL test program, checking why...
> > | *** The test program failed to compile or link. See the file config.log for the
> > | *** exact error that occured. This usually means SDL was incorrectly installed
> > | *** or that you have moved SDL since it was installed. In the latter case, you
> > | *** may want to edit the sdl-config script: /usr/bin/sdl-config
> > | configure: error: SDL >= 1.2.0 is required
> 
> Why is this happening? There is a build dependency on
> libsdl1.2-dev (>= 1.2.2-3.1).

Because of the missing build-depends on xutils; it screws up
autoconf's include file handling.  As I said, feel free to try it in a
chroot and see for yourself; it's easy to reproduce.  Install the
build-depends, run dpkg-buildpackage, it dies as above, install
xutils, rerun dpkg-buildpackage, it finds the SDL version correctly.

-- 
James



Reply sent to Aaron Lehmann <aaronl@vitelus.com>:
You have taken responsibility. Full text and rfc822 format available.

Notification sent to James Troup <james@nocrew.org>:
Bug acknowledged by developer. Full text and rfc822 format available.

Message #20 received at 123725-close@bugs.debian.org (full text, mbox):

From: Aaron Lehmann <aaronl@vitelus.com>
To: 123725-close@bugs.debian.org
Subject: Bug#123725: fixed in zsnes 1.337-4
Date: Mon, 17 Dec 2001 15:20:16 -0500
We believe that the bug you reported is fixed in the latest version of
zsnes, which has been installed in the Debian FTP archive:

zsnes_1.337-4.diff.gz
  to pool/contrib/z/zsnes/zsnes_1.337-4.diff.gz
zsnes_1.337-4.dsc
  to pool/contrib/z/zsnes/zsnes_1.337-4.dsc
zsnes_1.337-4_i386.deb
  to pool/contrib/z/zsnes/zsnes_1.337-4_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 123725@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aaron Lehmann <aaronl@vitelus.com> (supplier of updated zsnes package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 16 Dec 2001 14:31:19 -0800
Source: zsnes
Binary: zsnes
Architecture: source i386
Version: 1.337-4
Distribution: unstable
Urgency: low
Maintainer: Aaron Lehmann <aaronl@vitelus.com>
Changed-By: Aaron Lehmann <aaronl@vitelus.com>
Description: 
 zsnes      - Emulator of the Super Nintendo Entertainment System (TM)
Closes: 123725
Changes: 
 zsnes (1.337-4) unstable; urgency=low
 .
   * Fix build with new NASM
   * Update build-depends (Closes: #123725)
Files: 
 0856b448207e9b06c862fe4a3e73a761 640 contrib/otherosfs optional zsnes_1.337-4.dsc
 a839c4692358cb9087648a3b21cf874b 9864 contrib/otherosfs optional zsnes_1.337-4.diff.gz
 a4d1500bb65780de5fef1882535ff0af 496338 contrib/otherosfs optional zsnes_1.337-4_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6b-cvs (GNU/Linux)

iD8DBQE8HSRDdtqQf66JWJkRAqI3AJ0eo59+FyDwTrytn0DhW+1j3bDzAwCeNZ6Z
slAkk89rKmEOzFyaGtINb9I=
=zkKd
-----END PGP SIGNATURE-----




Send a report that this bug log contains spam.


Debian bug tracking system administrator <owner@bugs.debian.org>. Last modified: Thu Apr 17 22:22:47 2014; Machine Name: buxtehude.debian.org

Debian Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.